Subject: [Ace] ACE Rechartering

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 25 Aug 2015 13:18:09 +0200

Hi all,

at the last IETF meeting we discussed the inclusion of the architecture
document into the charter (and into the milestone list) of the ACE
working group. The participants of f2f meeting agreed to the adoption of
the document and the subsequent confirmation call on the mailing list
did not lead to a different conclusion.

Since the architecture document was not part of our charter we have to
update the charter text. You can find three files in the attachment, namely
 1) the current charter text,
 2) the new charter text, and
 3) a diff version (as PDF).

The changes to the current charter text are as follows:

 * editorial changes,
 * added the architecture document,
 * added a note about multicast, and
 * included a remark about application layer security.

Are you OK with the updated charter text?
If not, what other changes you would like to see?

Deadline for feedback: September 6th 2015

Ciao
Hannes & Kepeng

---

From: Somaraju Abhinav <[email-masked]>
Date: Tue, 25 Aug 2015 14:00:15 +0000

Hi Hannes,
Just one quick point which was raised by somebody (don’t remember who) at Prague. From my memory it was agreed at the meeting that we want to talk about security for group communication and not just multicast security. So does it makes sense to change the statement
"The ability to distribute keys for use with multicast security will also be explored as well as application layer security solutions"
to
"The ability to distribute keys for use with secure group communication including multicast security and application layer security solutions"
Abhinav

-----Original Message-----
From: Ace [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
Sent: Dienstag, 25. August 2015 13:18
To: [email-masked]
Subject: [Ace] ACE Rechartering

Hi all,

at the last IETF meeting we discussed the inclusion of the architecture document into the charter (and into the milestone list) of the ACE working group. The participants of f2f meeting agreed to the adoption of the document and the subsequent confirmation call on the mailing list did not lead to a different conclusion.

Since the architecture document was not part of our charter we have to update the charter text. You can find three files in the attachment, namely
 1) the current charter text,
 2) the new charter text, and
 3) a diff version (as PDF).

 * editorial changes,

Ciao
Hannes & Kepeng
________________________________________________________ The contents of this e-mail and any attachments are confidential to the intended recipient. They may not be disclosed to or used by or copied in any way by anyone other than the intended recipient. If this e-mail is received in error, please immediately notify the sender and delete the e-mail and attached documents. Please note that neither the sender nor the sender's company accept any responsibility for viruses and it is your responsibility to scan or otherwise check this e-mail and any attachments.

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 25 Aug 2015 16:15:29 +0200

That's good for me.

---

From: Michael Richardson <[email-masked]>
Date: Tue, 25 Aug 2015 10:50:43 -0400

I see that:

+ The ability to distribute keys for use with multicast security will also
+ be explored as well as application

has been added.  Is this need supported by our current use cases?
Given that DICE failed to do this in the general case, is the hope that
we can do it in ACE for some smaller scope?

I have no problems with any of the other changes to the charter.
I am undecided yet on whether multicast security is a good addition.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 25 Aug 2015 18:11:23 +0200

> Given that DICE failed to do this in the general case, 

DICE didn't fail; DICE never tried (the focus was always on the record
protocol, and doing a "multicast handshake" or some such wasn't on the
menu).

Conveying group keys using REST over bilateral security associations is
simple enough that not all of us are sure that this even needs to be
standardized.  Maybe at the level of RFC 7390 (defining a media type).

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Tue, 25 Aug 2015 12:35:56 -0400

Abhinav wrote:
    >> "The ability to distribute keys for use with multicast security will
    >> also be explored as well as application layer security solutions"

    >> "The ability to distribute keys for use with secure group
    >> communication including multicast security and application layer
    >> security solutions"

That would also make me happier.  It becomes clearer that we aren't trying
to do what DICE couldn't do, but rather enable some application layer keys.

---

From: Ludwig Seitz <[email-masked]>
Date: Thu, 27 Aug 2015 08:44:37 +0200

> If not, what other changes you would like to see?

I'm fine with the updated charter text + changing multicast to group 
communication.

/Ludwig

-- 
Ludwig Seitz, PhD
SICS Swedish ICT AB
Ideon Science Park
Building Beta 2
Scheelevägen 17
SE-223 70 Lund

Phone +46(0)70-349 92 51
http://www.sics.se