Subject: Re: [Ace] Update to Public Safety Use Case draft

From: Ludwig Seitz <[email-masked]>
Date: Mon, 03 Aug 2015 13:52:19 +0200

On 2015-07-28 20:06, Rahman, Akbar wrote:
> Hi Hannes/Kepeng/Ludwig,
>
>
> I have made an update of the Public Safety Use case draft to capture the key points from the Prague meeting.  Namely (from the minutes):
>
>         -https://www.ietf.org/proceedings/93/minutes/minutes-93-ace
>
>         -Hannes: please give us feedback about non-repudiation, clarification on integrity of the data.
>         -We should include this on the UC document: 12 hands Ok, 2 hand no.
>         -Conclusion: We will include it
>
>
>
> Please look at the diff of the draft and tell me if you agree with the updates (i.e. basically got rid of the offending items as suggested during the WG discussion as they strayed out of the Authentication/Authorization arena into Legal or other protocol areas).
>
> Htmlized:       https://tools.ietf.org/html/draft-rahman-ace-public-safety-use-case-01
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-rahman-ace-public-safety-use-case-01
>
> If so, I guess the next step is for Ludwig to incorporate into the WG Use Case draft.  If you merge, you can just acknowledge us but do not have to include us as authors in your WG Use Case draft.
>
>
> Please write back!
>
>
> Best Regards,
>
>
> Akbar
>

I'd suggest we integrate it with the building automation use case as a 
new section 2.4.2, moving the summary to 2.4.3 and replacing the second 
part of section 2.4.1.2. in which there already is a fire control 
scenario. Would that sound reasonable to you Akbar?

/Ludwig

-- 
Ludwig Seitz, PhD
SICS Swedish ICT AB
Ideon Science Park
Building Beta 2
Scheelevägen 17
SE-223 70 Lund

Phone +46(0)70-349 92 51
http://www.sics.se

---

From: Ludwig Seitz <[email-masked]>
Date: Mon, 03 Aug 2015 18:13:05 +0200

> scenario. Would that sound reasonable to you Akbar?

Working on this I realized a number of problems with your authorization 
problem summary.

1.) The problems don't explicitly follow from the text.  A reviewer 
asked us, for the other use cases, to mark in the text from where a 
requirement is drawn, and I find this impossible to pinpoint in the 
public safety case.

2.) Problems 1-5 are already reflected in the other use cases, I'd like 
to avoid duplicating them for this scenario if you don't object.

3.) Problem 6 is not really an authorization problem. We could rephrase 
it slightly to make it one. How about "The authorization mechanisms must 
be able to cope with extremely time-sensitive operations which have to 
be carried out in a quick manner." ?

4.) 7 and 8 are not really authorization problems either. They are 
auditing and message origin authentication problems. Do we want to list 
them here?
As an alternative we could add a paragraph to the security 
considerations instead specifying that we are aware of these types of 
problems, but that they are not in scope of the document (and ACE?).

Regards,

Ludwig

-- 
Ludwig Seitz, PhD
SICS Swedish ICT AB
Ideon Science Park
Building Beta 2
Scheelevägen 17
SE-223 70 Lund

Phone +46(0)70-349 92 51
http://www.sics.se

---

From: "Rahman, Akbar" <[email-masked]>
Date: Mon, 3 Aug 2015 20:19:48 +0000

Hi Ludwig,

>scenario. Would that sound reasonable to you Akbar?

Yes, this sounds like a good plan, especially if we could retain the "Public Safety" term as part of the new subsection title.

Best Regards,

Akbar

-----Original Message-----
From: Ludwig Seitz [mailto:[email-masked]]
Sent: Monday, August 03, 2015 7:52 AM
To: Rahman, Akbar <[email-masked]>; Hannes Tschofenig <[email-masked]>; Kepeng Li <[email-masked]>
Cc: [email-masked]
Subject: Re: Update to Public Safety Use Case draft

/Ludwig

--
Ludwig Seitz, PhD
SICS Swedish ICT AB
Ideon Science Park
Building Beta 2
Scheelevägen 17
SE-223 70 Lund

Phone +46(0)70-349 92 51
http://www.sics.se

---

From: "Rahman, Akbar" <[email-masked]>
Date: Mon, 3 Aug 2015 20:59:29 +0000

Hi Ludwig,

>requirement is drawn, and I find this impossible to pinpoint in the

Akbar - I think this problem mostly disappears due to your other suggestions below.

>to avoid duplicating them for this scenario if you don't object.

Akbar - That is okay with me.  Duplication should be avoided

>be carried out in a quick manner." ?

Akbar - Yes, good suggestion.

>problems, but that they are not in scope of the document (and ACE?).

Akbar:
- Perhaps we need to re-word Problem 7 rather than moving it out.  Problem 7 is trying to explicitly identify the need for source authentication.  For example, this is important in group communication scenarios (i.e. which specific member of the group sent the message) which I understood to be in the scope of ACE based on the discussions in Prague relating to draft-somaraju-ace-multicast.  And also even for non-group communication scenarios source authentication can be important.  For example, source authentication can be considered to be an important factor for the "Selling the house" scenario (section 2.2.4) and especially complementary to requirement U2.11 (transfer ownership).  So I would argue to retain Problem 7 as it is applicable to the Public Safety, Group communication, and financial use cases among others.

- On a related point.  The ACE charter is explicitly referring to both "authentication" and "authorization".  But in each of our Problem Summary subsections (e.g. 2.1.2, 2.2.5), you specifically refer to only "Authorization".  Was there a specific reason for that?

- I do agree that Problem 8 can be added as a note to the Security Considerations section.

Any feedback would be welcome.

Best Regards,

Akbar

-----Original Message-----
From: Ludwig Seitz [mailto:[email-masked]]
Sent: Monday, August 03, 2015 12:13 PM
To: Rahman, Akbar <[email-masked]>
Cc: [email-masked]
Subject: Re: Update to Public Safety Use Case draft

Regards,

Ludwig

--
Ludwig Seitz, PhD
SICS Swedish ICT AB
Ideon Science Park
Building Beta 2
Scheelevägen 17
SE-223 70 Lund

Phone +46(0)70-349 92 51
http://www.sics.se

---

From: Ludwig Seitz <[email-masked]>
Date: Tue, 04 Aug 2015 10:40:16 +0200

> Akbar - I think this problem mostly disappears due to your other suggestions below.

I agree.

...
> - Perhaps we need to re-word Problem 7 rather than moving it out.  Problem 7 is trying to explicitly identify the need for source authentication.
> For example, this is important in group communication scenarios (i.e. which specific member of the group sent the message) which I understood to be
> in the scope of ACE based on the discussions in Prague relating to draft-somaraju-ace-multicast.  And also even for non-group communication scenarios
 > source authentication can be important.  For example, source 
authentication can be considered to be an important factor for the 
"Selling the house"
 > scenario (section 2.2.4) and especially complementary to requirement 
U2.11 (transfer ownership).  So I would argue to retain Problem 7 as it is
 >  applicable to the Public Safety, Group communication, and financial 
use cases among others.

On second thought, I agree problem 7 is indeed in scope. I'll try to 
re-word it so this becomes clearer.

As for problem 8, currently auditing is mentioned in the privacy 
considerations (last paragraph), do you think that text covers it 
sufficiently or would you like to suggest improvements?

> - On a related point.  The ACE charter is explicitly referring to both "authentication" and "authorization".  But in each of our Problem Summary
> subsections (e.g. 2.1.2, 2.2.5), you specifically refer to only "Authorization".  Was there a specific reason for that?

None that I can recall, especially since we are mentioning 
authentication problems in the introduction and in some of the 
summaries. I guess we tried to avoid making the titles to long, I'll add 
authentication for clarity.

/Ludwig

-- 
Ludwig Seitz, PhD
SICS Swedish ICT AB
Ideon Science Park
Building Beta 2
Scheelevägen 17
SE-223 70 Lund

Phone +46(0)70-349 92 51
http://www.sics.se

---

From: "Rahman, Akbar" <[email-masked]>
Date: Tue, 4 Aug 2015 14:48:25 +0000

Hi Ludwig,

>sufficiently or would you like to suggest improvements?

The current text in Section 4 (Privacy Considerations) looks good.  Thanks.

/Akbar

-----Original Message-----
From: Ludwig Seitz [mailto:[email-masked]]
Sent: Tuesday, August 04, 2015 4:40 AM
To: Rahman, Akbar <[email-masked]>
Cc: [email-masked]
Subject: Re: Update to Public Safety Use Case draft

I agree.

...
use cases among others.

/Ludwig

--
Ludwig Seitz, PhD
SICS Swedish ICT AB
Ideon Science Park
Building Beta 2
Scheelevägen 17
SE-223 70 Lund

Phone +46(0)70-349 92 51
http://www.sics.se