Subject: Re: [Ace] Call for adoption for draft-gerdes-ace-actors-05

From: "Rahman, Akbar" <[email-masked]>
Date: Mon, 3 Aug 2015 21:38:59 +0000

Hi Kepeng/Hannes,

I support adopting the draft.  However, I did have a few comments that hopefully can be addressed as part of the update process:

1.       The mixing of "architecture" and "problem statement" terms is unnecessarily confusing (e.g. in the Abstract and 5th paragraph of Intro). The way I read the draft is that it is mostly a high level architecture (i.e. Sections 1-7) and a set of concise requirements (i.e. Section 8).  So I would suggest dropping references to "problem statement".

2.       I was expecting a clear linkage to Requirements from draft-ietf-ace-usecases to Section 8 (Assumptions and Requirements) but did not find it.  Why wasn't this done?

3.       There was no explicit mention of access "tokens" in the architecture description even though there were several references to OAUTH.  Do you think that should be added?

4.       The title refers only to "authorization" while the rest of the document clearly covers both "authorization and authentication".  So I think the title should be expanded.

Best Regards,

Akbar

From: Ace [mailto:[email-masked]] On Behalf Of Kepeng Li
Sent: Friday, July 24, 2015 7:18 AM
To: [email-masked]
Cc: Hannes Tschofenig <[email-masked]>
Subject: [Ace] Call for adoption for draft-gerdes-ace-actors-05

Hello all,

This note begins a Call For Adoption for draft-gerdes-ace-actors-05<http://datatracker.ietf.org/doc/draft-gerdes-ace-actors/> to

be adopted as an ACE working group item, and added in the charter.
The call ends on Aug 7, 2015.

Keep in mind that adoption of a document does not mean the document

as-is is ready for publication. It is merely acceptance of the

document as a starting point for what will be the final product

of the ACE working group. The working group is free to make changes to

the document according to the normal consensus process.

There were favorable supports toward adoption of this document at

IETF 93 in Prague. We will factor this into the decision at the close

of this Call.

Please reply on this thread with expressions of support or opposition,

preferably with comments, regarding accepting this as a work item.

Thanks,

Kind Regards

Kepeng & Hannes

---

From: "Cuellar, Jorge" <[email-masked]>
Date: Wed, 5 Aug 2015 14:59:39 +0000

I support adopting the draft as wg item.

Best,

Jorge

From: Ace [mailto:[email-masked]] On Behalf Of Kepeng Li
Sent: Friday, July 24, 2015 7:18 AM
To: [email-masked]<mailto:[email-masked]>
Cc: Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>
Subject: [Ace] Call for adoption for draft-gerdes-ace-actors-05

Hello all,

Thanks,

Kind Regards
Kepeng & Hannes