Subject: Re: [Ace] discussion on draft-vasu-ace-core-access-privilege-provisoining-00

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 2 May 2016 13:08:20 +0200

Hi Vasu,

thanks for your response.

> Could you explain a little bit what you mean by "verifies the device operation", and "integrity check with the network"?
> ---> Sorry for the wording, maybe it is not conveying the actual meaning. 
> ---> I mean it verifies whether the device can be operational in the network or not, and can join to the network or not.

Your description is a bit too fuzzy to be practical.  How can the
Commissioner determine when a device is "operational in a network" and
whether it can "join a network"? Neither 'joining' nor 'operational' are
concepts that are well defined in your write-up so that someone could
write code for it.

Ciao
Hannes

> 
> Thanks and Best Regards
> K Vasu
> 
> 
> -----Original Message-----
> From: Ace [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: 2016年4月23日 0:30
> To: [email-masked]
> Subject: Ace Digest, Vol 29, Issue 18
> 
> Send Ace mailing list submissions to
> 	[email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> 	https://www.ietf.org/mailman/listinfo/ace
> or, via email, send a message with subject or body 'help' to
> 	[email-masked]
> 
> You can reach the person managing the list at
> 	[email-masked]
> 
> When replying, please edit your Subject line so it is more specific than "Re: Contents of Ace digest..."
> 
> 
> 
> _______________________________________________
> Ace mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ace
>

---

From: Vasu Kantubukta <[email-masked]>
Date: Wed, 4 May 2016 13:14:35 +0000

Hi Hannes,

Plz find my inline response below

Your description is a bit too fuzzy to be practical.  How can the Commissioner determine when a device is "operational in a network" and whether it can "join a network"? Neither 'joining' nor 'operational' are concepts that are well defined in your write-up so that someone could write code for it.

---> Thanks for the suggestion, We will update the draft with more details about commissioning.

FYI, Plz find the commissioning is as explained below: 

We define commissioning at two stages: commissioning at pre-configuration, and commissioning at post configuration.

Commissioning before pre-configuration is a known topic as explained below: 
There are two functionalities for the commissioning of device i.e. commissioning server ( at End Device), and commissioning client (at Smart phone/tablet--CA). Initially any device that wishes to join to the network will advertize its identity (with any UUID/Manufacturer id of device) to the commissioning client. Once the device provides its commissioning profile information (i.e. Can be any device profile info) to the commissioning client, then commissioning client provides network configuration information (such as SSID, password) to the  commissioning server. Then commissioning server can use this information to connect to the m2mgw.

Commissioning at post configuration is something what we used in the draft. For example, after service advertised to rd server, commissioning client can define policies (admission and resource control policies) for the registered service at the provisioning server.

Thanks and Best Regards
K Vasu

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]] 
Sent: 2016年5月2日 16:38
To: Vasu Kantubukta; [email-masked]
Subject: Re: [Ace] discussion on draft-vasu-ace-core-access-privilege-provisoining-00

Hi Vasu,

> ---> I mean it verifies whether the device can be operational in the network or not, and can join to the network or not.

Your description is a bit too fuzzy to be practical.  How can the Commissioner determine when a device is "operational in a network" and whether it can "join a network"? Neither 'joining' nor 'operational' are concepts that are well defined in your write-up so that someone could write code for it.

Ciao
Hannes