Subject: Re: [Ace] A question for the ACE framework and CWT

From: Samuel Erdtman <[email-masked]>
Date: Tue, 5 Jul 2016 22:45:07 +0200

ping, any thoughts on this?

//Samuel

On Tue, Jun 21, 2016 at 8:32 AM, Samuel Erdtman <[email-masked]> wrote:

> It was pointed out to me that the sentence below ended abruptly (thanks
> Ludwig)
>
> "On the other hand it is not relay necessary to have it there, the reason
> for the mapping registries is to avoid CBOR label/key conflicts between
> attributes. So information about"
>
> It should be
>
> On the other hand it is not relay necessary to have it there, the reason
> for the mapping registries is to avoid CBOR label/key conflicts between
> attributes. So information about major type can just as well be kept in the
> specification defining the mapping.
>
> //Samuel
>
> On Sat, Jun 18, 2016 at 12:38 PM, Samuel Erdtman <[email-masked]>
> wrote:
>
>> Hi
>>
>> When writing the IANA mapping sections for the ACE framework and CWT I
>> first required registrations to include the CBOR major type, Later I did
>> not (e.g.
>> https://tools.ietf.org/html/draft-ietf-ace-oauth-authz-02#section-10.7).
>> I would like to here the preferences of the group so that we can update
>> mapping registries to have the same format.
>>
>> The benefit of having the CBOR major type in the registry is that one
>> then has more of the important information in one place.
>>
>> On the other hand it is not relay necessary to have it there, the reason
>> for the mapping registries is to avoid CBOR label/key conflicts between
>> attributes. So information about
>>
>> In COSE (https://tools.ietf.org/html/draft-ietf-cose-msg-13) it is
>> included "value  This contains the CBOR type for the value portion of the
>> label."
>>
>> I would vote to keep data in registries at a minimum, i.e. exclude CBOR
>> Major type from there.
>>
>> Opinions?
>>
>> Best regards
>> //Samuel
>>
>>
>>
>

---

From: Mike Jones <[email-masked]>
Date: Tue, 5 Jul 2016 20:55:12 +0000

I agree that we don’t need to / want to add this to the registry.

From: Ace [mailto:[email-masked]] On Behalf Of Samuel Erdtman
Sent: Tuesday, July 5, 2016 1:45 PM
To: [email-masked]
Subject: Re: [Ace] A question for the ACE framework and CWT

On Tue, Jun 21, 2016 at 8:32 AM, Samuel Erdtman <[email-masked]<mailto:[email-masked]>> wrote:
It was pointed out to me that the sentence below ended abruptly (thanks Ludwig)

"On the other hand it is not relay necessary to have it there, the reason for the mapping registries is to avoid CBOR label/key conflicts between attributes. So information about"

It should be

On the other hand it is not relay necessary to have it there, the reason for the mapping registries is to avoid CBOR label/key conflicts between attributes. So information about major type can just as well be kept in the specification defining the mapping.
//Samuel

On Sat, Jun 18, 2016 at 12:38 PM, Samuel Erdtman <[email-masked]<mailto:[email-masked]>> wrote:
Hi
When writing the IANA mapping sections for the ACE framework and CWT I first required registrations to include the CBOR major type, Later I did not (e.g. https://tools.ietf.org/html/draft-ietf-ace-oauth-authz-02#section-10.7). I would like to here the preferences of the group so that we can update mapping registries to have the same format.
The benefit of having the CBOR major type in the registry is that one then has more of the important information in one place.
On the other hand it is not relay necessary to have it there, the reason for the mapping registries is to avoid CBOR label/key conflicts between attributes. So information about

In COSE (https://tools.ietf.org/html/draft-ietf-cose-msg-13) it is included "value  This contains the CBOR type for the value portion of the label."
I would vote to keep data in registries at a minimum, i.e. exclude CBOR Major type from there.

Opinions?
Best regards
//Samuel