Subject: [Ace] ACE Roadmap Wiki (Was: Re: Volunteer to set up the wiki)

From: Göran Selander <[email-masked]>
Date: Wed, 27 Sep 2017 11:46:48 +0000

Hi all,

Here is a first attempt to draw a table outlining and comparing the
proposed ACE profiles:

https://trac.ietf.org/trac/ace/wiki/WikiStart

The table is not complete and some of the values I filled in quickly, so
profile authors are invited to verify and change/add to this table. In
order to edit the page you need to log in using your IETF datatracker
account. Please make your contribution before the end of next week
(October 6th).

The purpose of this exercise is to get an overview of the drafts targeting
the current charter and how they depend to each other. If you have any
comments, please let me know.

Best regards,
Göran

On 2017-09-18 18:44, "Göran Selander" <[email-masked]> wrote:

>Hi Kathleen, and all,
>
>Yes, I started today but got interrupted. I added your items to the list
>just now. 
>
>All: If you are missing some comparison criteria please add directly to
>the Wiki or respond to this mail
>
>
>Best regards,
>Göran
>
>
>On 2017-09-18 18:31, "Kathleen Moriarty"
><[email-masked]> wrote:
>
>>Hi Goran,
>>
>>I see you've started working on the wiki template, thank you!  You may
>>already have this as a planned addition, but I'd like to see
>>implementation and use cases listed as comparison points too.  This
>>might assist the working group with prioritization.
>>
>>Thanks, again!
>>Kathleen
>>
>>On Thu, Sep 14, 2017 at 9:57 AM, Göran Selander
>><[email-masked]> wrote:
>>> Hi Cigdem,
>>>
>>> From: Cigdem Sengul <[email-masked]>
>>> Date: Tuesday 12 September 2017 at 18:49
>>> To: Göran Selander <[email-masked]>
>>> Cc: Kathleen Moriarty <[email-masked]>,
>>>"[email-masked]"
>>> <[email-masked]>
>>> Subject: Re: [Ace] Volunteer to set up the wiki
>>>
>>> Hello,
>>>
>>> +1 for row and column information. For completeness sake,
>>> I was thinking whether the column information should be the  coming
>>>from the
>>> list in draft-ietf-ace-oauth-authz-07,  Appendix C.  Requirements on
>>> Profiles.
>>>
>>>
>>> Yes, that’s a good starting point.
>>>
>>> Thanks,
>>> Göran
>>>
>>>
>>> Thanks,
>>> --Cigdem
>>>
>>>
>>> On Tue, Sep 12, 2017 at 4:41 PM, Göran Selander
>>> <[email-masked]> wrote:
>>>>
>>>> Hi Kathleen,
>>>>
>>>> As I remember the reason to set up the Wiki was to generate a roadmap
>>>>for
>>>> the ACE work. We noted dependencies and potential overlap between
>>>> different profiles and some content rather belonging to the framework
>>>>than
>>>> individual profile. A starting point for deciding on the roadmap could
>>>>be
>>>> a table with rows for each profile and where the columns could be some
>>>> distinguishing features of each profile such as: the scope of the
>>>>profile,
>>>> nodes (if other than client and RS), protocols used between nodes
>>>> (including security protocols), dependence on other profiles,
>>>>candidate
>>>> framework functionality described in the draft, etc.
>>>>
>>>> If people agree with this I can help setting up the table, and those
>>>> proposing profiles could fill in the rows.
>>>>
>>>>
>>>> Best regards,
>>>> Göran
>>>>
>>>>
>>>>
>>>> On 2017-09-12 16:16, "Ace on behalf of Kathleen Moriarty"
>>>> <[email-masked] on behalf of [email-masked]>
>>>> wrote:
>>>>
>>>> >Hello,
>>>> >
>>>> >In Prague, we agreed as a next step we would pull together a
>>>> >comparison chart for profiles using the WG wiki.  Can I get a
>>>> >volunteer to set up the wiki page?  You should first get agreement
>>>> >(light agreement as we need to move on this) as to what we want to
>>>> >compare.  The list for comparison does not appear in the minutes, but
>>>> >was discussed in the meeting, so the recording might be helpful.
>>>> >
>>>> >Here is a link to the wiki:
>>>> >https://trac.ietf.org/trac/ace
>>>> >--
>>>> >
>>>> >Best regards,
>>>> >Kathleen
>>>> >
>>>> >_______________________________________________
>>>> >Ace mailing list
>>>> >[email-masked]
>>>> >https://www.ietf.org/mailman/listinfo/ace
>>>>
>>>> _______________________________________________
>>>> Ace mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/ace
>>>
>>>
>>>
>>> _______________________________________________
>>> Ace mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/ace
>>>
>>
>>
>>
>>-- 
>>
>>Best regards,
>>Kathleen
>

---

From: Göran Selander <[email-masked]>
Date: Wed, 27 Sep 2017 15:35:10 +0000

Hi again, 

One more thing: If we have missed some criteria for comparing the
profiles, just add another column.

Göran