Subject: Re: [Ace] Working group adoption of draft-vanderstok-ace-est

From: Eliot Lear <[email-masked]>
Date: Thu, 1 Feb 2018 09:57:03 +0100

Hi Jim,

I agree that this document should be adopted.  I am willing to review
and comment.

Eli

On 30.01.18 21:23, Jim Schaad wrote:
> This is the start of a two week call for input on the adoption of the WG of
> the document draft-vanderstok-ace-est.  The document has been presented at
> the last two meetings and has some significant recent updates to respond to
> feedback.  There seemed to be support at the last F2F to adopt. 
>
> Please provide feedback to the list/chairs if you believe that this document
> should be adopted as a WG document.    The adoption call will end on Feb 13
> 2018.
>
> Jim
>
>
> _______________________________________________
> Ace mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ace
>

---

From: Sandeep Kumar <[email-masked]>
Date: Thu, 1 Feb 2018 10:40:59 +0000

As co-author, I support adoption of the draft as WG document. There is need in industry and multiple standardization bodies for this draft.

Regards
Sandeep

-----Original Message-----
From: Ace [mailto:[email-masked]] On Behalf Of Jim Schaad
Sent: Tuesday, January 30, 2018 9:23 PM
To: [email-masked]
Subject: [Ace] Working group adoption of draft-vanderstok-ace-est

This is the start of a two week call for input on the adoption of the WG of the document draft-vanderstok-ace-est.  The document has been presented at the last two meetings and has some significant recent updates to respond to feedback.  There seemed to be support at the last F2F to adopt.

Jim

________________________________
The information contained in this email may be confidential and/or legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this email is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original email.

---

From: Shahid Raza <[email-masked]>
Date: Thu, 1 Feb 2018 10:56:16 +0000

As a co-author, I also strongly support the adoption of this draft as a WG document. Recall that , we already have an implementation of this draft, both in constrained devices (SICS Contiki) and in the Nexus CA software. Recently, we have also implemented the "integration of this draft into LwM2M", which is part of the latest LwM2M release.

Best,
Shahid

Shahid Raza, PhD
Director Security Lab and Expert Researcher
RISE - Research Institutes of Sweden
Division ICT - RISE SICS

[RISE logo]     Isafjordsgatan 22 / Kistagången 16
16440, Kista Stockholm
Mobile: +46 768831797
[email-masked] <mailto:[email-masked]>
http://www.shahidraza.net<http://www.shahidraza.info>
http://www.sics.se

The RISE institutes Innventia, SP and Swedish ICT have merged in order to become a stronger research and innovation partner for businesses and society.

On 1 Feb 2018, at 11:40, Sandeep Kumar <[email-masked]<mailto:[email-masked]>> wrote:

Regards
Sandeep

-----Original Message-----
From: Ace [mailto:[email-masked]] On Behalf Of Jim Schaad
Sent: Tuesday, January 30, 2018 9:23 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Ace] Working group adoption of draft-vanderstok-ace-est

Jim

_______________________________________________
Ace mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ace

---

From: "Beck, Stefan" <[email-masked]>
Date: Thu, 1 Feb 2018 11:51:57 +0000

+1
I support adoption, as it perfectly complements the existing EST work.

So far, just one general comment:
The draft could emphasize (e.g. in the intro) that coexistence of EST and EST-coaps is supported in target deployments. And you even may have a combination of constrained devices in a non-constrained network and vice versa.
If that matches the authors’ view, then some general statements need to be adapted. Two examples see below

Stevie

1. Abstract:
 "This allows low-resource constrained devices to re-use existing EST functionality. Example low-resource use cases for EST are: secure bootstrapping and certificate enrollment."

Well, to me those are the two main use cases for non-constrained devices using EST, too. So I would write:
 "This allows low-resource constrained devices to re-use existing EST functionality to implement use cases such as secure bootstrapping and certificate enrollment."

2. Chapter 3.5 (Deployment limits):
2a. " Although EST-coaps paves the way for the utilization of EST for constrained devices on constrained networks..."
--> s?on?and/or?

2b. " EST-coaps is intended to ensure that EST works for networks of constrained devices that choose to limit their communications stack to UDP/CoAP."
--> Remove "networks of"

---------------------
From: Ace [mailto:[email-masked]] On Behalf Of Shahid Raza
Sent: Thursday, February 01, 2018 11:56 AM
To: Sandeep Kumar <[email-masked]>
Cc: Jim Schaad <[email-masked]>; [email-masked]
Subject: Re: [Ace] Working group adoption of draft-vanderstok-ace-est

Best,
Shahid

Shahid Raza, PhD

Isafjordsgatan 22 / Kistagången 16 
16440, Kista Stockholm 
Mobile: +46 768831797 
[email-masked] 
http://www.shahidraza.net 
http://www.sics.se 
The RISE institutes Innventia, SP and Swedish ICT have merged in order to become a stronger research and innovation partner for businesses and society.

On 1 Feb 2018, at 11:40, Sandeep Kumar <[email-masked]> wrote:

Regards
Sandeep

-----Original Message-----
From: Ace [mailto:[email-masked]] On Behalf Of Jim Schaad
Sent: Tuesday, January 30, 2018 9:23 PM
To: [email-masked]
Subject: [Ace] Working group adoption of draft-vanderstok-ace-est

Jim

---

From: peter van der Stok <[email-masked]>
Date: Fri, 02 Feb 2018 09:45:24 +0100

Hi Stefan,

Thanks for the support.
I see your point of view; We will look at the text to avoid suggesting 
that EST/https and EST/coaps cannot exist together.

Peter

Beck, Stefan schreef op 2018-02-01 12:51:
> The draft could emphasize (e.g. in the intro) that coexistence of EST
> and EST-coaps is supported in target deployments. And you even may
> have a combination of constrained devices in a non-constrained network
> and vice versa.
>  "This allows low-resource constrained devices to re-use existing EST
> functionality. Example low-resource use cases for EST are: secure
> bootstrapping and certificate enrollment."
> 
> Well, to me those are the two main use cases for non-constrained
> devices using EST, too. So I would write:
>  "This allows low-resource constrained devices to re-use existing EST
> functionality to implement use cases such as secure bootstrapping and
> certificate enrollment."
> 
> 
> 2a. " Although EST-coaps paves the way for the utilization of EST for
> constrained devices on constrained networks..."
> --> s?on?and/or?
> 
> 2b. " EST-coaps is intended to ensure that EST works for networks of
> constrained devices that choose to limit their communications stack to
> UDP/CoAP."
> --> Remove "networks of"
> 
> ---------------------
> As a co-author, I also strongly support the adoption of this draft as
> a WG document. Recall that , we already have an implementation of this
> draft, both in constrained devices (SICS Contiki) and in the Nexus CA
> software. Recently, we have also implemented the "integration of this
> draft into LwM2M", which is part of the latest LwM2M release.
> 
> Best,
> Shahid
> 
> Shahid Raza, PhD
> The RISE institutes Innventia, SP and Swedish ICT have merged in order
> to become a stronger research and innovation partner for businesses
> and society.
> 
> 
> As co-author, I support adoption of the draft as WG document. There is
> need in industry and multiple standardization bodies for this draft.
> 
> Regards
> Sandeep
> 
> This is the start of a two week call for input on the adoption of the
> WG of the document draft-vanderstok-ace-est.  The document has been
> presented at the last two meetings and has some significant recent
> updates to respond to feedback.  There seemed to be support at the
> last F2F to adopt.
> 
> The information contained in this email may be confidential and/or
> legally protected under applicable law. The message is intended solely
> for the addressee(s). If you are not the intended recipient, you are
> hereby notified that any use, forwarding, dissemination, or
> reproduction of this email is strictly prohibited and may be unlawful.
> If you are not the intended recipient, please contact the sender by
> return e-mail and destroy all copies of the original email.
>

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Fri, 2 Feb 2018 20:18:10 +0000

I support the adoption of this draft.  The industrial IoT sector is establishing certificate based secure communications and will need a secure means to manage these certificates.  With the use of CoAp in that space, this draft can be the what/how to achieve just that.

Warm regards, Nancy

On 1/30/18, 12:23 PM, "Ace on behalf of Jim Schaad" <[email-masked] on behalf of [email-masked]> wrote:

    
    Jim

---

From: "Rupak Chandra (ruchandr)" <[email-masked]>
Date: Fri, 2 Feb 2018 20:47:44 +0000

I support the adoption of this draft. There is a great need for a standards based mechanism for secure enrollment of constrained endpoints, which this draft provides.

Thanks
Rupak
-----Original Message-----
From: Ace [mailto:[email-masked]] On Behalf Of Jim Schaad
Sent: Tuesday, January 30, 2018 12:23 PM
To: [email-masked]
Subject: [Ace] Working group adoption of draft-vanderstok-ace-est

Jim

---

From: Esko Dijk <[email-masked]>
Date: Tue, 13 Feb 2018 15:54:55 +0000

I support the WG adoption of this document. It will be a useful component to create a security solution for IoT  devices. On the current or a future version of this draft I can do a review, also.

Best regards
Esko Dijk

-----Original Message-----
From: Ace [mailto:[email-masked]] On Behalf Of Jim Schaad
Sent: Tuesday, January 30, 2018 21:23
To: [email-masked]
Subject: [Ace] Working group adoption of draft-vanderstok-ace-est

Jim

---

From: Göran Selander <[email-masked]>
Date: Wed, 14 Feb 2018 08:52:11 +0000

Sorry for being late- I also support adoption of this draft as it is a
natural optimization of EST making use of existing IoT device stacks.

Göran

On 2018-01-30 21:23, "Ace on behalf of Jim Schaad" <[email-masked]

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 19 Feb 2018 15:11:22 +0000

I support the adoption of this document. My concerns with earlier versions of the document have been addressed with the recent draft updates.

I have read the latest version of the draft and I believe it is even ready for a working group last call once adopted.

Ciao
Hannes

PS: Sorry for my late response.

-----Original Message-----
From: Ace [mailto:[email-masked]] On Behalf Of Jim Schaad
Sent: 30 January 2018 21:23
To: [email-masked]
Subject: [Ace] Working group adoption of draft-vanderstok-ace-est

Jim

_______________________________________________
Ace mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ace
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.