Subject: [Ace] Early media-type registration for EST over CoAP

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 15 May 2018 08:56:18 +0000

I get the impression that the EST over CoAP spec will not completed as soon as I had hoped.

I am curious whether it would be possible to ask for early media-type registration of at least these two types:
- application/pkcs7-mime
- application/pkcs10

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 15 May 2018 11:45:13 +0200

> I am curious whether it would be possible to ask for early media-type registration of at least these two types:

There already are registered.

I think you are talking about getting Content-Format numbers for these?
Do we need any parameters or content-codings with that?

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Tue, 15 May 2018 13:20:23 -0400

> I am curious whether it would be possible to ask for early media-type registration of at least these two types:

As previously said, these are already defined as MIME-TYPES, but
we need to get them CoAP CT= bindings.

We also need application/csrattrs and application/pkcs8.
And we need rt=ace.est.

All the chairs need to do is ask the AD.

Hannes: do you have any opinion about the necessity of going through
/.well-known/core to get the short URL, vs just using a /.well-known/est URL?
(RTT for the lookup vs extra bytes in the URL)

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 16 May 2018 10:15:35 +0000

Hi Carsten,

Yes, I am talking about the Content-Format numbers for them.
Would rt="ace.est" be the parameter you are talking about?

Ciao
Hannes

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]]
Sent: 15 May 2018 11:45
To: Hannes Tschofenig
Cc: [email-masked]; core
Subject: Re: [Ace] Early media-type registration for EST over CoAP

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 16 May 2018 12:26:40 +0200

I was thinking about media type parameters such as charset="utf-8". The RT value need to be registered separately, but we can be a bit lazy about that. 

Sent from mobile

> On 16. May 2018, at 12:15, Hannes Tschofenig <[email-masked]> wrote:
> 
> Hi Carsten,
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 16 May 2018 12:29:40 +0200

Forgot to add another example: the content-format numbers for COSE have parameters. 

Sent from mobile

> On 16. May 2018, at 12:26, Carsten Bormann <[email-masked]> wrote:
>

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 16 May 2018 10:39:46 +0000

> Hannes: do you have any opinion about the necessity of going through /.well-known/core to get the short URL, vs just using a /.well-known/est URL?

Are you asking me about these two options:

Option #1 - going through /.well-known/core

     REQ: GET /.well-known/core?rt=ace.est

     RES: 2.05 Content
   </est-root >; rt="ace.est"

Option #2 - using a /.well-known/est URL

     REQ: GET /.well-known/est

     RES: 2.05 Content
   </est-root>; rt="ace.est"

---

From: Michael Richardson <[email-masked]>
Date: Wed, 16 May 2018 08:15:52 -0400

>> /.well-known/core to get the short URL, vs just using a

Yes, exactly.  Is option #1 useful enough to justify the code to parse
links?  Os is the code impact already paid for in your view?

    >      RES: 2.05 Content </est-root >; rt="ace.est"

    >      RES: 2.05 Content </est-root>; rt="ace.est"

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 16 May 2018 12:49:06 +0000

I don't have a strong opinion about option #2 appears to be slightly better.

I guess hard-cording URLs will not work....

-----Original Message-----
From: Michael Richardson [mailto:[email-masked]]
Sent: 16 May 2018 14:16
To: Hannes Tschofenig
Cc: [email-masked]
Subject: Re: [Ace] Early media-type registration for EST over CoAP

    >> /.well-known/core to get the short URL, vs just using a

Yes, exactly.  Is option #1 useful enough to justify the code to parse links?  Os is the code impact already paid for in your view?

--
Michael Richardson <[email-masked]>, Sandelman Software Works  -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Wed, 16 May 2018 21:39:03 -0400

> I don't have a strong opinion about option #2 appears to be slightly

Oh, I misread your options before.

    >> RES: 2.05 Content </est-root>; rt="ace.est"

Option 2 is not substituting /.well-known/core for /.well-known/est
(and doing resource discovery and then learn one uses /est-root/rv, etc.)
but rather not doing resource discovery, just go directly
to /.well-known/est/rv, which is what we do in RFC7030.

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 24 May 2018 14:15:54 +0000

Hi all,

Trying to finalize this discussion: Could we do an early registry of the Content-Format numbers?

From the discussion so far I believe we concluded that the charset is utf-8 and that there are no parameters. Is that correct?

Ciao
Hannes

Sent: 16 May 2018 12:30

On 16. May 2018, at 12:26, Carsten Bormann <[email-masked]<mailto:[email-masked]>> wrote:
I was thinking about media type parameters such as charset="utf-8". The RT value need to be registered separately, but we can be a bit lazy about that.
Sent from mobile

On 16. May 2018, at 12:15, Hannes Tschofenig <[email-masked]<mailto:[email-masked]>> wrote:
Hi Carsten,

Ciao
Hannes

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]]
Sent: 15 May 2018 11:45
To: Hannes Tschofenig
Cc: [email-masked]<mailto:[email-masked]>; core
Subject: Re: [Ace] Early media-type registration for EST over CoAP

On May 15, 2018, at 10:56, Hannes Tschofenig <[email-masked]<mailto:[email-masked]>> wrote:

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 24 May 2018 16:37:20 +0200

> Trying to finalize this discussion: Could we do an early registry of the Content-Format numbers?

Yes.
 
> From the discussion so far I believe we concluded that the charset is utf-8

What charset?  I thought we don’t have parameters (see below).

> and that there are no parameters. Is that correct?

That is my understanding so far, but the point of me asking the question was to ask the actual experts about these media types.  Did we get that input?

Next step: make a proposal and raise this on [email-masked] so we get the needed input from the designated expert.

Grüße, Carsten

> IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you. _______________________________________________
> Ace mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ace

---

From: peter van der Stok <[email-masked]>
Date: Thu, 24 May 2018 16:54:34 +0200

Ok, I will raise the experts to-morrow.

Peter

Carsten Bormann schreef op 2018-05-24 16:37:
> That is my understanding so far, but the point of me asking the
> question was to ask the actual experts about these media types.  Did
> we get that input?
> 
> Next step: make a proposal and raise this on [email-masked]
> so we get the needed input from the designated expert.
> 
> Grüße, Carsten
> 
> 
>> 
>> Ciao
>> Hannes
>> 
>> I was thinking about media type parameters such as charset="utf-8". 
>> The RT value need to be registered separately, but we can be a bit 
>> lazy about that.
>> 
>> Sent from mobile
>> 
>> I am curious whether it would be possible to ask for early media-type 
>> registration of at least these two types:
>> - application/pkcs7-mime
>> - application/pkcs10
>> 
>> IMPORTANT NOTICE: The contents of this email and any attachments are 
>> confidential and may also be privileged. If you are not the intended 
>> recipient, please notify the sender immediately and do not disclose 
>> the contents to any other person, use it for any purpose, or store or 
>> copy the information in any medium. Thank you.
>> 
>> 
>> IMPORTANT NOTICE: The contents of this email and any attachments are 
>> confidential and may also be privileged. If you are not the intended 
>> recipient, please notify the sender immediately and do not disclose 
>> the contents to any other person, use it for any purpose, or store or 
>> copy the information in any medium. Thank you. 
>> _______________________________________________
>> Ace mailing list
>> [email-masked]
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Klaus Hartke <[email-masked]>
Date: Fri, 25 May 2018 12:23:09 +0200

Carsten Bormann wrote:
> Next step: make a proposal and raise this on [email-masked] so
we get the needed input from the designated expert.

Done.
https://www.ietf.org/mail-archive/web/core-parameters/current/msg00024.html

Klaus