Subject: [Ace] FW: New Version Notification for draft-schaad-cnf-cwt-id-00.txt

From: Jim Schaad <[email-masked]>
Date: Mon, 22 Oct 2018 11:49:01 -0700

I did not like the idea of using key identifiers when linking together CWTs for authorization purposes.  As part of that discussion I came up with the idea of using the CWT identifier instead since that is going to be specific to an AS.  This draft is a brief description of the idea and I would like to know how interested people would be in getting it finished.

Jim

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Monday, October 22, 2018 11:19 AM
To: Jim Schaad <[email-masked]>
Subject: New Version Notification for draft-schaad-cnf-cwt-id-00.txt

A new version of I-D, draft-schaad-cnf-cwt-id-00.txt has been successfully submitted by Jim Schaad and posted to the IETF repository.

Name:		draft-schaad-cnf-cwt-id
Revision:	00
Title:		Use of a CWT identifier as a Confirmation Method
Document date:	2018-10-22
Group:		Individual Submission
Pages:		6
URL:            https://www.ietf.org/internet-drafts/draft-schaad-cnf-cwt-id-00.txt
Status:         https://datatracker.ietf.org/doc/draft-schaad-cnf-cwt-id/
Htmlized:       https://tools.ietf.org/html/draft-schaad-cnf-cwt-id-00
Htmlized:       https://datatracker.ietf.org/doc/html/draft-schaad-cnf-cwt-id

Abstract:
   TBD

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 22 Oct 2018 21:09:14 +0200

On Oct 22, 2018, at 20:49, Jim Schaad <[email-masked]> wrote:
> 
> I did not like the idea of using key identifiers when linking together CWTs for authorization purposes.  

Right, they are not very useful as they don’t say anything about the authorization information that is attached to that key in a specific CWT.

> As part of that discussion I came up with the idea of using the CWT identifier instead since that is going to be specific to an AS.  

Sounds better.  I would feel even better if I knew what exactly that scope “an AS” is (it is not represented in the CWT, so there is some misuse potential).

> This draft is a brief description of the idea and I would like to know how interested people would be in getting it finished.

Will read it after the frenzy…

Grüße, Carsten

---

From: Jim Schaad <[email-masked]>
Date: Mon, 22 Oct 2018 14:02:14 -0700

> From: Carsten Bormann <[email-masked]>
> Sent: Monday, October 22, 2018 12:09 PM
> Cc: [email-masked]
> Subject: Re: [Ace] FW: New Version Notification for draft-schaad-cnf-cwt-id-
> 00.txt
> 
> Right, they are not very useful as they don’t say anything about the
> authorization information that is attached to that key in a specific CWT.
> 
> > As part of that discussion I came up with the idea of using the CWT
> identifier instead since that is going to be specific to an AS.
> 
> Sounds better.  I would feel even better if I knew what exactly that scope “an
> AS” is (it is not represented in the CWT, so there is some misuse potential)

Actually this can be placed in a CWT as the issuer field.

Jim

.
> 
> > This draft is a brief description of the idea and I would like to know how
> interested people would be in getting it finished.
>