Subject: [Ace] [Editorial Errata Reported] RFC8392 (5852)

From: RFC Errata System <[email-masked]>
Date: Tue, 3 Sep 2019 11:56:47 -0700 (PDT)

The following errata report has been submitted for RFC8392,
"CBOR Web Token (CWT)".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5852

--------------------------------------
Type: Editorial
Reported by: Laurence Lundblade <[email-masked]>

Section: A.3

Original Text
-------------
   d28443a10126a104524173796d6d657472696345434453413235365850a701756
   36f61703a2f2f61732e6578616d706c652e636f6d02656572696b77037818636f
   61703a2f2f6c696768742e6578616d706c652e636f6d041a5612aeb0051a5610d
   9f0061a5610d9f007420b7158405427c1ff28d23fbad1f29c4c7c6a555e601d6f
   a29f9179bc3d7438bacaca5acd08c8d4d4f96131680c429a01f85951ecee743a5
   2b9b63632c57209120e1c9e30

Corrected Text
--------------
   d28443a10126a104524173796d6d657472696345434453413235365850a70175
   636f61703a2f2f61732e6578616d706c652e636f6d02656572696b7703781863
   6f61703a2f2f6c696768742e6578616d706c652e636f6d041a5612aeb0051a56
   10d9f0061a5610d9f007420b7158405427c1ff28d23fbad1f29c4c7c6a555e60
   1d6fa29f9179bc3d7438bacaca5acd08c8d4d4f96131680c429a01f85951ecee
   743a52b9b63632c57209120e1c9e30

Notes
-----
The ASCII representation of binary bytes in Figure 10 is wrapped
on an odd number of ASCII characters. Since there are two ASCII
characters per binary bytes this splits the last byte over two
lines. 

The CBOR playground (http://cbor.me) cannot handle this and
errors out. 

This is slightly confusing for readers.

The actual bytes values are correct by all the checks I did.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8392 (draft-ietf-ace-cbor-web-token-15)
--------------------------------------
Title               : CBOR Web Token (CWT)
Publication Date    : May 2018
Author(s)           : M. Jones, E. Wahlstroem, S. Erdtman, H. Tschofenig
Category            : PROPOSED STANDARD
Source              : Authentication and Authorization for Constrained Environments
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Jim Schaad <[email-masked]>
Date: Tue, 3 Sep 2019 12:26:12 -0700

Recommend hold for update.

-----Original Message-----
From: RFC Errata System <[email-masked]> 
Sent: Tuesday, September 3, 2019 11:57 AM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Editorial Errata Reported] RFC8392 (5852)

The following errata report has been submitted for RFC8392, "CBOR Web Token (CWT)".

Section: A.3

Original Text
-------------

Corrected Text
--------------

Notes
-----
The ASCII representation of binary bytes in Figure 10 is wrapped on an odd number of ASCII characters. Since there are two ASCII characters per binary bytes this splits the last byte over two lines. 

The CBOR playground (http://cbor.me) cannot handle this and errors out. 

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please use "Reply All" to discuss whether it should be verified or rejected. When a decision is reached, the verifying party can log in to change the status and edit the report, if necessary.

---

From: Samuel Erdtman <[email-masked]>
Date: Wed, 4 Sep 2019 08:15:17 +0200

+1

On Tue, Sep 3, 2019 at 9:26 PM Jim Schaad <[email-masked]> wrote:

> To: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> The ASCII representation of binary bytes in Figure 10 is wrapped on an odd
> number of ASCII characters. Since there are two ASCII characters per binary
> bytes this splits the last byte over two lines.
>
> This erratum is currently posted as "Reported". If necessary, please use
> "Reply All" to discuss whether it should be verified or rejected. When a
> decision is reached, the verifying party can log in to change the status
> and edit the report, if necessary.
>