Subject: [Ace] ace-key-groupcomm-oscore-03

From: Peter van der Stok <[email-masked]>
Date: Tue, 19 Nov 2019 10:12:22 +0100

Hi Authors,

Having read the document and comparing it with ace-key-groupcomm, I have
to agree with Jim that this document repeats in "other" words the same
subjects as specified in ace-key-groupcomm.
In this form, it is very difficult to find out the differences between
the two documents.

It would be good if the same terminology was used or their equivalence
was pointed out:
eg: Client vs joining node
Group-manager versus KDC
joining request versus joining authorization

Secondly, I suggest to make this draft much shorter, and mostly refer to
the sections of ace-key-groupcomm and point out the differences. In many
cases a list of items that MUST be present, are optional or not present
at all will suffice. 
For example such an enumeration is done under the bullet key on page 15.

New parameters can receive more text as is done for cs_alg, cs_params,
cs_key_params, and cs_key_enc.

Hope this helps,
Thanks for all your work,
greetings,

Peter 
-- 

Peter van der Stok
vanderstok consultancy
mailto: [email-masked], [email-masked]
www: www.vanderstok.org [1]
tel NL: +31(0)492474673     F: +33(0)966015248 

Links:
------
[1] http://www.vanderstok.org

---

From: Francesca Palombini <[email-masked]>
Date: Wed, 20 Nov 2019 02:25:11 +0000

Hi Peter!

Thanks for your comment. We will definitely go back to try to shorten and remove duplicate text even more, I agree with you that we could do better there.

I might come back with questions on more precise advice once we give it another try.
Thanks!
Francesca

From: Ace <[email-masked]> on behalf of Peter van der Stok <[email-masked]>
Organisation: vanderstok consultancy
Reply to: "[email-masked]" <[email-masked]>
Date: Tuesday, 19 November 2019 at 17:12
To: Ace Wg <[email-masked]>
Subject: [Ace] ace-key-groupcomm-oscore-03

Hi Authors,

Having read the document and comparing it with ace-key-groupcomm, I have to agree with Jim that this document repeats in "other" words the same subjects as specified in ace-key-groupcomm.
In this form, it is very difficult to find out the differences between the two documents.

It would be good if the same terminology was used or their equivalence was pointed out:
eg: Client vs joining node
Group-manager versus KDC
joining request versus joining authorization

Secondly, I suggest to make this draft much shorter, and mostly refer to the sections of ace-key-groupcomm and point out the differences. In many cases a list of items that MUST be present, are optional or not present at all will suffice.
For example such an enumeration is done under the bullet key on page 15.

New parameters can receive more text as is done for cs_alg, cs_params, cs_key_params, and cs_key_enc.

Hope this helps,

Peter
--
Peter van der Stok
vanderstok consultancy
mailto: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
www: www.vanderstok.org<https://protect2.fireeye.com/v1/url?k=ef770c75-b3a30436-ef774cee-86a1150bc3ba-7bcc067d3277e8a2&q=1&e=6119d549-596d-4a75-8b43-57ff71dd5bd3&u=http%3A%2F%2Fwww.vanderstok.org%2F>
tel NL: +31(0)492474673     F: +33(0)966015248