Subject: [Ace] FW: [EXTERNAL] New Version Notification for draft-ietf-ace-oauth-authz-40.txt

From: Seitz Ludwig <[email-masked]>
Date: Mon, 26 Apr 2021 11:13:18 +0000

Hello ACE,

This update fixes the outstanding review comment from Roman about moving the text with considerations about storing multiple tokens to this document from the profiles (and some nits I discovered).

/Ludwig

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: den 26 april 2021 13:12
To: Erik Wahlstroem <[email-masked]>; Goeran Selander <[email-masked]>; Hannes Tschofenig <[email-masked]>; Seitz Ludwig <[email-masked]>; Samuel Erdtman <[email-masked]>
Subject: [EXTERNAL] New Version Notification for draft-ietf-ace-oauth-authz-40.txt

A new version of I-D, draft-ietf-ace-oauth-authz-40.txt has been successfully submitted by Ludwig Seitz and posted to the IETF repository.

Name:		draft-ietf-ace-oauth-authz
Revision:	40
Title:		Authentication and Authorization for Constrained Environments (ACE) using the OAuth 2.0 Framework (ACE-OAuth)
Document date:	2021-04-26
Group:		ace
Pages:		82
URL:            https://www.ietf.org/archive/id/draft-ietf-ace-oauth-authz-40.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-ace-oauth-authz/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-ace-oauth-authz
Htmlized:       https://tools.ietf.org/html/draft-ietf-ace-oauth-authz-40
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-ace-oauth-authz-40

Abstract:
   This specification defines a framework for authentication and
   authorization in Internet of Things (IoT) environments called ACE-
   OAuth.  The framework is based on a set of building blocks including
   OAuth 2.0 and the Constrained Application Protocol (CoAP), thus
   transforming a well-known and widely used authorization solution into
   a form suitable for IoT devices.  Existing specifications are used
   where possible, but extensions are added and profiles are defined to
   better serve the IoT use cases.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Seitz Ludwig <[email-masked]>
Date: Mon, 26 Apr 2021 11:23:25 +0000

Hello again,

It seems that the reference management system of xml2rfc is broken, since it resolved some ID-references to outdated versions (something I had to fix manually in -39 and hoped had gone away by now).

I will fix this in the IETF editor review.

/Ludwig

> From: Ace <[email-masked]> On Behalf Of Seitz Ludwig
> Sent: den 26 april 2021 13:13
> To: [email-masked]
> Subject: [Ace] FW: [EXTERNAL] New Version Notification for draft-ietf-ace-
> oauth-authz-40.txt
> 
> Hello ACE,
> 
> This update fixes the outstanding review comment from Roman about
> moving the text with considerations about storing multiple tokens to this
> document from the profiles (and some nits I discovered).
> 
> /Ludwig
> 
> To: Erik Wahlstroem <[email-masked]>; Goeran Selander
> <[email-masked]>; Hannes Tschofenig
> <[email-masked]>; Seitz Ludwig <[email-masked]>;
> Samuel Erdtman <[email-masked]>
> A new version of I-D, draft-ietf-ace-oauth-authz-40.txt has been successfully
> submitted by Ludwig Seitz and posted to the IETF repository.
> 
> Title:		Authentication and Authorization for
> Constrained Environments (ACE) using the OAuth 2.0 Framework (ACE-
> OAuth)
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> 
> _______________________________________________
> Ace mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ace

---

From: Daniel Migault <[email-masked]>
Date: Mon, 26 Apr 2021 13:37:32 +0000

Maybe just submit the txt version. It seems the xml2rfc version used on the web site has some issues. It seems version 3.7.0 has some issues. Using locally 3.5.0 which seems to work. I suggest for the time being, just submit the txt version and if that is not solved, we may simply send the xml version to the rfc editor. Maybe that will be raised by the AD. 
 
Yours 

-----Original Message-----
From: Ace <[email-masked]> On Behalf Of Seitz Ludwig
Sent: Monday, April 26, 2021 7:23 AM
To: [email-masked]
Subject: Re: [Ace] [EXTERNAL] New Version Notification for draft-ietf-ace-oauth-authz-40.txt

Hello again,

/Ludwig

> Subject: [Ace] FW: [EXTERNAL] New Version Notification for 
> draft-ietf-ace- oauth-authz-40.txt
> 
> Hello ACE,
> 
> moving the text with considerations about storing multiple tokens to 
> this document from the profiles (and some nits I discovered).
> 
> /Ludwig
> 
> A new version of I-D, draft-ietf-ace-oauth-authz-40.txt has been 
> successfully submitted by Ludwig Seitz and posted to the IETF repository.
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
>