Subject: Re: [Ace] I-D Action: draft-ietf-ace-key-groupcomm-14.txt

From: Daniel Migault <[email-masked]>
Date: Wed, 22 Dec 2021 19:55:30 -0500

Hi,

In order to complete the shepherd I would like the co-author to confirm
that any and all appropriate IPR disclosures required for full conformance
with the provisions of BCP 78 and BCP 79 have already been filed.

Please have also a look at the nits
https://www6.ietf.org/tools/idnits?url=https://www.ietf.org/archive/id/draft-ietf-ace-key-groupcomm-14.txt

There is a MAY NOT that causes an issue as well as unused references.

Yours,
Daniel

On Mon, Oct 25, 2021 at 12:48 PM Marco Tiloca <marco.tiloca=
[email-masked]> wrote:

> Hello ACE,
>
> This new version should have addressed all the WGLC comments from Göran
> [1] and Cigdem [2], as well as further points from follow-up discussions
> on the thread throughout the draft revision.
>
> Thank you very much for the good comments!
>
> Best,
> /Marco
>
> [1] https://mailarchive.ietf.org/arch/msg/ace/pr2gBhvqy9j8AfUdQVTZLwamXac/
>
> [2] https://mailarchive.ietf.org/arch/msg/ace/gv_uRo2Y45jqOLJghVSbAARWky0/
>
> On 2021-10-25 15:57, [email-masked] wrote:
> > A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> > This draft is a work item of the Authentication and Authorization for
> Constrained Environments WG of the IETF.
> >
> >          Title           : Key Provisioning for Group Communication
> using ACE
> >          Authors         : Francesca Palombini
> >                            Marco Tiloca
> >       Filename        : draft-ietf-ace-key-groupcomm-14.txt
> >       Pages           : 106
> >       Date            : 2021-10-25
> >
> > Abstract:
> >     This document defines how to use the Authentication and Authorization
> >     for Constrained Environments (ACE) framework to distribute keying
> >     material and configuration parameters for secure group communication.
> >     Candidate group members acting as Clients and authorized to join a
> >     group can do so by interacting with a Key Distribution Center (KDC)
> >     acting as Resource Server, from which they obtain the keying material
> >     to communicate with other group members.  While defining general
> >     message formats as well as the interface and operations available at
> >     the KDC, this document supports different approaches and protocols
> >     for secure group communication.  Therefore, details are delegated to
> >     separate application profiles of this document, as specialized
> >     instances that target a particular group communication approach and
> >     define how communications in the group are protected.  Compliance
> >     requirements for such application profiles are also specified.
> >
> >
> > The IETF datatracker status page for this draft is:
> >
> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-ace-key-groupcomm%2F&amp;data=04%7C01%7Cmarco.tiloca%40ri.se%7Ca638ee397ced4fc372ff08d997bf79b5%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637707672366321795%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=MUGHcPBWXrsBtP%2BEJ0PdmTxTlrfQ9jb3IZCzVopwCB4%3D&amp;reserved=0
> >
> > There is also an HTML version available at:
> >
> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-ietf-ace-key-groupcomm-14.html&amp;data=04%7C01%7Cmarco.tiloca%40ri.se%7Ca638ee397ced4fc372ff08d997bf79b5%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637707672366321795%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=y6LdDfymSDIs5cDuPgmhOciO%2BEahcrSXGvW3LfR98j8%3D&amp;reserved=0
> >
> > A diff from the previous version is available at:
> >
> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-ace-key-groupcomm-14&amp;data=04%7C01%7Cmarco.tiloca%40ri.se%7Ca638ee397ced4fc372ff08d997bf79b5%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637707672366321795%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=kmEdmD6senkWyvdWMwx5OzdzOq0OavECCx4yKI0g4Ds%3D&amp;reserved=0
> >
> >
> > Internet-Drafts are also available by anonymous FTP at:
> >
> https://eur02.safelinks.protection.outlook.com/?url=ftp%3A%2F%2Fftp.ietf.org%2Finternet-drafts%2F&amp;data=04%7C01%7Cmarco.tiloca%40ri.se%7Ca638ee397ced4fc372ff08d997bf79b5%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637707672366321795%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=WKVxFgT4gAanfyZHNav0mOWdBiw1pfz3rqJmuk1Ex8c%3D&amp;reserved=0
> >
> >
> > _______________________________________________
> > Ace mailing list
> > [email-masked]
> >
> https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Face&amp;data=04%7C01%7Cmarco.tiloca%40ri.se%7Ca638ee397ced4fc372ff08d997bf79b5%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637707672366321795%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=ALG3Ogjc4qxYzMyjQMd%2FnJNcenvEiMGb8X97ZP0dS7E%3D&amp;reserved=0
>
> --
> Marco Tiloca
> Ph.D., Senior Researcher
>
> Division: Digital System
> Department: Computer Science
> Unit: Cybersecurity
>
> RISE Research Institutes of Sweden
> https://www.ri.se
>
> Phone: +46 (0)70 60 46 501
> Isafjordsgatan 22 / Kistagången 16
> SE-164 40 Kista (Sweden)
>
>
> _______________________________________________
> Ace mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ace
>

-- 
Daniel Migault
Ericsson

---

From: Marco Tiloca <[email-masked]>
Date: Thu, 23 Dec 2021 14:05:09 +0100

Hello Daniel,

I do not have and I am not aware of any IPR on this document.

I have just submitted version -15, with the two requested fixes.

* In Section 3.3

OLD:
the KDC MAY NOT include 'sign_info' parameter

NEW:
the KDC MAY omit the 'sign_info' parameter

* The apparently unused reference "I-D.ietf-cose-rfc8152bis-struct" was 
actually used in Section 1.1. However, it was spread over two lines, 
hence probably missed by the nit checker. It's fixed now.

Best,
/Marco

On 2021-12-23 01:55, Daniel Migault wrote:
> Hi,
>
> In order to complete the shepherd I would like the co-author to 
> confirm that any and all appropriate IPR disclosures required for full 
> conformance with the provisions of BCP 78 and BCP 79 have already been 
> filed.
>
> <https://eur05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww6.ietf.org%2Ftools%2Fidnits%3Furl%3Dhttps%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-ietf-ace-key-groupcomm-14.txt&data=04%7C01%7Cmarco.tiloca%40ri.se%7C7370a0447e6940f4515a08d9c5aef774%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637758178729531544%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=9MzRKSbpg3bMwDcX6a3jjnn88H1d9j8rWVmGpX5VOQ4%3D&reserved=0>
>
> On Mon, Oct 25, 2021 at 12:48 PM Marco Tiloca 
> <marco.tiloca=[email-masked] <mailto:[email-masked]>> 
> wrote:
>
>     Hello ACE,
>
>     [1]
>     https://mailarchive.ietf.org/arch/msg/ace/pr2gBhvqy9j8AfUdQVTZLwamXac/
>     <https://eur05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Face%2Fpr2gBhvqy9j8AfUdQVTZLwamXac%2F&data=04%7C01%7Cmarco.tiloca%40ri.se%7C7370a0447e6940f4515a08d9c5aef774%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637758178729687782%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=TGGln2GwsahjKNoqmEnJfGCvlIyHkD2l7gzVoDxSqjc%3D&reserved=0>
>
>     [2]
>     https://mailarchive.ietf.org/arch/msg/ace/gv_uRo2Y45jqOLJghVSbAARWky0/
>     <https://eur05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Face%2Fgv_uRo2Y45jqOLJghVSbAARWky0%2F&data=04%7C01%7Cmarco.tiloca%40ri.se%7C7370a0447e6940f4515a08d9c5aef774%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637758178729687782%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=ieY4jgh2uJM1%2FlfupW0w6b2WScTlLuKcr1zVqMMGjF8%3D&reserved=0>
>
>     On 2021-10-25 15:57, [email-masked]
>     <mailto:[email-masked]> wrote:
>     > A New Internet-Draft is available from the on-line
>     Internet-Drafts directories.
>     > This draft is a work item of the Authentication and
>     Authorization for Constrained Environments WG of the IETF.
>     >
>     >          Title           : Key Provisioning for Group
>     Communication using ACE
>     <https://eur05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-ace-key-groupcomm%2F&data=04%7C01%7Cmarco.tiloca%40ri.se%7C7370a0447e6940f4515a08d9c5aef774%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637758178729687782%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=vycRl6Cec%2F919fwYZRGwuddQ1qmSNc9Kf4m58sesziA%3D&reserved=0>
>     >
>     <https://eur05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-ietf-ace-key-groupcomm-14.html&data=04%7C01%7Cmarco.tiloca%40ri.se%7C7370a0447e6940f4515a08d9c5aef774%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637758178729687782%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=GfaNB62R9qG%2BBLYxifA3S%2BYIBa1VrNvneOWbq%2F3PiuY%3D&reserved=0>
>     >
>     <https://eur05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-ace-key-groupcomm-14&data=04%7C01%7Cmarco.tiloca%40ri.se%7C7370a0447e6940f4515a08d9c5aef774%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637758178729687782%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=W0Hiw32Yg1BCs9FO19NXuin20ovy4TXdafzWuosKm3I%3D&reserved=0>
>     >
>     >
>     <https://eur05.safelinks.protection.outlook.com/?url=ftp%3A%2F%2Fftp.ietf.org%2Finternet-drafts%2F&data=04%7C01%7Cmarco.tiloca%40ri.se%7C7370a0447e6940f4515a08d9c5aef774%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637758178729687782%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=KNSxdLCBdN1UuNz2DUDdh0%2BIkcdk%2F1InrviHt5obyzM%3D&reserved=0>
>     >
>     >
>     > [email-masked] <mailto:[email-masked]>
>     >
>     <https://eur05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Face&data=04%7C01%7Cmarco.tiloca%40ri.se%7C7370a0447e6940f4515a08d9c5aef774%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637758178729687782%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=P04KN9haY8IS%2B1JT%2FvW4N44se5igpxcNzL7ixXgNpiM%3D&reserved=0>
>
>     -- 
>     Marco Tiloca
>     Ph.D., Senior Researcher
>
>     Division: Digital System
>     <https://eur05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ri.se%2F&data=04%7C01%7Cmarco.tiloca%40ri.se%7C7370a0447e6940f4515a08d9c5aef774%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637758178729687782%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=WQg7YOqjV6K1%2FtBFlk6eWazWaGRFeGB3L3H%2BUqIAWQw%3D&reserved=0>
>
>     [email-masked] <mailto:[email-masked]>
>     <https://eur05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Face&data=04%7C01%7Cmarco.tiloca%40ri.se%7C7370a0447e6940f4515a08d9c5aef774%7C5a9809cf0bcb413a838a09ecc40cc9e8%7C0%7C0%7C637758178729687782%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=P04KN9haY8IS%2B1JT%2FvW4N44se5igpxcNzL7ixXgNpiM%3D&reserved=0>
>
>
>
> -- 
> Daniel Migault
> Ericsson

-- 
Marco Tiloca
Ph.D., Senior Researcher

Division: Digital System

---

From: Daniel Migault <[email-masked]>
Date: Thu, 23 Dec 2021 09:39:58 -0500

Thanks Marco!

Yours,
Daniel

On Thu, Dec 23, 2021 at 8:05 AM Marco Tiloca <[email-masked]> wrote:

> actually used in Section 1.1. However, it was spread over two lines, hence
> probably missed by the nit checker. It's fixed now.
>
>
> Best,
> /Marco
>
> RISE Research Institutes of Swedenhttps://www.ri.se
>

-- 
Daniel Migault
Ericsson