Subject: [Ace] I-D Action: draft-ietf-ace-mqtt-tls-profile-14.txt

From: [email-masked]
Date: Thu, 17 Feb 2022 01:29:25 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Authentication and Authorization for Constrained Environments WG of the IETF.

        Title           : Message Queuing Telemetry Transport (MQTT)-TLS profile of Authentication and Authorization for Constrained Environments (ACE) Framework
        Authors         : Cigdem Sengul
                          Anthony Kirby
	Filename        : draft-ietf-ace-mqtt-tls-profile-14.txt
	Pages           : 43
	Date            : 2022-02-17

Abstract:
   This document specifies a profile for the ACE (Authentication and
   Authorization for Constrained Environments) framework to enable
   authorization in a Message Queuing Telemetry Transport (MQTT)-based
   publish-subscribe messaging system.  Proof-of-possession keys, bound
   to OAuth2.0 access tokens, are used to authenticate and authorize
   MQTT Clients.  The protocol relies on TLS for confidentiality and
   MQTT server (broker) authentication.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ace-mqtt-tls-profile/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-ace-mqtt-tls-profile-14

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ace-mqtt-tls-profile-14

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: Cigdem Sengul <[email-masked]>
Date: Thu, 17 Feb 2022 09:31:18 +0000

Dear Ace,
This version updates the document as required for the AD review, mainly
aligning the descriptions to DTLS-profile when TLS is used for client
authentication.

Kind regards,
--Cigdem

On Thu, 17 Feb 2022 at 09:29, <[email-masked]> wrote:

>         Title           : Message Queuing Telemetry Transport (MQTT)-TLS
> profile of Authentication and Authorization for Constrained Environments
> (ACE) Framework
>         Authors         : Cigdem Sengul
>                           Anthony Kirby
> _______________________________________________
> Ace mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ace
>

---

From: Daniel Migault <[email-masked]>
Date: Fri, 18 Feb 2022 07:50:36 -0500

Thanks for the update! I am happy this document is in LC!
Yours,
Daniel

-- 
Daniel Migault
Ericsson