Subject: [Acme] Fix signing order for key-change endpoint.

From: Jacob Hoffman-Andrews <[email-masked]>
Date: Wed, 14 Sep 2016 17:56:34 -0700

https://github.com/ietf-wg-acme/acme/pull/189

Signing with the current account key allows servers to use the same message
transport authentication that they use for other requests, simplifying the
verification.

Also fix two spots where we still described newKey/oldKey as thumbprints.

---

From: Daniel McCarney <[email-masked]>
Date: Tue, 20 Sep 2016 15:38:49 -0400

The simplified verification reads much clearer to me and I think better
matches the intention of the rollover operation, and which key is
performing the authorization. +1

On Wed, Sep 14, 2016 at 8:56 PM, Jacob Hoffman-Andrews <[email-masked]> wrote:

> _______________________________________________
> Acme mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/acme
>

---

From: Jacob Hoffman-Andrews <[email-masked]>
Date: Wed, 21 Sep 2016 15:21:09 -0700

Thanks! Any other comments? I'd like to merge this and get to implementing.

On 09/20/2016 12:38 PM, Daniel McCarney wrote:
> On Wed, Sep 14, 2016 at 8:56 PM, Jacob Hoffman-Andrews <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     <https://github.com/ietf-wg-acme/acme/pull/189>
> 
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/acme>
> 
> 
> 
>