Subject: [Acme] ambiguous server in acme

From: Josh Soref <[email-masked]>
Date: Tue, 21 Feb 2017 23:07:56 -0500

https://github.com/ietf-wg-acme/acme/blob/28295572ca191cd14d6a9a21912b8d03aa65b885/draft-ietf-acme-acme.md#http

> 3. Dereference the URI using an HTTP GET request. This request MUST be sent to TCP port 80 on the server.

I think server here is http-server

> 4. Verify that the body of the response is well-formed key authorization. The server SHOULD ignore whitespace characters at the end of the body.

I think here server is acme-server

> 5. Verify that key authorization provided by the server matches the token for this challenge and the client's account key.

I think here server is acme-server

I'm not certain, but in cases where acme spec is talking about the
acme server acting as an http client, I'd request that `server` not be
used bare.
The easiest solution imo is labeling `acme-server` and
`{http(s)}-server` / similar. But I'm open to other proposals.

---

From: Daniel McCarney <[email-masked]>
Date: Wed, 22 Feb 2017 09:48:37 -0500

> `{http(s)}-server` / similar. But I'm open to other proposals.

Agreed - I think this is a sensible change to reduce confusion. "ACME
server"
and "HTTP challenge server" seem like good choices but I'm also not tied to
anything.

>> 3. Dereference the URI using an HTTP GET request. This request MUST be
sent
>> to TCP port 80 on the server.

+1

>> 4. Verify that the body of the response is well-formed key
authorization. The
>> server SHOULD ignore whitespace characters at the end of the body.

+1

>> 5. Verify that key authorization provided by the server matches the
token for
this challenge and the client's account key.
> I think here server is acme-server

I think this one should be "Verify that the key authorization provided by
the
HTTP challenge server", not the acme-server (or I need more coffee/cleaner
glasses).

Are you going to send a PR for this? If you're tied up with your existing
PRs
I will find a pinch hitter.

- cpu

On Tue, Feb 21, 2017 at 11:07 PM, Josh Soref <[email-masked]> wrote:

> > 4. Verify that the body of the response is well-formed key
> authorization. The server SHOULD ignore whitespace characters at the end of
> the body.
>
> > 5. Verify that key authorization provided by the server matches the
> token for this challenge and the client's account key.
>
> _______________________________________________
> Acme mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/acme
>

---

From: Josh Soref <[email-masked]>
Date: Wed, 22 Feb 2017 09:56:59 -0500

I can't do this before tonight, and I'd want to cover the entire document,
so if you could find a pinch hitter, I think that's best.

On Feb 22, 2017 9:48 AM, "Daniel McCarney" <[email-masked]> wrote:

>> https://github.com/ietf-wg-acme/acme/blob/28295572ca191cd14d
>> 6a9a21912b8d03aa65b885/draft-ietf-acme-acme.md#http
>>
>> sent to TCP port 80 on the server.
>>

---

From: Daniel McCarney <[email-masked]>
Date: Wed, 22 Feb 2017 16:12:57 -0500

https://github.com/ietf-wg-acme/acme/pull/268

🏆⚾