Subject: [Acme] why is the status value "invalid"

From: Josh Soref <[email-masked]>
Date: Sat, 18 Feb 2017 21:07:31 -0500

> status (required, string): : The status of this order. Possible values are: "pending", "processing", "valid", and "invalid".
> expires (optional, string): : The timestamp after which the server will consider this order invalid,
> encoded in the format specified in RFC 3339 {{!RFC3339}}.

Is there a reason to call that status "invalid" instead of "expired"?

> This field is REQUIRED for objects with "pending" or "valid" in the status field.

---

From: Josh Soref <[email-masked]>
Date: Sat, 18 Feb 2017 22:18:43 -0500

Later on:
> an authorization includes several metadata fields,
> such as the status of the authorization (e.g., "pending", "valid", or "revoked")
> and which challenges were used to validate possession of the identifier.

It's odd that the example list isn't complete. Offhand, I'd vote for
not giving the examples. I don't think it adds value.

> status (required, string): : The status of this authorization. Possible values are: "pending", "processing", "valid", "invalid" and "revoked". If this field is missing, then the default value is "pending".

(Note: I'm making changes to this document in parallel to writing
these emails, but I won't make changes for things I'm emailing about.)