Subject: [Acme] Clarifying what to do with revocation requests with disallowed reasonCodes

From: Roland Bracewell Shoemaker <[email-masked]>
Date: Tue, 14 Feb 2017 14:53:12 -0800

The current draft leaves it ambiguous as to what the server should do
when a it receives a revocation request containing a reasonCode that it
disallows. I suggest we add a simple 'MUST reject request' clause to the
relevant section to resolve this ambiguity.

PR: https://github.com/ietf-wg-acme/acme/pull/251

---

From: Daniel McCarney <[email-masked]>
Date: Thu, 16 Feb 2017 11:16:29 -0500

+1 - I think this is clearer.

Would you be open to specifying what form the rejection takes? Do you think
it
would be advantageous to specify a new error in Section 5.7 for the purpose
(e.g. `urn:ietf:params:acme:error:invalidReasonCode`) or is there an
existing
candidate you'd use?

On Tue, Feb 14, 2017 at 5:53 PM, Roland Bracewell Shoemaker <
[email-masked]> wrote:

> _______________________________________________
> Acme mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/acme
>

---

From: Roland Bracewell Shoemaker <[email-masked]>
Date: Fri, 17 Feb 2017 12:32:27 -0800

We could add a new error type and accompany the problem document with an
extra field that defines the valid reason codes à la the 'alg' field
that is added when we return 'badSignatureAlgorithm'.

On 02/16/2017 08:16 AM, Daniel McCarney wrote:
> Would you be open to specifying what form the rejection takes? Do you
> think it
> On Tue, Feb 14, 2017 at 5:53 PM, Roland Bracewell Shoemaker
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     <https://github.com/ietf-wg-acme/acme/pull/251>
> 
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/acme>
> 
>