Subject: [Acme] example domains in specification

From: Josh Soref <[email-masked]>
Date: Sun, 19 Feb 2017 17:23:11 -0500

rfc 2606 provides multiple example TLDs.

The acme spec at present uses example.org 3 times,
example.net 2 times
example.com 92 times

It's somewhat hard to tell when a URL in an example refers to an ACME
server and when it refers to the user running the ACME client.

It would be helpful if the sample ACME server domain was example.net,
the sample domain requested by ACME clients was within example.com,
and the sample domain for ACME client users (and anything which isn't
the above two categories) was within example.org.

---

From: Hugo Landau <[email-masked]>
Date: Mon, 20 Feb 2017 03:12:44 +0000

This sounds good to me.

-- 
Hugo Landau
I know of no warrant or notice of a kind defined within the Investigatory
Powers Act 2016 or the Regulation of Investigatory Powers Act 2000 that has not
been brought to the attention of the public. I will always answer questions
about these or similar matters, assuming reasonable request rates, unless
legally prevented from doing so.

---

From: Roland Bracewell Shoemaker <[email-masked]>
Date: Sun, 19 Feb 2017 20:45:02 -0800

Making each host role have it's own distinct name would definitely be a
gain from a clarity perspective but making those distinctions based
solely on the TLD that is being used seems like it'd actually make
things somewhat more confusing.

Instead why not use subdomains below example.com that explicitly
indicate what their role is, e.g. {server,client,validation}.exmaple.com?

On 02/19/2017 02:23 PM, Josh Soref wrote:
> _______________________________________________
> Acme mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/acme
>