Subject: Re: [Acme] ACME resources relations

From: Richard Barnes <[email-masked]>
Date: Fri, 3 Feb 2017 10:46:42 -0800

This is a good question, and I'm not sure what the right answer is.  It
seems like there are basically three options:

1. Remove the "up" relation
2. Have the "up" relation point to the order that created the authz (if any)
3. Have multiple "up" relations pointing to all relevant orders

Of those options, I would probably prefer (1), just because I don't really
see much of a use case for it.

On Fri, Jan 20, 2017 at 8:08 AM, Andriy Mahats <[email-masked]>
wrote:

> Hi all!
>
>
>
> At the resource diagram in *6.1 Resources* section,
>
> there is an authz resource related to order by “up” relation.
>
>
>
> My question is for following case:
>
>
>
> The client orders a certificate
>
> and at the time of ordering it satisfied some of authorizations (let’s say
> 2 of 3)
>
> in previous transactions (possibly using pre-authorization: new-authz).
>
>
>
> When client queries such previously satisfied authorization,
>
> what order resource shall pointed using “up” relation,
>
> since that authorization can be used for many orders?
>
>
>
> I’ve created issue in GitHub for this. You can find it here:
> https://github.com/ietf-wg-acme/acme/issues/236
>
>
>
>
>
> Sincerely,
>
> Andriy
>
> _______________________________________________
> Acme mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/acme
>
>

---

From: Jacob Hoffman-Andrews <[email-masked]>
Date: Fri, 3 Feb 2017 11:36:36 -0800

On 02/03/2017 10:46 AM, Richard Barnes wrote:
> This is a good question, and I'm not sure what the right answer is. 
> It seems like there are basically three options:
>
> Of those options, I would probably prefer (1), just because I don't
> really see much of a use case for it.
I concur. I'd actually like to do a thorough review of the various link
relations and remove the unnecessary ones, but saving that for WGLC.