Subject: [Acme] Futures

From: "Salz, Rich" <[email-masked]>
Date: Fri, 21 Apr 2017 18:01:26 +0000

Having talked with the authors, we expect the base ACME draft to be ready for WGLC at least a month before the next IETF meeting.

The CAA document, which we adopted, is very short and straightforward and seems like it can be handled easily over email.

Does anyone have any new work items that would be ready to discuss in July?  Any rechartering discussion that looks promising?  If so, please post to the mailing list soon.

Thanks,
Rich and Ted's Excellent ACME Adventure

--
Senior Architect, Akamai Technologies
Member, OpenSSL Dev Team
IM: [email-masked] Twitter: RichSalz

---

From: Mary Barnes <[email-masked]>
Date: Tue, 25 Apr 2017 13:54:08 -0500

So we submitted a draft to define a new challenge type to support the
ATIS/SIP Forum NNI task group (SHAKEN) requirements, which are based on
using protocols defined in STIR:
https://datatracker.ietf.org/doc/draft-barnes-acme-service-provider/

It's not clear to me this would need to be a WG document to progress, but
ideally we want this published as people are implementing it.

Regards,
Mary.

On Fri, Apr 21, 2017 at 1:01 PM, Salz, Rich <[email-masked]> wrote:

> Having talked with the authors, we expect the base ACME draft to be ready
> for WGLC at least a month before the next IETF meeting.
>
>
>
> The CAA document, which we adopted, is very short and straightforward and
> seems like it can be handled easily over email.
>
>
>
> Does anyone have any new work items that would be ready to discuss in
> July?  Any rechartering discussion that looks promising?  If so, please
> post to the mailing list soon.
>
>
>
> Thanks,
>
> Rich and Ted’s Excellent ACME Adventure
>
>
>
>
>
> --
>
> _______________________________________________
> Acme mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/acme
>
>

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 25 Apr 2017 19:24:33 +0000

> So we submitted a draft to define a new challenge type to support the ATIS/SIP Forum NNI task group (SHAKEN) requirements, which are based on using protocols defined in STIR:

Would it make sense to move this forward in STIR?  I ask because https://datatracker.ietf.org/doc/draft-peterson-stir-certificates-shortlived/ now lives there and it seems that the two should be together.

--  
Senior Architect, Akamai Technologies
Member, OpenSSL Dev Team
IM: mailto:[email-masked] Twitter: RichSalz

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 25 Apr 2017 19:54:35 +0000

> Would it make sense to move this forward in STIR?

After some off-line email chat, I was wrong.  ACME is the most reasonable place for this.

So new question.  So far it seems unlikely we'll meet in Prague.  But would you be willing to talk about this if we do?  Should we meet so that we can talk about it (and CAA and any other things that come up?)

---

From: Roland Shoemaker <[email-masked]>
Date: Thu, 27 Apr 2017 17:02:53 +0000

I'd be interested in getting draft-shoemaker-acme-ip (current draft:
https://www.ietf.org/id/draft-shoemaker-acme-ip-00.txt with a revision
coming in the very near future) adopted by the WG. We are currently
considering implementing the extension defined in it in the Let's Encrypt
server software Boulder and it would be good to get consensus from the
group that it is an appropriate path forward for validating IP addresses.

Thanks,
Roland

--
Software Engineer, Let's Encrypt
Internet Security Research Group / Linux Foundation

---

From: "Peterson, Jon" <[email-masked]>
Date: Fri, 28 Apr 2017 16:13:30 +0000

Definitely I agree that we could use the ACME WG's help in moving forward
STIR/SHAKEN stuff that will rely on ACME. I kind of see these as joint
ventures with the STIR work, as it requires some coordination with the
things we're doing with certificates in STIR, and also with the kinds of
PASSporTs that we want these certificates to sign. But the baseline
mechanisms that acquire the certs need some attention from this group.

Jon Peterson
Neustar, Inc.

On 4/25/17, 3:54 PM, "Acme on behalf of Salz, Rich" <[email-masked]
on behalf of [email-masked]> wrote:

>So new question.  So far it seems unlikely we'll meet in Prague.  But
>would you be willing to talk about this if we do?  Should we meet so that
>we can talk about it (and CAA and any other things that come up?)
>
>--

---

From: KrustyButt <[email-masked]>
Date: Fri, 28 Apr 2017 13:11:27 -0400

I have never been to Prague.

KB

On 4/28/17 12:13 PM, Peterson, Jon wrote:
> 
> Definitely I agree that we could use the ACME WG's help in moving
> forward STIR/SHAKEN stuff that will rely on ACME. I kind of see
> these as joint ventures with the STIR work, as it requires some
> coordination with the things we're doing with certificates in STIR,
> and also with the kinds of PASSporTs that we want these
> certificates to sign. But the baseline mechanisms that acquire the
> certs need some attention from this group.
> 
> Jon Peterson Neustar, Inc.
> 
> On 4/25/17, 3:54 PM, "Acme on behalf of Salz, Rich"
> <[email-masked] on behalf of [email-masked]> wrote:
> 
>>>> So we submitted a draft to define a new challenge type to
>>>> support the ATIS/SIP Forum NNI task group (SHAKEN)
>>>> requirements, which are based
>>> on
>> So new question.  So far it seems unlikely we'll meet in Prague.
>> But would you be willing to talk about this if we do?  Should we
>> meet so that we can talk about it (and CAA and any other things
>> that come up?)
>> 
>> -- Senior Architect, Akamai Technologies Member, OpenSSL Dev
>> Team IM: [email-masked] Twitter: RichSalz 
>> _______________________________________________ Acme mailing
>> list [email-masked] https://www.ietf.org/mailman/listinfo/acme
> 
> _______________________________________________ Acme mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/acme
>