Subject: Re: [Acme] -09 draft: Challenge objects?

From: Daniel McCarney <[email-masked]>
Date: Fri, 2 Mar 2018 09:34:28 -0500

Hi Felipe,

Does this PR from Richard Barnes address your feedback?
https://github.com/ietf-wg-acme/acme/pull/399

Thanks!

On Sat, Jan 13, 2018 at 8:50 AM, Felipe Gasper <[email-masked]>
wrote:

> Hello,
>
>         I’ve been looking over the -09 draft and have created a Perl
> client module against Pebble as well as LE’s new testing endpoint.
>
>         I’m curious about whether the specification intends to define
> Challenge objects. They appear to exist, of course, but they’re not defined
> as objects per se in section 7.1 of the draft.
>
>         Thank you!
>
> -Felipe Gasper
> Mississauga, ON
> _______________________________________________
> Acme mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/acme
>

---

From: Felipe Gasper <[email-masked]>
Date: Fri, 2 Mar 2018 10:43:30 -0500

Hi Daniel,

	It definitely helps, yes. Would it be sensible to move the common list of parameters there as well, for parity with how the other object types are described?

-Felipe

> On Mar 2, 2018, at 9:34 AM, Daniel McCarney <[email-masked]> wrote:
> 
> Hi Felipe,
> 
> Does this PR from Richard Barnes address your feedback? https://github.com/ietf-wg-acme/acme/pull/399
> 
> Thanks!
> 
> On Sat, Jan 13, 2018 at 8:50 AM, Felipe Gasper <[email-masked]> wrote:
> Hello,
> 
>         I’ve been looking over the -09 draft and have created a Perl client module against Pebble as well as LE’s new testing endpoint.
> 
>         I’m curious about whether the specification intends to define Challenge objects. They appear to exist, of course, but they’re not defined as objects per se in section 7.1 of the draft.
> 
>         Thank you!
> 
> -Felipe Gasper
> Mississauga, ON

---

From: Daniel McCarney <[email-masked]>
Date: Fri, 2 Mar 2018 11:32:43 -0500

>
> Would it be sensible to move the common list of parameters there as well,
> for parity with how the other object types are described?

I think the forward pointer is probably sufficient.

Richard: What do you think?

On Fri, Mar 2, 2018 at 10:43 AM, Felipe Gasper <[email-masked]>
wrote:

> Hi Daniel,
>
>         It definitely helps, yes. Would it be sensible to move the common
> list of parameters there as well, for parity with how the other object
> types are described?
>
> -Felipe
>