Subject: [Acme] vestige of certificate GET

From: Felipe Gasper <[email-masked]>
Date: Tue, 6 Nov 2018 07:15:12 -0500

Hi all,

	Draft 16 has this:

-----
   An ACME client MAY attempt to fetch the certificate with a GET
   request.  If the server does not allow GET requests for certificate
   resources, then it will return an error as described in 
Section 6.3
.
   On receiving such an error, the client SHOULD fall back to a POST-as-
   GET request.
-----

	From what I can discern from this list’s most recent posts on the topic, I’m under the impression that plain GET for certificates is not to be part of the principal ACME spec; should the above, then, be removed?

-FG

---

From: Daniel McCarney <[email-masked]>
Date: Tue, 6 Nov 2018 08:21:42 -0500

>
>  I’m under the impression that plain GET for certificates is not to be
> part of the principal ACME spec; should the above, then, be removed?

Good catch, I agree. It doesn't look like EKR/Richard's PR (#467) covers
this so I opened another: https://github.com/ietf-wg-acme/acme/pull/468

On Tue, Nov 6, 2018 at 7:15 AM Felipe Gasper <[email-masked]>
wrote:

>         From what I can discern from this list’s most recent posts on the
> topic, I’m under the impression that plain GET for certificates is not to
> be part of the principal ACME spec; should the above, then, be removed?
>
> -FG
> _______________________________________________
> Acme mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/acme
>