Subject: [Actn] Client vs. Consumer

From: Leeyoung <[email-masked]>
Date: Fri, 3 Jan 2014 20:50:59 +0000

Hello everyone,

I just changed the subject name of this mailing thread to Client vs Consumer to allow a larger audience to participate this discussion. The context is found in the ACTN framework document just published:
http://datatracker.ietf.org/doc/draft-ceccarelli-actn-framework/

In this framework document of ACTN, there are three tiers of business relationships in ACTN model in Section 3:

Consumer
Service Provider
Network Provider

The discussion has been if "consumer" is a better term over "client" as Diego indicated that consumer may have its own "ultimate clients" hanging over it. If we were to say just 'client' then this term is a bit limited to allow recursiveness of SDN property.

Feel free to join the discussion.

Young

From: Diego R. Lopez [mailto:[email-masked]]
Sent: Friday, January 03, 2014 10:30 AM
To: Daniele Ceccarelli
Cc: Leeyoung; Luyuan Fang; Daniel King; Farrel Adrian
Subject: Re: ACTN framework 00.

Hi Danielle,

Essentially because the usage of the term "client" implies an end-system (or a system associated with an end-user) and a P2P relationship with a "server". I think the flexible scenarios we are considering in ACTN are better described by talking of a "consumer" that can act as a "provider" to other elements in the framework, even supporting a recursive approach in which one of these consumers could become a provider to a higher level of abstraction. Recursiveness is one of the most interesting properties in SDN, I'd say...

Be goode,

On 2 Jan 2014, at 13:43 , Daniele Ceccarelli wrote:

Hi Diego, all,

I'd like to better understand why you suggest to substitute client with consumer. I don't have serious concerns about a term or the other but to me it looks like a client and would like to understand the rationale of your suggestion.

Thanks and Happy New Year
Daniele

PS. In case we come to the conclusion that client is not the right term, why don't we use "customer" instead of "consumer"?

From: Diego R. Lopez [mailto:[email-masked]]
Sent: venerdì 27 dicembre 2013 10:16
To: Leeyoung
Cc: Daniele Ceccarelli; Luyuan Fang; Daniel King; Farrel Adrian
Subject: Re: ACTN framework 00.

Hi Young,

Actually, the message was ready a while ago, but I managed to get to a decently connected place only on Christmas Day...

Let's what the others think about the terminology rearrangement. In the mean time, let me wish you all a really Goode New Year!

On 26 Dec 2013, at 21:52 , Leeyoung wrote:

Hi Diego,

It seems that you were working on the Christmas Day :).

Thanks for your comments. It improves the readability of the document.

I think you have suggested two major changes to the terminology:
-          Client -> Consumer
-          Control -> Controller (for VNC and PNC).

I don't disagree with either terms; but I wanted to check with other folks how they think.

With this resolution, I think we are pretty much ready to publish 00 version of the framework unless we hear otherwise from the other contributors.

Thanks.
Have a blessed new year in 2014!

Young

From: Diego R. Lopez [mailto:[email-masked]]
Sent: Wednesday, December 25, 2013 2:45 PM
To: Leeyoung
Cc: Daniele Ceccarelli; Luyuan Fang; Daniel King; Farrel Adrian
Subject: Re: ACTN framework 00.

Hi,

Some additional comments and suggested changes on Daniele's last version...

And let me take the opportunity to wish you a Really Goode Christmas,

On 20 Dec 2013, at 15:58 , Daniele Ceccarelli wrote:

Hi Young,

Please find some comments in the attached file. They are pretty much the same of the ones I sent on the list.

Many thanks
Daniele

From: Leeyoung [mailto:[email-masked]]
Sent: giovedì 19 dicembre 2013 23:50
To: Daniele Ceccarelli; Luyuan Fang; 'Diego R. Lopez'
Cc: Daniel King; [email-masked]<mailto:[email-masked]>
Subject: ACTN framework 00.

Hi guys,

Here's 00 version of ACTN framework. Please review it and provide your comments/feedback before end of this week.

Sorry for the short notice, but I hope we can publish this to the ACTN list at the end of this week.

Thanks.
Young
<draft-lee-actn-framework-00-daniele.docx>

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041
Mobile: +34 682 051 091
-----------------------------------------

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041
Mobile: +34 682 051 091
-----------------------------------------

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041
Mobile: +34 682 051 091
-----------------------------------------

________________________________

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at:
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: 윤빈영 <[email-masked]>
Date: Mon, 6 Jan 2014 07:29:23 +0000

Hi,

I am a new person from ETRI.

Currently, two other SDOs of ONF and ITU-T are modeling the architecture of multilayer SDN.
ITU-T SG 15 is doing the SDN modeling for the multilayer based on ASON used for GMPLS.
In the exiting recommendation,
it is assumed that the client/server model is reclusively used for the hierarchical multilayer.
ONF OTWG also uses the same term(client/server) for the hierarchical architecture.

If this issue has any similarities with them in terms of modeling,
I think that we need to consider a unified term for better understanding each other.

Bin

From: Leeyoung [mailto:[email-masked]]
Sent: Saturday, January 04, 2014 5:51 AM
To: Diego R. Lopez; Daniele Ceccarelli
Cc: Farrel Adrian; Luyuan Fang; [email-masked]; Daniel King
Subject: [Actn] Client vs. Consumer

Hello everyone,

Consumer
Service Provider
Network Provider

The discussion has been if “consumer” is a better term over “client” as Diego indicated that consumer may have its own “ultimate clients” hanging over it. If we were to say just ‘client’ then this term is a bit limited to allow recursiveness of SDN property.

Young

From: Diego R. Lopez [mailto:[email-masked]]<mailto:[mailto:[email-masked]]>
Sent: Friday, January 03, 2014 10:30 AM
To: Daniele Ceccarelli
Cc: Leeyoung; Luyuan Fang; Daniel King; Farrel Adrian
Subject: Re: ACTN framework 00.

Hi Danielle,

Be goode,

Hi Diego, all,

I’d like to better understand why you suggest to substitute client with consumer. I don’t have serious concerns about a term or the other but to me it looks like a client and would like to understand the rationale of your suggestion.

PS. In case we come to the conclusion that client is not the right term, why don’t we use “customer” instead of “consumer”?

Hi Young,

Hi Diego,

It seems that you were working on the Christmas Day ☺.

I don’t disagree with either terms; but I wanted to check with other folks how they think.

Thanks.

Young

Hi,

Hi Young,

Many thanks
Daniele

Hi guys,

Here’s 00 version of ACTN framework. Please review it and provide your comments/feedback before end of this week.

Thanks.
Young

Dr Diego R. Lopez
Telefonica I+D

Dr Diego R. Lopez
Telefonica I+D

Dr Diego R. Lopez
Telefonica I+D

---

From: Dhruv Dhody <[email-masked]>
Date: Mon, 6 Jan 2014 22:01:30 +0530

>
>
> The discussion has been if “consumer” is a better term over “client” as
> Diego indicated that consumer may have its own “ultimate clients” hanging
> over it. If we were to say just ‘client’ then this term is a bit limited to
> allow recursiveness of SDN property.
>
> [DD]: I like the term 'consumer' and agree with Diego's reasoning behind
it.
It helps in explaining Packet + Optical Integration case, where packet
network controller may be a consumer from the optical transport network
point of view, further packet network may further have its own consumers.

Regards,
Dhruv

> *From:* Diego R. Lopez [mailto:[email-masked]]
> *Sent:* Friday, January 03, 2014 10:30 AM
> *To:* Daniele Ceccarelli
> *Cc:* Leeyoung; Luyuan Fang; Daniel King; Farrel Adrian
> *Subject:* Re: ACTN framework 00.
>
>
>
> Hi Danielle,
>
>
>
> Essentially because the usage of the term "client" implies an end-system
> (or a system associated with an end-user) and a P2P relationship with a
> "server". I think the flexible scenarios we are considering in ACTN are
> better described by talking of a "consumer" that can act as a "provider" to
> other elements in the framework, even supporting a recursive approach in
> which one of these consumers could become a provider to a higher level of
> abstraction. Recursiveness is one of the most interesting properties in
> SDN, I'd say...
>
>
>
> Be goode,
>
>
>
> I’d like to better understand why you suggest to substitute client with
> consumer. I don’t have serious concerns about a term or the other but to me
> it looks like a client and would like to understand the rationale of your
> suggestion.
>
>
>
> PS. In case we come to the conclusion that client is not the right term,
> why don’t we use “customer” instead of “consumer”?
>
>
>
> *From:* Diego R. Lopez [mailto:[email-masked] <[email-masked]>]
> *Sent:* venerdì 27 dicembre 2013 10:16
> *To:* Leeyoung
> *Cc:* Daniele Ceccarelli; Luyuan Fang; Daniel King; Farrel Adrian
> *Subject:* Re: ACTN framework 00.
>
>
>
> Hi Young,
>
>
>
> Actually, the message was ready a while ago, but I managed to get to a
> decently connected place only on Christmas Day...
>
>
>
> Let's what the others think about the terminology rearrangement. In the
> mean time, let me wish you all a really Goode New Year!
>
>
>
> It seems that you were working on the Christmas Day J.
>
>
>
> With this resolution, I think we are pretty much ready to publish 00
> version of the framework unless we hear otherwise from the other
> contributors.
>
>
>
> Thanks.
>
> *From:* Diego R. Lopez [mailto:[email-masked] <[email-masked]>]
> *Sent:* Wednesday, December 25, 2013 2:45 PM
> *To:* Leeyoung
> *Cc:* Daniele Ceccarelli; Luyuan Fang; Daniel King; Farrel Adrian
> *Subject:* Re: ACTN framework 00.
>
>
>
> Hi,
>
>
>
> *From:* Leeyoung [mailto:[email-masked] <[email-masked]>]
> *Sent:* giovedì 19 dicembre 2013 23:50
> *To:* Daniele Ceccarelli; Luyuan Fang; 'Diego R. Lopez'
> *Cc:* Daniel King; [email-masked]
> *Subject:* ACTN framework 00.
>
>
>
> Hi guys,
>
>
>
> Here’s 00 version of ACTN framework. Please review it and provide your
> comments/feedback before end of this week.
>
>
>
> e-mail: [email-masked]
>   ------------------------------
>
>
> Este mensaje se dirige exclusivamente a su destinatario. Puede consultar
> nuestra política de envío y recepción de correo electrónico en el enlace
> situado más abajo.
> This message is intended exclusively for its addressee. We only send and
> receive email on the basis of the terms set out at:
> e-mail: [email-masked]
>  ------------------------------
>
>
> Este mensaje se dirige exclusivamente a su destinatario. Puede consultar
> nuestra política de envío y recepción de correo electrónico en el enlace
> situado más abajo.
> This message is intended exclusively for its addressee. We only send and
> receive email on the basis of the terms set out at:
> e-mail: [email-masked]
>  ------------------------------
>
>
> Este mensaje se dirige exclusivamente a su destinatario. Puede consultar
> nuestra política de envío y recepción de correo electrónico en el enlace
> situado más abajo.
> This message is intended exclusively for its addressee. We only send and
> receive email on the basis of the terms set out at:
> _______________________________________________
> ACTN mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/actn
>
>

---

From: "King, Daniel" <[email-masked]>
Date: Mon, 6 Jan 2014 18:06:34 +0000

Hi All,

A few quick comments.

Dhruv, what you described seems like a classic ITU-T (G.805) definition of client-server model (as Bin mentioned earlier):

Client – Packet Interface (IP/MPLS Router/Switch)
Server – Optical Transport (DWDM Switch)

I.E., the Client layer network receives a (transport) service from the lower Server layer network.

Personally, I have no strong opinion of Consumer/Provider versus Client/Server, but I think it is important to reuse accepted terminology from industry/ SDOs where applicable.

To help discussion, can we also clarify the intention of the terms:

A “Consumer” is an entity that will request and use a service from the “Provider”.  The “Consumer” may then use the service, or provide the service wholly or in part, for its self or end-users (i.e. enterprise customers).

A “Provider” manages the transport infrastructure that the “Consumer” will request a service across.

Br, Dan.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: 06 January 2014 16:32
To: Leeyoung
Cc: Diego R. Lopez; Daniele Ceccarelli; Farrel Adrian; Luyuan Fang; [email-masked]; Daniel King
Subject: Re: [Actn] Client vs. Consumer

The discussion has been if “consumer” is a better term over “client” as Diego indicated that consumer may have its own “ultimate clients” hanging over it. If we were to say just ‘client’ then this term is a bit limited to allow recursiveness of SDN property.
[DD]: I like the term 'consumer' and agree with Diego's reasoning behind it.
It helps in explaining Packet + Optical Integration case, where packet network controller may be a consumer from the optical transport network point of view, further packet network may further have its own consumers.

Regards,
Dhruv

Young

From: Diego R. Lopez [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Friday, January 03, 2014 10:30 AM
To: Daniele Ceccarelli
Cc: Leeyoung; Luyuan Fang; Daniel King; Farrel Adrian
Subject: Re: ACTN framework 00.

Hi Danielle,

Be goode,

Hi Diego, all,

Hi Young,

Hi Diego,

Thanks.

Young

Hi,

Hi Young,

Many thanks
Daniele

Hi guys,

Thanks.
Young

Dr Diego R. Lopez
Telefonica I+D

Dr Diego R. Lopez
Telefonica I+D

Dr Diego R. Lopez
Telefonica I+D

_______________________________________________
ACTN mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/actn

---

From: Scott Brim <[email-masked]>
Date: Mon, 6 Jan 2014 16:49:25 -0500

If you like "consumer" you might be more inclined to the "added value
chain" concept of ITU-T Y.110 etc. instead of G.805.

On Mon, Jan 6, 2014 at 1:06 PM, King, Daniel <[email-masked]> wrote:
> Hi All,
>
>
>
> A few quick comments.
>
>
>
> Dhruv, what you described seems like a classic ITU-T (G.805) definition of
> client-server model (as Bin mentioned earlier):
>
>
>
> Personally, I have no strong opinion of Consumer/Provider versus
> Client/Server, but I think it is important to reuse accepted terminology
> from industry/ SDOs where applicable.
>
>
>
> A “Consumer” is an entity that will request and use a service from the
> “Provider”.  The “Consumer” may then use the service, or provide the service
> wholly or in part, for its self or end-users (i.e. enterprise customers).
>
>
>
> Essentially because the usage of the term "client" implies an end-system (or
> a system associated with an end-user) and a P2P relationship with a
> abstraction. Recursiveness is one of the most interesting properties in SDN,
> I'd say...
>
>
>
> Be goode,
>
>
>
> PS. In case we come to the conclusion that client is not the right term, why
> don’t we use “customer” instead of “consumer”?
>
>
>
> Let's what the others think about the terminology rearrangement. In the mean
> time, let me wish you all a really Goode New Year!
>
>
>
> With this resolution, I think we are pretty much ready to publish 00 version
> of the framework unless we hear otherwise from the other contributors.
>
>
>
> Thanks.
>
> Cc: Daniel King; [email-masked]

---

From: Leeyoung <[email-masked]>
Date: Mon, 6 Jan 2014 22:55:58 +0000

Client-server sounds to me a classical networking term while consumer-provider is more generic term.
Either way, we need to make sure there is a recursive nature where a client/consumer can also be in turn a server/provider. 

Young

-----Original Message-----
From: Scott Brim [mailto:[email-masked]] 
Sent: Monday, January 06, 2014 3:49 PM
To: King, Daniel
Cc: Dhruv Dhody; Leeyoung; 윤빈영; [email-masked]; Farrel Adrian; Luyuan Fang; Diego R. Lopez; Daniele Ceccarelli
Subject: Re: [Actn] Client vs. Consumer

If you like "consumer" you might be more inclined to the "added value chain" concept of ITU-T Y.110 etc. instead of G.805.

On Mon, Jan 6, 2014 at 1:06 PM, King, Daniel <[email-masked]> wrote:
> Hi All,
>
>
>
> A few quick comments.
>
>
>
> Dhruv, what you described seems like a classic ITU-T (G.805) 
> definition of client-server model (as Bin mentioned earlier):
>
>
>
> Client/Server, but I think it is important to reuse accepted 
> terminology from industry/ SDOs where applicable.
>
>
>
> “Provider”.  The “Consumer” may then use the service, or provide the 
> service wholly or in part, for its self or end-users (i.e. enterprise customers).
>
>
>
> The discussion has been if “consumer” is a better term over “client” 
> as Diego indicated that consumer may have its own “ultimate clients” 
> hanging over it. If we were to say just ‘client’ then this term is a 
> bit limited to allow recursiveness of SDN property.
>
> network controller may be a consumer from the optical transport 
> network point of view, further packet network may further have its own consumers.
>
>
>
> Regards,
>
> Dhruv
>
>
>
>
>
> Essentially because the usage of the term "client" implies an 
> end-system (or a system associated with an end-user) and a P2P 
> relationship with a "server". I think the flexible scenarios we are 
> considering in ACTN are better described by talking of a "consumer" 
> that can act as a "provider" to other elements in the framework, even 
> supporting a recursive approach in which one of these consumers could 
> become a provider to a higher level of abstraction. Recursiveness is 
> one of the most interesting properties in SDN, I'd say...
>
>
>
> Be goode,
>
>
>
> I’d like to better understand why you suggest to substitute client 
> with consumer. I don’t have serious concerns about a term or the other 
> but to me it looks like a client and would like to understand the 
> rationale of your suggestion.
>
>
>
> PS. In case we come to the conclusion that client is not the right 
> term, why don’t we use “customer” instead of “consumer”?
>
>
>
> Let's what the others think about the terminology rearrangement. In 
> the mean time, let me wish you all a really Goode New Year!
>
>
>
> version of the framework unless we hear otherwise from the other contributors.
>
>
>
> Thanks.
>
> Este mensaje se dirige exclusivamente a su destinatario. Puede 
> consultar nuestra política de envío y recepción de correo electrónico 
> en el enlace situado más abajo.
> This message is intended exclusively for its addressee. We only send 
> and receive email on the basis of the terms set out at:
> Este mensaje se dirige exclusivamente a su destinatario. Puede 
> consultar nuestra política de envío y recepción de correo electrónico 
> en el enlace situado más abajo.
> This message is intended exclusively for its addressee. We only send 
> and receive email on the basis of the terms set out at:
> Este mensaje se dirige exclusivamente a su destinatario. Puede 
> consultar nuestra política de envío y recepción de correo electrónico 
> en el enlace situado más abajo.
> This message is intended exclusively for its addressee. We only send 
> and receive email on the basis of the terms set out at:

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 8 Jan 2014 11:52:55 +0000

Hi all,

I tend to agree with Dan and Bin. If we need something different from what already exists we can introduce new terms and new definitions but, when possible, reusing existing terminology is always a good choice to prevent misunderstanding/misalignments.
What we need now is something that meets the following requirements:

1. allows for recursiveness 
2. is generic enough
3. ...others?

Up to now the client/server terminology seems to be meeting the requirements. Isn't it? Are there other requirements that are not met?

Cheers
Daniele

> Sent: lunedì 6 gennaio 2014 23:56
> To: Scott Brim; King, Daniel
> Cc: Dhruv Dhody; 윤빈영; [email-masked]; Farrel Adrian; Luyuan Fang; Diego R.
> Lopez; Daniele Ceccarelli
> Subject: RE: [Actn] Client vs. Consumer
> 
> Either way, we need to make sure there is a recursive nature where a
> client/consumer can also be in turn a server/provider.
> 
> Young
> 
> If you like "consumer" you might be more inclined to the "added value chain"
> concept of ITU-T Y.110 etc. instead of G.805.
> 
> > From: [email-masked] [mailto:[email-masked]] On Behalf
> Of
> > Dhruv Dhody

---

From: Dieter Beller <[email-masked]>
Date: Wed, 08 Jan 2014 13:01:05 +0100

Hi Young, all,

we need to distinguish administrative boundaries like network
domain boundaries from the  hierarchical layered structure

of transport networks (multi-layer architecture).

The client/server term is used in ITU-T Recommendations such as
G.805 to address multi-layer aspects:

In the VPN related IETF documents such as RFC 4847, the terms
customer/provider network are often used to address

the administrative boundary aspects (see terminology section).

I am not tied to any specific terminology, but iut is IMHO
important to make the distinction described above and I it

may be beneficial to adopt existing terminology where it makes
sense.

Thanks,

Dieter

On 06.01.2014 23:55, Leeyoung wrote:

Young

-----Original Message-----
From: Scott Brim [mailto:[email-masked]]
Sent: Monday, January 06, 2014 3:49 PM
To: King, Daniel
Cc: Dhruv Dhody; Leeyoung; 윤빈영; [email-masked]; Farrel Adrian; Luyuan Fang; Diego R. Lopez; Daniele Ceccarelli
Subject: Re: [Actn] Client vs. Consumer

Hi All,

A few quick comments.

I.E., the Client layer network receives a (transport) service from the
lower Server layer network.

A “Provider” manages the transport infrastructure that the “Consumer”
will request a service across.

Br, Dan.

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Dhruv Dhody
Sent: 06 January 2014 16:32
To: Leeyoung
Cc: Diego R. Lopez; Daniele Ceccarelli; Farrel Adrian; Luyuan Fang;
[email-masked]; Daniel King
Subject: Re: [Actn] Client vs. Consumer

Regards,

Dhruv

Young

Hi Danielle,

Be goode,

Hi Diego, all,

Daniele

Hi Young,

Hi Diego,

- Client -> Consumer

I don’t disagree with either terms; but I wanted to check with other
folks how they think.

Thanks.

Young

Hi,

Hi Young,

Please find some comments in the attached file. They are pretty much
the same of the ones I sent on the list.

Many thanks

Daniele

Hi guys,

Sorry for the short notice, but I hope we can publish this to the ACTN
list at the end of this week.

Thanks.

Young

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]
Tel: +34 913 129 041
Mobile: +34 682 051 091

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]
Tel: +34 913 129 041
Mobile: +34 682 051 091

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]
Tel: +34 913 129 041
Mobile: +34 682 051 091

--

DIETER
BELLER

ALCATEL-LUCENT
DEUTSCHLAND AG

PROJECT MANAGER ASON/GMPLS CONTROL PLANE

IP ROUTING AND TRANSPORT BL

IP TRANSPORT BU

Lorenzstrasse 10

70435 Stuttgart, Germany

Phone: +49 711 821 43125

Mobil: +49 175 7266874

[email-masked]

Alcatel-Lucent
Deutschland AG

Domicile of the Company: Stuttgart · Local Court Stuttgart HRB
4026

Chairman of the Supervisory Board: Michael Oppenhoff

Board of Management: Wilhelm Dresselhaus (Chairman) · Hans-Jörg
Daub · Andreas Gehe

This e-mail and its attachments, if any, may contain
confidential information.

If you have received this e-mail in error, please notify us and
delete or destroy the e-mail and its attachments, if any,
immediately.

If you have received this e-mail in error, you must not forward
or make use of the e-mail and its attachments, if any.

---

From: Dhruv Dhody <[email-masked]>
Date: Wed, 8 Jan 2014 18:26:48 +0530

Hi All,

A question to ask could be, does the section 3 "Business model of ACTN" in
draft-ceccarelli-actn-framework reads better with the term client/server or
consumer/producer or something entirely different?

http://tools.ietf.org/html/draft-ceccarelli-actn-framework-00#section-3

Regards,
Dhruv

On Wed, Jan 8, 2014 at 5:31 PM, Dieter Beller <
[email-masked]> wrote:

>  Hi Young, all,
>
> we need to distinguish administrative boundaries like network domain
> boundaries from the  hierarchical layered structure
> The client/server term is used in ITU-T Recommendations such as G.805 to
> address multi-layer aspects:
>
>
>
> I am not tied to any specific terminology, but iut is IMHO important to
> make the distinction described above and I it
> may be beneficial to adopt existing terminology where it makes sense.
>
>
> Thanks,
> Dieter
>
>
> From: Scott Brim [mailto:[email-masked] <[email-masked]>]
> On Mon, Jan 6, 2014 at 1:06 PM, King, Daniel <[email-masked]> <[email-masked]> wrote:
>
>  Hi All,
>
>
>
> A few quick comments.
>
>
>
> From: [email-masked] [mailto:[email-masked] <[email-masked]>] On Behalf Of
> Dhruv Dhody
> From: Diego R. Lopez [mailto:[email-masked] <[email-masked]>]
> From: Diego R. Lopez [mailto:[email-masked] <[email-masked]>]
> From: Diego R. Lopez [mailto:[email-masked] <[email-masked]>]
> From: Leeyoung [mailto:[email-masked] <[email-masked]>]
> and receive email on the basis of the terms set out at:http://www.tid.es/ES/PAGINAS/disclaimer.aspx
>
>
>
>
> --
> and receive email on the basis of the terms set out at:http://www.tid.es/ES/PAGINAS/disclaimer.aspx
>
>
>
>
> --
> and receive email on the basis of the terms set out at:http://www.tid.es/ES/PAGINAS/disclaimer.aspx
>
>
> ACTN mailing [email-masked]://www.ietf.org/mailman/listinfo/actn
>
>
>
>
> ACTN mailing [email-masked]://www.ietf.org/mailman/listinfo/actn
>
> ACTN mailing [email-masked]://www.ietf.org/mailman/listinfo/actn
>
>
> --
>
> DIETER BELLER
> ALCATEL-LUCENT DEUTSCHLAND AG
> Alcatel-Lucent Deutschland AG
> Domicile of the Company: Stuttgart · Local Court Stuttgart HRB 4026
> Board of Management: Wilhelm Dresselhaus (Chairman) · Hans-Jörg Daub ·
> Andreas Gehe
>
> This e-mail and its attachments, if any, may contain confidential
> information.
> If you have received this e-mail in error, please notify us and delete or
> destroy the e-mail and its attachments, if any, immediately.
> If you have received this e-mail in error, you must not forward or make
> use of the e-mail and its attachments, if any.
>

---

From: Oscar González de Dios <[email-masked]>
Date: Wed, 08 Jan 2014 18:05:52 +0000

Hi all,

 I like the VPN term customer, as it adds the notion of the ability to buy services from a provider, and that there is a legal bound, with SLAs . In this particular case, in the draft you mention network provider. You can be more specific and refer to physical network provider (or transport network provider), to emphasize the kind of network provided.

Oscar

Hi All,

A question to ask could be, does the section 3 "Business model of ACTN" in draft-ceccarelli-actn-framework reads better with the term client/server or consumer/producer or something entirely different?

Regards,
Dhruv

On Wed, Jan 8, 2014 at 5:31 PM, Dieter Beller <[email-masked]<mailto:[email-masked]>> wrote:
Hi Young, all,

we need to distinguish administrative boundaries like network domain boundaries from the  hierarchical layered structure
of transport networks (multi-layer architecture).

The client/server term is used in ITU-T Recommendations such as G.805 to address multi-layer aspects:

In the VPN related IETF documents such as RFC 4847, the terms customer/provider network are often used to address
the administrative boundary aspects (see terminology section).

I am not tied to any specific terminology, but iut is IMHO important to make the distinction described above and I it
may be beneficial to adopt existing terminology where it makes sense.

Thanks,
Dieter

Young

-----Original Message-----
From: Scott Brim [mailto:[email-masked]]
Sent: Monday, January 06, 2014 3:49 PM
To: King, Daniel
Cc: Dhruv Dhody; Leeyoung; 윤빈영; [email-masked]<mailto:[email-masked]>; Farrel Adrian; Luyuan Fang; Diego R. Lopez; Daniele Ceccarelli
Subject: Re: [Actn] Client vs. Consumer

On Mon, Jan 6, 2014 at 1:06 PM, King, Daniel <[email-masked]><mailto:[email-masked]> wrote:

Hi All,

A few quick comments.

Br, Dan.

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of
Dhruv Dhody
Sent: 06 January 2014 16:32
To: Leeyoung
Cc: Diego R. Lopez; Daniele Ceccarelli; Farrel Adrian; Luyuan Fang;
[email-masked]<mailto:[email-masked]>; Daniel King
Subject: Re: [Actn] Client vs. Consumer

Regards,

Dhruv

Young

Hi Danielle,

Be goode,

Hi Diego, all,

Daniele

Hi Young,

Hi Diego,

-          Client -> Consumer

Thanks.

Young

Hi,

Hi Young,

Many thanks

Daniele

Hi guys,

Thanks.

Young

Dr Diego R. Lopez
Telefonica I+D

Dr Diego R. Lopez
Telefonica I+D

Dr Diego R. Lopez
Telefonica I+D

_______________________________________________
ACTN mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/actn

_______________________________________________
ACTN mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/actn

_______________________________________________
ACTN mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/actn

Lorenzstrasse 10
70435 Stuttgart, Germany
Phone: +49 711 821 43125
Mobil: +49 175 7266874
[email-masked]<mailto:[email-masked]>

Alcatel-Lucent Deutschland AG
Domicile of the Company: Stuttgart · Local Court Stuttgart HRB 4026
Chairman of the Supervisory Board: Michael Oppenhoff
Board of Management: Wilhelm Dresselhaus (Chairman) · Hans-Jörg Daub · Andreas Gehe

This e-mail and its attachments, if any, may contain confidential information.
If you have received this e-mail in error, please notify us and delete or destroy the e-mail and its attachments, if any, immediately.
If you have received this e-mail in error, you must not forward or make use of the e-mail and its attachments, if any.

---

From: Leeyoung <[email-masked]>
Date: Wed, 8 Jan 2014 21:27:43 +0000

Hi Oscar and Dieter,

I think you have brought a need to clarify the business relationship aspect of ACTN model.  Currently, it is specified three tier model:

-          Consumer (Client) --- now Oscar suggests “Customer.”

-          Service Provider

-          Network Provider

To answer Oscar’s question, Network Provider is defined as physical network provider who owns physical network infrastructure. As to what type of network provider, I think this is still debatable, but in the introduction section (Section 2), we have defined we are concerned about “Transport Networks”:

   Transport networks in this draft refer to a set of different type of
   connection-oriented networks, primarily Connection-Oriented Circuit
   Switched (CO-CS) networks and Connection-Oriented Packet Switched
   (CO-PS) networks. This implies that at least the following transport
   networks are in scope of the discussion of this draft: L1 optical networks
  (e.g., OTN and WSON), MPLS-TP, MPLS-TE, as well as other
   emerging connection-oriented networks such as Segment Routing (SR).
   One of the characteristics of these network types is the ability of
   dynamic provisioning and traffic engineering such that resource
   guarantee can be provided to their clients.

I see a client/server relationship within transport network provider boundaries as Dieter refers to G.850.  I can see that this client/server terminology can be extended to describe a relationship between a consumer/client and a service provider as well as a service provider and a network provider. However, in this ACTN model, we are more concerned about a new business boundary and its relationships which appears beyond this client/server terminology.

If we were to deal with three-tier model in which there are three distinctive business entities (or even two –tier model where service provider is the same as network provider), it seems consumer(or customer)-provider terminology seems fit better.  I see ACTN as extended model of VPN rather than extended model of multi-layer network.

Disclaimer – I am not too much bogged down to either terminology, however, as long as we all recognize this business relationships/model aspect of ACTN.

Regards,
Young

From: ACTN [mailto:[email-masked]] On Behalf Of Oscar González de Dios
Sent: Wednesday, January 08, 2014 12:06 PM
To: Dhruv Dhody; [email-masked]
Subject: Re: [Actn] Client vs. Consumer

Hi all,

Oscar

Hi All,

Regards,
Dhruv

Thanks,
Dieter

Young

-----Original Message-----

To: King, Daniel

Hi All,

A few quick comments.

Br, Dan.

Dhruv Dhody

To: Leeyoung

Regards,

Dhruv

Young

To: Daniele Ceccarelli

Hi Danielle,

Be goode,

Hi Diego, all,

Daniele

To: Leeyoung

Hi Young,

Hi Diego,

-          Client -> Consumer

folks how they think.

Thanks.

Young

To: Leeyoung

Hi,

Hi Young,

Many thanks

Daniele

Hi guys,

Thanks.

Young

--

Dr Diego R. Lopez

Telefonica I+D

Tel:    +34 913 129 041

Mobile: +34 682 051 091

--

Dr Diego R. Lopez

Telefonica I+D

Tel:    +34 913 129 041

Mobile: +34 682 051 091

--

Dr Diego R. Lopez

Telefonica I+D

Tel:    +34 913 129 041

Mobile: +34 682 051 091

ACTN mailing list

ACTN mailing list

ACTN mailing list

Lorenzstrasse 10
70435 Stuttgart, Germany
Phone: +49 711 821 43125
Mobil: +49 175 7266874

---

From: Daniele Ceccarelli <[email-masked]>
Date: Thu, 9 Jan 2014 07:50:18 +0000

How could I agree more since a while ago I said

☺

Maybe we should extend the three tier model to show recursiveness more or less along the lines of:

-          Customer (of service B)

-          Customer (of service A) & Service Provider (of service B)

-          Service Provider (of service A)

-          Network Provider (always 1)
Maybe a drawing could be more helpful here…
Thoughts?

BR
Daniele

From: ACTN [mailto:[email-masked]] On Behalf Of Leeyoung
Sent: mercoledì 8 gennaio 2014 22:28
To: Oscar González de Dios; Dhruv Dhody; [email-masked]
Subject: Re: [Actn] Client vs. Consumer

Hi Oscar and Dieter,

-          Service Provider

-          Network Provider

Regards,
Young

From: ACTN [mailto:[email-masked]] On Behalf Of Oscar González de Dios
Sent: Wednesday, January 08, 2014 12:06 PM
To: Dhruv Dhody; [email-masked]<mailto:[email-masked]>
Subject: Re: [Actn] Client vs. Consumer

Hi all,

Oscar

Hi All,

Regards,
Dhruv

Thanks,
Dieter

Young

-----Original Message-----

To: King, Daniel

Hi All,

A few quick comments.

Br, Dan.

Dhruv Dhody

To: Leeyoung

Regards,

Dhruv

Young

To: Daniele Ceccarelli

Hi Danielle,

Be goode,

Hi Diego, all,

Daniele

To: Leeyoung

Hi Young,

Hi Diego,

-          Client -> Consumer

folks how they think.

Thanks.

Young

To: Leeyoung

Hi,

Hi Young,

Many thanks

Daniele

Hi guys,

Thanks.

Young

--

Dr Diego R. Lopez

Telefonica I+D

Tel:    +34 913 129 041

Mobile: +34 682 051 091

--

Dr Diego R. Lopez

Telefonica I+D

Tel:    +34 913 129 041

Mobile: +34 682 051 091

--

Dr Diego R. Lopez

Telefonica I+D

Tel:    +34 913 129 041

Mobile: +34 682 051 091

ACTN mailing list

ACTN mailing list

ACTN mailing list

Lorenzstrasse 10
70435 Stuttgart, Germany
Phone: +49 711 821 43125
Mobil: +49 175 7266874

---

From: Leeyoung <[email-masked]>
Date: Thu, 9 Jan 2014 17:19:34 +0000

I support this idea. Thanks.

Young

From: Daniele Ceccarelli [mailto:[email-masked]]
Sent: Thursday, January 09, 2014 1:50 AM
To: Leeyoung; Oscar González de Dios; Dhruv Dhody; [email-masked]
Subject: RE: [Actn] Client vs. Consumer

☺

BR
Daniele

From: ACTN [mailto:[email-masked]] On Behalf Of Leeyoung
Sent: mercoledì 8 gennaio 2014 22:28
To: Oscar González de Dios; Dhruv Dhody; [email-masked]<mailto:[email-masked]>
Subject: Re: [Actn] Client vs. Consumer

Hi Oscar and Dieter,

-          Service Provider

-          Network Provider

Regards,
Young

Hi all,

Oscar

Hi All,

Regards,
Dhruv

Thanks,
Dieter

Young

-----Original Message-----

To: King, Daniel

Hi All,

A few quick comments.

Br, Dan.

Dhruv Dhody

To: Leeyoung

Regards,

Dhruv

Young

To: Daniele Ceccarelli

Hi Danielle,

Be goode,

Hi Diego, all,

Daniele

To: Leeyoung

Hi Young,

Hi Diego,

-          Client -> Consumer

folks how they think.

Thanks.

Young

To: Leeyoung

Hi,

Hi Young,

Many thanks

Daniele

Hi guys,

Thanks.

Young

--

Dr Diego R. Lopez

Telefonica I+D

Tel:    +34 913 129 041

Mobile: +34 682 051 091

--

Dr Diego R. Lopez

Telefonica I+D

Tel:    +34 913 129 041

Mobile: +34 682 051 091

--

Dr Diego R. Lopez

Telefonica I+D

Tel:    +34 913 129 041

Mobile: +34 682 051 091

ACTN mailing list

ACTN mailing list

ACTN mailing list

Lorenzstrasse 10
70435 Stuttgart, Germany
Phone: +49 711 821 43125
Mobil: +49 175 7266874

---

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Thu, 09 Jan 2014 18:13:14 +0000

Hi,

There can be situation where the scenarios become more complex.

For instance, if the service providers needs to lease some part of the network capacity to complement its own infrastructure for serving a given customer you can have:

Customer (of service B)                                X -------------------------------------------------------------- X

Service Provider (of service B)   X -------------------------------------------------------------- X

Customer (of service A)                                X ----------------------------- X

Service Provider (of service A)   X ----------------------------- X

Network Provider 1                                                                        X ------------------------------ X

Network Provider 2                        X ----------------------------- X

Where Service Provider (of service B) is at the same time Network Provider 1 and Customer (of service A).

Some other complex cases could be in place. Maybe it is better to start working with a simpler model but allowing for more complex relationships.

Best regards,

Luis

De: ACTN [mailto:[email-masked]] En nombre de Leeyoung
Enviado el: jueves, 09 de enero de 2014 18:20
Para: Daniele Ceccarelli; Oscar González de Dios; Dhruv Dhody; [email-masked]
Asunto: Re: [Actn] Client vs. Consumer

Young

From: Daniele Ceccarelli [mailto:[email-masked]]
Sent: Thursday, January 09, 2014 1:50 AM
To: Leeyoung; Oscar González de Dios; Dhruv Dhody; [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] Client vs. Consumer

☺

BR
Daniele

Hi Oscar and Dieter,

-          Service Provider

-          Network Provider

Regards,
Young

Hi all,

Oscar

Hi All,

Regards,
Dhruv

Thanks,
Dieter

Young

-----Original Message-----

To: King, Daniel

Hi All,

A few quick comments.

Br, Dan.

Dhruv Dhody

To: Leeyoung

Regards,

Dhruv

Young

To: Daniele Ceccarelli

Hi Danielle,

Be goode,

Hi Diego, all,

Daniele

To: Leeyoung

Hi Young,

Hi Diego,

-          Client -> Consumer

folks how they think.

Thanks.

Young

To: Leeyoung

Hi,

Hi Young,

Many thanks

Daniele

Hi guys,

Thanks.

Young

--

Dr Diego R. Lopez

Telefonica I+D

Tel:    +34 913 129 041

Mobile: +34 682 051 091

--

Dr Diego R. Lopez

Telefonica I+D

Tel:    +34 913 129 041

Mobile: +34 682 051 091

--

Dr Diego R. Lopez

Telefonica I+D

Tel:    +34 913 129 041

Mobile: +34 682 051 091

ACTN mailing list

ACTN mailing list

ACTN mailing list

Lorenzstrasse 10
70435 Stuttgart, Germany
Phone: +49 711 821 43125
Mobil: +49 175 7266874

---

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Thu, 09 Jan 2014 18:21:10 +0000

Sorry,

I see the ASCII drawing cannot be easily understood. I attached the idea in ppt format for supporting my reasoning.

Regards,

Luis

De: ACTN [mailto:[email-masked]] En nombre de LUIS MIGUEL CONTRERAS MURILLO
Enviado el: jueves, 09 de enero de 2014 19:13
Para: Leeyoung; Daniele Ceccarelli; Oscar González de Dios; Dhruv Dhody; [email-masked]
Asunto: Re: [Actn] Client vs. Consumer

Hi,

Best regards,

Luis

De: ACTN [mailto:[email-masked]] En nombre de Leeyoung
Enviado el: jueves, 09 de enero de 2014 18:20
Para: Daniele Ceccarelli; Oscar González de Dios; Dhruv Dhody; [email-masked]<mailto:[email-masked]>
Asunto: Re: [Actn] Client vs. Consumer

Young

☺

BR
Daniele

Hi Oscar and Dieter,

-          Service Provider

-          Network Provider

Regards,
Young

Hi all,

Oscar

Hi All,

Regards,
Dhruv

Thanks,
Dieter

Young

-----Original Message-----

To: King, Daniel

Hi All,

A few quick comments.

Br, Dan.

Dhruv Dhody

To: Leeyoung

Regards,

Dhruv

Young

To: Daniele Ceccarelli

Hi Danielle,

Be goode,

Hi Diego, all,

Daniele

To: Leeyoung

Hi Young,

Hi Diego,

-          Client -> Consumer

folks how they think.

Thanks.

Young

To: Leeyoung

Hi,

Hi Young,

Many thanks

Daniele

Hi guys,

Thanks.

Young

--

Dr Diego R. Lopez

Telefonica I+D

Tel:    +34 913 129 041

Mobile: +34 682 051 091

--

Dr Diego R. Lopez

Telefonica I+D

Tel:    +34 913 129 041

Mobile: +34 682 051 091

--

Dr Diego R. Lopez

Telefonica I+D

Tel:    +34 913 129 041

Mobile: +34 682 051 091

ACTN mailing list

ACTN mailing list

ACTN mailing list

Lorenzstrasse 10
70435 Stuttgart, Germany
Phone: +49 711 821 43125
Mobil: +49 175 7266874

---

From: "King, Daniel" <[email-masked]>
Date: Thu, 9 Jan 2014 18:43:38 +0000

Hi Luis, 

Interesting scenario(s). 

Recent discussions have highlighted a need for recursion (nesting), where it should be possible for a network topology to be segmented to allow topology hierarchies with parent and child relationships. What you are suggesting here is that a Service Provider may need two topologies (one from Network Provider A, second from Network Provider B) which it would stitch together in order to provide the required connectivity for the consumer (Service1). Attached is my ascii art example :-)

Br, Dan. 

Hi,

 

 

 
 
Best regards,
 
Luis

 
Young

 
 
☺

 
BR
Daniele

Hi Oscar and Dieter,

 

 
 
Regards,
Young

 
 
Hi all, 

Oscar
 
Hi All,  

 
Regards,
Dhruv
 
On Wed, Jan 8, 2014 at 5:31 PM, Dieter Beller <[email-masked]> wrote:
Hi Young, all,

Thanks,
Dieter
 
Young
 
-----Original Message-----
From: Scott Brim [mailto:[email-masked]] 
Sent: Monday, January 06, 2014 3:49 PM
To: King, Daniel
Cc: Dhruv Dhody; Leeyoung; 윤빈영; [email-masked]; Farrel Adrian; Luyuan Fang; Diego R. Lopez; Daniele Ceccarelli
Subject: Re: [Actn] Client vs. Consumer

 
A few quick comments.

 

 

 

 

Br, Dan.

 

 

 
Regards,
 
Dhruv

 
Young

 
Hi Danielle,

 
Be goode,

 
Hi Diego, all,

 
 
Daniele

 

Hi Young,

 

 
Hi Diego,

 

 
-          Client -> Consumer

 

 
Thanks.

 
Young

 
Hi,

 

 
Hi Young,

 
Many thanks
 
Daniele

 
Hi guys,

 

Thanks.
 
Young

 

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091

 

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091

 

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091

_______________________________________________
ACTN mailing list
[email-masked]://www.ietf.org/mailman/listinfo/actn

 
_______________________________________________
ACTN mailing list
[email-masked]://www.ietf.org/mailman/listinfo/actn
_______________________________________________
ACTN mailing list
[email-masked]://www.ietf.org/mailman/listinfo/actn
 
-- 

DIETER BELLER 

Lorenzstrasse 10 
70435 Stuttgart, Germany 
Phone: +49 711 821 43125 
Mobil: +49 175 7266874 

________________________________________

________________________________________

________________________________________

---

From: Young Lee <[email-masked]>
Date: Thu, 9 Jan 2014 13:28:44 -0600

Yes, this senario Luis identified needs to be included as part of Service
provider's VNC (Virtual network controller) in which to support customer's
end to end connectivity customer that may span a number of network
providers.

In this senario, Service provider's VNC plays a role of service
coordination/orchestration to identify customer's end points and perform
path computation over these mutliple topologies to give the best route
possible.

Young
 On Jan 9, 2014 12:43 PM, "King, Daniel" <[email-masked]> wrote:

> Hi Luis,
>
> Interesting scenario(s).
>
> Recent discussions have highlighted a need for recursion (nesting), where
> it should be possible for a network topology to be segmented to allow
> topology hierarchies with parent and child relationships. What you are
> suggesting here is that a Service Provider may need two topologies (one
> from Network Provider A, second from Network Provider B) which it would
> stitch together in order to provide the required connectivity for the
> consumer (Service1). Attached is my ascii art example :-)
>
> Br, Dan.
>
> For instance, if the service providers needs to lease some part of the
> network capacity to complement its own infrastructure for serving a given
> customer you can have:
>
> Customer (of service B)                                X
> -------------------------------------------------------------- X
>
> Service Provider (of service B)   X
> -------------------------------------------------------------- X
>
> 1                                                                        X
> ------------------------------ X
>
> Some other complex cases could be in place. Maybe it is better to start
> working with a simpler model but allowing for more complex relationships.
>
> Best regards,
>
> Luis
>
>
> I think you have brought a need to clarify the business relationship
> aspect of ACTN model.  Currently, it is specified three tier model:
> To answer Oscar’s question, Network Provider is defined as physical
> network provider who owns physical network infrastructure. As to what type
> of network provider, I think this is still debatable, but in the
> introduction section (Section 2), we have defined we are concerned about
> “Transport Networks”:
>
> I see a client/server relationship within transport network provider
> boundaries as Dieter refers to G.850.  I can see that this client/server
> terminology can be extended to describe a relationship between a
> consumer/client and a service provider as well as a service provider and a
> network provider. However, in this ACTN model, we are more concerned about
> a new business boundary and its relationships which appears beyond this
> client/server terminology.
>
> If we were to deal with three-tier model in which there are three
> distinctive business entities (or even two –tier model where service
> provider is the same as network provider), it seems consumer(or
> customer)-provider terminology seems fit better.  I see ACTN as extended
> model of VPN rather than extended model of multi-layer network.
>
> Disclaimer – I am not too much bogged down to either terminology, however,
> as long as we all recognize this business relationships/model aspect of
> ACTN.
>
> Regards,
> Young
>
>
>
>
>  I like the VPN term customer, as it adds the notion of the ability to buy
> services from a provider, and that there is a legal bound, with SLAs . In
> this particular case, in the draft you mention network provider. You can be
> more specific and refer to physical network provider (or transport network
> provider), to emphasize the kind of network provided.
>
> Oscar
>
> Hi All,
>

---

From: Leeyoung <[email-masked]>
Date: Thu, 9 Jan 2014 23:42:01 +0000

I was not clear on the following email as I was writing using my smart phone.

My point was that as a service provider’s VNC deals with multiple network providers to connect customer’s end-to-end connectivity, service’s provider’s VNC needs to play a role of coordination and orchestration. See the below example:

From: Young Lee [mailto:[email-masked]]
Sent: Thursday, January 09, 2014 1:29 PM
To: King, Daniel
Cc: Daniele Ceccarelli; Dhruv Dhody; LUIS MIGUEL CONTRERAS MURILLO; [email-masked]; Oscar González de Dios; Leeyoung
Subject: Re: [Actn] Client vs. Consumer

Yes, this senario Luis identified needs to be included as part of Service provider's VNC (Virtual network controller) in which to support customer's end to end connectivity customer that may span a number of network providers.

In this senario, Service provider's VNC plays a role of service coordination/orchestration to identify customer's end points and perform path computation over these mutliple topologies to give the best route possible.

Young
On Jan 9, 2014 12:43 PM, "King, Daniel" <[email-masked]<mailto:[email-masked]>> wrote:
Hi Luis,

Interesting scenario(s).

Br, Dan.

De: ACTN [mailto:[email-masked]<mailto:[email-masked]>] En nombre de LUIS MIGUEL CONTRERAS MURILLO
Enviado el: jueves, 09 de enero de 2014 19:13
Para: Leeyoung; Daniele Ceccarelli; Oscar González de Dios; Dhruv Dhody; [email-masked]<mailto:[email-masked]>
Asunto: Re: [Actn] Client vs. Consumer

Hi,

Best regards,

Luis

De: ACTN [mailto:[email-masked]<mailto:[email-masked]>] En nombre de Leeyoung
Enviado el: jueves, 09 de enero de 2014 18:20
Para: Daniele Ceccarelli; Oscar González de Dios; Dhruv Dhody; [email-masked]<mailto:[email-masked]>
Asunto: Re: [Actn] Client vs. Consumer

Young

From: Daniele Ceccarelli [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, January 09, 2014 1:50 AM
To: Leeyoung; Oscar González de Dios; Dhruv Dhody; [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] Client vs. Consumer

☺

BR
Daniele

From: ACTN [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Leeyoung
Sent: mercoledì 8 gennaio 2014 22:28
To: Oscar González de Dios; Dhruv Dhody; [email-masked]<mailto:[email-masked]>
Subject: Re: [Actn] Client vs. Consumer

Hi Oscar and Dieter,

Regards,
Young

From: ACTN [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Oscar González de Dios
Sent: Wednesday, January 08, 2014 12:06 PM
To: Dhruv Dhody; [email-masked]<mailto:[email-masked]>
Subject: Re: [Actn] Client vs. Consumer

Hi all,

Oscar

Hi All,

Regards,
Dhruv

Thanks,
Dieter

Young

-----Original Message-----
From: Scott Brim [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, January 06, 2014 3:49 PM
To: King, Daniel
Cc: Dhruv Dhody; Leeyoung; 윤빈영; [email-masked]<mailto:[email-masked]>; Farrel Adrian; Luyuan Fang; Diego R. Lopez; Daniele Ceccarelli
Subject: Re: [Actn] Client vs. Consumer

On Mon, Jan 6, 2014 at 1:06 PM, King, Daniel <[email-masked]<mailto:[email-masked]>> wrote:
Hi All,

A few quick comments.

Br, Dan.

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of
Dhruv Dhody

Regards,

Dhruv

Young

Hi Danielle,

Be goode,

Hi Diego, all,

Daniele

Hi Young,

Hi Diego,

-          Client -> Consumer

Thanks.

Young

Hi,

Hi Young,

Many thanks

Daniele

From: Leeyoung [mailto:[email-masked]<mailto:[email-masked]>]

Hi guys,

Thanks.

Young

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041<tel:%2B34%20913%20129%20041>
Mobile: +34 682 051 091<tel:%2B34%20682%20051%20091>
-----------------------------------------

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041<tel:%2B34%20913%20129%20041>
Mobile: +34 682 051 091<tel:%2B34%20682%20051%20091>
-----------------------------------------

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041<tel:%2B34%20913%20129%20041>
Mobile: +34 682 051 091<tel:%2B34%20682%20051%20091>
-----------------------------------------

_______________________________________________
ACTN mailing list
[email-masked]://www.ietf.org/mailman/listinfo/actn<http://www.ietf.org/mailman/listinfo/actn>

_______________________________________________
ACTN mailing list
[email-masked]://www.ietf.org/mailman/listinfo/actn<http://www.ietf.org/mailman/listinfo/actn>
_______________________________________________
ACTN mailing list
[email-masked]://www.ietf.org/mailman/listinfo/actn<http://www.ietf.org/mailman/listinfo/actn>

--

DIETER BELLER

Lorenzstrasse 10
70435 Stuttgart, Germany
Phone: +49 711 821 43125<tel:%2B49%20711%20821%2043125>
Mobil: +49 175 7266874<tel:%2B49%20175%207266874>
[email-masked]<mailto:[email-masked]>

---

From: "Diego R. Lopez" <[email-masked]>
Date: Sun, 12 Jan 2014 22:17:05 +0000

Hi,

For you to know, my proposal for the terms "consumer" and "provider" came from the terminology currently in use within the NFV community. This is the definition made by the MANO (Management and Orchestration) WG:

8<---
5.5.1      Producer-Consumer paradigm

A producer functional block is a role played by a functional block that produces certain functions, and exposes them externally through public interfaces or APIs. A consumer functional block is a role played by a functional block that consumes certain functions. A functional block may play both producer and consumer roles. Interfaces represent a published contract offered by a producer functional block, exposing externally the functions produced. They can be consumed by any other consumer functional block that is authenticated and authorized to access and consume the functions offered; authentication mechanisms and authorization policies are defined to control access to and consumption of functions produced by functional block, to the level of granularity desired by the owner of the producer functional block. A producer functional block may offer different functions, and may offer different levels of granularity within each function; authorization policies should reflect such granularity because different access and consumption rights may be granted to different consumer functional blocks.

A consumer functional block may also have a choice of sending requests to several producer functional blocks offering the same function; in some cases the function offered may be completely identical, in other cases one producer functional block may offer the function with optional extensions. Depending on implementation choices, configuration policies may be used to determine which producer functional block may be invoked by a consumer functional block to provide the desired function.

Between the choices dictated by configuration policies available at the consuming functional block, the implementation choices of vendors offering the functions and the choices dictated by authorization policies at the producing functional block, the ability to  support some preferred operational flows, and disallow other operational flows in the Service Provider’s environment becomes straightforward.

8<---

This said, if you think using the terms "client"/"customer" or "server" will make things clearer to the main intended audience of the results of ACTN, I am happy of keeping the most commonly accepted terms.

Be goode,

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091

---

From: Leeyoung <[email-masked]>
Date: Mon, 13 Jan 2014 03:53:14 +0000

Hi Diego,

Is "producer" equivalent to "provider"?  Your NFV reference uses a term "consumer-producer" while you proposed in ACTN a term "consumer-provider".

In ACTN, we used "provider" as we deal with service providers and network providers.  It may be a little awkward to call these entities as service producers or network producers. :)

Thanks,
Young

From: Diego R. Lopez [mailto:[email-masked]]
Sent: Sunday, January 12, 2014 4:17 PM
To: Leeyoung
Cc: Young Lee; King, Daniel; Dhruv Dhody; [email-masked]; Oscar González de Dios; Daniele Ceccarelli; LUIS MIGUEL CONTRERAS MURILLO
Subject: Re: [Actn] Client vs. Consumer

Hi,

8<---

Between the choices dictated by configuration policies available at the consuming functional block, the implementation choices of vendors offering the functions and the choices dictated by authorization policies at the producing functional block, the ability to  support some preferred operational flows, and disallow other operational flows in the Service Provider's environment becomes straightforward.

8<---

Be goode,

Dr Diego R. Lopez
Telefonica I+D

---

From: "Diego R. Lopez" <[email-masked]>
Date: Mon, 13 Jan 2014 06:28:12 +0000

Hi Young,

Your right: I proposed "provider" when the canonical term is "producer". As I said, I'd like to align with common practice in the target community...

Be goode,

On 13 Jan 2014, at 04:53 , Leeyoung <[email-masked]<mailto:[email-masked]>> wrote:

Hi Diego,

Is “producer” equivalent to “provider”?  Your NFV reference uses a term “consumer-producer” while you proposed in ACTN a term “consumer-provider”.

In ACTN, we used “provider” as we deal with service providers and network providers.  It may be a little awkward to call these entities as service producers or network producers. :)

Thanks,
Young

From: Diego R. Lopez [mailto:[email-masked]]
Sent: Sunday, January 12, 2014 4:17 PM
To: Leeyoung
Cc: Young Lee; King, Daniel; Dhruv Dhody; [email-masked]<mailto:[email-masked]>; Oscar González de Dios; Daniele Ceccarelli; LUIS MIGUEL CONTRERAS MURILLO
Subject: Re: [Actn] Client vs. Consumer

Hi,

8<---

8<---

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091

---

From: Diego Caviglia <[email-masked]>
Date: Mon, 13 Jan 2014 07:46:48 +0000

Hi all
          I have also no strong preference on the terminology but I'm scared that if it took us more than 20 email to get a common point it could confuse the reader or at least become subject of arguing in the community while I think we should focus the attention on other aspects of this work.

Up to now to my understanding client/server and customer/producer are almost the same so we can use client/server stating is the a synonymous of client/server in the NFV domain.

My two cents

Ciao

D

From: ACTN [mailto:[email-masked]] On Behalf Of Diego R. Lopez
Sent: lunedì 13 gennaio 2014 07:28
To: Leeyoung
Cc: Dhruv Dhody; LUIS MIGUEL CONTRERAS MURILLO; Oscar González de Dios; King, Daniel; Young Lee; [email-masked]; Daniele Ceccarelli
Subject: Re: [Actn] Client vs. Consumer

Hi Young,

Be goode,

Hi Diego,

Thanks,
Young

Hi,

8<---

8<---

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Dr Diego R. Lopez
Telefonica I+D

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Sat, 18 Jan 2014 07:50:27 +0000

Hi, Dieter,

  Thank you for providing the information. So, we have both terms used in standards before and we need to decide which one we like to use for ACTN.

I like the term customer/provider more to be used in the ACTN context. As far as I understand, what we try to address is the resource can be managed by the customer itself (i.e., administrative boundary), not necessarily related to the technology boundaries.

Thoughts?

Regards,
Xian
From: ACTN [mailto:[email-masked]] On Behalf Of Dieter Beller
Sent: 2014年1月8日 20:01
To: Leeyoung; Scott Brim; King, Daniel
Cc: Dhruv Dhody; [email-masked]; 윤빈영; Luyuan Fang; Farrel Adrian; Diego R. Lopez; Daniele Ceccarelli
Subject: Re: [Actn] Client vs. Consumer

Hi Young, all,

Thanks,
Dieter

Young

-----Original Message-----

To: King, Daniel

Hi All,

A few quick comments.

Br, Dan.

Dhruv Dhody

To: Leeyoung

Regards,

Dhruv

Young

To: Daniele Ceccarelli

Hi Danielle,

Be goode,

Hi Diego, all,

Daniele

To: Leeyoung

Hi Young,

Hi Diego,

-          Client -> Consumer

folks how they think.

Thanks.

Young

To: Leeyoung

Hi,

Hi Young,

Many thanks

Daniele

Hi guys,

Thanks.

Young

--

Dr Diego R. Lopez

Telefonica I+D

Tel:    +34 913 129 041

Mobile: +34 682 051 091

--

Dr Diego R. Lopez

Telefonica I+D

Tel:    +34 913 129 041

Mobile: +34 682 051 091

--

Dr Diego R. Lopez

Telefonica I+D

Tel:    +34 913 129 041

Mobile: +34 682 051 091

ACTN mailing list

ACTN mailing list

ACTN mailing list

Lorenzstrasse 10
70435 Stuttgart, Germany
Phone: +49 711 821 43125
Mobil: +49 175 7266874

---

From: Fatai Zhang <[email-masked]>
Date: Tue, 21 Jan 2014 08:42:56 +0000

Hi all,

I just went over so many mails, :)

Is there a final decision/agreement on which terms should be picked up?

To me, I would like to second Oscar, ie., I personally prefer Customer/Provider.

Best Regards

Fatai

From: ACTN [mailto:[email-masked]] On Behalf Of Diego Caviglia
Sent: Monday, January 13, 2014 3:47 PM
To: Diego R. Lopez; Leeyoung
Cc: Dhruv Dhody; LUIS MIGUEL CONTRERAS MURILLO; Oscar González de Dios; King, Daniel; Young Lee; [email-masked]; Daniele Ceccarelli
Subject: Re: [Actn] Client vs. Consumer

Hi all

My two cents

Ciao

D

From: ACTN [mailto:[email-masked]] On Behalf Of Diego R. Lopez
Sent: lunedì 13 gennaio 2014 07:28
To: Leeyoung
Cc: Dhruv Dhody; LUIS MIGUEL CONTRERAS MURILLO; Oscar González de Dios; King, Daniel; Young Lee; [email-masked]<mailto:[email-masked]>; Daniele Ceccarelli
Subject: Re: [Actn] Client vs. Consumer

Hi Young,

Be goode,

Hi Diego,

Thanks,
Young

Hi,

8<---

8<---

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Dr Diego R. Lopez
Telefonica I+D

---

From: Dieter Beller <[email-masked]>
Date: Tue, 21 Jan 2014 10:39:52 +0100

Hi all,

On 21.01.2014 09:42, Fatai Zhang wrote:

Hi all,

I just went over so many mails,
☺

Is there a final decision/agreement on which
terms should be picked up?

To me, I would like to second Oscar, ie., I
personally prefer Customer/Provider.

this is my preference too.

Thanks,

Dieter

Best Regards

Fatai

From: ACTN [mailto:[email-masked]]
On Behalf Of Diego Caviglia

Cc: Dhruv Dhody; LUIS MIGUEL CONTRERAS MURILLO;
Oscar González de Dios; King, Daniel; Young Lee;
[email-masked]; Daniele Ceccarelli

Hi all

I have also no strong preference on
the terminology but I’m scared that if it took us more than
20 email to get a common point it could confuse the reader
or at least become subject of arguing in the community while
I think we should focus the attention on other aspects of
this work.

Up to now to my understanding client/server and
customer/producer are almost the same so we can use
client/server stating is the a synonymous of client/server
in the NFV domain.

My two cents

Ciao

D

From: ACTN [mailto:[email-masked]]
On Behalf Of Diego R. Lopez

To: Leeyoung

Cc: Dhruv Dhody; LUIS MIGUEL CONTRERAS MURILLO;
Oscar González de Dios; King, Daniel; Young Lee;
[email-masked];
Daniele Ceccarelli

Hi Young,

Your right: I
proposed "provider" when the canonical term is
"producer". As I said, I'd like to align with common
practice in the target community...

Be goode,

On 13 Jan 2014,
at 04:53 , Leeyoung <[email-masked]>
wrote:

Hi Diego,

Is “producer” equivalent to
“provider”?  Your NFV reference uses a term
“consumer-producer” while you proposed in ACTN a
term “consumer-provider”.

In ACTN, we used “provider” as we
deal with service providers and network
providers.  It may be a little awkward to call
these entities as service producers or network
producers. ☺

Thanks,

Young

Sent: Sunday,
January 12, 2014 4:17 PM

To: Leeyoung

Cc: Young
Lee; King, Daniel; Dhruv Dhody; [email-masked];
Oscar González de Dios; Daniele Ceccarelli;
LUIS MIGUEL CONTRERAS MURILLO

Subject: Re:
[Actn] Client vs. Consumer

Hi,

For you to
know, my proposal for the terms "consumer" and
"provider" came from the terminology currently
in use within the NFV community. This is the
definition made by the MANO (Management and
Orchestration) WG:

8<---

5.5.1      Producer-Consumer
paradigm

A producer functional block is a role played
by a functional block that produces certain
functions, and exposes them externally
through public interfaces or APIs. A
consumer functional block is a role played
by a functional block that consumes certain
functions. A functional block may play both
producer and consumer roles. Interfaces
represent a published contract offered by a
producer functional block, exposing
externally the functions produced. They can
be consumed by any other consumer functional
block that is authenticated and authorized
to access and consume the functions offered;
authentication mechanisms and authorization
policies are defined to control access to
and consumption of functions produced by
functional block, to the level of
granularity desired by the owner of the
producer functional block. A producer
functional block may offer different
functions, and may offer different levels of
granularity within each function;
authorization policies should reflect such
granularity because different access and
consumption rights may be granted to
different consumer functional blocks.

A consumer functional block may also have a
choice of sending requests to several
producer functional blocks offering the same
function; in some cases the function offered
may be completely identical, in other cases
one producer functional block may offer the
function with optional extensions. Depending
on implementation choices, configuration
policies may be used to determine which
producer functional block may be invoked by
a consumer functional block to provide the
desired function.

Between the choices dictated by
configuration policies available at the
consuming functional block, the
implementation choices of vendors offering
the functions and the choices dictated by
authorization policies at the producing
functional block, the ability to  support
some preferred operational flows, and
disallow other operational flows in the
Service Provider’s environment becomes
straightforward.

8<---

This said, if you think using
the terms "client"/"customer" or "server"
will make things clearer to the main
intended audience of the results of ACTN, I
am happy of keeping the most commonly
accepted terms.

Be goode,

--

Dr Diego R. Lopez

Telefonica I+D

e-mail: [email-masked]

Tel:    +34 913 129 041

Mobile: +34 682 051 091

Este mensaje se dirige exclusivamente a su
destinatario. Puede consultar nuestra política
de envío y recepción de correo electrónico en el
enlace situado más abajo.

This message is intended exclusively for its
addressee. We only send and receive email on the
basis of the terms set out at:

--

Dr Diego R. Lopez

Telefonica I+D

e-mail: [email-masked]

Tel:    +34 913 129 041

Mobile: +34 682 051 091

Este mensaje se dirige exclusivamente a su destinatario.
Puede consultar nuestra política de envío y recepción de
correo electrónico en el enlace situado más abajo.

This message is intended exclusively for its addressee. We
only send and receive email on the basis of the terms set
out at:

---

From: Leeyoung <[email-masked]>
Date: Tue, 21 Jan 2014 21:46:12 +0000

Please express your opinion on the following doodle poll (only if you care).

There are three suggestions here:

1.       Client/Provider

2.       Consumer/Provider

3.       Customer/Provider

We will conclude the poll result by the COB, Jan 24.

http://doodle.com/bymu2e2x4zzqbetg

Regards,
Young

From: Dieter Beller [mailto:[email-masked]]
Sent: Tuesday, January 21, 2014 3:40 AM
To: Fatai Zhang; Diego Caviglia; Diego R. Lopez; Leeyoung
Cc: Dhruv Dhody; LUIS MIGUEL CONTRERAS MURILLO; Oscar González de Dios; King, Daniel; Young Lee; [email-masked]; Daniele Ceccarelli
Subject: Re: [Actn] Client vs. Consumer

Hi all,

I just went over so many mails, ☺

Thanks,
Dieter

Best Regards

Fatai

Hi all
          I have also no strong preference on the terminology but I’m scared that if it took us more than 20 email to get a common point it could confuse the reader or at least become subject of arguing in the community while I think we should focus the attention on other aspects of this work.

My two cents

Ciao

D

Hi Young,

Be goode,

Hi Diego,

In ACTN, we used “provider” as we deal with service providers and network providers.  It may be a little awkward to call these entities as service producers or network producers. ☺

Thanks,
Young

Hi,

8<---

8<---

Be goode,

Dr Diego R. Lopez
Telefonica I+D

Dr Diego R. Lopez
Telefonica I+D

ACTN mailing list