Subject: Re: [Actn] Problem Statement Update

From: "Shew, Stephen" <[email-masked]>
Date: Wed, 16 Jul 2014 16:13:35 -0400

I'll be at IETF90, but may not make the BOF on Thursday so I've captured some comments on the ACTN problem statement below.

1.      P.5 "Multi-tenant" - it's not clear to me what this means.  Does it mean resources at a common site that are virtualized?

2.      P.7 "2.1 Virtual Private Networks".  For layer 1 networks, I did point out in the IETF88 timeframe, that ITU-T Recommendations Y.1312 and Y.1313 be examined. They are referenced in RFC4847.  What is significant about those 2 Recommendations is that they define VPNs in both the user plane (resources) and the control plane.  Much of what is described is directly applicable to the ACTN problem statement. For example, how a VPN user is able to create/release connections in a VPN that has dedicated resources.  I suggest that much of the terminology and concepts be referenced in ACTN as it comes from an SDO that standardizes much of the transport technologies referred to in the I-D.

3.      P.10 "3.2 Network Resource Recursiveness".  I think recursion is a powerful concept and recursion of network resources is well described in ITU-T G.800.  This section needs to be more precise in that it is also referring to recursion of the control of resources, not just the resources themselves. In that regard, the ONF SDN Architecture describes SDN Controller hierarchy which is performing this recursion of control.  The I-D should add a reference to https://www.opennetworking.org/images/stories/downloads/sdn-resources/technical-reports/TR_SDN_ARCH_1.0_06062014.pdf

4.      P. 13 "4.3 Common Data Models". The idea of a common data model is helpful for many reasons.  I suggest that the requirement be modified to say "common information model" as this is a representation in terms of the properties of thing and the relationship between those things.  Data models can then be developed from the common information model with specific encodings at interfaces.  I suggest that the I-D refer to TMF TR215 and that ACTN interact with the ONF as they consider a common information model.

Stephen

From: ACTN [mailto:[email-masked]] On Behalf Of Leeyoung
Sent: 04 June, 2014 00:28
To: [email-masked]
Subject: [Actn] Problem Statement Update

We have updated the problem statement for ACTN.

Major changes are:

-          Luis (Telefonica) has been added as a co-author. He provided many valuable text that enriched the draft.

-          Added some text on virtual network operational aspect.

Any comments are welcomed.

Young & Dan

---

From: Leeyoung <[email-masked]>
Date: Wed, 23 Jul 2014 14:52:31 +0000

Hi Stephen,

Sorry for my very late response. When I saw you today in Toronto, this reminded me of your email you posted last week.

Here's my response to you. Please see inline.

Thanks,
Young

From: ACTN [mailto:[email-masked]] On Behalf Of Shew, Stephen
Sent: Wednesday, July 16, 2014 3:14 PM
To: [email-masked]
Subject: Re: [Actn] Problem Statement Update

YOUNG>>  I think multi-tenant means many services are sharing the common transport resources. Please see KDDI use-case for detail.

http://tools.ietf.org/html/draft-kumaki-actn-multitenant-vno-00

YOUNG>> Thanks for the pointers. I agree that some of your pointed references may have some implication to the scope of ACTN. We will look into that.

YOUNG>> At this moment, we are not particularly looking at recursiveness aspect. As you read use-cases, we have an immediate need for an operator's multi-domain issue which is pretty flat layer. But as the PS draft alludes, there may be an implication for chains for client-server sets. Thanks for the pointer from ONF. Here we are mostly concerned about existing transport networks of various kinds (e.g., GMPLS/ASON, NMS based, PCE based etc.) Hierarchical concept is also addressed in IETF H-PCE and others. But at this moment, the focus of use-cases is pretty flat.

YOUNG>> Common DM/IM is important. We will definitely look into Yang and JSON-based Models to begin with. TMF model will be looked at. Thanks.

Stephen

From: ACTN [mailto:[email-masked]] On Behalf Of Leeyoung
Sent: 04 June, 2014 00:28
To: [email-masked]<mailto:[email-masked]>
Subject: [Actn] Problem Statement Update

Major changes are:

Young & Dan