Subject: [Actn] AD's summary of ACTN BoF

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 7 Aug 2014 13:32:48 +0100

Hi,

Apologies for the delay after IETF-90 caused by an excess of travel.

First, let me thank the chairs and all of you who spoke either to present or to
ask questions / make comments from the floor.

>From many perspectives, the ACTN BoF was successful. It was intended to provide
a venue for network operators to talk about the type of problem they are trying
to solve and the "pain points" they are encountering. From that perspective it
was very valuable, and it is nice to see a forum where operators can share their
thoughts and ideas without the vendors telling them what to think.

The BoF was billed as a "non-WG forming BoF" and we can say that the BoF was
very successful in that regard: no WG was formed ;-)

In re-reading my notes from the BoF and looking at the minutes posted to this
list (chairs: please be sure to post the minutes to the meetings materials page)
I think there were some common threads visible in the presentations/use-cases
from the different operators:

- Desire to request end-to-end services over multi-domain/layer networks

- Desire to express services to a network and to build abstract/virtual networks
to support those services

- A need to provision/control inter-domain links

There may be some more common threads, but perhaps we should be looking for just
a few ideas with wide support.

However, I didn't come away with any clarity about what actually needs work.
This should not be a huge surprise because that was not the top objective of the
BoF, but it should be the next focus for people wanting to work in this area. We
need to identify the topics that could be brought to the IETF for
standardisation activities.

To advance this, i suggest that the next step is for the proponents to convert
the use-cases into an architecture (developing the documents that already exist)
with the objective of seeing whether this architecture can be solved with
existing tools or if new tools (protocols) need to be built.

The result could be anything in a wide range including:
- nothing to be done in the IETF
- an applicability statement to show how to solve the problems with 
   existing tools
- some small protocol extensions (for example, a YANG model to
   represent/request a virtual network)
- a requirements statement for new protocols or substantial protocol
  extensions.

That is all a bit in the future. The first step, as i say, is to refine the
use-cases and hone the architecture.

I'll leave the mailing list open for discussion of the topic, but please
remember it is not a working group!

Thanks,
Adrian

---

From: Leeyoung <[email-masked]>
Date: Thu, 7 Aug 2014 14:45:52 +0000

Hi Adrian,

Thanks for providing AD's summary of ACTN BoF. 

Meeting minutes have been uploaded per your reminder:
https://datatracker.ietf.org/meeting/90/materials.html#rtg

Best regards,
Young

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Thursday, August 07, 2014 7:33 AM
To: [email-masked]
Cc: [email-masked]; Leeyoung
Subject: AD's summary of ACTN BoF

Hi,

First, let me thank the chairs and all of you who spoke either to present or to ask questions / make comments from the floor.

>From many perspectives, the ACTN BoF was successful. It was intended to provide a venue for network operators to talk about the type of problem they are trying to solve and the "pain points" they are encountering. From that perspective it was very valuable, and it is nice to see a forum where operators can share their thoughts and ideas without the vendors telling them what to think.

The BoF was billed as a "non-WG forming BoF" and we can say that the BoF was very successful in that regard: no WG was formed ;-)

In re-reading my notes from the BoF and looking at the minutes posted to this list (chairs: please be sure to post the minutes to the meetings materials page) I think there were some common threads visible in the presentations/use-cases from the different operators:

- Desire to express services to a network and to build abstract/virtual networks to support those services

There may be some more common threads, but perhaps we should be looking for just a few ideas with wide support.

However, I didn't come away with any clarity about what actually needs work.
This should not be a huge surprise because that was not the top objective of the BoF, but it should be the next focus for people wanting to work in this area. We need to identify the topics that could be brought to the IETF for standardisation activities.

To advance this, i suggest that the next step is for the proponents to convert the use-cases into an architecture (developing the documents that already exist) with the objective of seeing whether this architecture can be solved with existing tools or if new tools (protocols) need to be built.

That is all a bit in the future. The first step, as i say, is to refine the use-cases and hone the architecture.

I'll leave the mailing list open for discussion of the topic, but please remember it is not a working group!

Thanks,
Adrian