Subject: [Actn] Joining the group

From: Mike Mossbarger <[email-masked]>
Date: Thu, 11 Sep 2014 09:33:31 -0700

Hello All,

I am new to this conversation and was thrilled to find it so directly in
line with work that I am currently involved in at the Industrial Internet
Consortium. We have a use case on Connectivity that many of us are keen to
move towards a testbed - the problem is complex.

One key factor that must be addressed are roots of trust used for
credentialing systems across these different domains. Abstraction in a
standard way can be achieved (with some work) but quantifying 'trust'
across domain boundaries requires common roots of trust so that
cryptographic substantiation of identity is uniform. There is work along
the lines of Roots of Trust for Cyber-Physical Systems going on at the
Cyber Security Research Alliance although their work is focused on PKI, a
cryptosystem that can't support cross-domain trust.

Best,

Michael Mossbarger
Executive Director
*ENT Foundation*

*Resilient. Global. [email-masked] <[email-masked]>*
www.ENT.net
619-794-6677 Mobile
<[email-masked]>

---

From: Daniele Ceccarelli <[email-masked]>
Date: Fri, 12 Sep 2014 14:26:37 +0000

Hi Mike,

Glad to hear there are always new use cases related to ACTN. It seems your use case is something similar to security issues that have been addressed in the past by the PCE and CCAMP WGs when speaking about connectivity between PCEs from different vendors/operators or e.g. multi domain signaling/routing.

Maybe the issue can be solved with some pointer or references to existing work or maybe it will need a dedicated effort from the ACTN community, but in any case it is worth having it noted down and tracked. My suggestion is to write a draft with you use cases, specifying the issues to be addressed and possibly an evaluation of existing mechanisms or contact the authors of an existing draft to ask to include it in an existing document.

BR
Daniele

From: ACTN [mailto:[email-masked]] On Behalf Of Mike Mossbarger
Sent: giovedì 11 settembre 2014 18:34
To: [email-masked]
Subject: [Actn] Joining the group

Hello All,
I am new to this conversation and was thrilled to find it so directly in line with work that I am currently involved in at the Industrial Internet Consortium. We have a use case on Connectivity that many of us are keen to move towards a testbed - the problem is complex.
One key factor that must be addressed are roots of trust used for credentialing systems across these different domains. Abstraction in a standard way can be achieved (with some work) but quantifying 'trust' across domain boundaries requires common roots of trust so that cryptographic substantiation of identity is uniform. There is work along the lines of Roots of Trust for Cyber-Physical Systems going on at the Cyber Security Research Alliance although their work is focused on PKI, a cryptosystem that can't support cross-domain trust.

Best,

Michael Mossbarger
Executive Director
ENT Foundation
Resilient. Global. Identity.
[email-masked]<mailto:[email-masked]>

www.ENT.net<http://www.ENT.net>
619-794-6677 Mobile

---

From: Mike Mossbarger <[email-masked]>
Date: Fri, 12 Sep 2014 12:49:56 -0700

Hi Danielle,

Thanks for the response. I looked into both of those efforts and I don't
see much related to bridging roots of trust across control domains. We are
creating the type of documentation you mention as part of the testbed
effort so I should be able to submit those once completed.

Thanks again.

Best,

Michael Mossbarger
Executive Director
*ENT Foundation*

On Fri, Sep 12, 2014 at 7:26 AM, Daniele Ceccarelli <
[email-masked]> wrote:

>  Hi Mike,
>
>
>
> Glad to hear there are always new use cases related to ACTN. It seems your
> use case is something similar to security issues that have been addressed
> in the past by the PCE and CCAMP WGs when speaking about connectivity
> between PCEs from different vendors/operators or e.g. multi domain
> signaling/routing.
>
>
>
> Maybe the issue can be solved with some pointer or references to existing
> work or maybe it will need a dedicated effort from the ACTN community, but
> in any case it is worth having it noted down and tracked. My suggestion is
> to write a draft with you use cases, specifying the issues to be addressed
> and possibly an evaluation of existing mechanisms or contact the authors of
> an existing draft to ask to include it in an existing document.
>
>
>
> BR
> Daniele
>
>
>
> *From:* ACTN [mailto:[email-masked]] *On Behalf Of *Mike Mossbarger
> *Sent:* giovedì 11 settembre 2014 18:34
> *To:* [email-masked]
> *Subject:* [Actn] Joining the group
>
>
>
> Hello All,
>
> *Resilient. Global. Identity. [email-masked] <[email-masked]>*
>
>
> www.ENT.net
> 619-794-6677 Mobile
>

---

From: Leeyoung <[email-masked]>
Date: Fri, 12 Sep 2014 20:08:31 +0000

Hi Mike,

Look forward to seeing the document you are working on.

Thanks,
Young

From: ACTN [mailto:[email-masked]] On Behalf Of Mike Mossbarger
Sent: Friday, September 12, 2014 2:50 PM
To: Daniele Ceccarelli
Cc: [email-masked]
Subject: Re: [Actn] Joining the group

Hi Danielle,

Thanks for the response. I looked into both of those efforts and I don't see much related to bridging roots of trust across control domains. We are creating the type of documentation you mention as part of the testbed effort so I should be able to submit those once completed.
Thanks again.

Best,

Michael Mossbarger
Executive Director
ENT Foundation

On Fri, Sep 12, 2014 at 7:26 AM, Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>> wrote:
Hi Mike,

BR
Daniele

From: ACTN [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Mike Mossbarger
Sent: giovedì 11 settembre 2014 18:34
To: [email-masked]<mailto:[email-masked]>
Subject: [Actn] Joining the group

Hello All,

Best,

Michael Mossbarger
Executive Director
ENT Foundation

---

From: "King, Daniel" <[email-masked]>
Date: Mon, 15 Sep 2014 18:51:38 +0000

Welcome aboard Mike. You may also want to take a peek at our initial ACTN wiki, which also includes previous ACTN presentations and relevant papers.

https://sites.google.com/site/actnbof/

If you want to review previous list discussions then you can view the full archive at here:

http://www.ietf.org/mail-archive/web/actn/current/maillist.html

Finally, if you have a new use case we would recommend an internet-draft to help frame the discussion. There should be other people willing to help develop the initial document, do not be afraid to ask for support/reviews from anyone active on the list, myself included.

Br, Dan.

From: ACTN [mailto:[email-masked]] On Behalf Of Mike Mossbarger
Sent: 12 September 2014 20:50
To: Daniele Ceccarelli
Cc: [email-masked]
Subject: Re: [Actn] Joining the group

Hi Danielle,

Best,

Michael Mossbarger
Executive Director
ENT Foundation

BR
Daniele

Hello All,

Best,

Michael Mossbarger
Executive Director
ENT Foundation