Subject: [Actn] Comments on draft-ceccarelli-actn-framework-03

From: Dhruv Dhody <[email-masked]>
Date: Wed, 8 Oct 2014 23:36:07 +0530

(1) Sec 1. Terminology
- We should state that the following terms are defined in this document.
- We should also state which terms are borrowed from 4655 and 5440 -
PCE, PCC, PCEP etc

(2) Sec 2. Introduction
OLD:
   This implies that at least the following transport
   networks are in scope of the discussion of this draft: L1 optical
   networks (e.g., OTN and WDM), MPLS-TP, MPLS-TE, as well as other
   emerging connection-oriented networks such as Segment Routing (SR).
NEW:
   This implies that at least the following transport
   networks are in scope of the discussion of this draft: Layer 1 (L1) and
   Layer 0 (L0) optical networks (e.g., OTN, ODU, Och/WSON), MPLS-TP,
   MPLS-TE, as well as other emerging network technologies with
   connection-oriented behavior.
Reason: to align with charter discussion.

(3) Usage of the term 'virtual network element'; here it means generic
element that could be a virtual node/link -

   The level of virtual control
   given to the customers can vary from a tunnel connecting two end-
   points to virtual network elements that consist of a set of virtual
   nodes and virtual links in a mesh network topology.

Later, it is also used to mean only virtual nodes at -

   The level of topology abstraction is expressed in terms of
   the number of virtual network elements (VNEs) and virtual links
   (VLs).

Also it is used for Virtual Network Embedding in section 5.

This usage should be made uniform.

(4) In section 3.1. Customers, it can be clearly stated that we are
dealing with the case of "advanced customers" only in ACTN.

(5) In section 6.2.1. Customer Network Controller, it should be figure
6 and not figure 5 that shows an example physical network topology.

(6) In section 6.2.2. Virtual Network Controller, s/consumer
controller/customer controller/

(7) In section 6.2.3. Physical Network Controller, it says -

      PCE: This is the stateful PCE performing the path computation
        over the physical topology and that provides the vConnection
        agent with the network topology.

is network topology correct? Or should it be network paths (LSPs)? Or both?
Note that in the previous section it says -

     vConnection Agent: This module is in charge of mapping VN setup
        commands into network provisioning requests to the PNC.

which has no mention of network topology.

Do you mean to suggest that the PCE needs to communicate raw or
abstract topology to VNC as well? PCE does not expose such a interface
right now.

Also note that in figure 8,  vConnection Agent doesn't talk to PCE?

(8) In section 6.3. Abstracted Topology Illustration, it should be
figure 6 instead figure 2 is mentioned.

(9) In section 6.4. Workflows of ACTN Control Modules for Virtual
Network Service, it should be figure 8 instead figure 5 is mentioned.

Nits:
- Suggest to follow the new RFC style guide [1] with respect to
ordering of sections etc.
- Expand on first use OTN, WDM, MPLS-TP, MPLS-TE, PCE, TE, TDM....
- Reference to problem statement ID in section 3 is displayed as -
[REF probl stat]
- s/ONC OAM handler/PNC OAM handler [page 21]

Regards,
Dhruv

[1]: http://www.rfc-editor.org/rfc/rfc7322.txt

---

From: Luyuan Fang <[email-masked]>
Date: Wed, 8 Oct 2014 19:49:21 +0000

Hi Dhruv,

Appreciate for your feedback, very good comments, we should update the draft to align.
And I'm good to replace the old text with the new text that you suggested in Sec 2. Introduction, it is better.

Thanks,
Luyuan

-----Original Message-----
From: ACTN [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: Wednesday, October 8, 2014 2:06 PM
To: [email-masked]
Subject: [Actn] Comments on draft-ceccarelli-actn-framework-03

(1) Sec 1. Terminology
- We should state that the following terms are defined in this document.
- We should also state which terms are borrowed from 4655 and 5440 - PCE, PCC, PCEP etc

(2) Sec 2. Introduction
OLD:

(3) Usage of the term 'virtual network element'; here it means generic element that could be a virtual node/link -

(4) In section 3.1. Customers, it can be clearly stated that we are dealing with the case of "advanced customers" only in ACTN.

(6) In section 6.2.2. Virtual Network Controller, s/consumer controller/customer controller/

Do you mean to suggest that the PCE needs to communicate raw or abstract topology to VNC as well? PCE does not expose such a interface right now.

(8) In section 6.3. Abstracted Topology Illustration, it should be figure 6 instead figure 2 is mentioned.

(9) In section 6.4. Workflows of ACTN Control Modules for Virtual Network Service, it should be figure 8 instead figure 5 is mentioned.

Nits:
- Suggest to follow the new RFC style guide [1] with respect to ordering of sections etc.
- Expand on first use OTN, WDM, MPLS-TP, MPLS-TE, PCE, TE, TDM....
- Reference to problem statement ID in section 3 is displayed as - [REF probl stat]
- s/ONC OAM handler/PNC OAM handler [page 21]

Regards,
Dhruv

_______________________________________________
ACTN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/actn

---

From: Leeyoung <[email-masked]>
Date: Tue, 14 Oct 2014 17:03:34 +0000

Hi Dhruv,

As Luyuan has agreed to incorporate your comments, I agree with Luyuan and thank you for providing good comment. We will incorporate your comment in the upcoming revision.
Here's some additional comment back to you in-line.

Regards,
Young

-----Original Message-----
From: ACTN [mailto:[email-masked]] On Behalf Of Luyuan Fang
Sent: Wednesday, October 08, 2014 2:49 PM
To: Dhruv Dhody; [email-masked]
Subject: Re: [Actn] Comments on draft-ceccarelli-actn-framework-03

Hi Dhruv,

Thanks,
Luyuan

-----Original Message-----
From: ACTN [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: Wednesday, October 8, 2014 2:06 PM
To: [email-masked]
Subject: [Actn] Comments on draft-ceccarelli-actn-framework-03

(1) Sec 1. Terminology

(2) Sec 2. Introduction
OLD:

YOUNG>> Yes, Virtual network elements ---> Virtual Nodes. 
YOUNG>> VNE (Virtual Network Embedding) is a known terminology in research circle, which I think stands as is. 

YOUNG>> Both depending on the mode of operation. 
s/network topology/network topology/network paths (LSPs)

YOUNG>> Resource Manager does that. I added this more clearly in Resource Manager: 
The resource manager is in charge of receiving VNS instantiation requests from the Customer Network Controller and, as a consequence, triggering a concurrent path computation request to the PCE in the PNC based on the traffic matrix. The Resource manager is also in charge of generating the abstract topology for the customer. It may request abstract network topology to PNC.

YOUNG>> Yes, through VNC Proxy in PNC. 

YOUNG>> This only depicts VNV-PNC not meant to be specific flows between modules within VNC/PNC. 

Nits:

Regards,
Dhruv

---

From: Dhruv Dhody <[email-masked]>
Date: Wed, 15 Oct 2014 10:38:38 +0000

Hi Young, 

(snip)
 
> YOUNG>> VNE (Virtual Network Embedding) is a known terminology in
> research circle, which I think stands as is.

[Dhruv]: In the terminology we have stated VNE as Virtual Network Element and the most usage is for virtual nodes. 
Thus it would be better to remove the first text above which makes 'virtual network elements' a generic term including both virtual nodes and links. 
Regarding Virtual Network Embedding, we can avoid using the short form VNE here to avoid any confusion. And a reference can be found perhaps - http://ieeexplore.ieee.org/xpls/icp.jsp?arnumber=6463372

(snip)

> s/network topology/network topology/network paths (LSPs)

[Dhruv]: IMO the relationships are - 
Resource manager(VNC) ------- PCE (PNC) (for path computation)
Resource manager(VNC) ------- VNC Proxy (PNC) (for abstract topology)
vConnection Agent (VNC) ----- Provision Manager (PNC) (for provisioning)

If this is correct, perhaps s/network topology/network paths (LSPs) is the correct text?
As the topology (abstract/raw) is through VNC proxy.

> The resource manager is in charge of receiving VNS instantiation
> requests from the Customer Network Controller and, as a consequence,
> triggering a concurrent path computation request to the PCE in the PNC
> based on the traffic matrix. The Resource manager is also in charge of
> generating the abstract topology for the customer. It may request
> abstract network topology to PNC.

[Dhruv]: Ok, but see above. 

> YOUNG>> Yes, through VNC Proxy in PNC.

[Dhruv]: Okay, It's not the PCE module inside the PNC, As you point out below I assumed the flows are between the modules inside PNC/VNC.  

> between modules within VNC/PNC.

[Dhruv]: Can this be clarified in some way to avoid confusion?

(snip)

Regards,
Dhruv

---

From: Igor Bryskin <[email-masked]>
Date: Wed, 15 Oct 2014 14:00:50 +0000

Hello,

In the ACTN context I suggest avoiding term "physical" topology, resources, controller, etc. and replacing it with term "actual".
Note that PCE always works with TE topology, which is not physical topology, rather an abstraction that combines link/node configuration and auto-discovered parameters of physical network resources. Examples of physical resources in WDM layer are: transponders, amplifiers, regenerators, multiplexers, multi-degree roadms, directionless roadms, etc.
PCE works with TE links and nodes that represent said physical resources in  the TE domain.
I suggest using term "actual" topology elements (named in the provider naming space and known internally and in entirety to the provider) vs. 
"abstract" topology elements (named in client naming space and presented to the client/tenant).

Cheers,
Igor

-----Original Message-----
From: ACTN [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: Wednesday, October 15, 2014 6:39 AM
To: Leeyoung; Luyuan Fang; Dhruv Dhody; [email-masked]
Subject: Re: [Actn] Comments on draft-ceccarelli-actn-framework-03

Hi Young, 

(snip)

(snip)

[Dhruv]: IMO the relationships are -
Resource manager(VNC) ------- PCE (PNC) (for path computation) Resource manager(VNC) ------- VNC Proxy (PNC) (for abstract topology) vConnection Agent (VNC) ----- Provision Manager (PNC) (for provisioning)

(snip)

Regards,
Dhruv

---

From: Leeyoung <[email-masked]>
Date: Wed, 15 Oct 2014 20:22:03 +0000

Hi Dhruv,

Please see inline for my comment.

Thanks,
Young

-----Original Message-----
From: Dhruv Dhody 
Sent: Wednesday, October 15, 2014 5:39 AM
To: Leeyoung; Luyuan Fang; Dhruv Dhody; [email-masked]
Subject: RE: [Actn] Comments on draft-ceccarelli-actn-framework-03

Hi Young, 

(snip)

(snip)

YOUNG>> Good idea. I will add the reference as well.

YOUNG>> The relationships are correct. I will look at the text once more to sort it out based on these relationships. 

YOUNG>> Yes. 

YOUNG>> I will look into the draft to clarify this aspect. 

(snip)

Regards,
Dhruv

---

From: Leeyoung <[email-masked]>
Date: Wed, 15 Oct 2014 20:41:15 +0000

Hi Igor,

In regards to 'topology' passed between PNC and VNC, I agree with you that we can start TE level topology with various degree of granularity. I would not object calling TE topology as actual topology (with clear indication that this actual is TE level). And abstract topology is further abstraction from 'actual topology. 

In regards to PNC vs ANC, I prefer PNC over ANC. The reason is as follows: PNC is termed as such to include control/management planes of various types beyond GMPLS/PCE. SDN controllers and NMS are part of PNC. The degree of control over the networks varies depending on which regime of control/management entities we are talking about. GMPLS/PCEP are constantly augmented to do more on optical network resources control such as wavelengths, regeneration configuration among others while NMS/SDN Controllers do more than TE level control. I prefer PNC over ANC. 

Or simply calling it NC (Network Controller) is another way to reach an agreement. 

Regards,
Young

-----Original Message-----
From: Igor Bryskin [mailto:[email-masked]] 
Sent: Wednesday, October 15, 2014 9:01 AM
To: Dhruv Dhody; Leeyoung; Luyuan Fang; Dhruv Dhody; [email-masked]
Subject: RE: [Actn] Comments on draft-ceccarelli-actn-framework-03

Hello,

Cheers,
Igor

-----Original Message-----
From: ACTN [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: Wednesday, October 15, 2014 6:39 AM
To: Leeyoung; Luyuan Fang; Dhruv Dhody; [email-masked]
Subject: Re: [Actn] Comments on draft-ceccarelli-actn-framework-03

Hi Young, 

(snip)

(snip)

(snip)

Regards,
Dhruv