Subject: [Actn] FW: New Version Notification for draft-ceccarelli-actn-framework-06.txt

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 23 Dec 2014 19:19:09 +0000

Hi all,

We have updated the ACTN framework (v.6): http://datatracker.ietf.org/doc/draft-ceccarelli-actn-framework/. 
If you don't feel like reading the whole 47 pages from the beginning  think you might be interested in the new sections from 4.2 on and 5.

Major updates include the interface requirements in Section 5.1 (CMI) and 5.2 (MPI) and Section 4.2 (We have added one more Application figure for a ACTN, See section 4.2.3).
Peter’s comments on the IDINIT have also been addressed.

Many thanks and Merry Christmas
Daniele and the authors 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: martedì 23 dicembre 2014 17:11
To: Daniele Ceccarelli; Luyuan Fang; Young Lee; Daniel King; Luyuan Fang; Daniele Ceccarelli; Daniel King; Young Lee; Diego R. Lopez; Diego Lopez; Sergio Belotti; Sergio Belotti
Subject: New Version Notification for draft-ceccarelli-actn-framework-06.txt

A new version of I-D, draft-ceccarelli-actn-framework-06.txt
has been successfully submitted by Young Lee and posted to the IETF repository.

Name:		draft-ceccarelli-actn-framework
Revision:	06
Title:		Framework for Abstraction and Control of Transport Networks
Document date:	2014-12-23
Group:		Individual Submission
Pages:		47
URL:            http://www.ietf.org/internet-drafts/draft-ceccarelli-actn-framework-06.txt
Status:         https://datatracker.ietf.org/doc/draft-ceccarelli-actn-framework/
Htmlized:       http://tools.ietf.org/html/draft-ceccarelli-actn-framework-06
Diff:           http://www.ietf.org/rfcdiff?url2=draft-ceccarelli-actn-framework-06

Abstract:
   This draft provides a framework for abstraction and control of
   transport networks.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Zhenghaomian <[email-masked]>
Date: Mon, 29 Dec 2014 01:09:11 +0000

Hi Daniele and all,

Merry Christmas and happy new year!

I have not got a chance to review 05 and it is great you update 06 which allowed me to get involved again:) Please find my comments below:

- In section 3.2 and some other places, there are still MDSC mis-spelled as MSDC (totally 11 matches found), maybe a global replacement is helpful; besides one 'controllers' is written as 'controllersr' in the first paragraph of section 3.2, 'collocated' should be 'co-located';
- In Fig. 5, 6 and 7 (section 4.2), there are two DC4 without DC5, one of them need to be changed;  for the PNC at righthand side, 'Transport Network C' is preferred with a CAPITAL 'N';
- In section 4.2.2, VNF was discussed, however the terminology is too similar as NFV (also discussed in 4.2.3) which is well-known and may therefore result in unnecessary misunderstanding. Furthermore, what is the relationship between VNF and Application?
- In section 5.1 CMI requirement, I didn't see the need for interaction between CNC and MDSC for item 4 and 5, VN Topology Abstraction Model. My understanding such model is something inside MDSC, with which the abstracted topology could be provided to different customers. If this is true and we want to include some internal requirement in this section, there may also be some additional requirement, such as TED mgmt.
- In section 5.1 CMI requirement, item 7 and 8 has a strict requirement on real-time performance, therefore I think synchronization mechanism is an important piece of work on CMI. Do we need to mention such requirement? Or we have already had such description?
- In section 5.2 MPI requirement, for item 2, I suggest also include 'other types' to make it consistent with item 2 of section 5.1;
- In section 5.2 MPI requirement, besides creation and update of LSP, the resource query (from MDSC to PNC) and removal of LSP are missed, both of which should be extensible from PCEP/YANG. I think we can mention these in this section.

Thank you very much.

Best wishes,
Haomian

-----邮件原件-----
发件人: Daniele Ceccarelli [mailto:[email-masked]]
发送时间: 2014年12月24日 3:19
收件人: [email-masked]
主题: [Actn] FW: New Version Notification for draft-ceccarelli-actn-framework-06.txt

Hi all,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: martedì 23 dicembre 2014 17:11
To: Daniele Ceccarelli; Luyuan Fang; Young Lee; Daniel King; Luyuan Fang; Daniele Ceccarelli; Daniel King; Young Lee; Diego R. Lopez; Diego Lopez; Sergio Belotti; Sergio Belotti
Subject: New Version Notification for draft-ceccarelli-actn-framework-06.txt

Abstract:

The IETF Secretariat