Subject: Re: [Actn] charter 1.4_protection _ oam

From: 윤빈영 <[email-masked]>
Date: Wed, 10 Dec 2014 12:33:46 +0000

Hi Young,

As I mentioned early,
protection service for customers(CNC), I also think, is essential part for transport networks;
Customers can request protection service for their critical paths at the stage of connection setup or after connection setup.
Specially, for multi-domains, ACTN will surely compensate for the existing protection methods.
So, I want you to address it in the charter.

I think that OAM is a basic flavor to enrich functional aspects in ACTN.
For an example, using OAM information, the service provider can passively just indicate status of customers’ VN,
as well as actively do restoration to guarantee customers’ QoS against certain failures.
Although those functions have already been dealt in other WGs,
they are not described in the context of CNC, VNC, and PNC(interactions among them).
So, I think that it is in the scope of ACTN.

Sincerely yours,

From: Khuzema Pithewan [mailto:[email-masked]]
Sent: Wednesday, December 10, 2014 7:08 AM
Subject: Re: [Actn] charter 1.4

Hi,

Need for OAM co-ordination across domain boundaries leads me to think about

·         need for protection aspect of services from flexibility standpoint for multi-layer network i.e. ability to choose layers for protection in a multi-layer environment for a given end-2-end service.

Another important aspect of network operation is achieving efficiency in network utilization. This may mean re-grooming of existing services from time to time. May be this aspect is part of service elasticity to an extent (not sure though).

One more point, may not be part of charter. Since ACTN framework will contain multiple components which would work with each other in tandem, the coherency of operation of ACTN framework should be ensured.

To generalize, reliability aspect need to captured in the charter.

Thanks
Khuzema

From: ACTN [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: Tuesday, December 09, 2014 9:31 AM
To: Leeyoung
Cc: [email-masked]
Subject: Re: [Actn] charter 1.4

Young,

Good addition for the LIME WG reference.

With regards to the quoted paragraph, how about:

Virtual service coordination function in ACTN incorporates
customer's service-related knowledge in virtual network operation in order to
seamlessly operate virtual networks while meeting customer's service
requirements. This may require OAM coordination across domain boundaries.

Cheers,
Andy

On Tue, Dec 9, 2014 at 11:32 AM, Leeyoung <[email-masked]<mailto:[email-masked]>> wrote:
Hi Andy,

Very good point you are raising. Actually as for the LIME WG coordination, Carlos (LIME WG’s co-chair) and I have touched base already in Honolulu to ensure there will be a close coordination between LIME and ACTN.

How about, adding another dashed item at the end of this text (in bold and italic)

The ACTN WG will coordinate with the following working groups:

-With the LIME WG on architectural, modeling, and protocol coordination for OAM.

As for your suggestion to include operational OAM coordination across domain boundaries, I agree with you.
Will you be able to suggest specific text perhaps to the quoted paragraph?

Thanks,
Young

From: Andrew G. Malis [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Tuesday, December 09, 2014 9:32 AM
To: Leeyoung
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Actn] charter 1.4

Young,

This is a very good looking charter. I have one comment on the following paragraph:

Virtual service coordination function in ACTN incorporates
customer's service-related knowledge in virtual network operation in order to
seamlessly operate virtual networks while meeting customer's service
requirements.

Given that ongoing operation (not just (virtual) network or service provisioning) would be in charter, should there be an explicit mention of operational OAM coordination across domain boundaries, and also architectural, modeling, and protocol coordination with the LIME WG?

Cheers,
Andy

---

From: Leeyoung <[email-masked]>
Date: Thu, 11 Dec 2014 02:03:00 +0000

Hi Bin,

I think this discussion is similar to what Khuzema raised. I agree with you that protection and OAM are not new things, but CNC’s policy enforcement element is new for both protection and OAM.

As the charter added more explicitly on virtual service operation from customer’s VN service aspect, VN survivability and VN OAM are new elements, I think.

Best regards,
Young

From: ACTN [mailto:[email-masked]] On Behalf Of ???
Sent: Wednesday, December 10, 2014 6:34 AM
To: [email-masked]
Subject: Re: [Actn] charter 1.4_protection _ oam

Hi Young,

As I mentioned early,

Sincerely yours,

Hi,

Thanks
Khuzema

Young,

Cheers,
Andy

Thanks,
Young

Young,

Cheers,
Andy