Subject: Re: [Actn] New Version Notification for draft-ceccarelli-actn-framework-06.txt

From: Dhruv Dhody <[email-masked]>
Date: Sat, 3 Jan 2015 12:13:52 +0000

Hi All, 

Thanks for the new version. I have some quick comments listed below mostly on the new sections/text. 

~ There should be a bit of description around 'Figure 3: ACTN Control Hierarchy' explaining that this shows some of the possible combinations. The presence of PCE or GMPLS trigger needs some explanation as well. 

~ We have used the term 'service' to mean multiple things in the document "services offered by service providers", "service functions", "service awareness - delay, jitter", "VM" etc. All of them are valid. We might benefit from a disclaimer in the introduction section itself (similar to text in section 3) as we use the term throughout the document. 

~ In Sec 4.2.1, we should highlight what is the benefit of endpoint destination selection done by MDSC instead of CNC? 

~ In Sec 4.2.2, we should highlight that for some VN applications, just selection of endpoint is not enough, there is a requirement for fulfillment of certain VNF. MDSC should take that into consideration while making the endpoint selection. 

~ I am not sure of the difference between 4.2.2 and 4.2.3, I think we can merge them? 

~ In Sec 5.1, I agree that VN Topology query is [new], but as an interface requirement is it really that different from Path query, and if yes maybe we should highlight that or make it [ext]. 

~ In Sec 5.2, requirement 1, I am not sure how PCEP/Yang can be extended for this? 

~ We should highlight that most of the IETF Yang work is focused on the NE, some augmentation work needs to be done so that they might be applied to controller (whole domain or VN)

Editorial Nits: 
o Section 4: Having reference instead of draft names would be a good idea. 

Ohh and Happy New Year!

Regards,
Dhruv

> -----Original Message-----
> From: ACTN [mailto:[email-masked]] On Behalf Of Daniele
> Ceccarelli
> Sent: 24 December 2014 00:49
> To: [email-masked]
> Subject: [Actn] FW: New Version Notification for draft-ceccarelli-actn-
> framework-06.txt
> 
> Hi all,
> 
> We have updated the ACTN framework (v.6):
> http://datatracker.ietf.org/doc/draft-ceccarelli-actn-framework/.
> If you don't feel like reading the whole 47 pages from the beginning
> think you might be interested in the new sections from 4.2 on and 5.
> 
> Major updates include the interface requirements in Section 5.1 (CMI)
> and 5.2 (MPI) and Section 4.2 (We have added one more Application
> figure for a ACTN, See section 4.2.3).
> Peter’s comments on the IDINIT have also been addressed.
> 
> Many thanks and Merry Christmas
> Daniele and the authors
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: martedì 23 dicembre 2014 17:11
> To: Daniele Ceccarelli; Luyuan Fang; Young Lee; Daniel King; Luyuan
> Fang; Daniele Ceccarelli; Daniel King; Young Lee; Diego R. Lopez; Diego
> Lopez; Sergio Belotti; Sergio Belotti
> Subject: New Version Notification for draft-ceccarelli-actn-framework-
> 06.txt
> 
> 
> A new version of I-D, draft-ceccarelli-actn-framework-06.txt
> has been successfully submitted by Young Lee and posted to the IETF
> repository.
> 
> Name:		draft-ceccarelli-actn-framework
> Revision:	06
> Title:		Framework for Abstraction and Control of Transport
> Networks
> Document date:	2014-12-23
> Group:		Individual Submission
> Pages:		47
> URL:            http://www.ietf.org/internet-drafts/draft-ceccarelli-
> actn-framework-06.txt
> Status:         https://datatracker.ietf.org/doc/draft-ceccarelli-actn-
> framework/
> Htmlized:       http://tools.ietf.org/html/draft-ceccarelli-actn-
> framework-06
> Diff:           http://www.ietf.org/rfcdiff?url2=draft-ceccarelli-actn-
> framework-06
> 
> Abstract:
>    This draft provides a framework for abstraction and control of
>    transport networks.
> 
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> 
> The IETF Secretariat
> 
> _______________________________________________
> ACTN mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/actn

---

From: Leeyoung <[email-masked]>
Date: Tue, 6 Jan 2015 19:33:12 +0000

Hi Dhruv,

Thanks for your comments. I exepct Daniele and other authors who wrote their sections will respond some of your comment, but here's mine (please see in-line).

Best regards,
Young 

-----Original Message-----
From: ACTN [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: Saturday, January 03, 2015 6:14 AM
To: Daniele Ceccarelli; [email-masked]
Subject: Re: [Actn] New Version Notification for draft-ceccarelli-actn-framework-06.txt

Hi All, 

YOUNG>> I agree. Sergio may be the right person for this. 

YOUNG>> Good idea. Next revision will take of that. 

YOUNG>> Yes. 

YOUNG>> Agree. 

YOUNG>> Good point. I think the main difference is 4.2.2 talks about the Customers being the initiator of certain VNFs associated with their VN request including the location of such VNFs (e.g., Data Centers) while 4.2.3 talks about a different case where the location of VNFs are not known to the customers and providers will provide this function as part of their operation. But both can be explained in the same section. 

YOUNG>> This is subtle. We can demote it to [ext] from [new], but there is some info/data model difference between VN topology query and path query. For instances, if VN topology query were to ask specific granularity with the endpoint information, this will be new aspect path query does not normally have.

YOUNG>> Actually, you’re right, this may be a new item for ACTN. Is that what you are thinking? 

YOUNG>> Great point, do you think we may need a new semantic change in YANG? 

Editorial Nits: 

YOUNG>> Good idea. Will do. 

Ohh and Happy New Year!

Regards,
Dhruv

---

From: Leeyoung <[email-masked]>
Date: Tue, 6 Jan 2015 19:52:14 +0000

Hi Haomian,

Sorry for a very late response to your comment. Just got back to work. 

Please see inline for my comment.

Thanks.
Young

-----Original Message-----
From: ACTN [mailto:[email-masked]] On Behalf Of Zhenghaomian
Sent: Sunday, December 28, 2014 7:09 PM
To: Daniele Ceccarelli; [email-masked]
Subject: [Actn] 答复: FW: New Version Notification for draft-ceccarelli-actn-framework-06.txt

Hi Daniele and all,

Merry Christmas and happy new year!

I have not got a chance to review 05 and it is great you update 06 which allowed me to get involved again:) Please find my comments below:

- In section 3.2 and some other places, there are still MDSC mis-spelled as MSDC (totally 11 matches found), maybe a global replacement is helpful; besides one 'controllers' is written as 'controllersr' in the first paragraph of section 3.2, 'collocated' should be 'co-located';

YOUNG>> Good catch, will correct. 

- In Fig. 5, 6 and 7 (section 4.2), there are two DC4 without DC5, one of them need to be changed;  for the PNC at righthand side, 'Transport Network C' is preferred with a CAPITAL 'N';

YOUNG>> OK. 

- In section 4.2.2, VNF was discussed, however the terminology is too similar as NFV (also discussed in 4.2.3) which is well-known and may therefore result in unnecessary misunderstanding. Furthermore, what is the relationship between VNF and Application?

YOUNG>> Yes, it is VNF from NFV. As customer applications might need both network connectivity and certain VNFs (e.g., security verification, etc.) this applicability associates VN request with VNFs. 

- In section 5.1 CMI requirement, I didn't see the need for interaction between CNC and MDSC for item 4 and 5, VN Topology Abstraction Model. My understanding such model is something inside MDSC, with which the abstracted topology could be provided to different customers. If this is true and we want to include some internal requirement in this section, there may also be some additional requirement, such as TED mgmt.

YOUNG>> Here 4, 5 do not mean internal model. 4,5 are meant to provide customer VNs, not the network-wide ones. 

- In section 5.1 CMI requirement, item 7 and 8 has a strict requirement on real-time performance, therefore I think synchronization mechanism is an important piece of work on CMI. Do we need to mention such requirement? Or we have already had such description?

YOUNG>> Yes, we have forgot to put a synchronization requirement. But we put in Section 5.2 (MPI) under item 10 from a network side. 

- In section 5.2 MPI requirement, for item 2, I suggest also include 'other types' to make it consistent with item 2 of section 5.1;

YOUNG>> Ok. 

- In section 5.2 MPI requirement, besides creation and update of LSP, the resource query (from MDSC to PNC) and removal of LSP are missed, both of which should be extensible from PCEP/YANG. I think we can mention these in this section.

YOUNG>> We have in Section 5.1 on life cycle management of VNs (item 8). We may need this in Section 5.2 as well. 

Thank you very much.

Best wishes,
Haomian

-----邮件原件-----
发件人: Daniele Ceccarelli [mailto:[email-masked]]
发送时间: 2014年12月24日 3:19
收件人: [email-masked]
主题: [Actn] FW: New Version Notification for draft-ceccarelli-actn-framework-06.txt

Hi all,

We have updated the ACTN framework (v.6): http://datatracker.ietf.org/doc/draft-ceccarelli-actn-framework/.
If you don't feel like reading the whole 47 pages from the beginning  think you might be interested in the new sections from 4.2 on and 5.

Major updates include the interface requirements in Section 5.1 (CMI) and 5.2 (MPI) and Section 4.2 (We have added one more Application figure for a ACTN, See section 4.2.3).
Peter’s comments on the IDINIT have also been addressed.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: martedì 23 dicembre 2014 17:11
To: Daniele Ceccarelli; Luyuan Fang; Young Lee; Daniel King; Luyuan Fang; Daniele Ceccarelli; Daniel King; Young Lee; Diego R. Lopez; Diego Lopez; Sergio Belotti; Sergio Belotti
Subject: New Version Notification for draft-ceccarelli-actn-framework-06.txt

A new version of I-D, draft-ceccarelli-actn-framework-06.txt
has been successfully submitted by Young Lee and posted to the IETF repository.

Name:           draft-ceccarelli-actn-framework
Revision:       06
Title:          Framework for Abstraction and Control of Transport Networks
Document date:  2014-12-23
Group:          Individual Submission
Pages:          47
URL:            http://www.ietf.org/internet-drafts/draft-ceccarelli-actn-framework-06.txt
Status:         https://datatracker.ietf.org/doc/draft-ceccarelli-actn-framework/
Htmlized:       http://tools.ietf.org/html/draft-ceccarelli-actn-framework-06
Diff:           http://www.ietf.org/rfcdiff?url2=draft-ceccarelli-actn-framework-06

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat