Subject: [Actn] ACTN progress

From: Leeyoung <[email-masked]>
Date: Wed, 14 Jan 2015 19:11:30 +0000

Hi All,

Just wanted to share some private emails exchanged among a limited interested parties in the past week with a permission with Igor.

In a nutshell, I think we are converging with a common view on ACTN interfaces and architecture. Please check the following email thread. Please comment if you have any question.

Thanks,
Young

From: Igor Bryskin [mailto:[email-masked]]
Sent: Thursday, January 08, 2015 2:13 PM
To: Leeyoung; Daniele Ceccarelli
Cc: AshwoodsmithPeter
Subject: RE: Recap this morning's call

Hi Young,
You've captured all pretty accurately. I nominate you for the ACTN scribe job :=)

Igor

From: Leeyoung [mailto:[email-masked]]
Sent: Thursday, January 08, 2015 3:09 PM
To: Igor Bryskin; Daniele Ceccarelli
Cc: AshwoodsmithPeter
Subject: Recap this morning's call

Hi Igor,

Thanks for this morning's call. I just wanted to recap what was agreed upon. Please feel free to correct if anything needs to be corrected.

We have identified several models to be implemented in ACTN control hierarchy (CNC-MDSC-PNC). Among them are, but not limited to:

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

5.      Client Mapping/Policy Model

There could be more to the list. We can identify and add later on if we will.

Now, with these models, different components (i.e., different controller type) will implement whatever relevant models and support its interfaces. For instance, PNC may need not support Client mapping/policy model while CNC may not need to support Provisioning model.

We also agree that MDSC can interface another MDSC or PNCs with transparency. MDSC should not be able to distinguish if it interfaces MDSC or PNCs (i.e., the same interface).

And you also said, CNC interfacing MDSC should be essentially the same interface as MDSC interfacing another MDSC or PNCs.

Let us start from here. Then we can discuss further.

Thanks,
Young

---

From: Zhenghaomian <[email-masked]>
Date: Thu, 15 Jan 2015 03:08:40 +0000

Hi, Young and Igor,

Thanks for the sharing, great to see a more converged architecture. From my perspective, the model work mentioned are all necessary, but it seems such model should be dependent on protocol works, i.e., we need to complete protocol first and then modeling. Parallel style is also good for protocol and model, but I prefer we turn to protocol if they have some inconsistency between protocol and model. Besides I still have some questions:

In the previous mail, I am a little bit confused with the limitation on MDSC connection. It seems MDSC is not clear with who it is connecting by mentioning “MDSC should not be able to distinguish if it interfaces MDSC or PNCs (i.e., the same interface)”. My opinion is it is not necessary to limit the knowledge of MDSC, i.e., it is fine if a MDSC has the ability to detect whether it is connecting with a PNC or another MDSC. At least, a MDSC MUST have the ability to identify CNC from MDSC/PNCs.  Or maybe you are saying “A PNC can become MDSC if there is recursive hierarchy? ”. I like this due to the dynamic topology growing in the network.

By reading “CNC interfacing MDSC should be essentially the same interface as MDSC interfacing another MDSC or PNCs”, I feel that the functionalities on interface B and C (defined in fwk draft) are becoming similar, which quite confuse me as well. I agree that these interfaces may have similar message flow during service request, provisioning and so on, but they are quite different during OAM, recovery and resource mgmt. I don’t think it is a good idea to consider these two interface “the same as each other”.

Would you please help explain the issue above? Thanks a lot.

Best wishes,
Haomian

发件人: Leeyoung [mailto:[email-masked]]
发送时间: 2015年1月15日 3:12
收件人: [email-masked]
主题: [Actn] ACTN progress

Hi All,

Thanks,
Young

Hi Young,
You’ve captured all pretty accurately. I nominate you for the ACTN scribe job :=)

Igor

Hi Igor,

Thanks for this morning’s call. I just wanted to recap what was agreed upon. Please feel free to correct if anything needs to be corrected.

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Leeyoung <[email-masked]>
Date: Thu, 15 Jan 2015 04:20:30 +0000

Haomian,

Thanks for your comment.

First of all, I think I used the term ‘model’ loosely. It really means roles/functions of control entities to perform and it requires data models and protocols to support the data models.

MSDC and PNC are still different components and are to be distinguished. In the ACTN hierarchy, the top level is the CNC and the bottom level is the PNC. And in between of a hierarchy there may be MDSCs and PNCs. Look at the following recursive diagram (thanks to Adrian who first drew this):

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

From this figure, for the middle MDSC interfacing a PNC (via f, g interfaces) and a MDSC (via f, h interfaces), efficient data models and protocol design should be able to support both interfaces as if they are the same. That is what it means to “MDSC should not be able to distinguish if it interfaces MDSC or PNCs (i.e., the same interface)”.  This is different from saying the MDSC should not have ability to identify MDSCs or PNCs in its south bound.  Indeed the MDSC would know (in most implementations) who it is and what it interfaces.

I think Dhruv used an analogy from PCEP.  A PCEP interface can mean a PCE-PCC or a PCE-PCE interface.  PCEP has a common model and protocol to support both interfaces. In a similar way, I think ACTN can have a common model and protocol to support all its interfaces.

“CNC interfacing MDSC should be essentially the same interface as MDSC interfacing another MDSC or PNCs” --- I think what this means is that the model and protocol primitives can share the common property between CNC-MDSC and MDSC-PNC/MDSC. The granularity and policy context may differ, but we can develop the common model that encompass all interfaces. We can define objects to allow contextual differences, but still with the same model.

Thanks,
Young

From: Zhenghaomian
Sent: Wednesday, January 14, 2015 9:09 PM
To: Leeyoung; [email-masked]
Cc: Igor Bryskin
Subject: 答复: [Actn] ACTN progress

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: 윤빈영 <[email-masked]>
Date: Thu, 15 Jan 2015 04:51:23 +0000

Hi Young,

I like to catch up with you.

So I like to translate your saying into my words for my clear understanding as follows.

For future ACTN work, we will keep the same architecture consisting of CNC-MDSC-PNC,

and the interfaces between them should be the same as Igor insists.

Each controller has the same functions conceptually,

but some functions may not be used depending on the type of controller(MDSC/PNC).

In order to implement the models(Provisioning, OAM, etc.) required for transport SDN,

ACTN will describe the interface of each controller based on the architecture of CNC-MDSC-PNC.

The interfaces between the controllers may be different practically due to some functions not used.

We can say like the following if those above are true.

Some can implement a super(general) transport SDN controller to support all the functions,

while other can implement specific purposed(targeted) controllers such as PNC and MDSC.

For the former, the CMI is the same as the MPI.

For the latter, the CMI may not be the same as the MPI due to some functions not used.

ACTN will follow the latter for T-SDN implementation incorporating existing control systems like GMPLS and EMS/NMS.

Correct me if there is any misunderstanding.

Thanks,

Bin

From: Leeyoung [mailto:[email-masked]]
Sent: Thursday, January 15, 2015 4:12 AM
To: [email-masked]
Subject: [Actn] ACTN progress

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Zhenghaomian <[email-masked]>
Date: Thu, 15 Jan 2015 07:54:44 +0000

Hi, Young,

Great to see this figure, very helpful for understanding. I would like to propose two more points for clarification.

Firstly, my understanding was, the relationship between CNC and MDSC is N-to-1 instead of N-to-M, i.e., each CNC should have ONLY one (dedicated) MDSC. From this figure, I am not sure whether there can be potential message flow on the c-d interface, that is another CNC-MDSC connection. Similarly I think the relationship between MDSC and PNC is 1-to-N instead of M-to-N, each PNC should have only one MDSC, instead of cross-over. In your figure for the left-bottom PNC, it seems to me g-h is also a possible interface.

If the relationship are strictly limited to 1-to-N and N-to-1, I convert your figure as follow, which may be equivalent, but more clear on the hierarchy:

        +-----+           +-------+
       | CNC|        |  CNC  |                    Customer level
        +-----+           +-------+
           |a                     | c
           |                       |
           |b                     | e
       +--------+ d     e +----------+ f       h+------------+
      | MDSC|-------- | MDSC |---------|  MDSC  |          Virtual Control level
       +--------+            +----------+           +------------+
                                      |f                        i |
                                      |                           |
                              |                            |
                                     |g                        j |
                            +--------+                 +--------+
                            | PNC |                   | PNC |      Physical level
                            +--------+                 +--------+

Actually there can be more interaction on the Virtual Control level, which means there can be more connections among MDSCs.

Secondly, it is good to make analogy to PCC-PCE. For service provisioning, such customer-provider relationship always exists, we may find something in common on CMI and MPI, but there are certainly extensions.

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21
收件人: Zhenghaomian; Leeyoung; [email-masked]
抄送: Igor Bryskin
主题: RE: [Actn] ACTN progress

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian
Sent: Wednesday, January 14, 2015 9:09 PM
To: Leeyoung; [email-masked]<mailto:[email-masked]>
Cc: Igor Bryskin
Subject: 答复: [Actn] ACTN progress

Hi, Young and Igor,

Best wishes,
Haomian

发件人: Leeyoung [mailto:[email-masked]]
发送时间: 2015年1月15日 3:12
收件人: [email-masked]<mailto:[email-masked]>
主题: [Actn] ACTN progress

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Igor Bryskin <[email-masked]>
Date: Thu, 15 Jan 2015 13:54:10 +0000

Hi Bin,
Your understanding is correct. Conceptually, the interfaces are the same. Practically, a given interface may support only a sub-set of functionality.

Igor

From: ACTN [mailto:[email-masked]] On Behalf Of ???
Sent: Wednesday, January 14, 2015 11:51 PM
To: Leeyoung; [email-masked]
Subject: Re: [Actn] ACTN progress

Hi Young,

Thanks,

Bin

From: Leeyoung [mailto:[email-masked]]
Sent: Thursday, January 15, 2015 4:12 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Actn] ACTN progress

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Leeyoung <[email-masked]>
Date: Thu, 15 Jan 2015 17:00:06 +0000

Hi Bin and Igor,

I agree with Igor on his short reply to Bin. Please see inline for my comment, Bin.

Thanks,
Young

From: Igor Bryskin [mailto:[email-masked]]
Sent: Thursday, January 15, 2015 7:54 AM
To: 윤빈영; Leeyoung; [email-masked]
Subject: RE: [Actn] ACTN progress

Hi Bin,

Igor

Hi Young,

YOUNG>> Yes.

YOUNG>> Yes, but it would great if we can design the interfaces transparently so that one interface design will accommodate all functions.

YOUNG>> For the latter, we can design the MDSC-PNC interface as if CNC talking to PNC(s) directly, (which is termed as ‘transparency’) so that one interface design would fit to all cases. There may be some functions not used, which is fine, but we would say it is one interface design.

Thanks,

Bin

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Leeyoung <[email-masked]>
Date: Thu, 15 Jan 2015 20:20:40 +0000

Hi Haomian,

I think the original figure was only for illustration purpose to illustrate a recursive relationship in a hierarchy. I agree with you in general that cross-over makes things complicated.

In an advanced case, one CNC may interface multiple MDSCs (one MDSC for one operator and the other for another operator). If this is in scope or not, I don’t have a particular opinion about that although I would prefer to defer this case in a later phase.

Thanks,
Young

From: Zhenghaomian
Sent: Thursday, January 15, 2015 1:55 AM
To: Leeyoung; [email-masked]
Cc: Igor Bryskin
Subject: 答复: [Actn] ACTN progress

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: 윤빈영 <[email-masked]>
Date: Fri, 16 Jan 2015 08:23:10 +0000

Hi Young,

You newly define the term of “transparency (direct talk between CNC and PNC) ”.
It makes sense that the CNC directly interfaces with the PNC.
To me, it is like that MDSC is not used any more for this case.
So we can define two types of ACTN control hierarchy as follows.

- Three-level model: CNC-MDSC-PNC(current model)
- Two-level model: CNC-PNC(for the case that MDSC is transparent)

If it is right, the framework document should be modified to support the two-level model in terms of functionalities and architecture, as it currently describes only the three-level model.
In the current framework document, the PNC of the three-level model supports only two functionalities including “multi domain coordination function” and “virtualization/abstraction function”.
However, the PNC of the two-level model needs to support four functionalities for the direct interface to the CNC, as the CNC additionally requires “customer VN mapping function” and “virtual service coordination function”. Therefore, the document should be in line with the two-level model.

Correct me if I am wrong.

Sincerely yours

From: Leeyoung [mailto:[email-masked]]
Sent: Friday, January 16, 2015 2:00 AM
To: Igor Bryskin; 윤빈영; [email-masked]
Subject: Re: [Actn] ACTN progress

Hi Bin and Igor,

Thanks,
Young

From: Igor Bryskin [mailto:[email-masked]]
Sent: Thursday, January 15, 2015 7:54 AM
To: 윤빈영; Leeyoung; [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Hi Bin,

Igor

Hi Young,

YOUNG>> Yes.

Thanks,

Bin

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Leeyoung <[email-masked]>
Date: Fri, 16 Jan 2015 16:36:57 +0000

Hi Bin,

Sorry for the confusion I may have incurred. I did not mean “transparency” to bypass the MDSC.

I said: “For the latter, we can design the MDSC-PNC interface as if CNC talking to PNC(s) directly, (which is termed as ‘transparency’) so that one interface design would fit to all cases. There may be some functions not used, which is fine, but we would say it is one interface design. “

Transparency is meant, from a PNC point of view, it should not make substantial differences if it talks to CNC or MDSC.

Thanks,
Young

From: 윤빈영 [mailto:[email-masked]]
Sent: Friday, January 16, 2015 2:23 AM
To: Leeyoung; Igor Bryskin; [email-masked]
Subject: RE: [Actn] ACTN progress

Hi Young,

- Three-level model: CNC-MDSC-PNC(current model)
– Two-level model: CNC-PNC(for the case that MDSC is transparent)

Sincerely yours

Hi Bin and Igor,

Thanks,
Young

Hi Bin,

Igor

Hi Young,

YOUNG>> Yes.

Thanks,

Bin

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: "BELOTTI, SERGIO (SERGIO)" <[email-masked]>
Date: Fri, 16 Jan 2015 17:40:58 +0000

Hi Young, Haomian,

“I agree with you in general that cross-over makes things complicated.”
I think that  cross-over would be in contrast with the hierarchical view of controllers, so absolutely to avoid.

Thanks
Sergio

From: ACTN [mailto:[email-masked]] On Behalf Of Leeyoung
Sent: giovedì 15 gennaio 2015 21:21
To: Zhenghaomian; [email-masked]
Cc: Igor Bryskin
Subject: Re: [Actn] ACTN progress

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21
收件人: Zhenghaomian; Leeyoung; [email-masked]<mailto:[email-masked]>
抄送: Igor Bryskin
主题: RE: [Actn] ACTN progress

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Arashmid Akhavain <[email-masked]>
Date: Fri, 16 Jan 2015 18:55:24 +0000

I don’t think Young’s comment meant to collapse the 3-level model to a 2-level model. The interface design will be the same. But I think that is different from saying that CNC can bypass the MDSC and talk to PNC directly.

Regards,
Arashmid

From: ACTN [mailto:[email-masked]] On Behalf Of ???
Sent: 16 January 2015 03:23
To: Leeyoung; Igor Bryskin; [email-masked]
Subject: Re: [Actn] ACTN progress

Hi Young,

Sincerely yours

From: Leeyoung [mailto:[email-masked]]
Sent: Friday, January 16, 2015 2:00 AM
To: Igor Bryskin; 윤빈영; [email-masked]<mailto:[email-masked]>
Subject: Re: [Actn] ACTN progress

Hi Bin and Igor,

Thanks,
Young

Hi Bin,

Igor

Hi Young,

YOUNG>> Yes.

Thanks,

Bin

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Daniele Ceccarelli <[email-masked]>
Date: Sun, 18 Jan 2015 09:45:30 +0000

Hi Arashmid, all,

Up to now we have always considered the 3-level model but it is possible to say that is also include the 2-level model. From an implementation point of view we can have a CNC interfacing with a single controller which implements MDSC and PNC functionalities (basically able to speak with CNC and with nodes at the same time).
I don’t see any issue in allowing for a controller to be both PNC and MDSC at the same time.

BR
Daniele

From: ACTN [mailto:[email-masked]] On Behalf Of Arashmid Akhavain
Sent: venerdì 16 gennaio 2015 19:55
To: 윤빈영; Leeyoung; Igor Bryskin; [email-masked]
Subject: Re: [Actn] ACTN progress

Regards,
Arashmid

From: ACTN [mailto:[email-masked]] On Behalf Of ???
Sent: 16 January 2015 03:23
To: Leeyoung; Igor Bryskin; [email-masked]<mailto:[email-masked]>
Subject: Re: [Actn] ACTN progress

Hi Young,

Sincerely yours

Hi Bin and Igor,

Thanks,
Young

Hi Bin,

Igor

Hi Young,

YOUNG>> Yes.

Thanks,

Bin

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Dhruv Dhody <[email-masked]>
Date: Sun, 18 Jan 2015 17:00:05 +0530

I agree with Daniele.

Also the framework might be applied to a single domain to get the
Abstraction and the Virtualization function without the need for
multi-domain coordination, though that is not the main motivation for
the ACTN work.

Happy Sunday!!

~Dhruv

On Sun, Jan 18, 2015 at 3:15 PM, Daniele Ceccarelli
<[email-masked]> wrote:
> Hi Arashmid, all,
>
>
>
> Up to now we have always considered the 3-level model but it is possible to
> say that is also include the 2-level model. From an implementation point of
> view we can have a CNC interfacing with a single controller which implements
> MDSC and PNC functionalities (basically able to speak with CNC and with
> nodes at the same time).
>
> I don’t think Young’s comment meant to collapse the 3-level model to a
> 2-level model. The interface design will be the same. But I think that is
> different from saying that CNC can bypass the MDSC and talk to PNC directly.
>
>
>
> Regards,
>
> Arashmid
>
>
>
>
>
> If it is right, the framework document should be modified to support the
> two-level model in terms of functionalities and architecture, as it
> currently describes only the three-level model.
>
> In the current framework document, the PNC of the three-level model supports
> only two functionalities including “multi domain coordination function” and
> “virtualization/abstraction function”.
>
> However, the PNC of the two-level model needs to support four
> functionalities for the direct interface to the CNC, as the CNC additionally
> requires “customer VN mapping function” and “virtual service coordination
> function”. Therefore, the document should be in line with the two-level
> model.
>
>
>
> Your understanding is correct. Conceptually, the interfaces are the same.
> Practically, a given interface may support only a sub-set of functionality.
>
>
>
> Igor
>
>
>
> YOUNG>> Yes, but it would great if we can design the interfaces
> transparently so that one interface design will accommodate all functions.
>
>
>
> YOUNG>> For the latter, we can design the MDSC-PNC interface as if CNC
> talking to PNC(s) directly, (which is termed as ‘transparency’) so that one
> interface design would fit to all cases. There may be some functions not
> used, which is fine, but we would say it is one interface design.
>
>
>
> Just wanted to share some private emails exchanged among a limited
> interested parties in the past week with a permission with Igor.
>
>
>
> In a nutshell, I think we are converging with a common view on ACTN
> interfaces and architecture. Please check the following email thread. Please
> comment if you have any question.
>
>
>
> Thanks,
>
> Young
>
>
>
> Thanks for this morning’s call. I just wanted to recap what was agreed upon.
> Please feel free to correct if anything needs to be corrected.
>
>
>
> We have identified several models to be implemented in ACTN control
> hierarchy (CNC-MDSC-PNC). Among them are, but not limited to:
>
>
>
> 1.      Topology Model
>
> 2.      Provisioning Model
>
> 3.      Service Model
>
> 4.      OAM Model
>
> Now, with these models, different components (i.e., different controller
> type) will implement whatever relevant models and support its interfaces.
> For instance, PNC may need not support Client mapping/policy model while CNC
> may not need to support Provisioning model.
>
>
>
> We also agree that MDSC can interface another MDSC or PNCs with
> transparency. MDSC should not be able to distinguish if it interfaces MDSC
> or PNCs (i.e., the same interface).
>
>
>
> And you also said, CNC interfacing MDSC should be essentially the same
> interface as MDSC interfacing another MDSC or PNCs.
>
>
>
> _______________________________________________
> ACTN mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/actn
>

---

From: Zhenghaomian <[email-masked]>
Date: Mon, 19 Jan 2015 01:28:58 +0000

Thanks Sergio and Young.

My understanding for the term ‘cross-over’ is only talking about inter-connections of MDSCs. I don’t think there should be any kinds of cross-over on CNC or PNC level. It is still quite clean hierarchy, i.e., we have CMI and MPI on the ‘vertical’ direction, and allow some inter-MDSC interface on the ‘horizontal’ direction. In my opinion this structure is rather simple, unless there are thousands of MDSC interconnections:)

I also agree on Young’s suggestion on ‘advanced case’, at the moment let’s try to keep it simple and solve it first.

Best wishes,
Haomian

发件人: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
发送时间: 2015年1月17日 1:41
收件人: Leeyoung; Zhenghaomian
抄送: Igor Bryskin; [email-masked]
主题: RE: [Actn] ACTN progress

Hi Young, Haomian,

Thanks
Sergio

From: ACTN [mailto:[email-masked]] On Behalf Of Leeyoung
Sent: giovedì 15 gennaio 2015 21:21
To: Zhenghaomian; [email-masked]<mailto:[email-masked]>
Cc: Igor Bryskin
Subject: Re: [Actn] ACTN progress

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Dhruv Dhody <[email-masked]>
Date: Mon, 19 Jan 2015 02:46:41 +0000

Hi Haomian,

From: ACTN [mailto:[email-masked]] On Behalf Of Zhenghaomian
Sent: 19 January 2015 06:59
To: BELOTTI, SERGIO (SERGIO); Leeyoung
Cc: [email-masked]; Igor Bryskin
Subject: [Actn] 答复: ACTN progress

Thanks Sergio and Young.

My understanding for the term ‘cross-over’ is only talking about inter-connections of MDSCs. I don’t think there should be any kinds of cross-over on CNC or PNC level. It is still quite clean hierarchy, i.e., we have CMI and MPI on the ‘vertical’ direction, and allow some inter-MDSC interface on the ‘horizontal’ direction. In my opinion this structure is rather simple, unless there are thousands of MDSC interconnections:)
[Dhruv]: I feel it is necessary to have MDSC as one logical entity to the PNC, CNC; to keep the framework clean. Now if some implementation choose to implement MDSC in distributed fashion, that is okay!
But do we need a standard inter-MDSC interface for a multi-vendor MDSC scenario? I am not sure…

I also agree on Young’s suggestion on ‘advanced case’, at the moment let’s try to keep it simple and solve it first.
[Dhruv]: Yup, let’s keep things simple for now…

Regards,
Dhruv

Best wishes,
Haomian

发件人: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
发送时间: 2015年1月17日 1:41
收件人: Leeyoung; Zhenghaomian
抄送: Igor Bryskin; [email-masked]<mailto:[email-masked]>
主题: RE: [Actn] ACTN progress

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Daniele Ceccarelli <[email-masked]>
Date: Mon, 19 Jan 2015 06:03:43 +0000

+1

BR
Daniele

Sent from a mobile device, please forgive spelling mistakes and short replies

-------- Messaggio originale --------
Da: Dhruv Dhody
Data:19/01/2015 03:47 (GMT+01:00)
A: Zhenghaomian ,"BELOTTI, SERGIO (SERGIO)" ,Leeyoung
Cc: [email-masked],Igor Bryskin
Oggetto: Re: [Actn] 答复: ACTN progress

Hi Haomian,

Thanks Sergio and Young.

Regards,
Dhruv

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Zhenghaomian <[email-masked]>
Date: Mon, 19 Jan 2015 07:01:51 +0000

Hi, Dhruv,

By mentioning interaction among MDSCs I was trying to avoid such interaction at other levels. From the architecture level, the only motivation to include such ‘horizontal’ interface is to guarantee the proposed architecture could support network with larger-scale. I like the ‘MDSC logical entity’, which may be implemented in a distributed way, my understanding is such implementation is not within the current scope of ACTN.

Furthermore, it is also difficult to judge whether we need a standard inter-MDSC interface for multi-vendor case or not, but I believe this should become clear once we complete the work on CMI and MPI.

Best wishes,
Haomian

发件人: Dhruv Dhody
发送时间: 2015年1月19日 10:47
收件人: Zhenghaomian; BELOTTI, SERGIO (SERGIO); Leeyoung
抄送: [email-masked]; Igor Bryskin
主题: RE: [Actn] 答复: ACTN progress

Hi Haomian,

Cc: [email-masked]<mailto:[email-masked]>; Igor Bryskin

Thanks Sergio and Young.

Regards,
Dhruv

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: 윤빈영 <[email-masked]>
Date: Mon, 19 Jan 2015 08:16:28 +0000

Hi Daniele,

Your answer makes me rethink about the 2-level model.

I think that ACTN needs to cover the 2-level model CONCEPTUALLY as well as the 3-level model to provide for a complete transport SDN solution, keeping up the PNC/MDSC/CNC architecture. Looking back the discussion on the PNC/MDSC interface and transparency, I think that we need to clearly define the relationship between the SDN controller(widely accepted among other groups) and the PNC/MDSC, which ,in my opinion, caused the debate on the recursive interface issue. The following is my view on the definition and a way to support the 2-level model based on the 3-level model.

It is generally said that the SDN controller should have all of the four functions the same as the MDSC. However, ACTN defines that the PNC has only two functions, so that it is not sufficient to call it a complete SDN controller. So the PNC are needed to combine with the MDSC to implement a complete T-SDN controller based on physical transport networks to support the four functions. We also need to define another transport controller running over virtual transport networks for the recursive SDN controller model. So we can define two types of a transport SDN controller to support all the four functions as follows.

-      T-SDN Controller(based on physical networks): Non-recursive =  PNC + MDSC

-      T-SDN Controller(based on virtual networks): Recursive =  MDSC

The MDSC can interface with a single PNC or multiple PNCs. For the single PNC, the multi-domain coordination function of the MDSC is disabled, three functions being kept.

Regareds,
Bin

________________________________
보낸 사람 : "Daniele Ceccarelli" <[email-masked]>
보낸 날짜 : 2015-01-18 18:45:36 ( +09:00 )
받는 사람 : Arashmid Akhavain <[email-masked]>, 윤빈영 <[email-masked]>, Leeyoung <[email-masked]>, Igor Bryskin <[email-masked]>, [email-masked] <[email-masked]>
참조 :
제목 : RE: [Actn] ACTN progress

Hi Arashmid, all,

BR
Daniele

Regards,
Arashmid

From:ACTN [mailto:[email-masked]] On Behalf Of ???
Sent: 16 January 2015 03:23
To: Leeyoung; Igor Bryskin; [email-masked]<mailto:[email-masked]>
Subject: Re: [Actn] ACTN progress

Hi Young,

Sincerely yours

Hi Bin and Igor,

Thanks,
Young

Hi Bin,

Igor

Hi Young,

YOUNG>> Yes.

Thanks,

Bin

From:Leeyoung [mailto:[email-masked]]
Sent: Thursday, January 15, 2015 4:12 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Actn] ACTN progress

Hi All,

Thanks,
Young

From:Igor Bryskin [mailto:[email-masked]]
Sent: Thursday, January 08, 2015 2:13 PM
To: Leeyoung; Daniele Ceccarelli
Cc: AshwoodsmithPeter
Subject: RE: Recap this morning's call

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: "BELOTTI, SERGIO (SERGIO)" <[email-masked]>
Date: Mon, 19 Jan 2015 08:18:55 +0000

Hi Haomian,

Reading your original comment my understanding is that you’re referring to g-h piece of interface in the original Adrian’s picture, this would preclude the “1:1” relationship between a PNC and MSDC . The relationship between different MSDC is not at the moment first priority in ACTN context, but nothing preclude to think about “distributed implementation” of MSDC, maintaining the logical 1:1 relation between PNC and his own MSDC. This would be my view.

Thanks a lot

Sergio

From: Zhenghaomian [mailto:[email-masked]]
Sent: lunedì 19 gennaio 2015 02:29
To: BELOTTI, SERGIO (SERGIO); Leeyoung
Cc: Igor Bryskin; [email-masked]
Subject: 答复: [Actn] ACTN progress

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Daniele Ceccarelli <[email-masked]>
Date: Mon, 19 Jan 2015 10:44:43 +0000

Hi,

I think that if an “horizontal” interface is needed, it’s just for routing info exchange, maybe including topology and VPNs, so I would say that in that case BGP/BGP-LS/MP-BGP should be enough.
Am I right? I there any further “horizontal” info exchange needed?

Everything that is ACTN is vertical IMHO.

BR
Daniele

From: ACTN [mailto:[email-masked]] On Behalf Of Zhenghaomian
Sent: lunedì 19 gennaio 2015 08:02
To: Dhruv Dhody; BELOTTI, SERGIO (SERGIO); Leeyoung
Cc: [email-masked]; Igor Bryskin
Subject: [Actn] 答复: 答复: ACTN progress

Hi, Dhruv,

Best wishes,
Haomian

发件人: Dhruv Dhody
发送时间: 2015年1月19日 10:47
收件人: Zhenghaomian; BELOTTI, SERGIO (SERGIO); Leeyoung
抄送: [email-masked]<mailto:[email-masked]>; Igor Bryskin
主题: RE: [Actn] 答复: ACTN progress

Hi Haomian,

Thanks Sergio and Young.

Regards,
Dhruv

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Igor Bryskin <[email-masked]>
Date: Mon, 19 Jan 2015 13:36:34 +0000

The cardinality of two adjacent  in ACTN hierarchy MDSCs is M:N, i.e. the upper MDSC can talk to any number m of lower (serving) MDSCs, each of which can serve any number n of client MDSCs. Numbers m and n are independent of each other. Furthermore, the ACTN interface between the two adjacent MDSCs is oblivious of numbers m and n, i.e. each MDSC “believes” that the other one talks only to him.
I also hope that we have agreed that an MDSC represents the entire set of functionalities of a transport SDN controller supported by the ACTN architecture, which in practice could be limited to CNC, PNC, “partial” MDSC, etc., which, however, at any time can enable more or disable some of supported features. Actual set of supported features is known to a given pair of adjacent  in ACTN hierarchy MDSCs and is dynamically (re-)learnt via the capability auto-discovery supported by the ACTN interface and is known only to the pair but no other MDSCs

Cheers,
Igor

From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
Sent: Monday, January 19, 2015 3:19 AM
To: Zhenghaomian; Leeyoung
Cc: Igor Bryskin; [email-masked]
Subject: RE: [Actn] ACTN progress

Hi Haomian,

Thanks a lot

Sergio

Cc: Igor Bryskin; [email-masked]<mailto:[email-masked]>

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Daniele Ceccarelli <[email-masked]>
Date: Mon, 19 Jan 2015 14:07:12 +0000

Hi Igor,

This is for sure a desirable scenario but I see it pretty complex to manage. I would prefer to start with the assumption of 1 parent MDSC (let me call it so) connecting to M child MDSCs, but each child speaking to a single parent. It should be M:1 in your terminology.
We might then consider extending to M:N but I’d fly down at the beginning :)

Cheers
Daniele

From: ACTN [mailto:[email-masked]] On Behalf Of Igor Bryskin
Sent: lunedì 19 gennaio 2015 14:37
To: BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]
Subject: Re: [Actn] ACTN progress

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Igor Bryskin <[email-masked]>
Date: Mon, 19 Jan 2015 14:18:19 +0000

Hi Danielle,
First, this simplification does not give you anything, because the parent MDSC never knows who else the child MDSC is talking to, i.e. the parent always assumes that it has the child’s undivided attention.
Second, what if the child MDSC (such as ADVA) actually needs to serve more than one client ?
Third, m:n also includes 1:1 and m:1 with no overhead,

Igor

From: Daniele Ceccarelli [mailto:[email-masked]]
Sent: Monday, January 19, 2015 9:07 AM
To: Igor Bryskin; BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]
Subject: RE: [Actn] ACTN progress

Hi Igor,

Cheers
Daniele

Cc: [email-masked]<mailto:[email-masked]>

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Dave Hood <[email-masked]>
Date: Mon, 19 Jan 2015 17:08:48 +0000

If the child exports an interface to more than one parent, it is the child’s responsibility to ensure isolation amongst the parents, either through hard partitioning of resources or through contractually understood sharing arrangements, for example best-efforts bandwidth or first-come-first-served access.

A parent is not expected to know whether it is sharing resources with peers.

Dave

From: ACTN [mailto:[email-masked]] On Behalf Of Igor Bryskin
Sent: Monday, January 19, 2015 6:18 AM
To: Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]
Subject: Re: [Actn] ACTN progress

Hi Danielle,

Igor

Hi Igor,

Cheers
Daniele

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Igor Bryskin <[email-masked]>
Date: Mon, 19 Jan 2015 18:37:21 +0000

Exactly right.
________________________________________
From: Dave Hood [[email-masked]]
Sent: Monday, January 19, 2015 12:08 PM
To: Igor Bryskin; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]
Subject: RE: [Actn] ACTN progress

Dave

Hi Danielle,

Igor

Hi Igor,

This is for sure a desirable scenario but I see it pretty complex to manage. I would prefer to start with the assumption of 1 parent MDSC (let me call it so) connecting to M child MDSCs, but each child speaking to a single parent. It should be M:1 in your terminology.
We might then consider extending to M:N but I’d fly down at the beginning ☺

Cheers
Daniele

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

My understanding for the term ‘cross-over’ is only talking about inter-connections of MDSCs. I don’t think there should be any kinds of cross-over on CNC or PNC level. It is still quite clean hierarchy, i.e., we have CMI and MPI on the ‘vertical’ direction, and allow some inter-MDSC interface on the ‘horizontal’ direction. In my opinion this structure is rather simple, unless there are thousands of MDSC interconnections☺

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Arashmid Akhavain <[email-masked]>
Date: Mon, 19 Jan 2015 19:02:15 +0000

Hi Daniele,  all,

I agree that the MDSC and PNC functionalities can be provided by a single controller. I also agree that a single controller can be both MDSC and PNC.

But does this mean that we bypass the MDSC functional block in these cases? Or a request from CNC still goes through MDSC block and then to PNC block?

Bsst Regards,

Arashmid

From: ACTN [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: 18 January 2015 04:46
To: Arashmid Akhavain; 윤빈영; Leeyoung; Igor Bryskin; [email-masked]
Subject: Re: [Actn] ACTN progress

Hi Arashmid, all,

BR
Daniele

From: ACTN [mailto:[email-masked]] On Behalf Of Arashmid Akhavain
Sent: venerdì 16 gennaio 2015 19:55
To: 윤빈영; Leeyoung; Igor Bryskin; [email-masked]<mailto:[email-masked]>
Subject: Re: [Actn] ACTN progress

Regards,
Arashmid

Hi Young,

Sincerely yours

Hi Bin and Igor,

Thanks,
Young

Hi Bin,

Igor

Hi Young,

YOUNG>> Yes.

Thanks,

Bin

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Igor Bryskin <[email-masked]>
Date: Mon, 19 Jan 2015 20:14:58 +0000

Hi Arashmid

When CNC talks down, it does not know (nor makes assumptions) whether it talks to MDSC or PNC. In either case it uses the same API.

Igor

From: Arashmid Akhavain [mailto:[email-masked]]
Sent: Monday, January 19, 2015 2:02 PM
To: Daniele Ceccarelli; 윤빈영; Leeyoung; Igor Bryskin; [email-masked]
Subject: RE: [Actn] ACTN progress

Hi Daniele,  all,

Bsst Regards,

Arashmid

Hi Arashmid, all,

BR
Daniele

Regards,
Arashmid

Hi Young,

Sincerely yours

Hi Bin and Igor,

Thanks,
Young

Hi Bin,

Igor

Hi Young,

YOUNG>> Yes.

Thanks,

Bin

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Leeyoung <[email-masked]>
Date: Mon, 19 Jan 2015 20:44:33 +0000

Hi,

I agree with Dave and Igor, m:n does not add any overhead and we can start with m (=1) and n (>1). 

Dave's points on "the child's responsibility to ensure isolation amongst the parents" (and "a parent is not expected to know whether it is sharing resources with peers") are important to grasp. This mean there would be no cross-over control flows between MDSCs in the same peer level, observing the "isolation" rule. I believe this what Sergio was talking about in one of the previous emails. 

Thanks,
Young

-----Original Message-----
From: Igor Bryskin [mailto:[email-masked]] 
Sent: Monday, January 19, 2015 12:37 PM
To: Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]
Subject: RE: [Actn] ACTN progress

Exactly right.

Dave

Hi Danielle,

Igor

Hi Igor,

Cheers
Daniele

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Leeyoung <[email-masked]>
Date: Mon, 19 Jan 2015 21:08:08 +0000

Hi Arashmid and Igor,

I think you guys are talking about the same thing. From an interface standpoint, the CNC would have an interface to a network controller. It can be a MDSC or a PNC or a combo, but the CNC would not care what type of controller it interfaces with.

When the CNC interfaces with the PNC type of controller in the network, then in effect MDSC function can be said “bypassed”, but, from an interface standpoint, we should make the design “transparently” irrespective of CNC-MDSC or CNC-PNC or CNC-MDSC-PNCs.

Thanks,
Young

From: Igor Bryskin [mailto:[email-masked]]
Sent: Monday, January 19, 2015 2:15 PM
To: Arashmid Akhavain; Daniele Ceccarelli; 윤빈영; Leeyoung; [email-masked]
Subject: RE: [Actn] ACTN progress

Hi Arashmid

Igor

Hi Daniele,  all,

Bsst Regards,

Arashmid

Hi Arashmid, all,

BR
Daniele

Regards,
Arashmid

Hi Young,

Sincerely yours

Hi Bin and Igor,

Thanks,
Young

Hi Bin,

Igor

Hi Young,

YOUNG>> Yes.

Thanks,

Bin

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Arashmid Akhavain <[email-masked]>
Date: Mon, 19 Jan 2015 21:12:43 +0000

Hi Igor,
I agree with your statement. The CNC will use the same API and doesn’t see the underlying hierarchy.
But what happens at the next level in MDSC and PNC combo scenarios? Do we maintain a layered architecture in these cases?
In other words, does the MDSC logical block processes the request first, and then invokes the PNC functions/API?
Will we have a case where CNC will be directly talking to a PNC (granted that the CNC doesn’t know that it is talking to a PNC)?
I can see CNC --- PNC communication in a single domain scenarios. In these scenarios there is still a MDSC. The MDSC and PNC are collapsed into a single entity and the MDSC logical layer might simply act as a pass through conduit. Isn’t this the case?

Arashmid

From: Igor Bryskin [mailto:[email-masked]]
Sent: 19 January 2015 15:15
To: Arashmid Akhavain; Daniele Ceccarelli; 윤빈영; Leeyoung; [email-masked]
Subject: RE: [Actn] ACTN progress

Hi Arashmid

Igor

From: Arashmid Akhavain [mailto:[email-masked]]
Sent: Monday, January 19, 2015 2:02 PM
To: Daniele Ceccarelli; 윤빈영; Leeyoung; Igor Bryskin; [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Hi Daniele,  all,

Bsst Regards,

Arashmid

From: ACTN [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: 18 January 2015 04:46
To: Arashmid Akhavain; 윤빈영; Leeyoung; Igor Bryskin; [email-masked]<mailto:[email-masked]>
Subject: Re: [Actn] ACTN progress

Hi Arashmid, all,

BR
Daniele

Regards,
Arashmid

Hi Young,

Sincerely yours

Hi Bin and Igor,

Thanks,
Young

Hi Bin,

Igor

Hi Young,

YOUNG>> Yes.

Thanks,

Bin

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Arashmid Akhavain <[email-masked]>
Date: Mon, 19 Jan 2015 21:22:35 +0000

Thanks for your comment Young.
Yes, the MDSC would be still present in the architecture, but it simply acts as a conduit to PNC. The CNC as Igor and you mentioned is not aware of the underlying hierarchy.

Arashmid

From: Leeyoung
Sent: 19 January 2015 16:08
To: Igor Bryskin; Arashmid Akhavain; Daniele Ceccarelli; 윤빈영; [email-masked]
Subject: RE: [Actn] ACTN progress

Hi Arashmid and Igor,

Thanks,
Young

From: Igor Bryskin [mailto:[email-masked]]
Sent: Monday, January 19, 2015 2:15 PM
To: Arashmid Akhavain; Daniele Ceccarelli; 윤빈영; Leeyoung; [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Hi Arashmid

Igor

Hi Daniele,  all,

Bsst Regards,

Arashmid

Hi Arashmid, all,

BR
Daniele

Regards,
Arashmid

Hi Young,

Sincerely yours

Hi Bin and Igor,

Thanks,
Young

Hi Bin,

Igor

Hi Young,

YOUNG>> Yes.

Thanks,

Bin

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Leeyoung <[email-masked]>
Date: Mon, 19 Jan 2015 21:28:24 +0000

Hi Arashmid,

Yes. That is how I see.

Thanks,
Young

From: Arashmid Akhavain
Sent: Monday, January 19, 2015 3:23 PM
To: Leeyoung; Igor Bryskin; Daniele Ceccarelli; 윤빈영; [email-masked]
Subject: RE: [Actn] ACTN progress

Arashmid

From: Leeyoung

Hi Arashmid and Igor,

Thanks,
Young

Hi Arashmid

Igor

Hi Daniele,  all,

Bsst Regards,

Arashmid

Hi Arashmid, all,

BR
Daniele

Regards,
Arashmid

Hi Young,

Sincerely yours

Hi Bin and Igor,

Thanks,
Young

Hi Bin,

Igor

Hi Young,

YOUNG>> Yes.

Thanks,

Bin

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: 윤빈영 <[email-masked]>
Date: Tue, 20 Jan 2015 00:51:15 +0000

Hi Young,

I have a question about the sentence that the MDSC acts as a conduit to the PNC when the CNC talks to the PNC “transparently”.
Rather than the conduit as a role of the MDSC, I think that the MDSC still need to provide for adaptation function like the customer VN mapping function.
It is because the PNC doesn’t support the customer VN mapping function to support the VN services of the CNC in ACTN.

Sincerely yours,

From: Leeyoung [mailto:[email-masked]]
Sent: Tuesday, January 20, 2015 6:28 AM
Subject: Re: [Actn] ACTN progress

Hi Arashmid,

Yes. That is how I see.

Thanks,
Young

From: Arashmid Akhavain
Sent: Monday, January 19, 2015 3:23 PM
To: Leeyoung; Igor Bryskin; Daniele Ceccarelli; 윤빈영; [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Arashmid

From: Leeyoung
Sent: 19 January 2015 16:08
To: Igor Bryskin; Arashmid Akhavain; Daniele Ceccarelli; 윤빈영; [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Hi Arashmid and Igor,

Thanks,
Young

Hi Arashmid

Igor

Hi Daniele,  all,

Bsst Regards,

Arashmid

Hi Arashmid, all,

BR
Daniele

Regards,
Arashmid

Hi Young,

Sincerely yours

Hi Bin and Igor,

Thanks,
Young

Hi Bin,

Igor

Hi Young,

YOUNG>> Yes.

Thanks,

Bin

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Tue, 20 Jan 2015 01:04:40 +0000

Hi, Bin, all,

     I think your first case below matches what Daniele said, i.e., “From an implementation point of view we can have a CNC interfacing with a single controller which implements MDSC and PNC functionalities (basically able to speak with CNC and with nodes at the same time).” This applies for the scenario where single PNC is connected to MDSC as Bin mentioned below.

     Given that we have agreed MDSC has the recursive nation (your second case), In my humble opinion, the two cases you mentioned below are already covered by the architecture we are currently converging.  In your second case, even though you do not include PNC as part of your T-SDN controller definition, but architecturally speaking, there should be a PNC to support the MDSC.

  Overall, your explanation does comply with the 3-level architecture we are discussing. Maybe, what is missing is some explanation text documented somewhere, so we are clear how the architecture can be put into different scenarios, if needed. Thoughts?

Cheers,
Xian

From: ACTN [mailto:[email-masked]] On Behalf Of ???
Sent: 2015年1月19日 16:16
To: Daniele Ceccarelli; Arashmid Akhavain; Leeyoung; Igor Bryskin; [email-masked]
Subject: Re: [Actn] ACTN progress

Hi Daniele,

Regareds,
Bin

BR
Daniele

Regards,
Arashmid

Hi Young,

Sincerely yours

Hi Bin and Igor,

Thanks,
Young

Hi Bin,

Igor

Hi Young,

YOUNG>> Yes.

Thanks,

Bin

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: "BELOTTI, SERGIO (SERGIO)" <[email-masked]>
Date: Tue, 20 Jan 2015 10:28:17 +0000

Hi Young,
I share completely Dave's point about child responsibility, and yes, you got it my previous thought: independently of the number of parents MSDC , while in the relationship with his parent child is expecting to deal with confidentiality and isolation, this does not happen to be the case for cross-over relation. Any reference in the original picture from Adrian's.

Thanks
Sergio

Belotti Sergio - System Architect
ALCATEL-LUCENT  IP Routing&Transport
via Trento 30 Vimercate (MB) - Italy
phone +39 (039) 6863033

-----Original Message-----
From: Leeyoung [mailto:[email-masked]] 
Sent: lunedì 19 gennaio 2015 21:45
To: Igor Bryskin; Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian
Cc: [email-masked]
Subject: RE: [Actn] ACTN progress

Hi,

Thanks,
Young

-----Original Message-----
From: Igor Bryskin [mailto:[email-masked]] 
Sent: Monday, January 19, 2015 12:37 PM
To: Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]
Subject: RE: [Actn] ACTN progress

Exactly right.

Dave

Hi Danielle,

Igor

Hi Igor,

Cheers
Daniele

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 20 Jan 2015 17:10:45 +0000

Hi all,

Changing the subject as there are multiple threads ongoing with the same subject.

This time I have to disagree guys. It is possible to keep the complexity limited to the child only in some cases I. E. Hard separation of resources and no preemption.

If resources of a PNC are shared between MDSC1 e MDSC2, assigned to MSDC1 and then preempted by a new LSP or a restoration of an LSP of  MSDC2 the PNC must be able to tell MDSC1 : "I'm sorry, your resources were stolen".
If we don't want to support this, that's fine with me but we must clearly state what is supported and what is not.
That said I'm fine with the m:n with limitations or extra complexity.
Cheers,
Daniele

-------- Messaggio originale --------
Da: "BELOTTI, SERGIO (SERGIO)"
Data:20/01/2015 11:28 (GMT+01:00)
A: Leeyoung ,Igor Bryskin ,Dave Hood ,Daniele Ceccarelli ,Zhenghaomian
Cc: [email-masked]
Oggetto: RE: [Actn] ACTN progress

Hi Young,

Thanks
Sergio

-----Original Message-----
From: Leeyoung [mailto:[email-masked]]
Sent: lunedì 19 gennaio 2015 21:45
To: Igor Bryskin; Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian
Cc: [email-masked]
Subject: RE: [Actn] ACTN progress

Hi,

Thanks,
Young

-----Original Message-----
From: Igor Bryskin [mailto:[email-masked]]
Sent: Monday, January 19, 2015 12:37 PM
To: Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]
Subject: RE: [Actn] ACTN progress

Exactly right.

Dave

Hi Danielle,

Igor

Hi Igor,

Cheers
Daniele

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: "BELOTTI, SERGIO (SERGIO)" <[email-masked]>
Date: Tue, 20 Jan 2015 17:27:08 +0000

Hi Daniele,

what is your point of disagreement? About the child responsibility in general or the complexity?
the important point is to permit parent of looking at resources as they would be the only one acting on these.
As David said “A parent is not expected to know whether it is sharing resources with peers.”
So , how you want to complicate your level of policy and confidentiality it is another story. But you’re right that the case you mentioned has to be addressed

Thanks
Ciao
Sergio

From: Daniele Ceccarelli [mailto:[email-masked]]
Sent: martedì 20 gennaio 2015 18:11
To: BELOTTI, SERGIO (SERGIO); Leeyoung; Igor Bryskin; Dave Hood; Zhenghaomian
Cc: [email-masked]
Subject: MSDC-PNC m:n (was R: [Actn] ACTN progress)

Hi all,

-------- Messaggio originale --------

Hi Young,

Thanks
Sergio

-----Original Message-----
From: Leeyoung [mailto:[email-masked]]
Sent: lunedì 19 gennaio 2015 21:45
To: Igor Bryskin; Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Hi,

Thanks,
Young

-----Original Message-----
From: Igor Bryskin [mailto:[email-masked]]
Sent: Monday, January 19, 2015 12:37 PM
To: Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Exactly right.

Dave

Hi Danielle,

Igor

Hi Igor,

Cheers
Daniele

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Leeyoung <[email-masked]>
Date: Tue, 20 Jan 2015 17:33:49 +0000

Hi Daniele,

Good point you are brining. Perhaps I was confused.

What I should have said, we can begin with m:n (with m=1, n>0), m being the number of MSDC and n that of PNCs. This is a base case and a simple case, which people can agree.

Now when m > 1 (say there is MDSC 1 and MDSC 2), I don’t see any realistic cases that both MDSCs belong to the same administration. If multiple numbers of MDSC belonging to one administration should be modeled as “logically centralized” (in effect, distributed). So in this case, there is no need inter MDSC communication (i.e., no MDSC-MDSC control flow)

So I don’t see the need for the PNC to talk to other MDSC which belongs to other administration.

Regards,
Young

From: ACTN [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: Tuesday, January 20, 2015 11:11 AM
To: BELOTTI, SERGIO (SERGIO); Leeyoung; Igor Bryskin; Dave Hood; Zhenghaomian
Cc: [email-masked]
Subject: [Actn] MSDC-PNC m:n (was R: ACTN progress)

Hi all,

-------- Messaggio originale --------

Hi Young,

Thanks
Sergio

-----Original Message-----
From: Leeyoung [mailto:[email-masked]]
Sent: lunedì 19 gennaio 2015 21:45
To: Igor Bryskin; Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian
Cc: [email-masked]
Subject: RE: [Actn] ACTN progress

Hi,

Thanks,
Young

-----Original Message-----
From: Igor Bryskin [mailto:[email-masked]]
Sent: Monday, January 19, 2015 12:37 PM
To: Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]
Subject: RE: [Actn] ACTN progress

Exactly right.

Dave

Hi Danielle,

Igor

Hi Igor,

Cheers
Daniele

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Leeyoung <[email-masked]>
Date: Tue, 20 Jan 2015 18:03:22 +0000

Hi Daniele,

Let us look at the figure below for a single administration domain case.

                 +-----+
                 | CNC |
                 +--+--+
                    |
                    |
                    |
      +-------------+-----------+
      |  +--------+ +--------+  |
      |  | MDSC a | | MDSC b |  |
      |  +--------+ +--------+  |
      +---+-------+--------+----+
          |       |        |
          |       |        |
          |       |        |
          |       |        |
     +----+-+  +--+--+  +--+--+
     | PNC a|  |PNC b|  |PNC c|
     +------+  +-----+  +-----+

MDSC a and MDSC b can be logically centralized to represent as one MDSC. So no need for PNC to interface two MSDCs. What this means m:n can be generalized as 1:n.

Now let us look at the case where CNC may want to establish two administrations for its diversity service, etc.

                              +----------+
                              |          |
                              |   CNC    |
                              +----------+-
                             --    |       --
                          ---      |         ---
                        --         |            ---
                      --           |               --
      +-------------+-----------+  |   +-------------+-----------+
      |  +--------+ +--------+  |  |   |  +--------+ +--------+  |
      |  | MDSC a | | MDSC b |  |  |   |  | MDSC a | | MDSC b |  |
      |  +--------+ +--------+  |  |   |  +--------+ +--------+  |
      +---+-------+--------+----+  |   +---+-------+--------+----+
          |       |        |       |       |       |        |
          |       |        |       |       |       |        |
          |       |        |       |       |       |        |
          |       |        |       |       |       |        |
     +----+-+  +--+--+  +--+--+    |  +----+-+  +--+--+  +--+--+
     | PNC a|  |PNC b|  |PNC c|    |  | PNC a|  |PNC b|  |PNC c|
     +------+  +-----+  +-----+    |  +------+  +-----+  +-----+
                                   |
                                   |
          Administration A         |       Administration B
                                   |

As you see here, again there is no need for PNC to talk to multiple MDSCs with an obvious reason.

CNC in this case may impose MDSC in Admin A to talk to MDSC in Admin B, but I think this is out of scope for ACTN at least for an initial phase. This case only makes sense if there is control connectivity between PNCs in Administration A and the MDSC in Administration B and vice verse. But I don’t see any general case this can be done unless there is a mutual agreement between Admin A and B. This is an advance case I referred in one of the past emails.

Thanks,
Young
From: Leeyoung
Sent: Tuesday, January 20, 2015 11:34 AM
To: 'Daniele Ceccarelli'; BELOTTI, SERGIO (SERGIO); Igor Bryskin; Dave Hood; Zhenghaomian
Cc: [email-masked]
Subject: RE: [Actn] MSDC-PNC m:n (was R: ACTN progress)

Hi Daniele,

Regards,
Young

Hi all,

-------- Messaggio originale --------

Hi Young,

Thanks
Sergio

-----Original Message-----
From: Leeyoung [mailto:[email-masked]]
Sent: lunedì 19 gennaio 2015 21:45
To: Igor Bryskin; Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian
Cc: [email-masked]
Subject: RE: [Actn] ACTN progress

Hi,

Thanks,
Young

-----Original Message-----
From: Igor Bryskin [mailto:[email-masked]]
Sent: Monday, January 19, 2015 12:37 PM
To: Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]
Subject: RE: [Actn] ACTN progress

Exactly right.

Dave

Hi Danielle,

Igor

Hi Igor,

Cheers
Daniele

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Arashmid Akhavain <[email-masked]>
Date: Tue, 20 Jan 2015 19:19:02 +0000

Hi Daniele,
Assuming that the MDSCs belong to different administrative domains, in the case of PNC resources being shared among multiple MDSCs,
shouldn’t the type of pre-emption you mentioned be disallowed by policy?

BR,
Arashmid

From: ACTN [mailto:[email-masked]] On Behalf Of Daniele Ceccarelli
Sent: 20 January 2015 12:11
To: BELOTTI, SERGIO (SERGIO); Leeyoung; Igor Bryskin; Dave Hood; Zhenghaomian
Cc: [email-masked]
Subject: [Actn] MSDC-PNC m:n (was R: ACTN progress)

Hi all,

-------- Messaggio originale --------

Hi Young,

Thanks
Sergio

-----Original Message-----
From: Leeyoung [mailto:[email-masked]]
Sent: lunedì 19 gennaio 2015 21:45
To: Igor Bryskin; Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Hi,

Thanks,
Young

-----Original Message-----
From: Igor Bryskin [mailto:[email-masked]]
Sent: Monday, January 19, 2015 12:37 PM
To: Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Exactly right.

Dave

Hi Danielle,

Igor

Hi Igor,

Cheers
Daniele

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Arashmid Akhavain <[email-masked]>
Date: Tue, 20 Jan 2015 19:46:56 +0000

Actually, the question is how PNC resources under MDSC in administrative domain A can be shared with MDSC in administrative domain B.

Best regards,
Arashmid

From: ACTN [mailto:[email-masked]] On Behalf Of Arashmid Akhavain
Sent: 20 January 2015 14:19
To: Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Leeyoung; Igor Bryskin; Dave Hood; Zhenghaomian
Cc: [email-masked]
Subject: Re: [Actn] MSDC-PNC m:n (was R: ACTN progress)

Hi Daniele,

BR,
Arashmid

Hi all,

-------- Messaggio originale --------

Hi Young,

Thanks
Sergio

-----Original Message-----
From: Leeyoung [mailto:[email-masked]]
Sent: lunedì 19 gennaio 2015 21:45
To: Igor Bryskin; Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Hi,

Thanks,
Young

-----Original Message-----
From: Igor Bryskin [mailto:[email-masked]]
Sent: Monday, January 19, 2015 12:37 PM
To: Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Exactly right.

Dave

Hi Danielle,

Igor

Hi Igor,

Cheers
Daniele

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Dave Hood <[email-masked]>
Date: Tue, 20 Jan 2015 21:32:07 +0000

If preemption is allowed by the contract, then the tenant must be prepared to receive a notification (from a well-behaved controller) that its service has been pre-empted. Otherwise, it shouldn’t happen. A similar kind of thing is always to be expected in case of network failures, especially if unprotected, but by exception, even for protected services that cannot be restored. The properly constructed tenant will be prepared to deal with rainy-day events.

Dave

From: Arashmid Akhavain [mailto:[email-masked]]
Sent: Tuesday, January 20, 2015 11:47 AM
To: Arashmid Akhavain; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Leeyoung; Igor Bryskin; Dave Hood; Zhenghaomian
Cc: [email-masked]
Subject: RE: [Actn] MSDC-PNC m:n (was R: ACTN progress)

Best regards,
Arashmid

Hi Daniele,

BR,
Arashmid

Hi all,

-------- Messaggio originale --------

Hi Young,

Thanks
Sergio

-----Original Message-----
From: Leeyoung [mailto:[email-masked]]
Sent: lunedì 19 gennaio 2015 21:45
To: Igor Bryskin; Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Hi,

Thanks,
Young

-----Original Message-----
From: Igor Bryskin [mailto:[email-masked]]
Sent: Monday, January 19, 2015 12:37 PM
To: Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Exactly right.

Dave

Hi Danielle,

Igor

Hi Igor,

Cheers
Daniele

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Zhenghaomian <[email-masked]>
Date: Wed, 21 Jan 2015 03:46:16 +0000

Hi, Sergio and Daniele,

I would like to share some considerations among these discussions.  Firstly I hope we are talking about the same question. My understanding is we are debating whether a slice of physical resource from PNC could be shared with more than one MDSCs or not.

Solution I is to make each individual slice of physical resource dedicated to one MDSC entity with hard separation, as Daniele suggest. Different slice of physical resource (should be located in the different PNCs) can be allocated to either different MDSC entities or just one MDSC entity. It is worth noting that this is consistent with “A parent is not expected to know whether it is sharing resources with peers.”

Solution II is to make the individual slice of physical resource shared by multiple MDSC entities, proposed by Sergio (and Dave, Igor? ). There should be some priority configuration for the resources and corresponding pre-emption mechanism to guarantee the effective usage of the physical resource.

Please correct me if anything wrong for the above understanding.

Personally I prefer solution I because I have not seen any advantage for solution II, as long as there are sufficient of physical resources. The only advantage I can see for physical resource sharing is the improvement of resource utilization, which should be considered as optimization technique. We need to think about use case first and then talk about the related standard work. However, solution II introduces a lot of extra work (like priority config and pre-emption mechanism).

Thanks a lot.

Best wishes,
Haomian

发件人: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]]
发送时间: 2015年1月21日 1:27
收件人: Daniele Ceccarelli; Leeyoung; Igor Bryskin; Dave Hood; Zhenghaomian
抄送: [email-masked]
主题: RE: MSDC-PNC m:n (was R: [Actn] ACTN progress)

Hi Daniele,

Thanks
Ciao
Sergio

Hi all,

-------- Messaggio originale --------

Hi Young,

Thanks
Sergio

-----Original Message-----
From: Leeyoung [mailto:[email-masked]]
Sent: lunedì 19 gennaio 2015 21:45
To: Igor Bryskin; Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Hi,

Thanks,
Young

-----Original Message-----
From: Igor Bryskin [mailto:[email-masked]]
Sent: Monday, January 19, 2015 12:37 PM
To: Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Exactly right.

Dave

Hi Danielle,

Igor

Hi Igor,

Cheers
Daniele

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: 윤빈영 <[email-masked]>
Date: Wed, 21 Jan 2015 04:55:57 +0000

Hi,

I am trying to track down why the debate comes to us.
The following is my view.

I think that our main debates so far come from a slightly different view of the PNC.
It is because some people including me sometimes take the PNC as a complete SDN controller.
Let’s go the two following cases of the debates with Daniele and Igor.

[Igor’s case]
If the PNC is a complete SDN controller, it should have all of the four functionalities addressed in the framework doc.
If it is the case, the interface B would logically be the same as the interface C.
However, the interface C is slightly distinguished from the interface B as the PNC just having two functionalities is not a complete SDN controller.

[Daniele’s case]
If the PNC is a complete SDN controller, it can interface with multiple MDSCs.
It can operate as a physical network provider where the MDSCs are customers of the PNC.
So I think that Daniels’ opinion is reasonable on the relationship between MDSC and the PNC, if the PNC is assumed as a complete SDN controller.
As only the complete SDN controller can talk to the CNC, the PNC is required to interface with one single MDSC to be a complete SDN controller.
That is the reason that the PNC does not interface with multiple MDSCs.

In conclusion, the PNC is not a complete SDN controller that people generally think.
It is required to combine with the MDSC to be a complete SDN controller.
If my view is O.K, I think that we need to describe it clearly in the framework document.
Otherwise, we can have a similar case like those above again and again.

Best regards,
Bin

From: Dave Hood [mailto:[email-masked]]
Sent: Wednesday, January 21, 2015 6:32 AM
Subject: Re: [Actn] MSDC-PNC m:n (was R: ACTN progress)

Dave

Best regards,
Arashmid

Hi Daniele,

BR,
Arashmid

Hi all,

-------- Messaggio originale --------

Hi Young,

Thanks
Sergio

-----Original Message-----
From: Leeyoung [mailto:[email-masked]]
Sent: lunedì 19 gennaio 2015 21:45
To: Igor Bryskin; Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Hi,

Thanks,
Young

-----Original Message-----
From: Igor Bryskin [mailto:[email-masked]]
Sent: Monday, January 19, 2015 12:37 PM
To: Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Exactly right.

Dave

Hi Danielle,

Igor

Hi Igor,

Cheers
Daniele

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Wed, 21 Jan 2015 06:12:12 +0000

Hi, Young,

   I agree with you that we should start with 1:n case first since we have a clear use case presented before (in IETF90 BOFs) . For the more complicated one (aka m:n), we probably better identify the necessity/scenario first.

Cheers,
Xian

From: ACTN [mailto:[email-masked]] On Behalf Of Leeyoung
Sent: 2015年1月21日 1:34
To: Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Igor Bryskin; Dave Hood; Zhenghaomian
Cc: [email-masked]
Subject: Re: [Actn] MSDC-PNC m:n (was R: ACTN progress)

Hi Daniele,

Regards,
Young

Hi all,

-------- Messaggio originale --------

Hi Young,

Thanks
Sergio

-----Original Message-----
From: Leeyoung [mailto:[email-masked]]
Sent: lunedì 19 gennaio 2015 21:45
To: Igor Bryskin; Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian
Cc: [email-masked]
Subject: RE: [Actn] ACTN progress

Hi,

Thanks,
Young

-----Original Message-----
From: Igor Bryskin [mailto:[email-masked]]
Sent: Monday, January 19, 2015 12:37 PM
To: Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]
Subject: RE: [Actn] ACTN progress

Exactly right.

Dave

Hi Danielle,

Igor

Hi Igor,

Cheers
Daniele

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 21 Jan 2015 06:48:29 +0000

Hi Young, all,

The discussion raised a very good point and I think that we can say that there are 3 scenarios, but two of which with the same degree of complexity:

1. m:1 scenario
2. M:n scenario with hard separation of resources or sharing without preemption.
3. M:n scenario with sharing and preemption

Scenarios 1 and 2 have the same degree of complexity  (Agree with igor here) and allow for having the MDSC not be aware of peer MDSCs (Agree with Sergio and Dave here).
SO, since there is interest from the floor on the m:n, BUT it is wise to start with something easier, I would suggest to start from 2.

Cheers,
Daniele

-------- Messaggio originale --------
Da: Leeyoung
Data:20/01/2015 18:34 (GMT+01:00)
A: Daniele Ceccarelli ,"BELOTTI, SERGIO (SERGIO)" ,Igor Bryskin ,Dave Hood ,Zhenghaomian
Cc: [email-masked]
Oggetto: RE: [Actn] MSDC-PNC m:n (was R: ACTN progress)

Hi Daniele,

Regards,
Young

Hi all,

-------- Messaggio originale --------

Hi Young,

Thanks
Sergio

-----Original Message-----
From: Leeyoung [mailto:[email-masked]]
Sent: lunedì 19 gennaio 2015 21:45
To: Igor Bryskin; Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian
Cc: [email-masked]
Subject: RE: [Actn] ACTN progress

Hi,

Thanks,
Young

-----Original Message-----
From: Igor Bryskin [mailto:[email-masked]]
Sent: Monday, January 19, 2015 12:37 PM
To: Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]
Subject: RE: [Actn] ACTN progress

Exactly right.

Dave

Hi Danielle,

Igor

Hi Igor,

Cheers
Daniele

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 21 Jan 2015 06:55:28 +0000

Via a policy manager. The PNC can show such resources (real, virtual or abstract) to the different MDSCs with different priorities.

BR
Daniele

-------- Messaggio originale --------
Da: Arashmid Akhavain
Data:20/01/2015 20:47 (GMT+01:00)
A: Arashmid Akhavain ,Daniele Ceccarelli ,"BELOTTI, SERGIO (SERGIO)" ,Leeyoung ,Igor Bryskin ,Dave Hood ,Zhenghaomian
Cc: [email-masked]
Oggetto: RE: [Actn] MSDC-PNC m:n (was R: ACTN progress)

Best regards,
Arashmid

Hi Daniele,

BR,
Arashmid

Hi all,

-------- Messaggio originale --------

Hi Young,

Thanks
Sergio

-----Original Message-----
From: Leeyoung [mailto:[email-masked]]
Sent: lunedì 19 gennaio 2015 21:45
To: Igor Bryskin; Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Hi,

Thanks,
Young

-----Original Message-----
From: Igor Bryskin [mailto:[email-masked]]
Sent: Monday, January 19, 2015 12:37 PM
To: Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Exactly right.

Dave

Hi Danielle,

Igor

Hi Igor,

Cheers
Daniele

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Dave Hood <[email-masked]>
Date: Wed, 21 Jan 2015 15:05:03 +0000

Policy manager, right. But the question that arises is whether admin domain A and B have separate controllers, each talking to the same PNC resources. At some point, the owner of the PNC resources (admin domain C?) needs to commit contractually to its customers A and B. If A and B generate conflicting requests, someone needs to arbitrate.

The arbiter would confirm that the request, say from A, is within the bounds of the contractual commitment; if not, it just rejects the request, and we go on. If the request is legal, we get into several possibilities, depending on the contract:

·         The contract allows A to pre-empt B. Then A’s request is satisfied, B is downgraded, re-routed, disrupted, or whatever is appropriate, and a notification goes to B and of course to C’s accounting records.

·         The contract allows for sharing with B on some kind of weighted, prioritized contract. The arbiter accepts the request. Depending on weights and priorities, B may experience reduced throughput, but it should still be within the bounds of B’s contract.

·         … unless C has oversubscribed the resources. In that case, the arbiter must still decide what to do, satisfy one or the other, split the baby, or whatever the operator determines.

Clearly the arbiter is a single decision point in access to the resources, and C must provision the arbiter to know about the contracts with A and B. It is not forbidden to put arbiters down onto network elements directly, but it is strongly recommended that this be a function of C’s SDN controller. As well as offloading a substantial body of software from the NEs, this obviates the security issue of cross-admin control access directly to NEs, while the relatively centralized position of the SDN controller potentially permits the arbiter to satisfy requests on a subnetwork-wide basis, rather than only on the basis of specific resources.

Of course, it can be that C is (for example) the same administration as A, but the analysis remains the same.
Dave

From: Daniele Ceccarelli
Sent: Tuesday, January 20, 2015 10:55 PM
To: Arashmid Akhavain; BELOTTI, SERGIO (SERGIO); Leeyoung; Igor Bryskin; Dave Hood; Zhenghaomian
Cc: [email-masked]
Subject: R: [Actn] MSDC-PNC m:n (was R: ACTN progress)

BR
Daniele

-------- Messaggio originale --------
Da: Arashmid Akhavain

Best regards,
Arashmid

Hi Daniele,

BR,
Arashmid

Hi all,

-------- Messaggio originale --------

Hi Young,

Thanks
Sergio

-----Original Message-----
From: Leeyoung [mailto:[email-masked]]
Sent: lunedì 19 gennaio 2015 21:45
To: Igor Bryskin; Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Hi,

Thanks,
Young

-----Original Message-----
From: Igor Bryskin [mailto:[email-masked]]
Sent: Monday, January 19, 2015 12:37 PM
To: Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Exactly right.

Dave

Hi Danielle,

Igor

Hi Igor,

Cheers
Daniele

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Daniele Ceccarelli <[email-masked]>
Date: Wed, 21 Jan 2015 15:58:41 +0000

I couldn’t have said it better ☺

Such policies need to be implemented in a single point. In case we have MDSC1 and MDSC2 sharing the access to the same PNC, the policies need to be implemented on that PNC, while if we are speaking about CNC1 and CNC2 having access to the same MDSC the policies need to be implemented on that MDSC.
There is also the recursive case in which parent (upper level) MDSC1 and parent MDSC2 share the same child (lower level) MDSC, in that case such policies need to be implemented on the child MDSC.

BR
Daniele

From: Dave Hood
Sent: mercoledì 21 gennaio 2015 16:05
To: Daniele Ceccarelli; Arashmid Akhavain; BELOTTI, SERGIO (SERGIO); Leeyoung; Igor Bryskin; Zhenghaomian
Cc: [email-masked]
Subject: RE: [Actn] MSDC-PNC m:n (was R: ACTN progress)

Dave

From: Daniele Ceccarelli

BR
Daniele

-------- Messaggio originale --------
Da: Arashmid Akhavain

Best regards,
Arashmid

Hi Daniele,

BR,
Arashmid

Hi all,

-------- Messaggio originale --------

Hi Young,

Thanks
Sergio

-----Original Message-----
From: Leeyoung [mailto:[email-masked]]
Sent: lunedì 19 gennaio 2015 21:45
To: Igor Bryskin; Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Hi,

Thanks,
Young

-----Original Message-----
From: Igor Bryskin [mailto:[email-masked]]
Sent: Monday, January 19, 2015 12:37 PM
To: Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Exactly right.

Dave

Hi Danielle,

Igor

Hi Igor,

Cheers
Daniele

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young

---

From: Arashmid Akhavain <[email-masked]>
Date: Wed, 21 Jan 2015 16:54:24 +0000

Dave, you hit the nail on the head!
They key point is that the resource owner is the only entity that can make pre-emption decision and ensure that everyone behaves within the boundaries of the contract. A MDSC doesn’t have control over the resources it doesn’t own and hence cannot directly pre-empt those resources without going through the owner MDSC.

Best regards
Arashmid

From: Dave Hood [mailto:[email-masked]]
Sent: 21 January 2015 10:05
To: Daniele Ceccarelli; Arashmid Akhavain; BELOTTI, SERGIO (SERGIO); Leeyoung; Igor Bryskin; Zhenghaomian
Cc: [email-masked]
Subject: RE: [Actn] MSDC-PNC m:n (was R: ACTN progress)

Dave

From: Daniele Ceccarelli

BR
Daniele

-------- Messaggio originale --------
Da: Arashmid Akhavain

Best regards,
Arashmid

Hi Daniele,

BR,
Arashmid

Hi all,

-------- Messaggio originale --------

Hi Young,

Thanks
Sergio

-----Original Message-----
From: Leeyoung [mailto:[email-masked]]
Sent: lunedì 19 gennaio 2015 21:45
To: Igor Bryskin; Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Hi,

Thanks,
Young

-----Original Message-----
From: Igor Bryskin [mailto:[email-masked]]
Sent: Monday, January 19, 2015 12:37 PM
To: Dave Hood; Daniele Ceccarelli; BELOTTI, SERGIO (SERGIO); Zhenghaomian; Leeyoung
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [Actn] ACTN progress

Exactly right.

Dave

Hi Danielle,

Igor

Hi Igor,

Cheers
Daniele

Cheers,
Igor

Hi Haomian,

Thanks a lot

Sergio

Thanks Sergio and Young.

Best wishes,
Haomian

Hi Young, Haomian,

Thanks
Sergio

Hi Haomian,

Thanks,
Young

From: Zhenghaomian

Hi, Young,

        +-----+           +-------+

Best wishes,
Haomian

发件人: Leeyoung
发送时间: 2015年1月15日 12:21

Haomian,

Thanks for your comment.

                              CNC

                               |a

                               |

                               |b

                CNC          MDSC

                 |c            |d

                 |             |

                  ------+------

                        |

                        |e

                      MDSC

                        |f

                        |

                  ------+------

                 |             |

                 |g            |h

                PNC           MDSC

                               |i

                               |

                              |j

                              PNC

Thanks,
Young

From: Zhenghaomian

Hi, Young and Igor,

Best wishes,
Haomian

Hi All,

Thanks,
Young

Hi Young,

Igor

Hi Igor,

1.      Topology Model

2.      Provisioning Model

3.      Service Model

4.      OAM Model

Thanks,
Young