Subject: Re: [admin-discuss] A clerical correction to the IETF Trust Legal Provisions 5.0

From: Lars Eggert <[email-masked]>
Date: Tue, 21 Sep 2021 11:57:08 +0300

Hi,

On 2021-8-24, at 5:18, John R Levine <[email-masked]> wrote:
> The trustees recently noted a confusing clerical error in the TLP where it describes the license we offer on code components of RFCs and other IETF contributions.
...
> Since this update only corrects a mistake and makes no substantive change to the TLP or the licenses it grants, we plan to post this as a correction rather than as a new version of the TLP.  Once we have done that we also plan to request changes to I-D and RFC boilerplate that use the wrong name, again, with no changes to the licenses themselves.

is there a timeline for this correction to happen?

I'm asking, because while for the Trust this is a relatively straightforward update to some of their web pages, on the IETF side we need some tools work to implement this change (in addition to also needing to update a larger number of web sites and open source repositories.)

Thanks,
Lars

---

From: "John Levine" <[email-masked]>
Date: 22 Sep 2021 00:26:08 -0400

It appears that Lars Eggert  <[email-masked]> said:
>rather than as a new version of the TLP.  Once we have done that we also plan to request changes to I-D and RFC boilerplate that use the wrong name,
>again, with no changes to the licenses themselves.
>

We met today and agreed to do it this week.

>I'm asking, because while for the Trust this is a relatively straightforward update to some of their web pages, on the IETF side we need some tools
>work to implement this change (in addition to also needing to update a larger number of web sites and open source repositories.)

We realize that it will take a while, perhaps a very long while, to
find and fix all the places it says "Simplified" and change them to
"Revised". There's no chance of finding and fixing everything all at
once across all of the IETF's web sites and tools (xml2rfc has to
change, for example) so it'll be a rolling fix.

Once again, the license itself has not changed and will not change, it's just
referring to it by the correct name.  Having read the TLP in detail while
reformatting it and looking for other mistakes, I do not expect that we
will make any other changes or fixes in the forseeable future.  I sure
hope not, this one word is painful enough as it is.

R's,
John

---

From: "John Levine" <[email-masked]>
Date: 23 Sep 2021 09:41:19 -0400

We published the correction to the TLP on the trust web site today.

Announcement here:

https://trustee.ietf.org/documents/trust-legal-provisions/

Corrected TLP here:

https://trustee.ietf.org/documents/trust-legal-provisions/tlp-5/

As I said before, we realize it that the old "Simplified" language appears in many places, and it will
take a while to find them and correct them.  The actual license has not changed, only the name used to
refer to it.

R's,
John