Subject: Re: [Adslmib] draft-ietf-adslmib-vdsl-02.txt

From: Randy Presuhn <[email-masked]>
Date: Mon, 29 Apr 2002 18:05:34 -0700 (PDT)

Hi -

> From: "Bob Ray" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>, <[email-masked]>
> Date: Wed, 10 Apr 2002 08:16:31 -0500
> Message-ID: <[email-masked]>
> In-Reply-To: <[email-masked]>
> Subject: [Adslmib] draft-ietf-adslmib-vdsl-02.txt
> 
> A new version of the vdsl mib with the IMPLIED keyword removed is 
> on the IETF website.
> 
> http://www.ietf.org/internet-drafts/draft-ietf-adslmib-vdsl-02.txt
> 
> Please rip this one apart!
...

A few things jumped out before I could start the shredder:

 - A couple of definitions (e.g. vdslLineConeProfile) use
   "Integer32", but the type is not listed in the IMPORTS
   from SNMPv2-SMI

 - The definition of vdslLineConfProfileEntry references
   an index "vdslLineContrProfileNameIndex".  No such thing
   is defined in the document, but the table *does* have
   two read-create columns, "vdslLineContrProfileName" and
   "vdslLineContrProfileIndex"...

 - Something is mangled in the DESCRIPTION of 
   vdslLineMCMConfProfileMaxTxPSDEntry (try saying that
   three times quickly!)  The text after the second '"'
   seems to belong somewhere else.

 - Reference [22] should have an "and" in place of the
   comma after the "G."

 - many of the other references have a comma before the
   "and" in the editor/author lists.  This appears to
   not conform to the current fashion espoused by
   <draft-rfc-editor-rfc2223bis-02.txt>

 - Are all the references normative?

 - I hope someone from the WG can comment on the substance.

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

_______________________________________________
Adslmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/adslmib

---

From: "Bob Ray" <[email-masked]>
Date: Tue, 30 Apr 2002 16:42:19 -0500

>A few things jumped out before I could start the shredder:

Thanks!!!  It's tough writing these things without a MIB
compiler.  I'm going to bite the bullet and switch over to
Linux so I can compile these things before I submit them
(good idea, huh?).  

I'll fix these problems and add Moti's suggestions as well.

Regards,
Bob Ray