Subject: Re: [Adslmib] RE: Proposed changes to draft ADSL2 MIB

From: [email-masked]
Date: Thu, 23 Jun 2005 17:47:02 +0300

Hi Bob,

We think that using XML may accelerate the development process, but we lack
the expertise in this area.
Is it possible to get as an example the XML file that Clay Sikes used?

Thanks,
Moti Morgenstern & Menachem Dodge
ECI Telecom Ltd.
Broadband Access Division
30 Hasivim St.
Petach Tikva, Israel 49517
Tel.: +972-3-9266258/9268421
Fax: +972-3-9287342
www.ecitele.com

                      "Ray, Robert"                                                                                                    
                      <RobertRay@pesa.         To:      "Scott Andrew Baillie" <[email-masked]>, "Moti Morgenstern"            
                      com>                     <[email-masked]>, "Menachem Dodge" <[email-masked]>           
                      Sent by:                 cc:      adslmib mailing list <[email-masked]>                                        
                      adslmib-bounces@         Subject: [Adslmib] RE: Proposed changes to draft ADSL2 MIB                              
                      ietf.org                                                                                                         

                      22/06/2005 22:35                                                                                                 

Editors:

Do you plan to use the xml2rfc tool at http://xml.resource.org/?

The RFC Editor really likes us to use this.  Clay Sikes, author of
http://www.ietf.org/internet-drafts/draft-ietf-adslmib-gshdslbis-11.txt,
has experience with this tool having written the g.shdslbis draft in
XML.

Bob Ray

_______________________________________________
Adslmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/adslmib

_______________________________________________
Adslmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/adslmib

---

From: "Clay Sikes" <[email-masked]>
Date: Thu, 23 Jun 2005 12:09:57 -0400

Hi Moti and Menachem,

Please find attached the xml for the latest SHDSL MIB module draft.  
More examples can be found at http://xml.resource.org/public/rfc/xml/.

I have been swamped lately, but hope to look over the ADSL2 drafts 
within the next 2 weeks.  I am happy to help in any way including 
helping with the editing.  Please feel free to use me in any that you 
feel would be helpful.

Thanks,
Clay

>                      adslmib-bounces@         Subject: [Adslmib] RE: Proposed changes to draft ADSL2 MIB                              

-- Paradyne Mail --
<?xml version="1.0"?>
<!DOCTYPE rfc SYSTEM "rfc2629.dtd"
[
<!ENTITY rfc2119 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.2119.xml'>
<!ENTITY rfc2662 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.2662.xml'>
<!ENTITY rfc2578 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.2578.xml'>
<!ENTITY rfc2579 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.2579.xml'>
<!ENTITY rfc2580 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.2580.xml'>
<!ENTITY rfc2863 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.2863.xml'>
<!ENTITY rfc3020 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.3020.xml'>
<!ENTITY rfc3410 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.3410.xml'>
<!ENTITY rfc3276 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.3276.xml'>
<!ENTITY rfc3411 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.3411.xml'>
<!ENTITY rfc3418 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.3418.xml'>
<!ENTITY rfc3593 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.3593.xml'>
]>
<!--       <?rfc strict='yes' ?>  -->
<?rfc toc='yes' ?>
<?rfc tocindent='yes' ?>
<?rfc symrefs='yes' ?>
<?rfc sortrefs='yes' ?>
<?rfc iprnotified='yes' ?>
<?rfc compact='yes'?>
<?rfc subcompact='yes'?>
<?rfc tocdepth="2" ?>

<rfc ipr="full3978" docName="draft-ietf-adslmib-gshdslbis-11.txt"
    category="std" >
    
<front>
     
    <title abbrev="HDSL2-SHDSL-LINE MIB">
        Definitions of Managed Objects for High Bit-Rate DSL - 2nd generation
        (HDSL2) and Single-Pair High-Speed Digital Subscriber
        Line (SHDSL) Lines
    </title>

    <author initials="C." surname="Sikes" fullname="Clay Sikes">
        <organization>Paradyne Networks, Inc.</organization>
        <address>
            <postal>
                <street>8454 126th Ave. N.</street>
                <city>Largo</city>
                <region>FL</region>
                <code>33773</code>
                <country>US</country>
            </postal>
            <phone>+1 727 530 8257</phone>
            <facsimile>+1 727 532 5698</facsimile>
            <email>[email-masked]</email>
        </address>
    </author>

    <author initials="B." surname="Ray" fullname="Bob Ray">
        <organization>PESA Switching Systems, Inc.</organization>
        <address>
            <postal>
                <street>330-A Wynn Drive</street>
                <city>Huntsville</city>
                <region>AL</region>
                <code>35805</code>
                <country>US</country>
            </postal>
            <phone>+1 256 726 9200 ext. 142</phone>
            <facsimile>+1 256 726 9271</facsimile>
            <email>[email-masked]</email>
        </address>
    </author>

    <author initials="R." surname="Abbi" fullname="Rajesh Abbi">
        <organization>Alcatel USA</organization>
        <address>
            <postal>
                <street>2912 Wake Forest Road</street>
                <city>Raleigh</city>
                <region>NC</region>
                <code>27609-7860</code>
                <country>US</country>
            </postal>
            <phone>+1 919-850-6194</phone>
            <facsimile>+1 919-850-6670</facsimile>
            <email>[email-masked]</email>
        </address>
    </author>

    <date month="May" year="2005" />

    <!-- Meda Data Elements -->
    <area>Operations and Management</area>
    <workgroup>Network Working Group</workgroup>

    <abstract>
        <t>
            This document defines a Management Information Base (MIB) module 
            for use with network management protocols in the Internet community.  
            In particular, it describes objects used for managing High Bit-Rate 
            Digital Subscriber Line (DSL) - 2nd generation (HDSL2) and Single-Pair 
            High-Speed Digital Subscriber Line (SHDSL) interfaces.  This document 
            introduces extensions to several objects and textual conventions 
            defined in HDSL2-SHDSL-Line MIB (RFC 3276).  This document obsoletes
            RFC 3276.
        </t>
    </abstract>

</front>

<middle>

    <section title="The Internet-Standard Management Framework">

        <t>
            For a detailed overview of the documents that describe the current
            Internet-Standard Management Framework, please refer to Section 7 of RFC 3410
            <xref target="RFC3410"/>.
        </t>
        <t>
            Managed objects are accessed via a virtual information store, termed 
            the Management Information Base or MIB.  MIB objects are generally
            accessed through the Simple Network Management Protocol (SNMP).
            Objects in the MIB are defined using the mechanisms defined in the
            Structure of Management Information (SMI).  This memo specifies a MIB
            module that is compliant to the SMIv2, which is described in STD 58, 
            RFC 2578 <xref target="RFC2578"/>, STD 58, RFC 2579 
            <xref target="RFC2579"/> and STD 58, RFC 2580 <xref target="RFC2580"/>.
        </t>
        <t>
            The key words &quot;MUST&quot;, &quot;MUST NOT&quot;, 
            &quot;REQUIRED&quot;, &quot;SHALL&quot;, &quot;SHALL NOT&quot;, 
            &quot;SHOULD&quot;, &quot;SHOULD NOT&quot;, &quot;RECOMMENDED&quot;, 
            &quot;MAY&quot;, and &quot;OPTIONAL&quot; in this document are to 
            be interpreted as described in RFC 2119 <xref target="RFC2119"/>.
        </t>

    </section>  <!--  title="The Internet-Standard Management Framework"  -->

    <section title="Overview">

        <t>
            This document defines a Management Information Base (MIB) module for use 
            with network management protocols in the Internet community for the purpose
            of managing HDSL2/SHDSL Lines.  
        </t>
        <t> 
            The MIB module described in RFC 3276 <xref target="RFC3276"/> describes objects 
            used for managing High Bit-Rate DSL - 2nd generation (HDSL2) <xref target="T1E1.4"/> 
            and Single-Pair High-Speed Digital Subscriber Line (SHDSL) 
            interfaces <xref target="G.991.2"/>.  These object descriptions are based upon the 
            specifications for the HDSL2 and SHDSL Embedded Operations Channel (EOC) as defined 
            in American National Standards Institute (ANSI) T1E1.4/2000-006 <xref target="T1E1.4"/> 
            and International Telecommunication Union (ITU) G.991.2 <xref target="G.991.2"/>.
        </t>
        <t>
            This document obsoletes RFC 3276 <xref target="RFC3276"/> which supports G.shdsl in 
            that the MIB module described herein supports G.shdsl.bis as described in the 
            G.991.2 <xref target="G.991.2"/>.  In addition, objects have been added to improve 
            the management of SHDSL lines.
        </t>
        <t>
            The MIB module is located in the MIB tree under MIB 2 transmission, as
            discussed in the MIB-2 Integration (RFC 2863 <xref target="RFC2863"/>) 
            section of this document.
        </t>

        <section title="Relationship to other MIBs">
            <t>
                This section outlines the relationship of this MIB module with other 
                MIB modules described in RFCs.  Specifically, IF-MIB as presented in 
                RFC 2863 <xref target="RFC2863"/> is discussed.
            </t>

            <section title="General IF-MIB Integration (RFC 2863)">
                <t>
                    The HDSL2/SHDSL Line MIB specifies the detailed attributes 
                    of a data interface.  As such, it needs to integrate with 
                    RFC 2863 <xref target="RFC2863"/>.  The IANA has assigned 
                    the following ifTypes to HDSL2 and SHDSL:
                </t>

                <figure><artwork>
   IANAifType ::= TEXTUAL-CONVENTION
       ...
   SYNTAX INTEGER {
       ...
       hdsl2 (168), -- High Bit-Rate DSL, 2nd generation
       shdsl (169), -- Multirate HDSL2
       ...
       }
                </artwork></figure>
      
                <t>
                    Note that the ifFixedLengthGroup from RFC 2863 
                    <xref target="RFC2863"/> MUST be supported and that the 
                    ifRcvAddressGroup does not apply to this MIB module.
                </t>

            </section>  <!--  title="General IF-MIB Integration (RFC 2863)"  -->

            <section title="Usage of ifTable">

                <t>
                    The MIB branch identified by this ifType contains tables appropriate
                    for this interface type.  Most such tables extend the ifEntry table,
                    and are indexed by ifIndex.  For interfaces in systems implementing
                    this MIB module, those table entries indexed by ifIndex MUST be persistent.
                </t>

                <t>
                    The following attributes are part of the mandatory 
                    ifGeneralInformationGroup in RFC 2863 <xref target="RFC2863"/>, and 
                    are not duplicated in the HDSL2/SHDSL Line MIB.
                </t>

                <t>
                    <vspace blankLines="25" />   
                    <!-- Kludge to get next line on same page as its table dat -->
                    ===================================================================        <vspace blankLines="1" />
                    <list style="empty">
                    <t>
                        ifIndex                  Interface index.                              <vspace blankLines="1" />

                        ifDescr                  See interfaces MIB <xref target="RFC2863"/>.  <vspace blankLines="1" />

                        ifType                   hdsl2(168) or shdsl(169).

                                                 <figure><artwork>
   ifSpeed                  Set as appropriate. 
                            (This is fixed at 1552000 for HDSL2         
                            lines)                                       

   ifPhysAddress            This object MUST have an octet string
                            with zero length.
                                                 </artwork></figure> <vspace blankLines="0" />

                        ifAdminStatus            See interfaces MIB <xref target="RFC2863"/>.  <vspace blankLines="1" />

                        ifOperStatus             See interfaces MIB <xref target="RFC2863"/>.  <vspace blankLines="1" />

                        ifLastChange             See interfaces MIB <xref target="RFC2863"/>.  <vspace blankLines="1" />

                        ifName                   See interfaces MIB <xref target="RFC2863"/>.  <vspace blankLines="1" />

                        ifAlias                  See interfaces MIB <xref target="RFC2863"/>.  <vspace blankLines="1" />

                        ifLinkUpDownTrapEnable   Default to enabled(1).

                                                 <figure><artwork>
   ifHighSpeed              Set as appropriate.
                            (For HDSL2 lines, this is fixed at 2)
                                                 </artwork></figure> <vspace blankLines="0" />

                        ifConnectorPresent       Set as appropriate. 

                    </t>
                    </list>

                    <figure><artwork>
===================================================================         
                  Figure 1: Use of ifTable Objects
                    </artwork></figure>
                </t>

            </section> <!-- title="Usage of ifTable" -->

        </section>  <!--  title="Relationship of the HDSL2/SHDSL Line MIB to other MIBs"  -->

        <section title="IANA Considerations">

            <t>
                The HDSL2-SHDSL-LINE-MIB module requires the allocation of a single
                object identifier for its MODULE-IDENTITY.  The IANA has allocated
                this object identifier in the transmission subtree (48), defined in
                the SNMPv2-SMI MIB module.
            </t>
            <t>
                The assignment was in fact done when RFC 3276 was published, and 
                this revision of the RFC does not require any new action from IANA.
            </t>

        </section>  <!--  title="IANA Considerations"  -->

        <section title="Conventions used in the MIB Module">

            <section title="Naming Conventions"> 
 
               <vspace blankLines="1" />

                <list style="hanging">
                    <t hangText="A. ">   xtuC refers to a central site terminal unit;                </t>
                    <t hangText="   ">  H2TU-C for HDSL2, or STU-C for SHDSL.                        </t>
                    <t hangText="B. ">   xtuR refers to a remote site terminal unit;                 </t>
                    <t hangText="   ">  H2TU-R for HDSL2, or STU-R for SHDSL.                        </t>
                    <t hangText="C. ">   xtu refers to a terminal unit; either an xtuC or xtuR.      </t>
                    <t hangText="D. ">   xru refer to a regenerator unit;                            </t>
                    <t hangText="   ">  H2RU for HDSL2, or SRU for SHDSL.                            </t>
                    <t hangText="E. ">   xU refers to any HDSL2/SHDSL unit; either an xtu or xru.    </t>
                    <t hangText="F. ">   CRC is cyclic redundancy check <xref target="G.991.2"/>.    </t>
                    <t hangText="G. ">   ES means errored second <xref target="G.991.2"/>.           </t>
                    <t hangText="J. ">   LOSW means loss of sync word <xref target="G.991.2"/>.      </t>
                    <t hangText="I. ">   LOSWS means LOSW seconds <xref target="G.991.2"/>.          </t>
                    <t hangText="J. ">   SES means severely errored second <xref target="G.991.2"/>. </t>
                    <t hangText="K. ">   SNR means signal-to-noise ratio <xref target="G.991.2"/>.   </t>
                    <t hangText="L. ">   UAS means unavailable second <xref target="G.991.2"/>.      </t>
                </list>

            </section>  <!--  title="Naming Conventions"  -->

            <section title="Textual Conventions">

                <t>
                    The following textual conventions are defined to reflect the 
                    line topology in the MIB module (further discussed in the following 
                    section) and to define the behavior of the statistics to be 
                    maintained by an agent.
                    <vspace blankLines="1" />

                    <list style="symbols">
                        <t>
                            Hdsl2ShdslUnitId: 
                            <vspace blankLines="1" />

                            Attributes with this syntax uniquely identify each 
                            unit in a HDSL2/SHDSL span.  It mirrors the EOC 
                            addressing mechanism: 

                            <figure><artwork>
      xtuC(1)                - central office (CO) terminal unit
      xtuR(2)                - customer premises equipment (CPE) 
                               terminal unit
      xru1(3) .. xru8(10)    - regenerators, numbered from
                               central office side
                            </artwork></figure>
                        </t>
                        <t>
                            Hdsl2ShdslUnitSide:
                            <vspace blankLines="1" />

                            Attributes with this syntax reference the two sides 
                            of a unit:

                            <figure><artwork>
      networkSide(1)   - N in figure 2, below
      customerSide(2)  - C in figure 2, below
                            </artwork></figure>
                        </t>
                        <t>
                            Hdsl2ShdslWirePair:
                            <vspace blankLines="1" />

                            Attributes with this syntax reference the wire pairs 
                            connecting the units:

                            <figure><artwork>
      wirePair1(1)   - First pair for HDSL2/SHDSL.
      wirePair2(2)   - Optional second pair for SHDSL only.
      wirePair3(3)   - Optional third pair for SHDSL.bis only.
      wirePair4(4)   - Optional fourth pair for SHDSL.bis only.
                            </artwork></figure>
                        </t>
                        <t>
                            Hdsl2ShdslTransmissionModeType:
                            <vspace blankLines="1" />

                            Attributes with this syntax specify the regional 
                            setting for a SHDSL line.  Specified as a BITS 
                            construct, the two mode types are:

                            <figure><artwork>
      region1   - ITU-T G.991.2 Annex A
      region2   - ITU-T G.991.2 Annex B
                            </artwork></figure>
                        </t>
                        <t>
                            Hdsl2ShdslPerfCurrDayCount:
                            <vspace blankLines="1" />

                            Attributes with this syntax define the behavior of 
                            the 1-day (24 hour) gauges found in the MIB module.
                            <vspace blankLines="1" />
                        </t>
                        <t>
                            Hdsl2Shdsl1DayIntervalCount:
                            <vspace blankLines="1" />

                            Attributes with this syntax define the behavior of 
                            the 1-day (24 hour) interval counters found in the 
                            MIB module.
                            <vspace blankLines="1" />
                        </t>
                        <t>
                            Hdsl2ShdslPerfTimeElapsed:
                            <vspace blankLines="1" />

                            Attributes with this syntax define the behavior of the elapsed time
                            counters found in the MIB module.
                            <vspace blankLines="1" />
                        </t>
                        <t>
                            Hdsl2ShdslPerfIntervalThreshold:
                            <vspace blankLines="1" />

                            Attributes with this syntax define the behavior 
                            of the alarm thresholds found in the MIB module.
                            <vspace blankLines="1" />
                        </t>
                        <t>
                            Hdsl2ShdslClockReferenceType:
                            <vspace blankLines="1" />

                            Attributes with this syntax define the clock 
                            references for the HDSL2/SHDSL span.
                        </t>
                    </list>
                </t>

            </section>  <!--  title="Textual Conventions"  -->

        </section>   <!--  title="Conventions used in the MIB"  -->         

        <section title="Structure" >

            <t>
                The MIB module is structured into following MIB groups:
                <vspace blankLines="1" />

                <list style="symbols">
                    <t>
                        Span Configuration Group:
                        <vspace blankLines="1" />

                        This group supports MIB objects for configuring 
                        parameters for the HDSL2/SHDSL span.  It contains 
                        the following table:
                         
                        <figure><artwork>                           
      - hdsl2ShdslSpanConfTable
                            </artwork></figure>
                    </t>
                    <t>
                        Span Status Group:
                        <vspace blankLines="1" />

                        This group supports MIB objects for retrieving span 
                        status information.  It contains the following 
                        table:
                        <figure><artwork>
      - hdsl2ShdslSpanStatusTable
                        </artwork></figure>
                    </t>
                    <t>
                        Unit Inventory Group:
                        <vspace blankLines="1" />

                        This group supports MIB objects for retrieving unit 
                        inventory information about units in HDSL2/SHDSL 
                        lines via the EOC. It contains the following table:

                        <figure><artwork>
      - hdsl2ShdslInventoryTable
                        </artwork></figure>
                    </t>
                    <t>
                        Segment Endpoint Configuration Group:
                        <vspace blankLines="1" />

                        This group supports MIB objects for configuring 
                        parameters for the HDSL2/SHDSL segment endpoints.  
                        It contains the following table:

                        <figure><artwork>
      - hdsl2ShdslEndpointConfTable
                        </artwork></figure>
                    </t>
                    <t>
                        Segment Endpoint Current Status/Performance Group:
                        <vspace blankLines="1" />

                        This group supports MIB objects that provide the 
                        current status/performance information relating to 
                        segment endpoints.  It contains the following table:

                        <figure><artwork>
      - hdsl2ShdslEndpointCurrTable
                        </artwork></figure>
                    </t>
                    <t>
                        Segment Endpoint 15-Minute Interval Status/Performance 
                        Group:
                        <vspace blankLines="1" />

                        This group supports MIB objects that provide historic
                        status/performance information relating to segment 
                        endpoints in 15-minute intervals.  It contains the 
                        following table:

                        <figure><artwork>
      - hdsl2Shdsl15MinIntervalTable
                        </artwork></figure>
                    </t>
                    <t>
                        Segment Endpoint 1-Day Interval Status/Performance 
                        Group:
                        <vspace blankLines="1" />

                        This group supports MIB objects that provide historic
                        status/performance information relating to segment 
                        endpoints in 1-day intervals.  It contains the 
                        following table:

                        <figure><artwork>
      - hdsl2Shdsl1DayIntervalTable
                        </artwork></figure>
                    </t>
                    <t>
                        Maintenance Group:
                        <vspace blankLines="1" />

                        This group supports MIB objects for performing 
                        maintenance operations such as loopbacks for 
                        HDSL2/SHDSL lines.  It contains the following
                        table(s):

                        <figure><artwork>
      - hdsl2ShdslEndpointMaintTable
      - hdsl2ShdslUnitMaintTable
                        </artwork></figure>
                    </t>
                    <t>
                        Span Configuration Profile Group:
                        <vspace blankLines="1" />

                        This group supports MIB objects for defining 
                        configuration profiles for HDSL2/SHDSL Spans.  
                        It contains the following table:

                        <figure><artwork>
      - hdsl2ShdslSpanConfProfileTable
                        </artwork></figure>
                    </t>
                    <t>
                        Segment Endpoint Alarm Configuration Profile Group:
                        <vspace blankLines="1" />

                        This group supports MIB objects for defining alarm 
                        configuration profiles for HDSL2/SHDSL Segment 
                        Endpoints.  It contains the following table:

                        <figure><artwork>
      - hdsl2ShdslEndpointAlarmConfProfileTable
                        </artwork></figure>
                    </t>
                    <t>
                        Notifications Group:
                        <vspace blankLines="1" />

                        This group defines the notifications supported for 
                        HDSL2/SHDSL lines:

                        <figure><artwork>
         - hdsl2ShdslLoopAttenCrossing
         - hdsl2ShdslSNRMarginCrossing
         - hdsl2ShdslPerfESThresh
         - hdsl2ShdslPerfSESThresh
         - hdsl2ShdslPerfCRCanomaliesThresh
         - hdsl2ShdslPerfLOSWSThresh
         - hdsl2ShdslPerfUASThresh
         - hdsl2ShdslSpanInvalidNumRepeaters
         - hdsl2ShdslLoopbackFailure
         - hdsl2ShdslpowerBackoff
         - hdsl2ShdsldeviceFault
         - hdsl2ShdsldcContinuityFault
         - hdsl2ShdslconfigInitFailure
         - hdsl2ShdslprotocolInitFailure
         - hdsl2ShdslnoNeighborPresent
         - hdsl2ShdslLocalPowerLoss
                        </artwork></figure>
                    </t>
                    <t>
                        SHDSL Wire Pair Group:
                        <vspace blankLines="1" />

                        This group supports MIB objects which provide 
                        status of the SHDSL-specific wire pairs.

                        <figure><artwork>
         - hdsl2ShdslEndpointCurrTipRingReversal
         - hdsl2ShdslEndpointCurrActivationState
                        </artwork></figure>
                    </t>
                    <t>
                        Payload Group:
                        <vspace blankLines="1" />

                        This group supports MIB objects for retrieving 
                        payload rates which excludes any framing overhead.           

                        <figure><artwork>
         - hdsl2ShdslStatusMaxAttainablePayloadRate
         - hdsl2ShdslStatusActualPayloadRate
                        </artwork></figure>
                    </t>
                </list>
            </t>

        </section>   <!-- title="Structure" -- >

        <section title="Line Topology">

            <t>
                <preamble>
                    An HDSL2/SHDSL Line consists of a minimum of two 
                    units - xtuC (the central termination unit) and an 
                    xtuR (the remote termination unit).  The line may 
                    optionally support up to 8 repeater/regenerator units
                    (xru) as shown in the figure below.
                 </preamble>
                 <artwork><![CDATA[

    <-- Network Side                            Customer Side -->

    |</////////////////// HDSL2/SHDSL Span ////////////////////>|

            <~~~>       <~~~> HDSL2/SHDSL Segments  <~~~>

    +-------+   +-------+   +-------+       +-------+   +-------+
    +       C=1=N       C=1=N       C=..1..=N       C=1=N       +
    | xtuC  |   |  xru1 |   |  xru2 |       |  xru8 |   |  xtuR |
    +       C=2=N       C=2=N       C=..2..=N       C=2=N       +
    +-------+   +-------+   +-------+       +-------+   +-------+

    Key:  <////> HDSL2/SHDSL Span
          <~~~~> HDSL2/SHDSL Segment
          =1=    HDSL2/SHDSL wire-pair-1
          =2=    SHDSL optional wire-pair-2 (Not applicable to HDSL2)
          C      Customer Side Segment Endpoint (modem)
          N      Network Side Segment Endpoint (modem)
              ]]></artwork>
               <postamble>    
                   Figure 2: General topology for an HDSL2/SHDSL Line
                </postamble>
            </t>

            </section>   <!--  title="Line Topology"  -->

        <section title="Counters, Interval Buckets and Thresholds">

            <t>
                For SNR Margin, Loop Attenuation, ES, SES, CRC anomalies, LOSW, and
                UAS, there are event counters, current 15-minute and 0 to 96
                15-minute history bucket(s) of "interval-counters", as well as current
                and 0 to 30 previous 1-day interval-counter(s).  Each current
                15-minute event bucket has an associated threshold notification.
            </t>
            <t>
                Unlike RFC 3593 <xref target="RFC3593"/> and RFC 2662 
                <xref target="RFC2662"/>, there is no representation in the MIB module for 
                invalid buckets.  In those cases where the data for an interval is 
                suspect or known to be invalid, the agent MUST NOT report the interval.  
                If the current 15-minute event bucket is determined to be invalid, 
                notifications based upon the value of the event bucket MUST NOT be 
                generated.
            </t>
            <t>
                Not reporting an interval will result in holes in the associated
                table.  For example, the table, hdsl2Shdsl15MinIntervalTable, is
                indexed by { ifIndex, hdsl2ShdslInvIndex, hdsl2ShdslEndpointSide,
                hdsl2ShdslEndpointWirePair, hdsl2Shdsl15MinIntervalNumber}.  If
                interval 12 is determined to be invalid but intervals 11 and 13 are
                valid, a Get Next operation on the indices .1.1.1.1.11 would return
                indices .1.1.1.1.13.
            </t>
            <t>
                There is no requirement for an agent to ensure a fixed relationship
                between the start of a fifteen minute interval and any wall clock;
                however some implementations may align the fifteen minute intervals
                with quarter hours.  Likewise, an implementation may choose to align
                one day intervals with the start of a day.
            </t>
            <t>
                Counters are not reset when an xU is reinitialized, only when the
                agent is reset or reinitialized (or under specific request outside
                the scope of this MIB module).
            </t>

        </section>   <!--  title="Counters, Interval Buckets and Thresholds"  -->

        <section title="Profiles" >

            <t>
                As a managed node can handle a large number of xUs, (e.g., hundreds
                or perhaps thousands of lines), provisioning every parameter on every
                xU may become burdensome.  Moreover, most lines are provisioned
                identically with the same set of parameters.  To simplify the
                provisioning process, this MIB module makes use of profiles.  A 
                profile is a set of parameters that can be shared by multiple lines 
                using the same configuration.
            </t>
            <t>
                The following profiles are used in this MIB module:
                <vspace blankLines="1" />

                <list style="symbols">
                    <t>
                        Span Configuration Profiles - Span configuration profiles contain
                        parameters for configuring HDSL2/SHDSL spans.  They are defined in
                        the hdsl2ShdslSpanConfProfileTable.  Since span configuration
                        parameters are only applicable for SHDSL, the support for span
                        configuration profiles are optional for HDSL2 interfaces.
                        <vspace blankLines="1" />

                        Note that the configuration of the span dictates the behavior for
                        each individual segment endpoint in the span.  If a different
                        configuration is provisioned for any given segment endpoint
                        within the span, the new configuration for this segment endpoint
                        will override the span configuration for this segment endpoint
                        only.
                        <vspace blankLines="1" />
                    </t>
                    <t>
                        Segment Endpoint Alarm Configuration Profiles - These profiles
                        contain parameters for configuring alarm thresholds for
                        HDSL2/SHDSL segment endpoints.  These profiles are defined in the
                        hdsl2ShdslEndpointAlarmConfProfileTable.
                        <vspace blankLines="1" />

                        The index value for this profile is a locally-unique
                        administratively assigned name for the profile having the textual
                        convention &apos;SnmpAdminString&apos; (RFC 3411 
                        <xref target="RFC3411"/>).
                    </t>
                </list>
            </t>
            <t>
                One or more lines may be configured to share parameters of a single
                profile (e.g., hdsl2ShdslEndpointAlarmConfProfile = &apos;silver&apos;) 
                by setting its hdsl2ShdslEndpointAlarmConfProfile objects to the value
                of this profile.  If a change is made to the profile, all lines that
                refer to it will be reconfigured to the changed parameters.  Before a
                profile can be deleted or taken out of service it must be first
                unreferenced from all associated lines.
            </t>
            <t>
                Implementations MUST provide a default profile whose name is 
                &apos;DEFVAL&apos; for each profile type.  The values of the associated 
                parameters will be vendor specific unless otherwise indicated in this 
                document.  Before a line&apos;s profiles have been set, these profiles 
                will be automatically used by setting hdsl2ShdslEndpointAlarmConfProfile 
                and hdsl2ShdslSpanConfProfile to &apos;DEFVAL&apos; where appropriate.  
                This default profile name, &apos;DEFVAL&apos;, is considered reserved 
                in the context of profiles defined in this MIB module.
            </t>
            <t>
                Profiles are created, assigned, and deleted dynamically using the
                profile name and profile row status in each of the four profile
                tables.
            </t>
            <t>
                Profile changes MUST take effect immediately.  These changes MAY
                result in a restart (hard reset or soft restart) of the units on the
                line.
            </t>

        </section>  <!--  title="Profiles"  -->

        <section title="Notifications">

            <t>
                The ability to generate the SNMP notifications coldStart/WarmStart
                (per <xref target="RFC3418"/>) which are per agent (e.g., per Digital 
                Subscriber Line Access Multiplexer, or DSLAM, in such a device), and 
                linkUp/linkDown (per <xref target="RFC2863"/>) which are per interface 
                (i.e., HDSL2/SHDSL line) is required.
            </t>
            <t>
                A linkDown notification MAY be generated whenever any of ES, SES, CRC
                Anomaly, LOSW, or UAS event occurs.  The corresponding linkUp
                notification MAY be sent when all link failure conditions are
                cleared.
            </t>
            <t>
                The notifications defined in this MIB module are for initialization failure
                and for the threshold crossings associated with the following events:
                ES, SES, CRC Anomaly, LOSW, and UAS.  Each threshold has its own
                enable/threshold value.  When that value is 0, the notification is
                disabled.
            </t>
            <t>
                The hdsl2ShdslEndpointCurrStatus is a bitmask representing all
                outstanding error conditions associated with a particular Segment
                Endpoint.  Note that since status of remote endpoints is obtained via
                the EOC, this information may be unavailable for units that are
                unreachable via EOC during a line error condition.  Therefore, not
                all conditions may always be included in its current status.
                Notifications corresponding to the bit fields in this object are
                defined.
            </t>
            <t>
                Two alarm conditions, SNR Margin Alarm and Loop Attenuation Alarm,
                are organized in a manner slightly different from that implied in the
                EOC specifications.  In the MIB module, these alarm conditions are tied to
                the two thresholds hdsl2ShdslEndpointThreshSNRMargin and
                hdsl2ShdslEndpointThreshLoopAttenuation found in the
                hdsl2ShdslEndpointAlarmConfProfileTable.  In the EOC, the alarm
                conditions associated with these thresholds are per-unit.  In the
                MIB module, these alarm conditions are per-endpoint.  For terminal units,
                this has no impact.  For repeaters, this implies an implementation
                variance where the agent in the terminal unit is responsible for
                detecting a threshold crossing.  As the reporting of a repeater
                detected alarm condition to the polling terminal unit occurs in the
                same EOC message as the reporting of the current SNR Margin and Loop
                Attenuation values, it is anticipated that this will have very little
                impact on agent implementation.
            </t>
            <t>
                A threshold notification occurs whenever the corresponding current
                15-minute interval error counter becomes equal to, or exceeds the
                threshold value.  Only one notification SHOULD be sent per interval per
                interface.  Since the current 15-minute counter is reset to 0 every
                15 minutes, and if the condition persists, the notification may recur
                as often as every 15 minutes.  For example, to get a notification
                whenever a &quot;loss of&quot; event occurs (but at most once every 15
                minutes), set the corresponding threshold to 1.  The agent will
                generate a notification when the event originally occurs.
            </t>
            <t>
                Notifications, other than the threshold notifications listed above, SHOULD
                be rate limited (throttled) such that there is at least a one-minute gap 
                between the generation of consecutive notification of the same event.  When
                notifications are rate limited, they are dropped and not queued for sending
                at a future time.  This is intended to be a general rate-limiting statement
                for notifications that have no explicit rate limiting assertions in this
                document otherwise.
            </t>
            <t>
                Note that the Network Management System, or NMS, may receive a
                linkDown notification, as well, if enabled (via
                ifLinkUpDownTrapEnable <xref target="RFC2863"/>).  At the beginning of 
                the next 15 minute interval, the counter is reset.  When the first second 
                goes by and the event occurs, the current interval bucket will be 1, 
                which equals the threshold, and the notification will be sent again.
            </t>
            <t>
                A hdsl2ShdslSpanInvalidNumRepeaters notification may be generated
                following completion of the discovery phase if the number of
                repeaters discovered on the line differs from the number of repeaters
                specified in hdsl2ShdslSpanConfNumRepeaters.  For those conditions
                where the number of provisioned repeaters is greater than those
                encountered during span discovery, all table entries associated with
                the nonexistent repeaters are to be discarded.  For those conditions
                where the number of provisioned repeaters is less than those
                encountered during span discovery, additional table entries are to be
                created using the default span configuration profile.
            </t>

        </section>   <!-- title="Notifications"  -->

    </section>  <!--  title="Overview"  -->

    <section title="Definitions">
   
    <figure><artwork>
HDSL2-SHDSL-LINE-MIB DEFINITIONS ::= BEGIN

IMPORTS
   MODULE-IDENTITY,
   OBJECT-TYPE,
   Counter32,
   Unsigned32,
   Gauge32,
   NOTIFICATION-TYPE,
   Integer32,
   transmission
      FROM SNMPv2-SMI
   RowStatus,
   TEXTUAL-CONVENTION
      FROM SNMPv2-TC
   ifIndex
      FROM IF-MIB
   PerfCurrentCount,
   PerfIntervalCount
      FROM PerfHist-TC-MIB
   SnmpAdminString
      FROM SNMP-FRAMEWORK-MIB
   MODULE-COMPLIANCE,
   OBJECT-GROUP,
   NOTIFICATION-GROUP
      FROM SNMPv2-CONF;

hdsl2ShdslMIB MODULE-IDENTITY
   LAST-UPDATED &quot;200505260000Z&quot; -- May 26, 2005
   ORGANIZATION &quot;ADSLMIB Working Group&quot;
   CONTACT-INFO &quot;WG-email:  [email-masked]
      WG-URL:     
         http://www.ietf.org/html.charters/adslmib-charter.html
      Info:       https://www1.ietf.org/mailman/listinfo/adslmib
      Chair:      Mike Sneed
      Postal:     P.O. Box 37324
                  Raleigh NC 27627-7324 USA
      Email:      [email-masked]

      Co-Chair    Bob Ray
                  PESA Switching Systems, Inc.
      Postal      330-A Wynn Drive
                  Huntsville, AL 35805 USA
      Phone       +1 256 726 9200 ext. 142

      Co-editor:  Clay Sikes
                  Paradyne Networks, Inc.
      Postal:     8545 126th Ave. N.
                  Largo, FL 33772 USA
      Email:      [email-masked]
      Phone:      +1 727 530 8257

      Co-editor:  Bob Ray
                  PESA Switching Systems, Inc.
      Postal:     330-A Wynn Drive
                  Huntsville, AL 35805 USA
      Email:      [email-masked]
      Phone:      +1 256 726 9200 ext. 142

      Co-editor:  Rajesh Abbi
                  Alcatel USA
      Postal:     2912 Wake Forest Road
                  Raleigh, NC 27609-7860 USA

      Email:      [email-masked]
      Phone:      +1 919 850 6194&quot;

DESCRIPTION
     &quot;This MIB module defines a collection of objects for managing
      HDSL2/SHDSL lines.  An agent may reside at either end of the
      line, however the MIB module is designed to require no 
      management communication between the modems beyond that 
      inherent in the low-level EOC line protocol as defined in 
      ANSI T1E1.4/2000-006 (for HDSL2 lines), or in ITU G.991.2 
      (for SHDSL lines).

      Copyright (C) The Internet Society (2005).  This version of
      this MIB module is part of RFC xxxx; see the RFC itself for
      full legal notices.&quot;

REVISION    &quot;200505260000Z&quot; -- May 26, 2005
DESCRIPTION &quot;This version, published as RFC xxxx.
      The following changes have been made in this version:
        1.  Added a 3rd and 4th wire pair.
        2.  Modified all rates such that their rates are only
            constrained by an unsigned 32-bit value and not by
            what today's perceived technology limitations are.
        3.  Clarified that the rates from RFC 3276 include
            payload and any applicable framing and added
            objects for payload-only rates.
        4.  Added an object to indicate whether or not the
            tip and ring are reversed on a wire pair.
        5.  Added an object to display the activation state
            of a wire pair.
        6.  Added references as necessary for clarification.
        7.  Added display hints to textual conventions as
            necessary.
        8.  Updated conformance statements as necessary.
        9.  Some changes were due to IETF requirements and
            RFC generation tools.&quot;

REVISION    &quot;200205090000Z&quot; -- May 9, 2002
DESCRIPTION &quot;Initial version, published as RFC 3276.&quot;

::= { transmission 48 }

hdsl2ShdslMibObjects OBJECT IDENTIFIER ::= { hdsl2ShdslMIB 1 }

-- Textual Conventions used in this MIB module
--

Hdsl2ShdslPerfCurrDayCount ::= TEXTUAL-CONVENTION
   DISPLAY-HINT "d"
   STATUS    current
   DESCRIPTION
     &quot;A gauge associated with interface performance measurements in
      a current 1-day (24 hour) measurement interval.

      The value of this gauge starts at zero at the beginning of an
      interval and is increased when associated events occur, until
      the end of the 1-day interval.  At that time the value of the
      gauge is stored in the previous 1-day history interval, as
      defined in a companion object of type
      Hdsl2Shdsl1DayIntevalCount, and the current interval gauge
      is restarted at zero.

      In the case where the agent has no valid data available for
      this interval the corresponding object instance is not
      available and upon a retrieval request a corresponding error
      message shall be returned to indicate that this instance does
      not exist.  Please note that zero is a valid value.&quot;
   SYNTAX  Gauge32

Hdsl2Shdsl1DayIntervalCount ::= TEXTUAL-CONVENTION
   DISPLAY-HINT "d"
   STATUS    current
   DESCRIPTION
     &quot;A counter associated with interface performance measurements
      during the most previous 1-day (24 hour) measurement interval.
      The value of this gauge is equal to the value of the current
      day gauge, as defined in a companion object of type
      Hdsl2ShdslPerfCurrDayCount, at the end of its most recent
      interval.

      In the case where the agent has no valid data available for
      this interval the corresponding object instance is not
      available and upon a retrieval request a corresponding error
      message shall be returned to indicate that this instance does
      not exist.&quot;
   SYNTAX  Gauge32

Hdsl2ShdslPerfTimeElapsed ::= TEXTUAL-CONVENTION
   DISPLAY-HINT "d"
   STATUS    current
   DESCRIPTION
     &quot;The number of seconds that have elapsed since the beginning of
      the current measurement period.  If, for some reason, such as
      an adjustment in the system&apos;s time-of-day clock or the addition
      of a leap second, the current interval exceeds the maximum
      value, the agent will return the maximum value.

      For 15 minute intervals, the range is limited to (0..899).
      For 24 hour intervals, the range is limited to (0..86399).&quot;
   SYNTAX    Unsigned32(0..86399)

Hdsl2ShdslPerfIntervalThreshold ::= TEXTUAL-CONVENTION
   DISPLAY-HINT "d"
   STATUS    current
   DESCRIPTION
     &quot;This convention defines a range of values that may be set in
      a fault threshold alarm control.  As the number of seconds in
      a 15-minute interval numbers at most 900, objects of this type
      may have a range of 0...900, where the value of 0 disables the
      alarm.&quot;
   SYNTAX    Unsigned32(0..900)

Hdsl2ShdslUnitId ::= TEXTUAL-CONVENTION
   STATUS    current
   DESCRIPTION
     &quot;This is the unique identification for all units in a
      HDSL2/SHDSL Span.  It is based on the EOC unit addressing
      scheme with reference to the xtuC.&quot;
   SYNTAX    INTEGER
           {
           xtuC(1),
           xtuR(2),
           xru1(3),
           xru2(4),
           xru3(5),
           xru4(6),
           xru5(7),
           xru6(8),
           xru7(9),
           xru8(10)
           }

Hdsl2ShdslUnitSide ::= TEXTUAL-CONVENTION
   STATUS    current
   DESCRIPTION
     &quot;This is the referenced side of a HDSL2/SHDSL unit - Network
      or Customer side.  The side facing the Network is the Network
      side, while the side facing the Customer is the Customer side.&quot;
   SYNTAX    INTEGER
           {
           networkSide(1),
           customerSide(2)
           }

Hdsl2ShdslWirePair ::= TEXTUAL-CONVENTION
   STATUS    current
   DESCRIPTION
     &quot;This is the referenced pair of wires in a HDSL2/SHDSL Segment.
      HDSL2 only supports a single pair (wirePair1 or two wire), 
      SHDSL lines support an optional second pair (wirePair2 or four 
      wire), and G.shdsl.bis support an optional third pair 
      (wirePair3 or six wire) and an optional fourth pair
      (wirePair4 or eight wire).&quot;
   SYNTAX    INTEGER
           {
           wirePair1(1),    -- two wire
           wirePair2(2),    -- four wire
           wirePair3(3),    -- six wire
           wirePair4(4)     -- eight wire
           }

Hdsl2ShdslTransmissionModeType ::= TEXTUAL-CONVENTION
   STATUS    current
   DESCRIPTION
     &quot;Contains the regional setting of the HDSL2/SHDSL span,
      represented as a bit-map of possible settings. The various
      bit positions are:

      Bit   Meaning      Description
      1     region 1     Indicates ITU-T G.991.2 Annex A.
      2     region 2     Indicates ITU-T G.991.2 Annex B.&quot;
   SYNTAX      BITS
           {
           region1(0),
           region2(1)
           }

Hdsl2ShdslClockReferenceType ::= TEXTUAL-CONVENTION
   STATUS    current
   DESCRIPTION
     &quot;The various STU-C symbol clock references for the
      HDSL2/SHDSL span, represented as an enumeration.&quot;
   SYNTAX    INTEGER
          {
          localClk(1),          -- Mode-1 per G991.2
          networkClk(2),        -- Mode-2 per G991.2
          dataOrNetworkClk(3),  -- Mode-3a per G991.2
          dataClk(4)            -- Mode-3b per G991.2
          }

-- Span Configuration Group
--

hdsl2ShdslSpanConfTable OBJECT-TYPE
   SYNTAX     SEQUENCE OF Hdsl2ShdslSpanConfEntry
   MAX-ACCESS not-accessible
   STATUS     current
   DESCRIPTION
     &quot;This table supports overall configuration of HDSL2/SHDSL
      Spans.  Entries in this table MUST be maintained in a
      persistent manner.&quot;
   ::= { hdsl2ShdslMibObjects 1 }

hdsl2ShdslSpanConfEntry OBJECT-TYPE
   SYNTAX      Hdsl2ShdslSpanConfEntry
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;An entry in the hdsl2ShdslSpanConfTable.  Each entry
      represents the complete Span in a single HDSL2/SHDSL line.
      It is indexed by the ifIndex of the associated HDSL2/SHDSL
      line.&quot;
   INDEX { ifIndex }
   ::= { hdsl2ShdslSpanConfTable 1 }

Hdsl2ShdslSpanConfEntry ::=
   SEQUENCE
   {
   hdsl2ShdslSpanConfNumRepeaters          Unsigned32,
   hdsl2ShdslSpanConfProfile               SnmpAdminString,
   hdsl2ShdslSpanConfAlarmProfile          SnmpAdminString
   }

   hdsl2ShdslSpanConfNumRepeaters OBJECT-TYPE
   SYNTAX      Unsigned32(0..8)
   UNITS       &quot;repeaters&quot;
   MAX-ACCESS  read-write
   STATUS      current
   DESCRIPTION
     &quot;This object provisions the number of repeaters/regenerators
      in this HDSL2/SHDSL Span.&quot;
   ::= { hdsl2ShdslSpanConfEntry 1 }

hdsl2ShdslSpanConfProfile OBJECT-TYPE
   SYNTAX      SnmpAdminString (SIZE(1..32))
   MAX-ACCESS  read-write
   STATUS      current
   DESCRIPTION
     &quot;This object is a pointer to a span configuration profile in
      the hdsl2ShdslSpanConfProfileTable, which applies to this 
      span.  The value of this object is the index of the referenced 
      profile in the hdsl2ShdslSpanConfProfileTable.  Note that span
      configuration profiles are only applicable to SHDSL lines.

      HDSL2 lines MUST reference the default profile, &apos;DEFVAL&apos;.
      By default, this object will have the value &apos;DEFVAL&apos; 
      (the index of the default profile).

      Any attempt to set this object to a value that is not the value
      of the index for an active entry in the profile table,
      hdsl2ShdslSpanConfProfileTable, MUST be rejected.&quot;
   ::= { hdsl2ShdslSpanConfEntry 2 }

hdsl2ShdslSpanConfAlarmProfile OBJECT-TYPE
   SYNTAX      SnmpAdminString (SIZE(1..32))
   MAX-ACCESS  read-write
   STATUS      current
   DESCRIPTION
     &quot;This object is a pointer to an Alarm configuration profile in
      the hdsl2ShdslEndpointAlarmConfProfileTable.  The value of 
      this object is the index of the referenced profile in the
      hdsl2ShdslEndpointAlarmConfProfileTable.  The alarm 
      threshold configuration in the referenced profile will be 
      used by default for all segment endpoints in this span.  
      Individual endpoints may override this profile by explicitly 
      specifying some other profile in the 
      hdsl2ShdslEndpointConfTable.  By default, this object will 
      have the value &apos;DEFVAL&apos; (the index of the default 
      profile).

      Any attempt to set this object to a value that is not the value
      of the index for an active entry in the profile table,
      hdsl2ShdslEndpointAlarmConfProfileTable, MUST be rejected.&quot;
   ::= { hdsl2ShdslSpanConfEntry 3 }

-- Span Status Group
--

hdsl2ShdslSpanStatusTable OBJECT-TYPE
   SYNTAX     SEQUENCE OF Hdsl2ShdslSpanStatusEntry
   MAX-ACCESS not-accessible
   STATUS     current
   DESCRIPTION
     &quot;This table provides overall status information of
      HDSL2/SHDSL spans.  This table contains live data from
      equipment.  As such, it is NOT persistent.&quot;
   ::= { hdsl2ShdslMibObjects 2 }

hdsl2ShdslSpanStatusEntry OBJECT-TYPE
   SYNTAX      Hdsl2ShdslSpanStatusEntry
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;An entry in the hdsl2ShdslSpanStatusTable.  Each entry
      represents the complete span in a single HDSL2/SHDSL line.
      It is indexed by the ifIndex of the associated HDSL2/SHDSL
      line.&quot;
   INDEX { ifIndex }
   ::= { hdsl2ShdslSpanStatusTable 1 }

Hdsl2ShdslSpanStatusEntry ::=
   SEQUENCE
   {
   hdsl2ShdslStatusNumAvailRepeaters        Unsigned32,
   hdsl2ShdslStatusMaxAttainableLineRate    Unsigned32,
   hdsl2ShdslStatusActualLineRate           Unsigned32,
   hdsl2ShdslStatusTransmissionModeCurrent
                        Hdsl2ShdslTransmissionModeType,
   hdsl2ShdslStatusMaxAttainablePayloadRate Unsigned32,
   hdsl2ShdslStatusActualPayloadRate        Unsigned32
   }

hdsl2ShdslStatusNumAvailRepeaters OBJECT-TYPE
   SYNTAX      Unsigned32(0..8)
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Contains the actual number of repeaters/regenerators
      discovered in this HDSL2/SHDSL span.&quot;
   ::= { hdsl2ShdslSpanStatusEntry 1 }

hdsl2ShdslStatusMaxAttainableLineRate OBJECT-TYPE
   SYNTAX      Unsigned32(0..4294967295)
   UNITS       &quot;bps&quot;
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Contains the maximum attainable line rate in this HDSL2/SHDSL
      span.  This object provides the maximum rate the line is
      capable of achieving.  This is based upon measurements made
      during line probing.  This rate includes payload (user data)
      and any applicable framing overhead.&quot;
   ::= { hdsl2ShdslSpanStatusEntry 2 }

hdsl2ShdslStatusActualLineRate OBJECT-TYPE
   SYNTAX      Unsigned32(0..4294967295)
   UNITS       &quot;bps&quot;
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Contains the actual line rate in this HDSL2/SHDSL span.  This
      SHOULD equal ifSpeed.  This rate includes payload (user data)
      and any applicable framing overhead&quot;
   ::= { hdsl2ShdslSpanStatusEntry 3 }

hdsl2ShdslStatusTransmissionModeCurrent OBJECT-TYPE
   SYNTAX      Hdsl2ShdslTransmissionModeType
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Contains the current Power Spectral Density (PSD) regional
      setting of the HDSL2/SHDSL span.&quot;
   ::= { hdsl2ShdslSpanStatusEntry 4 }

hdsl2ShdslStatusMaxAttainablePayloadRate OBJECT-TYPE
   SYNTAX      Unsigned32(0..4294967295)
   UNITS       &quot;bps&quot;
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Contains the maximum attainable payload (user data) 
      line rate in this HDSL2/SHDSL span.  This object provides 
      the maximum rate the line is capable of achieving.  This 
      is based upon measurements made during line probing.  Any
      framing overhead is not included.&quot;
   ::= { hdsl2ShdslSpanStatusEntry 5 }

hdsl2ShdslStatusActualPayloadRate OBJECT-TYPE
   SYNTAX      Unsigned32(0..4294967295)
   UNITS       &quot;bps&quot;
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Contains the actual line rate in this HDSL2/SHDSL span.  Any
      framing overhead is not included.&quot;
   ::= { hdsl2ShdslSpanStatusEntry 6 }

-- Unit Inventory Group
--

hdsl2ShdslInventoryTable OBJECT-TYPE
   SYNTAX     SEQUENCE OF Hdsl2ShdslInventoryEntry
   MAX-ACCESS not-accessible
   STATUS     current
   DESCRIPTION
     &quot;This table supports retrieval of unit inventory information
      available via the EOC from units in a HDSL2/SHDSL line.

      Entries in this table are dynamically created during the
      line discovery process.  The life cycle for these entries
      is as follows:

         - xtu discovers a device, either a far-end xtu or an xru
         - an inventory table entry is created for the device
         - the line goes down for whatever reason
         - inventory table entries for unreachable devices are
           destroyed.

      As these entries are created/destroyed dynamically, they
      are NOT persistent.&quot;
   ::= { hdsl2ShdslMibObjects 3 }

hdsl2ShdslInventoryEntry OBJECT-TYPE
   SYNTAX      Hdsl2ShdslInventoryEntry
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;An entry in the hdsl2ShdslInventoryTable.  Each entry
      represents inventory information for a single unit in a
      HDSL2/SHDSL line.  It is indexed by the ifIndex of the
      HDSL2/SHDSL line and the Hdsl2ShdslUnitId of the
      associated unit.&quot;
   INDEX { ifIndex, hdsl2ShdslInvIndex }
   ::= { hdsl2ShdslInventoryTable 1 }

Hdsl2ShdslInventoryEntry ::=
   SEQUENCE
   {
   hdsl2ShdslInvIndex                      Hdsl2ShdslUnitId,
   hdsl2ShdslInvVendorID                   OCTET STRING,
   hdsl2ShdslInvVendorModelNumber          OCTET STRING,
   hdsl2ShdslInvVendorSerialNumber         OCTET STRING,
   hdsl2ShdslInvVendorEOCSoftwareVersion   Integer32,
   hdsl2ShdslInvStandardVersion            Integer32,
   hdsl2ShdslInvVendorListNumber           OCTET STRING,
   hdsl2ShdslInvVendorIssueNumber          OCTET STRING,
   hdsl2ShdslInvVendorSoftwareVersion      OCTET STRING,
   hdsl2ShdslInvEquipmentCode              OCTET STRING,
   hdsl2ShdslInvVendorOther                OCTET STRING,
   hdsl2ShdslInvTransmissionModeCapability
                         Hdsl2ShdslTransmissionModeType
   }

hdsl2ShdslInvIndex OBJECT-TYPE
   SYNTAX      Hdsl2ShdslUnitId
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;Each entry in this table corresponds to a physical element
      in a HDSL2/SHDSL Span.  It is based on the EOC unit addressing
      scheme with reference to the xtuC.&quot;
   ::= { hdsl2ShdslInventoryEntry 1 }

hdsl2ShdslInvVendorID OBJECT-TYPE
   SYNTAX      OCTET STRING(SIZE(8))
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Vendor ID as reported in an Inventory Response message.&quot;
   REFERENCE   
     &quot;G.991.2, Section 9.5.5.7.4, Inventory response - Message ID 
      130, Octets 25-32.&quot;
   ::= { hdsl2ShdslInventoryEntry 2 }

hdsl2ShdslInvVendorModelNumber OBJECT-TYPE
   SYNTAX      OCTET STRING(SIZE(12))
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Vendor model number as reported in an Inventory Response
      message.&quot;
   REFERENCE   
     &quot;G.991.2, Section 9.5.5.7.4, Inventory response - Message ID 
      130, Octets 33-44.&quot;
   ::= { hdsl2ShdslInventoryEntry 3 }

hdsl2ShdslInvVendorSerialNumber OBJECT-TYPE
   SYNTAX      OCTET STRING(SIZE(12))
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Vendor serial number as reported in an Inventory Response
      message.&quot;
   REFERENCE   
     &quot;G.991.2, Section 9.5.5.7.4, Inventory response - Message ID 
      130, Octets 45-56.&quot;
   ::= { hdsl2ShdslInventoryEntry 4 }

hdsl2ShdslInvVendorEOCSoftwareVersion OBJECT-TYPE
   SYNTAX      Integer32
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Vendor EOC version as reported in a Discovery Response
      message.&quot;
   REFERENCE   
     &quot;G.991.2, Section 9.5.5.7.2, Discovery response - Message ID 
      130, Octet 12.&quot;
   ::= { hdsl2ShdslInventoryEntry 5 }

hdsl2ShdslInvStandardVersion OBJECT-TYPE
   SYNTAX      Integer32
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Version of the HDSL2/SHDSL standard implemented, as reported
      in an Inventory Response message.&quot;
   REFERENCE   
     &quot;G.991.2, Section 9.5.5.7.4, Inventory response - Message ID 
      130, Octet 2.&quot;
   ::= { hdsl2ShdslInventoryEntry 6 }

hdsl2ShdslInvVendorListNumber OBJECT-TYPE
   SYNTAX      OCTET STRING(SIZE(3))
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Vendor list number as reported in an Inventory Response
      message.&quot;
   REFERENCE   
     &quot;G.991.2, Section 9.5.5.7.4, Inventory response - Message ID 
      130, Octets 3-5.&quot;
   ::= { hdsl2ShdslInventoryEntry 7 }

hdsl2ShdslInvVendorIssueNumber OBJECT-TYPE
   SYNTAX      OCTET STRING(SIZE(2))
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Vendor issue number as reported in an Inventory Response
      message.&quot;
   REFERENCE   
     &quot;G.991.2, Section 9.5.5.7.4, Inventory response - Message ID 
      130, Octets 6-7.&quot;
   ::= { hdsl2ShdslInventoryEntry 8 }

hdsl2ShdslInvVendorSoftwareVersion OBJECT-TYPE
   SYNTAX      OCTET STRING(SIZE(6))
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Vendor software version as reported in an Inventory Response
      message.&quot;
   REFERENCE   
     &quot;G.991.2, Section 9.5.5.7.4, Inventory response - Message ID 
      130, Octets 8-13.&quot;
   ::= { hdsl2ShdslInventoryEntry 9 }

hdsl2ShdslInvEquipmentCode OBJECT-TYPE
   SYNTAX      OCTET STRING(SIZE(10))
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Equipment code conforming to ANSI T1.213, Coded Identification
      of Equipment Entities.&quot;
   REFERENCE   
     &quot;G.991.2, Section 9.5.5.7.4, Inventory response - Message ID 
      130, Octets 14-23.&quot;
   ::= { hdsl2ShdslInventoryEntry 10 }

hdsl2ShdslInvVendorOther OBJECT-TYPE
   SYNTAX      OCTET STRING(SIZE(12))
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Other vendor information as reported in an Inventory Response
      message.&quot;
   REFERENCE   
     &quot;G.991.2, Section 9.5.5.7.4, Inventory response - Message ID 
      130, Octets 57-68.&quot;
   ::= { hdsl2ShdslInventoryEntry 11 }

hdsl2ShdslInvTransmissionModeCapability OBJECT-TYPE
   SYNTAX      Hdsl2ShdslTransmissionModeType
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Contains the transmission mode capability of the SHDSL unit.&quot;
   ::= { hdsl2ShdslInventoryEntry 12 }

-- Segment Endpoint Configuration Group
--

hdsl2ShdslEndpointConfTable OBJECT-TYPE
   SYNTAX      SEQUENCE OF Hdsl2ShdslEndpointConfEntry
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;This table supports configuration parameters for segment
      endpoints in a HDSL2/SHDSL line.  As this table is indexed
      by ifIndex, it MUST be maintained in a persistent manner.&quot;
   ::= { hdsl2ShdslMibObjects 4 }

hdsl2ShdslEndpointConfEntry OBJECT-TYPE
   SYNTAX      Hdsl2ShdslEndpointConfEntry
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;An entry in the hdsl2ShdslEndpointConfTable.  Each entry
      represents a single segment endpoint in a HDSL2/SHDSL line.
      It is indexed by the ifIndex of the HDSL2/SHDSL line, the
      UnitId of the associated unit, the side of the unit, and the
      wire pair of the associated modem.&quot;
   INDEX { ifIndex, hdsl2ShdslInvIndex, hdsl2ShdslEndpointSide,
           hdsl2ShdslEndpointWirePair}
   ::= { hdsl2ShdslEndpointConfTable 1 }

Hdsl2ShdslEndpointConfEntry ::=
   SEQUENCE
   {
   hdsl2ShdslEndpointSide                   Hdsl2ShdslUnitSide,
   hdsl2ShdslEndpointWirePair               Hdsl2ShdslWirePair,
   hdsl2ShdslEndpointAlarmConfProfile       SnmpAdminString
   }

hdsl2ShdslEndpointSide OBJECT-TYPE
   SYNTAX      Hdsl2ShdslUnitSide
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;The side of the unit associated with this segment endpoint -
      Network/Customer side - as per the Hdsl2ShdslUnitSide textual
      convention.&quot;
   ::= { hdsl2ShdslEndpointConfEntry 1 }

hdsl2ShdslEndpointWirePair OBJECT-TYPE
   SYNTAX      Hdsl2ShdslWirePair
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;The wire pair of the modem associated with this segment
      endpoint as per the Hdsl2ShdslWirePair textual convention.&quot;
   ::= { hdsl2ShdslEndpointConfEntry 2 }

hdsl2ShdslEndpointAlarmConfProfile OBJECT-TYPE
   SYNTAX      SnmpAdminString (SIZE(0..32))
   MAX-ACCESS  read-write
   STATUS      current
   DESCRIPTION
     &quot;This object configures the alarm threshold values to be used
      for this segment endpoint.  The values are obtained from the
      alarm configuration profile referenced by this object.  The
      value of this object is the index of the referenced profile in
      the hdsl2ShdslEndpointAlarmConfProfileTable, or NULL (a 
      zero-length SnmpAdminString).  If the value is a zero-length
      SnmpAdminString, the endpoint uses the default Alarm
      Configuration Profile for the associated span as per the
      hdsl2ShdslSpanConfAlarmProfile object in the
      hdsl2ShdslSpanConfTable.  The default value of this object is
      a zero-length SnmpAdminString.

      Any attempt to set this object to a value that is not the value
      of the index for an active entry in the profile table,
      hdsl2ShdslEndpointAlarmConfProfileTable, MUST be rejected.&quot;
   ::= { hdsl2ShdslEndpointConfEntry 3 }

-- Segment Endpoint Current Status/Performance Group
--

hdsl2ShdslEndpointCurrTable OBJECT-TYPE
   SYNTAX      SEQUENCE OF Hdsl2ShdslEndpointCurrEntry
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;This table contains current status and performance information
      for segment endpoints in HDSL2/SHDSL Lines.  As with other
      tables in this MIB module indexed by ifIndex, entries in this 
      table MUST be maintained in a persistent manner.&quot;
   ::= { hdsl2ShdslMibObjects 5 }

hdsl2ShdslEndpointCurrEntry OBJECT-TYPE
   SYNTAX      Hdsl2ShdslEndpointCurrEntry
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;An entry in the hdsl2ShdslEndpointCurrTable.  Each entry
      contains status and performance information relating to a
      single segment endpoint.  It is indexed by the ifIndex of the
      HDSL2/SHDSL line, the UnitId of the associated unit, the side
      of the unit, and the wire pair of the associated modem.&quot;
   INDEX { ifIndex, hdsl2ShdslInvIndex, hdsl2ShdslEndpointSide,
           hdsl2ShdslEndpointWirePair }
   ::= { hdsl2ShdslEndpointCurrTable 1 }

Hdsl2ShdslEndpointCurrEntry ::=
   SEQUENCE
   {
   hdsl2ShdslEndpointCurrAtn                Integer32,
   hdsl2ShdslEndpointCurrSnrMgn             Integer32,
   hdsl2ShdslEndpointCurrStatus             BITS,
   hdsl2ShdslEndpointES                     Counter32,
   hdsl2ShdslEndpointSES                    Counter32,
   hdsl2ShdslEndpointCRCanomalies           Counter32,
   hdsl2ShdslEndpointLOSWS                  Counter32,
   hdsl2ShdslEndpointUAS                    Counter32,
   hdsl2ShdslEndpointCurr15MinTimeElapsed
                            Hdsl2ShdslPerfTimeElapsed,
   hdsl2ShdslEndpointCurr15MinES            PerfCurrentCount,
   hdsl2ShdslEndpointCurr15MinSES           PerfCurrentCount,
   hdsl2ShdslEndpointCurr15MinCRCanomalies  PerfCurrentCount,
   hdsl2ShdslEndpointCurr15MinLOSWS         PerfCurrentCount,
   hdsl2ShdslEndpointCurr15MinUAS           PerfCurrentCount,
   hdsl2ShdslEndpointCurr1DayTimeElapsed
                                   Hdsl2ShdslPerfTimeElapsed,
   hdsl2ShdslEndpointCurr1DayES
                                  Hdsl2ShdslPerfCurrDayCount,
   hdsl2ShdslEndpointCurr1DaySES
                                  Hdsl2ShdslPerfCurrDayCount,
   hdsl2ShdslEndpointCurr1DayCRCanomalies
                                  Hdsl2ShdslPerfCurrDayCount,
   hdsl2ShdslEndpointCurr1DayLOSWS
                                  Hdsl2ShdslPerfCurrDayCount,
   hdsl2ShdslEndpointCurr1DayUAS
                                  Hdsl2ShdslPerfCurrDayCount,
   hdsl2ShdslEndpointCurrTipRingReversal    INTEGER,
   hdsl2ShdslEndpointCurrActivationState    INTEGER
   }

hdsl2ShdslEndpointCurrAtn OBJECT-TYPE
   SYNTAX      Integer32(-127..128)
   UNITS       &quot;dB&quot;
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;The current loop attenuation for this endpoint as reported in
      a Network or Customer Side Performance Status message.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 1 }

hdsl2ShdslEndpointCurrSnrMgn OBJECT-TYPE
   SYNTAX      Integer32(-127..128)
   UNITS       &quot;dB&quot;
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;The current SNR margin for this endpoint as reported in a
      Status Response/SNR message.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 2 }

hdsl2ShdslEndpointCurrStatus OBJECT-TYPE
   SYNTAX      BITS
               {
               noDefect(0),
               powerBackoff(1),
               deviceFault(2),
               dcContinuityFault(3),
               snrMarginAlarm(4),
               loopAttenuationAlarm(5),
               loswFailureAlarm(6),
               configInitFailure(7),
               protocolInitFailure(8),
               noNeighborPresent(9),
               loopbackActive(10)
               }
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Contains the current state of the endpoint.  This is a
      bit-map of possible conditions.  The various bit positions
      are:

      noDefect               There are no defects on the line.

      powerBackoff           Indicates enhanced Power Backoff.

      deviceFault            Indicates a vendor-dependent
                             diagnostic or self-test fault
                             has been detected.

      dcContinuityFault      Indicates vendor-dependent
                             conditions that interfere with
                             span powering such as short and
                             open circuits.

      snrMarginAlarm         Indicates that the SNR margin
                             has dropped below the alarm threshold.

      loopAttenuationAlarm   Indicates that the loop attenuation
                             exceeds the alarm threshold.

      loswFailureAlarm       Indicates a forward LOSW alarm.

      configInitFailure      Endpoint failure during initialization
                             due to paired endpoint not able to
                             support requested configuration.

      protocolInitFailure    Endpoint failure during initialization
                             due to incompatible protocol used by
                             the paired endpoint.

      noNeighborPresent      Endpoint failure during initialization
                             due to no activation sequence detected
                             from paired endpoint.

      loopbackActive         A loopback is currently active at this
                             Segment Endpoint.

      This is intended to supplement ifOperStatus.  Note that there
      is a 1:1 relationship between the status bits defined in this
      object and the notification thresholds defined elsewhere in
      this MIB module.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 3 }

hdsl2ShdslEndpointES OBJECT-TYPE
   SYNTAX      Counter32
   UNITS       &quot;seconds&quot;
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Count of Errored Seconds (ES) on this endpoint since the xU
      was last restarted.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 4 }

hdsl2ShdslEndpointSES OBJECT-TYPE
   SYNTAX       Counter32
   UNITS        &quot;seconds&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Count of Severely Errored Seconds (SES) on this endpoint
      since the xU was last restarted.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 5 }

hdsl2ShdslEndpointCRCanomalies OBJECT-TYPE
   SYNTAX       Counter32
   UNITS        &quot;detected CRC Anomalies&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Count of CRC anomalies on this endpoint since the xU was
      last restarted.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 6 }

hdsl2ShdslEndpointLOSWS OBJECT-TYPE
   SYNTAX       Counter32
   UNITS        &quot;seconds&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Count of Loss of Sync Word (LOSW) Seconds on this endpoint
      since the xU was last restarted.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 7 }

hdsl2ShdslEndpointUAS OBJECT-TYPE
   SYNTAX       Counter32
   UNITS        &quot;seconds&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Count of Unavailable Seconds (UAS) on this endpoint since
      the xU was last restarted.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 8 }

hdsl2ShdslEndpointCurr15MinTimeElapsed OBJECT-TYPE
   SYNTAX       Hdsl2ShdslPerfTimeElapsed
   UNITS        &quot;seconds&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Total elapsed seconds in the current 15-minute interval.&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 9 }

hdsl2ShdslEndpointCurr15MinES OBJECT-TYPE
   SYNTAX       PerfCurrentCount
   UNITS        &quot;seconds&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Count of Errored Seconds (ES) in the current 15-minute
      interval.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 10 }

hdsl2ShdslEndpointCurr15MinSES OBJECT-TYPE
   SYNTAX       PerfCurrentCount
   UNITS        &quot;seconds&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Count of Severely Errored Seconds (SES) in the current
      15-minute interval.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 11 }

hdsl2ShdslEndpointCurr15MinCRCanomalies OBJECT-TYPE
   SYNTAX       PerfCurrentCount
   UNITS        &quot;detected CRC Anomalies&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Count of CRC anomalies in the current 15-minute interval.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 12 }

hdsl2ShdslEndpointCurr15MinLOSWS OBJECT-TYPE
   SYNTAX       PerfCurrentCount
   UNITS        &quot;seconds&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Count of Loss of Sync Word (LOSW) Seconds in the current
      15-minute interval.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 13 }

hdsl2ShdslEndpointCurr15MinUAS OBJECT-TYPE
   SYNTAX       PerfCurrentCount
   UNITS        &quot;seconds&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Count of Unavailable Seconds (UAS) in the current 15-minute
      interval.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 14 }

hdsl2ShdslEndpointCurr1DayTimeElapsed OBJECT-TYPE
   SYNTAX       Hdsl2ShdslPerfTimeElapsed
   UNITS        &quot;seconds&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Number of seconds that have elapsed since the beginning of
      the current 1-day interval.&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 15 }

hdsl2ShdslEndpointCurr1DayES OBJECT-TYPE
   SYNTAX       Hdsl2ShdslPerfCurrDayCount
   UNITS        &quot;seconds&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Count of Errored Seconds (ES) during the current day as
      measured by hdsl2ShdslEndpointCurr1DayTimeElapsed.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 16 }

hdsl2ShdslEndpointCurr1DaySES OBJECT-TYPE
   SYNTAX       Hdsl2ShdslPerfCurrDayCount
   UNITS        &quot;seconds&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Count of Severely Errored Seconds (SES) during the current
      day as measured by hdsl2ShdslEndpointCurr1DayTimeElapsed.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 17 }

hdsl2ShdslEndpointCurr1DayCRCanomalies OBJECT-TYPE
   SYNTAX       Hdsl2ShdslPerfCurrDayCount
   UNITS        &quot;detected CRC Anomalies&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Count of CRC anomalies during the current day as measured
      by hdsl2ShdslEndpointCurr1DayTimeElapsed.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 18 }

hdsl2ShdslEndpointCurr1DayLOSWS OBJECT-TYPE
   SYNTAX       Hdsl2ShdslPerfCurrDayCount
   UNITS        &quot;seconds&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Count of Loss of Sync Word (LOSW) Seconds during the current
      day as measured by hdsl2ShdslEndpointCurr1DayTimeElapsed.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 19 }

hdsl2ShdslEndpointCurr1DayUAS OBJECT-TYPE
   SYNTAX       Hdsl2ShdslPerfCurrDayCount
   UNITS        &quot;seconds&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Count of Unavailable Seconds (UAS) during the current day as
      measured by hdsl2ShdslEndpointCurr1DayTimeElapsed.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 20 }

hdsl2ShdslEndpointCurrTipRingReversal OBJECT-TYPE
   SYNTAX      INTEGER
               {
               normal(1),
               reversed(2)
               }
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;This object indicates the state of the tip/ring for the
      wire pair.&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 21 }

hdsl2ShdslEndpointCurrActivationState OBJECT-TYPE
   SYNTAX      INTEGER
               {
               preActivation(1),  -- PreTrain
               activation(2),     -- Training
               data(3)            -- Trained
               }
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;This object indicates the activation or training state of 
      the wire pair.&quot;
   REFERENCE   &quot;ITU-T G.991.2, Section 6.2 PMD Activation Sequence&quot;
   ::= { hdsl2ShdslEndpointCurrEntry 22 }

-- Segment Endpoint 15-Minute Interval Status/Performance Group
--

hdsl2Shdsl15MinIntervalTable OBJECT-TYPE
   SYNTAX      SEQUENCE OF Hdsl2Shdsl15MinIntervalEntry
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;This table provides one row for each HDSL2/SHDSL endpoint
      performance data collection interval.  This table contains
      live data from equipment.  As such, it is NOT persistent.&quot;
   ::= { hdsl2ShdslMibObjects 6 }

hdsl2Shdsl15MinIntervalEntry OBJECT-TYPE
   SYNTAX      Hdsl2Shdsl15MinIntervalEntry
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;An entry in the hdsl2Shdsl15MinIntervalTable.&quot;
   INDEX { ifIndex, hdsl2ShdslInvIndex, hdsl2ShdslEndpointSide,
           hdsl2ShdslEndpointWirePair, hdsl2Shdsl15MinIntervalNumber}
   ::= { hdsl2Shdsl15MinIntervalTable 1 }

Hdsl2Shdsl15MinIntervalEntry ::=
   SEQUENCE
   {
   hdsl2Shdsl15MinIntervalNumber         Unsigned32,
   hdsl2Shdsl15MinIntervalES             PerfIntervalCount,
   hdsl2Shdsl15MinIntervalSES            PerfIntervalCount,
   hdsl2Shdsl15MinIntervalCRCanomalies   PerfIntervalCount,
   hdsl2Shdsl15MinIntervalLOSWS          PerfIntervalCount,
   hdsl2Shdsl15MinIntervalUAS            PerfIntervalCount
   }

hdsl2Shdsl15MinIntervalNumber OBJECT-TYPE
   SYNTAX      Unsigned32(1..96)
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;Performance Data Interval number.  Interval 1 is the most 
      recent previous interval; interval 96 is 24 hours ago.  
      Intervals 2..96 are optional.&quot;
   ::= { hdsl2Shdsl15MinIntervalEntry 1 }

hdsl2Shdsl15MinIntervalES OBJECT-TYPE
   SYNTAX      PerfIntervalCount
   UNITS       &quot;seconds&quot;
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Count of Errored Seconds (ES) during the interval.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2Shdsl15MinIntervalEntry 2 }

hdsl2Shdsl15MinIntervalSES OBJECT-TYPE
   SYNTAX      PerfIntervalCount
   UNITS       &quot;seconds&quot;
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Count of Severely Errored Seconds (SES) during the interval.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2Shdsl15MinIntervalEntry 3 }

hdsl2Shdsl15MinIntervalCRCanomalies OBJECT-TYPE
   SYNTAX      PerfIntervalCount
   UNITS       &quot;detected CRC Anomalies&quot;
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Count of CRC anomalies during the interval.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2Shdsl15MinIntervalEntry 4 }

hdsl2Shdsl15MinIntervalLOSWS OBJECT-TYPE
   SYNTAX      PerfIntervalCount
   UNITS       &quot;seconds&quot;
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Count of Loss of Sync Word (LOSW) Seconds during the
      interval.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2Shdsl15MinIntervalEntry 5 }

hdsl2Shdsl15MinIntervalUAS OBJECT-TYPE
   SYNTAX      PerfIntervalCount
   UNITS       &quot;seconds&quot;
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;Count of Unavailable Seconds (UAS) during the interval.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2Shdsl15MinIntervalEntry 6 }

-- Segment Endpoint 1-Day Interval Status/Performance Group
--

hdsl2Shdsl1DayIntervalTable OBJECT-TYPE
   SYNTAX      SEQUENCE OF Hdsl2Shdsl1DayIntervalEntry
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;This table provides one row for each HDSL2/SHDSL endpoint
      performance data collection interval.  This table contains
      live data from equipment.  As such, it is NOT persistent.&quot;
   ::= { hdsl2ShdslMibObjects 7 }

hdsl2Shdsl1DayIntervalEntry OBJECT-TYPE
   SYNTAX      Hdsl2Shdsl1DayIntervalEntry
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;An entry in the hdsl2Shdsl1DayIntervalTable.&quot;
   INDEX { ifIndex, hdsl2ShdslInvIndex, hdsl2ShdslEndpointSide,
           hdsl2ShdslEndpointWirePair, hdsl2Shdsl1DayIntervalNumber }
   ::= { hdsl2Shdsl1DayIntervalTable 1 }

Hdsl2Shdsl1DayIntervalEntry ::=
   SEQUENCE
   {
   hdsl2Shdsl1DayIntervalNumber         Unsigned32,
   hdsl2Shdsl1DayIntervalMoniSecs       Hdsl2ShdslPerfTimeElapsed,
   hdsl2Shdsl1DayIntervalES             Hdsl2Shdsl1DayIntervalCount,
   hdsl2Shdsl1DayIntervalSES            Hdsl2Shdsl1DayIntervalCount,
   hdsl2Shdsl1DayIntervalCRCanomalies   Hdsl2Shdsl1DayIntervalCount,
   hdsl2Shdsl1DayIntervalLOSWS          Hdsl2Shdsl1DayIntervalCount,
   hdsl2Shdsl1DayIntervalUAS            Hdsl2Shdsl1DayIntervalCount
   }

hdsl2Shdsl1DayIntervalNumber OBJECT-TYPE
   SYNTAX      Unsigned32(1..30)
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;History Data Interval number.  Interval 1 is the most
      recent previous day; interval 30 is 30 days ago.  Intervals
      2..30 are optional.&quot;
   ::= { hdsl2Shdsl1DayIntervalEntry 1 }

hdsl2Shdsl1DayIntervalMoniSecs OBJECT-TYPE
   SYNTAX       Hdsl2ShdslPerfTimeElapsed
   UNITS        &quot;seconds&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;The amount of time in the 1-day interval over which the
      performance monitoring information is actually counted.
      This value will be the same as the interval duration except
      in a situation where performance monitoring data could not
      be collected for any reason.&quot;
   ::= { hdsl2Shdsl1DayIntervalEntry 2 }

hdsl2Shdsl1DayIntervalES OBJECT-TYPE
   SYNTAX       Hdsl2Shdsl1DayIntervalCount
   UNITS        &quot;seconds&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Count of Errored Seconds (ES) during the 1-day interval as
      measured by hdsl2Shdsl1DayIntervalMoniSecs.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2Shdsl1DayIntervalEntry 3 }

hdsl2Shdsl1DayIntervalSES OBJECT-TYPE
   SYNTAX       Hdsl2Shdsl1DayIntervalCount
   UNITS        &quot;seconds&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Count of Severely Errored Seconds (SES) during the 1-day
      interval as measured by hdsl2Shdsl1DayIntervalMoniSecs.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2Shdsl1DayIntervalEntry 4 }

hdsl2Shdsl1DayIntervalCRCanomalies OBJECT-TYPE
   SYNTAX       Hdsl2Shdsl1DayIntervalCount
   UNITS        &quot;detected CRC Anomalies&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Count of CRC anomalies during the 1-day interval as
      measured by hdsl2Shdsl1DayIntervalMoniSecs.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2Shdsl1DayIntervalEntry 5 }

hdsl2Shdsl1DayIntervalLOSWS OBJECT-TYPE
   SYNTAX       Hdsl2Shdsl1DayIntervalCount
   UNITS        &quot;seconds&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Count of Loss of Sync Word (LOSW) Seconds during the 1-day
      interval as measured by hdsl2Shdsl1DayIntervalMoniSecs.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2Shdsl1DayIntervalEntry 6 }

hdsl2Shdsl1DayIntervalUAS OBJECT-TYPE
   SYNTAX       Hdsl2Shdsl1DayIntervalCount
   UNITS        &quot;seconds&quot;
   MAX-ACCESS   read-only
   STATUS       current
   DESCRIPTION
     &quot;Count of Unavailable Seconds (UAS) during the 1-day interval
      as measured by hdsl2Shdsl1DayIntervalMoniSecs.&quot;
   REFERENCE   &quot;HDSL2 Section 7.5.3.7; SHDSL Section 9.5.5.7&quot;
   ::= { hdsl2Shdsl1DayIntervalEntry 7 }

-- Maintenance Group
--

hdsl2ShdslEndpointMaintTable OBJECT-TYPE
   SYNTAX      SEQUENCE OF Hdsl2ShdslEndpointMaintEntry
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;This table supports maintenance operations (e.g. loopbacks)
      to be performed on HDSL2/SHDSL segment endpoints.  This table
      contains live data from equipment.  As such, it is NOT
      persistent.&quot;
   ::= { hdsl2ShdslMibObjects 8 }

hdsl2ShdslEndpointMaintEntry OBJECT-TYPE
   SYNTAX      Hdsl2ShdslEndpointMaintEntry
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;An entry in the hdsl2ShdslEndpointMaintTable.  Each entry
      corresponds to a single segment endpoint, and is indexed by the
      ifIndex of the HDSL2/SHDSL line, the UnitId of the associated
      unit and the side of the unit.&quot;
   INDEX { ifIndex, hdsl2ShdslInvIndex, hdsl2ShdslEndpointSide }
   ::= { hdsl2ShdslEndpointMaintTable 1 }

Hdsl2ShdslEndpointMaintEntry ::=
   SEQUENCE
   {
   hdsl2ShdslMaintLoopbackConfig      INTEGER,
   hdsl2ShdslMaintTipRingReversal     INTEGER,
   hdsl2ShdslMaintPowerBackOff        INTEGER,
   hdsl2ShdslMaintSoftRestart         INTEGER
   }

hdsl2ShdslMaintLoopbackConfig OBJECT-TYPE
   SYNTAX      INTEGER
               {
               noLoopback(1),
               normalLoopback(2),
               specialLoopback(3)
               }
   MAX-ACCESS  read-write
   STATUS      current
   DESCRIPTION
     &quot;This object controls configuration of loopbacks for the
      associated segment endpoint.  The status of the loopback
      is obtained via the hdsl2ShdslEndpointCurrStatus object.&quot;
   ::= { hdsl2ShdslEndpointMaintEntry 1 }

hdsl2ShdslMaintTipRingReversal OBJECT-TYPE
   SYNTAX      INTEGER
               {
               normal(1),
               reversed(2)
               }
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;This object indicates the state of the tip/ring pair at the
      associated segment endpoint.&quot;
   ::= { hdsl2ShdslEndpointMaintEntry 2 }

hdsl2ShdslMaintPowerBackOff OBJECT-TYPE
   SYNTAX      INTEGER
               {
               default(1),
               enhanced(2)
               }
   MAX-ACCESS  read-write
   STATUS      current
   DESCRIPTION
     &quot;This object configures the receiver at the associated
      segment endpoint to operate in default or enhanced power
      backoff mode.&quot;
   ::= { hdsl2ShdslEndpointMaintEntry 3 }

hdsl2ShdslMaintSoftRestart OBJECT-TYPE
   SYNTAX      INTEGER
               {
               ready(1),
               restart(2)
               }
   MAX-ACCESS  read-write
   STATUS      current
   DESCRIPTION
     &quot;This object enables the manager to trigger a soft restart
      of the modem at the associated segment endpoint.  The 
      manager may only set this object to the &apos;restart(2)&apos; 
      value, which initiates a restart.  The agent will perform a 
      restart after approximately 5 seconds.  Following the 5 second 
      period, the agent will restore the object to the &apos;ready(1)&apos; 
      state.&quot;
   ::= { hdsl2ShdslEndpointMaintEntry 4 }

hdsl2ShdslUnitMaintTable OBJECT-TYPE
   SYNTAX      SEQUENCE OF Hdsl2ShdslUnitMaintEntry
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;This table supports maintenance operations for units in a
      HDSL2/SHDSL line.  Entries in this table MUST be maintained
      in a persistent manner.&quot;
   ::= { hdsl2ShdslMibObjects 9 }

hdsl2ShdslUnitMaintEntry OBJECT-TYPE
   SYNTAX      Hdsl2ShdslUnitMaintEntry
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;An entry in the hdsl2ShdslUnitMaintTable.  Each entry
      corresponds to a single unit, and is indexed by the 
      ifIndex of the HDSL2/SHDSL line and the UnitId of the 
      associated unit.&quot;
   INDEX { ifIndex, hdsl2ShdslInvIndex  }
   ::= { hdsl2ShdslUnitMaintTable 1 }

Hdsl2ShdslUnitMaintEntry ::=
   SEQUENCE
   {
   hdsl2ShdslMaintLoopbackTimeout     Integer32,
   hdsl2ShdslMaintUnitPowerSource     INTEGER
   }

hdsl2ShdslMaintLoopbackTimeout OBJECT-TYPE
   SYNTAX      Integer32(0..4095)
   UNITS       &quot;minutes&quot;
   MAX-ACCESS  read-write
   STATUS      current
   DESCRIPTION
     &quot;This object configures the timeout value for loopbacks
      initiated at segments endpoints contained in the associated
      unit.  A value of 0 disables the timeout.&quot;
   ::= { hdsl2ShdslUnitMaintEntry 1 }

hdsl2ShdslMaintUnitPowerSource OBJECT-TYPE
   SYNTAX      INTEGER
               {
               local(1),
               span(2)
               }
   MAX-ACCESS  read-only
   STATUS      current
   DESCRIPTION
     &quot;This object indicates the DC power source being used by the
      associated unit.&quot;
   ::= { hdsl2ShdslUnitMaintEntry 2 }

-- Span Configuration Profile Group
--

hdsl2ShdslSpanConfProfileTable OBJECT-TYPE
   SYNTAX      SEQUENCE OF Hdsl2ShdslSpanConfProfileEntry
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;This table supports definitions of span configuration
      profiles for SHDSL lines.  HDSL2 does not support these
      configuration options.  This table MUST be maintained
      in a persistent manner.&quot;
   ::= { hdsl2ShdslMibObjects 10 }

hdsl2ShdslSpanConfProfileEntry OBJECT-TYPE
   SYNTAX      Hdsl2ShdslSpanConfProfileEntry
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;Each entry corresponds to a single span configuration
      profile.  Each profile contains a set of span configuration
      parameters.  The configuration parameters in a profile are
      applied to those lines referencing that profile (see the
      hdsl2ShdslSpanConfProfile object).  Profiles may be
      created/deleted using the row creation/deletion mechanism
      via hdsl2ShdslSpanConfProfileRowStatus.  If an active
      entry is referenced in hdsl2ShdslSpanConfProfile, the
      entry MUST remain active until all references are removed.&quot;
   INDEX { IMPLIED hdsl2ShdslSpanConfProfileName }
   ::= { hdsl2ShdslSpanConfProfileTable 1 }

Hdsl2ShdslSpanConfProfileEntry ::=
   SEQUENCE
   {
   hdsl2ShdslSpanConfProfileName               SnmpAdminString,
   hdsl2ShdslSpanConfWireInterface             INTEGER,
   hdsl2ShdslSpanConfMinLineRate               Unsigned32,
   hdsl2ShdslSpanConfMaxLineRate               Unsigned32,
   hdsl2ShdslSpanConfPSD                       INTEGER,
   hdsl2ShdslSpanConfTransmissionMode
                           Hdsl2ShdslTransmissionModeType,
   hdsl2ShdslSpanConfRemoteEnabled             INTEGER,
   hdsl2ShdslSpanConfPowerFeeding              INTEGER,
   hdsl2ShdslSpanConfCurrCondTargetMarginDown  Integer32,
   hdsl2ShdslSpanConfWorstCaseTargetMarginDown Integer32,
   hdsl2ShdslSpanConfCurrCondTargetMarginUp    Integer32,
   hdsl2ShdslSpanConfWorstCaseTargetMarginUp   Integer32,
   hdsl2ShdslSpanConfUsedTargetMargins         BITS,
   hdsl2ShdslSpanConfReferenceClock            
                             Hdsl2ShdslClockReferenceType,
   hdsl2ShdslSpanConfLineProbeEnable           INTEGER,
   hdsl2ShdslSpanConfProfileRowStatus          RowStatus
   }

hdsl2ShdslSpanConfProfileName OBJECT-TYPE
   SYNTAX      SnmpAdminString (SIZE(1..32))
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;This object is the unique index associated with this profile.
      Entries in this table are referenced via the object
      hdsl2ShdslSpanConfProfile in Hdsl2ShdslSpanConfEntry.&quot;
   ::= { hdsl2ShdslSpanConfProfileEntry 1 }

hdsl2ShdslSpanConfWireInterface OBJECT-TYPE
   SYNTAX      INTEGER
               {
               twoWire(1),
               fourWire(2),
               sixWire(3),
               eightWire(4)
               }
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object configures the two-wire or optional four-wire,
      six-wire, or eight-wire operation for SHDSL Lines.&quot;
   DEFVAL      { twoWire }
   ::= { hdsl2ShdslSpanConfProfileEntry 2 }

hdsl2ShdslSpanConfMinLineRate OBJECT-TYPE
   SYNTAX      Unsigned32(0..4294967295)
   UNITS       &quot;bps&quot;
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object configures the minimum transmission rate for
      the associated SHDSL Line in bits-per-second (bps) and includes
      both payload (user data) and any applicable framing overhead.  
      If the minimum line rate equals the maximum line rate
      (hdsl2ShdslSpanMaxLineRate), the line rate is considered
      &apos;fixed&apos;.  If the minimum line rate is less than the 
      maximum line rate, the line rate is considered 
      &apos;rate-adaptive&apos;.&quot;
   DEFVAL      { 1552000 }
   ::= { hdsl2ShdslSpanConfProfileEntry 3 }

hdsl2ShdslSpanConfMaxLineRate OBJECT-TYPE
   SYNTAX      Unsigned32(0..4294967295)
   UNITS       &quot;bps&quot;
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object configures the maximum transmission rate for
      the associated SHDSL Line in bits-per-second (bps) and includes
      both payload (user data) and any applicable framing overhead.  
      If the minimum line rate equals the maximum line rate
      (hdsl2ShdslSpanMaxLineRate), the line rate is considered
      &apos;fixed&apos;.  If the minimum line rate is less than the 
      maximum line rate, the line rate is considered 
      &apos;rate-adaptive&apos;.&quot;
   DEFVAL      { 1552000 }
   ::= { hdsl2ShdslSpanConfProfileEntry 4 }

hdsl2ShdslSpanConfPSD OBJECT-TYPE
   SYNTAX      INTEGER
               {
               symmetric(1),
               asymmetric(2)
               }
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object configures use of symmetric/asymmetric PSD (Power
      Spectral Density) Mask for the associated SHDSL Line.  Support
      for symmetric PSD is mandatory for all supported data rates.
      Support for asymmetric PSD is optional.&quot;
   DEFVAL      { symmetric }
   ::= { hdsl2ShdslSpanConfProfileEntry 5 }

hdsl2ShdslSpanConfTransmissionMode OBJECT-TYPE
   SYNTAX      Hdsl2ShdslTransmissionModeType
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object specifies the regional setting for the SHDSL
      line.&quot;
   DEFVAL      { { region1 } }
   ::= { hdsl2ShdslSpanConfProfileEntry 6 }

hdsl2ShdslSpanConfRemoteEnabled OBJECT-TYPE
   SYNTAX      INTEGER
               {
               enabled(1),
               disabled(2)
               }
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object enables/disables support for remote management
      of the units in a SHDSL line from the STU-R via the EOC.&quot;
   DEFVAL      { enabled }
   ::= { hdsl2ShdslSpanConfProfileEntry 7 }

hdsl2ShdslSpanConfPowerFeeding OBJECT-TYPE
   SYNTAX      INTEGER
               {
               noPower(1),
               powerFeed(2),
               wettingCurrent(3)
               }
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object enables/disables support for optional power
      feeding in a SHDSL line.&quot;
   DEFVAL      { noPower }
   ::= { hdsl2ShdslSpanConfProfileEntry 8 }

hdsl2ShdslSpanConfCurrCondTargetMarginDown OBJECT-TYPE
   SYNTAX      Integer32(-10..21)
   UNITS       &quot;dB&quot;
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object specifies the downstream current condition target
      SNR margin for a SHDSL line.  The SNR margin is the difference
      between the desired SNR and the actual SNR.  Target SNR margin
      is the desired SNR margin for a unit.&quot;
   DEFVAL      { 0 }
   ::= { hdsl2ShdslSpanConfProfileEntry 9 }

hdsl2ShdslSpanConfWorstCaseTargetMarginDown OBJECT-TYPE
   SYNTAX      Integer32(-10..21)
   UNITS       &quot;dB&quot;
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object specifies the downstream worst case target SNR
      margin for a SHDSL line.  The SNR margin is the difference
      between the desired SNR and the actual SNR.  Target SNR
      margin is the desired SNR margin for a unit.&quot;
   DEFVAL      { 0 }
   ::= { hdsl2ShdslSpanConfProfileEntry 10 }

hdsl2ShdslSpanConfCurrCondTargetMarginUp OBJECT-TYPE
   SYNTAX      Integer32(-10..21)
   UNITS       &quot;dB&quot;
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object specifies the upstream current condition target
      SNR margin for a SHDSL line.  The SNR margin is the difference
      between the desired SNR and the actual SNR.  Target SNR margin
      is the desired SNR margin for a unit.&quot;
   DEFVAL      { 0 }
   ::= { hdsl2ShdslSpanConfProfileEntry 11 }

hdsl2ShdslSpanConfWorstCaseTargetMarginUp OBJECT-TYPE
   SYNTAX      Integer32(-10..21)
   UNITS       &quot;dB&quot;
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object specifies the upstream worst case target SNR
      margin for a SHDSL line.  The SNR margin is the difference
      between the desired SNR and the actual SNR.  Target SNR margin
      is the desired SNR margin for a unit.&quot;
   DEFVAL      { 0 }
   ::= { hdsl2ShdslSpanConfProfileEntry 12 }

hdsl2ShdslSpanConfUsedTargetMargins OBJECT-TYPE
   SYNTAX      BITS
               {
               currCondDown(0),
               worstCaseDown(1),
               currCondUp(2),
               worstCaseUp(3)
               }
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;Indicates whether a target SNR margin is enabled or
      disabled.  This is a bit-map of possible settings.  The
      various bit positions are:

      currCondDown   - current condition downstream target SNR
                       margin enabled

      worstCaseDown  - worst case downstream target SNR margin
                       enabled

      currCondUp     - current condition upstream target SNR
                       margin enabled

      worstCaseUp    - worst case upstream target SNR margin
                       enabled.&quot;
   DEFVAL      { { currCondDown } }
   ::= { hdsl2ShdslSpanConfProfileEntry 13 }

hdsl2ShdslSpanConfReferenceClock OBJECT-TYPE
   SYNTAX      Hdsl2ShdslClockReferenceType
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object configures the clock reference for the STU-C
      in a SHDSL Line.&quot;
   DEFVAL      { localClk }
   ::= { hdsl2ShdslSpanConfProfileEntry 14 }

hdsl2ShdslSpanConfLineProbeEnable OBJECT-TYPE
   SYNTAX      INTEGER
               {
               disable(1),
               enable(2)
               }
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object enables/disables support for Line Probe of
      the units in a SHDSL line.  When Line Probe is enabled, the
      system performs Line Probing to find the best possible
      rate.  If Line probe is disabled, the rate adaptation phase
      is skipped to shorten set up time.&quot;
   DEFVAL      { disable }
   ::= { hdsl2ShdslSpanConfProfileEntry 15 }

hdsl2ShdslSpanConfProfileRowStatus OBJECT-TYPE
   SYNTAX      RowStatus
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object controls creation/deletion of the associated
      entry in this table per the semantics of RowStatus.  If an
      active entry is referenced in hdsl2ShdslSpanConfProfile, the
      entry MUST remain active until all references are removed.&quot;
   ::= { hdsl2ShdslSpanConfProfileEntry 16 }

-- Segment Endpoint Alarm Configuration Profile group
--

hdsl2ShdslEndpointAlarmConfProfileTable OBJECT-TYPE
   SYNTAX      SEQUENCE OF Hdsl2ShdslEndpointAlarmConfProfileEntry
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;This table supports definitions of alarm configuration
      profiles for HDSL2/SHDSL segment endpoints.  This table
      MUST be maintained in a persistent manner.&quot;
   ::= { hdsl2ShdslMibObjects 11 }

hdsl2ShdslEndpointAlarmConfProfileEntry OBJECT-TYPE
   SYNTAX      Hdsl2ShdslEndpointAlarmConfProfileEntry
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;Each entry corresponds to a single alarm configuration profile.
      Each profile contains a set of parameters for setting alarm
      thresholds for various performance attributes monitored at
      HDSL2/SHDSL segment endpoints.  Profiles may be created/deleted
      using the row creation/deletion mechanism via
      hdsl2ShdslEndpointAlarmConfProfileRowStatus.  If an active
      entry is referenced in either hdsl2ShdslSpanConfAlarmProfile
      or hdsl2ShdslEndpointAlarmConfProfile, the entry MUST remain
      active until all references are removed.&quot;
   INDEX { IMPLIED hdsl2ShdslEndpointAlarmConfProfileName }
   ::= { hdsl2ShdslEndpointAlarmConfProfileTable 1 }

Hdsl2ShdslEndpointAlarmConfProfileEntry ::=
   SEQUENCE
   {
   hdsl2ShdslEndpointAlarmConfProfileName       SnmpAdminString,
   hdsl2ShdslEndpointThreshLoopAttenuation      Integer32,
   hdsl2ShdslEndpointThreshSNRMargin            Integer32,
   hdsl2ShdslEndpointThreshES
                                Hdsl2ShdslPerfIntervalThreshold,
   hdsl2ShdslEndpointThreshSES
                                Hdsl2ShdslPerfIntervalThreshold,
   hdsl2ShdslEndpointThreshCRCanomalies         Integer32,
   hdsl2ShdslEndpointThreshLOSWS
                                Hdsl2ShdslPerfIntervalThreshold,
   hdsl2ShdslEndpointThreshUAS
                                Hdsl2ShdslPerfIntervalThreshold,
   hdsl2ShdslEndpointAlarmConfProfileRowStatus  RowStatus
   }

hdsl2ShdslEndpointAlarmConfProfileName OBJECT-TYPE
   SYNTAX      SnmpAdminString (SIZE(1..32))
   MAX-ACCESS  not-accessible
   STATUS      current
   DESCRIPTION
     &quot;This object is the unique index associated with this profile.&quot;
   ::= { hdsl2ShdslEndpointAlarmConfProfileEntry 1 }

hdsl2ShdslEndpointThreshLoopAttenuation OBJECT-TYPE
   SYNTAX      Integer32(-127..128)
   UNITS       &quot;dB&quot;
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object configures the loop attenuation alarm threshold.
      When the current value of hdsl2ShdslEndpointCurrAtn reaches
      or exceeds this threshold, a hdsl2ShdslLoopAttenCrossing
      MAY be generated.&quot;
   DEFVAL      { 0 }
   ::= { hdsl2ShdslEndpointAlarmConfProfileEntry 2 }

hdsl2ShdslEndpointThreshSNRMargin OBJECT-TYPE
   SYNTAX      Integer32(-127..128)
   UNITS       &quot;dB&quot;
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object configures the SNR margin alarm threshold.
      When the current value of hdsl2ShdslEndpointCurrSnrMgn
      reaches or drops below this threshold, a
      hdsl2ShdslSNRMarginCrossing MAY be generated.&quot;
   DEFVAL      { 0 }
   ::= { hdsl2ShdslEndpointAlarmConfProfileEntry 3 }

hdsl2ShdslEndpointThreshES OBJECT-TYPE
   SYNTAX      Hdsl2ShdslPerfIntervalThreshold
   UNITS       &quot;seconds&quot;
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object configures the threshold for the number of
      errored seconds (ES) within any given 15-minute performance
      data collection interval.  If the value of errored seconds
      in a particular 15-minute collection interval reaches/
      exceeds this value, a hdsl2ShdslPerfESThresh MAY be
      generated.  At most one notification will be sent per
      interval per endpoint.&quot;
   DEFVAL      { 0 }
   ::= { hdsl2ShdslEndpointAlarmConfProfileEntry 4 }

hdsl2ShdslEndpointThreshSES OBJECT-TYPE
   SYNTAX      Hdsl2ShdslPerfIntervalThreshold
   UNITS       &quot;seconds&quot;
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object configures the threshold for the number of
      severely errored seconds (SES) within any given 15-minute
      performance data collection interval.  If the value of
      severely errored seconds in a particular 15-minute collection
      interval reaches/exceeds this value, a hdsl2ShdslPerfSESThresh
      MAY be generated.  At most one notification will be sent per
      interval per endpoint.&quot;
   DEFVAL      { 0 }
   ::= { hdsl2ShdslEndpointAlarmConfProfileEntry 5 }

hdsl2ShdslEndpointThreshCRCanomalies OBJECT-TYPE
   SYNTAX      Integer32
   UNITS       &quot;detected CRC Anomalies&quot;
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object configures the threshold for the number of
      CRC anomalies within any given 15-minute performance data
      collection interval.  If the value of CRC anomalies in a
      particular 15-minute collection interval reaches/exceeds
      this value, a hdsl2ShdslPerfCRCanomaliesThresh MAY be
      generated.  At most one notification will be sent per
      interval per endpoint.&quot;
   DEFVAL      { 0 }
   ::= { hdsl2ShdslEndpointAlarmConfProfileEntry 6 }

hdsl2ShdslEndpointThreshLOSWS OBJECT-TYPE
   SYNTAX      Hdsl2ShdslPerfIntervalThreshold
   UNITS       &quot;seconds&quot;
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object configures the threshold for the number of
      Loss of Sync Word (LOSW) Seconds within any given 15-minute
      performance data collection interval.  If the value of LOSW
      in a particular 15-minute collection interval reaches/exceeds
      this value, a hdsl2ShdslPerfLOSWSThresh MAY be generated.
      At most one notification will be sent per interval per
      endpoint.&quot;
   DEFVAL      { 0 }
   ::= { hdsl2ShdslEndpointAlarmConfProfileEntry 7 }

hdsl2ShdslEndpointThreshUAS OBJECT-TYPE
   SYNTAX      Hdsl2ShdslPerfIntervalThreshold
   UNITS       &quot;seconds&quot;
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object configures the threshold for the number of
      unavailable seconds (UAS) within any given 15-minute
      performance data collection interval.  If the value of UAS
      in a particular 15-minute collection interval reaches/exceeds
      this value, a hdsl2ShdslPerfUASThresh MAY be generated.
      At most one notification will be sent per interval per
      endpoint.&quot;
   DEFVAL      { 0 }
   ::= { hdsl2ShdslEndpointAlarmConfProfileEntry 8 }

hdsl2ShdslEndpointAlarmConfProfileRowStatus OBJECT-TYPE
   SYNTAX      RowStatus
   MAX-ACCESS  read-create
   STATUS      current
   DESCRIPTION
     &quot;This object controls creation/deletion of the associated
      entry in this table as per the semantics of RowStatus.
      If an active entry is referenced in either
      hdsl2ShdslSpanConfAlarmProfile or
      hdsl2ShdslEndpointAlarmConfProfile, the entry MUST remain
      active until all references are removed.&quot;
   ::= { hdsl2ShdslEndpointAlarmConfProfileEntry 9 }

-- Notifications Group
--

hdsl2ShdslNotifications OBJECT IDENTIFIER ::= { hdsl2ShdslMIB 0 }

hdsl2ShdslLoopAttenCrossing NOTIFICATION-TYPE
   OBJECTS
   {
   hdsl2ShdslEndpointCurrAtn,
   hdsl2ShdslEndpointThreshLoopAttenuation
   }
   STATUS     current
   DESCRIPTION
     &quot;This notification indicates that the loop attenuation
      threshold (as per the hdsl2ShdslEndpointThreshLoopAttenuation
      value) has been reached/exceeded for the HDSL2/SHDSL segment
      endpoint.&quot;
   ::= { hdsl2ShdslNotifications 1 }

hdsl2ShdslSNRMarginCrossing NOTIFICATION-TYPE
   OBJECTS
   {
   hdsl2ShdslEndpointCurrSnrMgn,
   hdsl2ShdslEndpointThreshSNRMargin
   }
   STATUS     current
   DESCRIPTION
     &quot;This notification indicates that the SNR margin threshold (as
      per the hdsl2ShdslEndpointThreshSNRMargin value) has been
      reached/exceeded for the HDSL2/SHDSL segment endpoint.&quot;
   ::= { hdsl2ShdslNotifications 2 }

hdsl2ShdslPerfESThresh NOTIFICATION-TYPE
   OBJECTS
   {
   hdsl2ShdslEndpointCurr15MinES,
   hdsl2ShdslEndpointThreshES
   }
   STATUS     current
   DESCRIPTION
     &quot;This notification indicates that the errored seconds 
      threshold (as per the hdsl2ShdslEndpointThreshES value) 
      has been reached/exceeded for the HDSL2/SHDSL segment 
      endpoint.&quot;
   ::= { hdsl2ShdslNotifications 3 }

hdsl2ShdslPerfSESThresh NOTIFICATION-TYPE
   OBJECTS
   {
   hdsl2ShdslEndpointCurr15MinSES,
   hdsl2ShdslEndpointThreshSES
   }
   STATUS     current
   DESCRIPTION
     &quot;This notification indicates that the severely errored seconds
      threshold (as per the hdsl2ShdslEndpointThreshSES value) has
      been reached/exceeded for the HDSL2/SHDSL Segment Endpoint.&quot;
   ::= { hdsl2ShdslNotifications 4 }

hdsl2ShdslPerfCRCanomaliesThresh NOTIFICATION-TYPE
   OBJECTS
   {
   hdsl2ShdslEndpointCurr15MinCRCanomalies,
   hdsl2ShdslEndpointThreshCRCanomalies
   }
   STATUS    current
   DESCRIPTION
     &quot;This notification indicates that the CRC anomalies threshold
      (as per the hdsl2ShdslEndpointThreshCRCanomalies value) has
      been reached/exceeded for the HDSL2/SHDSL Segment Endpoint.&quot;
   ::= { hdsl2ShdslNotifications 5 }

hdsl2ShdslPerfLOSWSThresh NOTIFICATION-TYPE
   OBJECTS
   {
   hdsl2ShdslEndpointCurr15MinLOSWS,
   hdsl2ShdslEndpointThreshLOSWS
   }
   STATUS     current
   DESCRIPTION
     &quot;This notification indicates that the LOSW seconds threshold
      (as per the hdsl2ShdslEndpointThreshLOSWS value) has been
      reached/exceeded for the HDSL2/SHDSL segment endpoint.&quot;
   ::= { hdsl2ShdslNotifications 6 }

hdsl2ShdslPerfUASThresh NOTIFICATION-TYPE
   OBJECTS
   {
   hdsl2ShdslEndpointCurr15MinUAS,
   hdsl2ShdslEndpointThreshUAS
   }
   STATUS     current
   DESCRIPTION
     &quot;This notification indicates that the unavailable seconds
      threshold (as per the hdsl2ShdslEndpointThreshUAS value) has
      been reached/exceeded for the HDSL2/SHDSL segment endpoint.&quot;
   ::= { hdsl2ShdslNotifications 7 }

hdsl2ShdslSpanInvalidNumRepeaters NOTIFICATION-TYPE
   OBJECTS
   {
   hdsl2ShdslSpanConfNumRepeaters
   }
   STATUS     current
   DESCRIPTION
     &quot;This notification indicates that a mismatch has been detected
      between the number of repeater/regenerator units configured
      for a HDSL2/SHDSL line via the hdsl2ShdslSpanConfNumRepeaters
      object and the actual number of repeater/regenerator units
      discovered via the EOC.&quot;
   ::= { hdsl2ShdslNotifications 8 }

hdsl2ShdslLoopbackFailure NOTIFICATION-TYPE
   OBJECTS
   {
   hdsl2ShdslMaintLoopbackConfig
   }
   STATUS     current
   DESCRIPTION
     &quot;This notification indicates that an endpoint maintenance
      loopback command failed for an HDSL2/SHDSL segment.&quot;
   ::= { hdsl2ShdslNotifications 9 }

hdsl2ShdslpowerBackoff NOTIFICATION-TYPE
   OBJECTS
   {
   hdsl2ShdslEndpointCurrStatus
   }
   STATUS    current
   DESCRIPTION
     &quot;This notification indicates that the bit setting for
      powerBackoff in the hdsl2ShdslEndpointCurrStatus object for
      this endpoint has changed.&quot;
   ::= { hdsl2ShdslNotifications 10 }

hdsl2ShdsldeviceFault NOTIFICATION-TYPE
   OBJECTS
   {
   hdsl2ShdslEndpointCurrStatus
   }
   STATUS    current
   DESCRIPTION
     &quot;This notification indicates that the bit setting for
      deviceFault in the hdsl2ShdslEndpointCurrStatus object for
      this endpoint has changed.&quot;
   ::= { hdsl2ShdslNotifications 11 }

hdsl2ShdsldcContinuityFault NOTIFICATION-TYPE
   OBJECTS
   {
   hdsl2ShdslEndpointCurrStatus
   }
   STATUS    current
   DESCRIPTION
     &quot;This notification indicates that the bit setting for
      dcContinuityFault in the hdsl2ShdslEndpointCurrStatus object
      for this endpoint has changed.&quot;
   ::= { hdsl2ShdslNotifications 12 }

hdsl2ShdslconfigInitFailure NOTIFICATION-TYPE
   OBJECTS
   {
   hdsl2ShdslEndpointCurrStatus
   }
   STATUS    current
   DESCRIPTION
     &quot;This notification indicates that the bit setting for
      configInitFailure in the hdsl2ShdslEndpointCurrStatus object
      for this endpoint has changed.&quot;
   ::= { hdsl2ShdslNotifications 13 }

hdsl2ShdslprotocolInitFailure NOTIFICATION-TYPE
   OBJECTS
   {
   hdsl2ShdslEndpointCurrStatus
   }
   STATUS    current
   DESCRIPTION
     &quot;This notification indicates that the bit setting for
      protocolInitFailure in the hdsl2ShdslEndpointCurrStatus
      object for this endpoint has changed.&quot;
   ::= { hdsl2ShdslNotifications 14 }

hdsl2ShdslnoNeighborPresent NOTIFICATION-TYPE
   OBJECTS
   {
   hdsl2ShdslEndpointCurrStatus
   }
   STATUS    current
   DESCRIPTION
     &quot;This notification indicates that the bit setting for
      noNeighborPresent in the hdsl2ShdslEndpointCurrStatus object
      for this endpoint has changed.&quot;
   ::= { hdsl2ShdslNotifications 15 }

hdsl2ShdslLocalPowerLoss NOTIFICATION-TYPE
   OBJECTS
   {
   hdsl2ShdslInvVendorID
   }
   STATUS    current
   DESCRIPTION
     &quot;This notification indicates impending unit failure due to
      loss of local power (last gasp).&quot;
   ::= { hdsl2ShdslNotifications 16 }

-- conformance information
--

hdsl2ShdslConformance OBJECT IDENTIFIER ::= { hdsl2ShdslMIB 3 }
hdsl2ShdslGroups      OBJECT IDENTIFIER ::=
             { hdsl2ShdslConformance 1 }
hdsl2ShdslCompliances OBJECT IDENTIFIER ::=
             { hdsl2ShdslConformance 2 }

-- agent compliance statements

hdsl2ShdslLineMibCompliance MODULE-COMPLIANCE
   STATUS  deprecated
   DESCRIPTION
     &quot;The compliance statement for SNMP entities which implement 
     HDSL2 and SHDSL.  The version of SHDSL supported in this
     compliance statement is g.shdsl.

     **** This compliance statement is deprecated. ****&quot;
   MODULE
   MANDATORY-GROUPS
   {
   hdsl2ShdslSpanConfGroup,
   hdsl2ShdslSpanStatusGroup,
   hdsl2ShdslInventoryGroup,
   hdsl2ShdslEndpointConfGroup,
   hdsl2ShdslEndpointCurrGroup,
   hdsl2Shdsl15MinIntervalGroup,
   hdsl2Shdsl1DayIntervalGroup,
   hdsl2ShdslMaintenanceGroup,
   hdsl2ShdslEndpointAlarmConfGroup,
   hdsl2ShdslNotificationGroup
   }

GROUP  hdsl2ShdslInventoryShdslGroup
   DESCRIPTION
     &quot;Support for this group is only required for implementations
     supporting SHDSL lines.&quot;

GROUP  hdsl2ShdslSpanShdslStatusGroup
   DESCRIPTION
     &quot;Support for this group is only required for implementations
     supporting SHDSL lines.&quot;

GROUP  hdsl2ShdslSpanConfProfileGroup
   DESCRIPTION
     &quot;Support for this group is only required for implementations
     supporting SHDSL lines.&quot;

OBJECT hdsl2ShdslSpanConfWireInterface
   SYNTAX      INTEGER
               {
               twoWire(1),
               fourWire(2)
               }
   DESCRIPTION
     &quot;An implementation only has to support the range as
     applicable for the original g.shdsl specification defined
     in RFC 3276.&quot;

OBJECT hdsl2ShdslStatusMaxAttainableLineRate
   SYNTAX      Unsigned32(0..4112000)
   DESCRIPTION
     &quot;An implementation only has to support the range as
     applicable for the original g.shdsl specification defined
     in RFC 3276.&quot;

OBJECT hdsl2ShdslStatusActualLineRate
   SYNTAX      Unsigned32(0..4112000)
   DESCRIPTION
     &quot;An implementation only has to support the range as
     applicable for the original g.shdsl specification defined
     in RFC 3276.&quot;

OBJECT hdsl2ShdslSpanConfMinLineRate
   SYNTAX      Unsigned32(0..4112000)
   DESCRIPTION
     &quot;An implementation only has to support the range as
     applicable for the original g.shdsl specification defined
     in RFC 3276.&quot;

OBJECT hdsl2ShdslSpanConfMaxLineRate
   SYNTAX      Unsigned32(0..4112000)
   DESCRIPTION
     &quot;An implementation only has to support the range as
     applicable for the original g.shdsl specification defined
     in RFC 3276.&quot;

   ::= { hdsl2ShdslCompliances 1 }

hdsl2GshdslbisLineMibCompliance MODULE-COMPLIANCE
   STATUS  current
   DESCRIPTION
     &quot;The compliance statement for SNMP entities which implement 
     HDSL2 and SHDSL.  The version of SHDSL supported in this 
     compliance statement is g.shdsl.bis.&quot;
   MODULE
   MANDATORY-GROUPS
   {
   hdsl2ShdslSpanConfGroup,
   hdsl2ShdslSpanStatusGroup,
   hdsl2ShdslInventoryGroup,
   hdsl2ShdslEndpointConfGroup,
   hdsl2ShdslEndpointCurrGroup,
   hdsl2Shdsl15MinIntervalGroup,
   hdsl2Shdsl1DayIntervalGroup,
   hdsl2ShdslMaintenanceGroup,
   hdsl2ShdslEndpointAlarmConfGroup,
   hdsl2ShdslNotificationGroup
   }

GROUP  hdsl2ShdslInventoryShdslGroup
   DESCRIPTION
     &quot;Support for this group is only required for implementations
     supporting SHDSL lines.&quot;

GROUP  hdsl2ShdslSpanShdslStatusGroup
   DESCRIPTION
     &quot;Support for this group is only required for implementations
     supporting SHDSL lines.&quot;

GROUP  hdsl2ShdslSpanConfProfileGroup
   DESCRIPTION
     &quot;Support for this group is only required for implementations
     supporting SHDSL lines.&quot;

GROUP hdsl2ShdslWirePairGroup
   DESCRIPTION
     &quot;Support for this group is only required for implementations
     supporting SHDSL lines.&quot;

GROUP hdsl2ShdslPayloadRateGroup
   DESCRIPTION
     &quot;Support for this group is only required for implementations
     supporting SHDSL lines.&quot;

   ::= { hdsl2ShdslCompliances 2 }

-- units of conformance
--

hdsl2ShdslSpanConfGroup OBJECT-GROUP
   OBJECTS
   {
   hdsl2ShdslSpanConfNumRepeaters,
   hdsl2ShdslSpanConfProfile,
   hdsl2ShdslSpanConfAlarmProfile
   }
   STATUS      current
   DESCRIPTION
     &quot;This group supports objects for configuring span related
      parameters for HDSL2/SHDSL lines.&quot;
   ::= { hdsl2ShdslGroups 1 }

hdsl2ShdslSpanStatusGroup OBJECT-GROUP
   OBJECTS
   {
   hdsl2ShdslStatusNumAvailRepeaters
   }
   STATUS      current
   DESCRIPTION
     &quot;This group supports objects for retrieving span related
      status for HDSL2/SHDSL lines.&quot;
   ::= { hdsl2ShdslGroups 2 }

hdsl2ShdslInventoryShdslGroup OBJECT-GROUP
   OBJECTS
   {
   hdsl2ShdslInvTransmissionModeCapability
   }
   STATUS      current
   DESCRIPTION
     &quot;This group supports objects for retrieving SHDSL-specific
      inventory information.&quot;
   ::= { hdsl2ShdslGroups 3 }

hdsl2ShdslSpanShdslStatusGroup OBJECT-GROUP
   OBJECTS
   {
   hdsl2ShdslStatusMaxAttainableLineRate,
   hdsl2ShdslStatusActualLineRate,
   hdsl2ShdslStatusTransmissionModeCurrent
   }
   STATUS      current
   DESCRIPTION
     &quot;This group supports objects for retrieving SHDSL-specific
      span related status.&quot;
   ::= { hdsl2ShdslGroups 4 }

hdsl2ShdslInventoryGroup OBJECT-GROUP
   OBJECTS
   {
   hdsl2ShdslInvVendorID,
   hdsl2ShdslInvVendorModelNumber,
   hdsl2ShdslInvVendorSerialNumber,
   hdsl2ShdslInvVendorEOCSoftwareVersion,
   hdsl2ShdslInvStandardVersion,
   hdsl2ShdslInvVendorListNumber,
   hdsl2ShdslInvVendorIssueNumber,
   hdsl2ShdslInvVendorSoftwareVersion,
   hdsl2ShdslInvEquipmentCode,
   hdsl2ShdslInvVendorOther
   }
   STATUS      current
   DESCRIPTION
     &quot;This group supports objects that provide unit inventory
      information about the units in HDSL2/SHDSL lines.&quot;
   ::= { hdsl2ShdslGroups 5 }

hdsl2ShdslEndpointConfGroup OBJECT-GROUP
   OBJECTS
   {
   hdsl2ShdslEndpointCurrAtn
   }
   STATUS      current
   DESCRIPTION
     &quot;This group supports objects for configuring parameters for
      segment endpoints in HDSL2/SHDSL lines.&quot;
   ::= { hdsl2ShdslGroups 6 }

hdsl2ShdslEndpointCurrGroup OBJECT-GROUP
   OBJECTS
   {
   hdsl2ShdslEndpointCurrAtn,
   hdsl2ShdslEndpointCurrSnrMgn,
   hdsl2ShdslEndpointCurrStatus,
   hdsl2ShdslEndpointES,
   hdsl2ShdslEndpointSES,
   hdsl2ShdslEndpointCRCanomalies,
   hdsl2ShdslEndpointLOSWS,
   hdsl2ShdslEndpointUAS,
   hdsl2ShdslEndpointCurr15MinTimeElapsed,
   hdsl2ShdslEndpointCurr15MinES,
   hdsl2ShdslEndpointCurr15MinSES,
   hdsl2ShdslEndpointCurr15MinCRCanomalies,
   hdsl2ShdslEndpointCurr15MinLOSWS,
   hdsl2ShdslEndpointCurr15MinUAS,
   hdsl2ShdslEndpointCurr1DayTimeElapsed,
   hdsl2ShdslEndpointCurr1DayES,
   hdsl2ShdslEndpointCurr1DaySES,
   hdsl2ShdslEndpointCurr1DayCRCanomalies,
   hdsl2ShdslEndpointCurr1DayLOSWS,
   hdsl2ShdslEndpointCurr1DayUAS
   }
   STATUS      current
   DESCRIPTION
     &quot;This group supports objects which provide current status and
      performance measurements relating to segment endpoints in
      HDSL2/SHDSL lines.&quot;
   ::= { hdsl2ShdslGroups 7 }

hdsl2Shdsl15MinIntervalGroup OBJECT-GROUP
   OBJECTS
   {
   hdsl2Shdsl15MinIntervalES,
   hdsl2Shdsl15MinIntervalSES,
   hdsl2Shdsl15MinIntervalCRCanomalies,
   hdsl2Shdsl15MinIntervalLOSWS,
   hdsl2Shdsl15MinIntervalUAS
   }
   STATUS      current
   DESCRIPTION
     &quot;This group supports objects which maintain historic
      performance measurements relating to segment endpoints in
      HDSL2/SHDSL lines in 15-minute intervals.&quot;
   ::= { hdsl2ShdslGroups 8 }

hdsl2Shdsl1DayIntervalGroup OBJECT-GROUP
   OBJECTS
   {
   hdsl2Shdsl1DayIntervalMoniSecs,
   hdsl2Shdsl1DayIntervalES,
   hdsl2Shdsl1DayIntervalSES,
   hdsl2Shdsl1DayIntervalCRCanomalies,
   hdsl2Shdsl1DayIntervalLOSWS,
   hdsl2Shdsl1DayIntervalUAS
   }
   STATUS      current
   DESCRIPTION
     &quot;This group supports objects which maintain historic
      performance measurements relating to segment endpoints in
      HDSL2/SHDSL lines in 1-day intervals.&quot;
   ::= { hdsl2ShdslGroups 9 }

hdsl2ShdslMaintenanceGroup OBJECT-GROUP
   OBJECTS
   {
   hdsl2ShdslMaintLoopbackConfig,
   hdsl2ShdslMaintTipRingReversal,
   hdsl2ShdslMaintPowerBackOff,
   hdsl2ShdslMaintSoftRestart,
   hdsl2ShdslMaintLoopbackTimeout,
   hdsl2ShdslMaintUnitPowerSource
   }
   STATUS      current
   DESCRIPTION
     &quot;This group supports objects that provide support for
      maintenance actions for HDSL2/SHDSL lines.&quot;
   ::= { hdsl2ShdslGroups 10 }

hdsl2ShdslEndpointAlarmConfGroup OBJECT-GROUP
   OBJECTS
   {
   hdsl2ShdslEndpointAlarmConfProfile,
   hdsl2ShdslEndpointThreshLoopAttenuation,
   hdsl2ShdslEndpointThreshSNRMargin,
   hdsl2ShdslEndpointThreshES,
   hdsl2ShdslEndpointThreshSES,
   hdsl2ShdslEndpointThreshCRCanomalies,
   hdsl2ShdslEndpointThreshLOSWS,
   hdsl2ShdslEndpointThreshUAS,
   hdsl2ShdslEndpointAlarmConfProfileRowStatus
   }
   STATUS      current
   DESCRIPTION
     &quot;This group supports objects that allow configuration of alarm
      thresholds for various performance parameters for HDSL2/SHDSL
      lines.&quot;
   ::= { hdsl2ShdslGroups 11 }

hdsl2ShdslNotificationGroup NOTIFICATION-GROUP
   NOTIFICATIONS
   {
   hdsl2ShdslLoopAttenCrossing,
   hdsl2ShdslSNRMarginCrossing,
   hdsl2ShdslPerfESThresh,
   hdsl2ShdslPerfSESThresh,
   hdsl2ShdslPerfCRCanomaliesThresh,
   hdsl2ShdslPerfLOSWSThresh,
   hdsl2ShdslPerfUASThresh,
   hdsl2ShdslSpanInvalidNumRepeaters,
   hdsl2ShdslLoopbackFailure,
   hdsl2ShdslpowerBackoff,
   hdsl2ShdsldeviceFault,
   hdsl2ShdsldcContinuityFault,
   hdsl2ShdslconfigInitFailure,
   hdsl2ShdslprotocolInitFailure,
   hdsl2ShdslnoNeighborPresent,
   hdsl2ShdslLocalPowerLoss
   }
   STATUS      current
   DESCRIPTION
     &quot;This group supports notifications of significant conditions
      associated with HDSL2/SHDSL lines.&quot;
   ::= { hdsl2ShdslGroups 12 }

hdsl2ShdslSpanConfProfileGroup OBJECT-GROUP
   OBJECTS
   {
   hdsl2ShdslSpanConfWireInterface,
   hdsl2ShdslSpanConfMinLineRate,
   hdsl2ShdslSpanConfMaxLineRate,
   hdsl2ShdslSpanConfPSD,
   hdsl2ShdslSpanConfTransmissionMode,
   hdsl2ShdslSpanConfRemoteEnabled,
   hdsl2ShdslSpanConfPowerFeeding,
   hdsl2ShdslSpanConfCurrCondTargetMarginDown,
   hdsl2ShdslSpanConfWorstCaseTargetMarginDown,
   hdsl2ShdslSpanConfCurrCondTargetMarginUp,
   hdsl2ShdslSpanConfWorstCaseTargetMarginUp,
   hdsl2ShdslSpanConfUsedTargetMargins,
   hdsl2ShdslSpanConfReferenceClock,
   hdsl2ShdslSpanConfLineProbeEnable,
   hdsl2ShdslSpanConfProfileRowStatus
   }
   STATUS      current
   DESCRIPTION
     &quot;This group supports objects that constitute configuration
      profiles for configuring span related parameters in SHDSL
      lines.&quot;
   ::= { hdsl2ShdslGroups 13 }

hdsl2ShdslWirePairGroup OBJECT-GROUP
   OBJECTS
   {
   hdsl2ShdslEndpointCurrTipRingReversal,
   hdsl2ShdslEndpointCurrActivationState
   }
   STATUS      current
   DESCRIPTION
     &quot;This group supports objects which provide the status 
      of SHDSL-specific wire pairs.&quot;
   ::= { hdsl2ShdslGroups 14 }

hdsl2ShdslPayloadRateGroup OBJECT-GROUP
   OBJECTS
   {
   hdsl2ShdslStatusMaxAttainablePayloadRate,
   hdsl2ShdslStatusActualPayloadRate
   }
   STATUS      current
   DESCRIPTION
     &quot;This group supports object for retrieving payload rates
      which excludes any framing overhead.&quot;
   ::= { hdsl2ShdslGroups 15 }

END

    </artwork></figure>

    </section>  <!--  title="Definitions"  -->
    
    <section title="Implementation Analysis" anchor="Implementation Analysis">

        <t>
            A management application which supports RFC 3276 could mistakenly
            flag a unit which responds with a rate or wire pair which exceeds
            the ranges and/or enumerations specified in RFC 3276.  For example,
            a G.shdsl.bis line with four wire pairs would report statistics
            for wire pairs that do not exist in RFC 3276.  That is, a 
            GET-NEXT request issues with the object identifier:
            <vspace blankLines="1" />
            <list style="empty">
                <t>
                    hdsl2ShdslEndpointCurrAtn.1.1.1.2
                </t>
            </list>
            <vspace blankLines="1" />

            might return
            <vspace blankLines="1" />

            <list style="empty">
                <t>
                    hdsl2ShdslEndpointCurrAtn.1.1.1.3 = 0
                </t>
            </list>
            <vspace blankLines="1" />

            with a G.shdsl.bis unit and
            <vspace blankLines="1" />

            <list style="empty">
                <t>
                    hdsl2ShdslEndpointCurrSnrMgn.1.1.1.1 = 0
                </t>
            </list>
            <vspace blankLines="1" />

            with an HDSL2 unit as these objects are indexed by
            <vspace blankLines="0" />

            <figure><artwork>
   INDEX  { ifIndex, hdsl2ShdslInvIndex, hdsl2ShdslendpointSide,
            hdsl2ShdslEndpointWirePair }
            </artwork></figure>

        </t>
        <t>
            A management application intended to manage G.shdsl.bis agents
            SHOULD be modified to accept this sequence.
        </t>
        <t>
            One should note that this same unmodified management application is
            still capable of managing G.shdsl.bis agents albeit to the degree
            of G.SHDSL (non-bis) limitations.  That is, it can create and monitor
            configurations limited to two wire pairs with an upper rate limit
            of 4112000 bits/second.
        </t>

    </section>  <!--  title="Implementation Analysis"  -->

    <section title="Security Considerations">

        <t>
            There are a number of management objects defined in this MIB module
            with a MAX-ACCESS clause of read-write and/or read-create.  Such
            objects may be considered sensitive or vulnerable in some network
            environments.  The support for SET operations in a non-secure
            environment without proper protection can have a negative effect on
            network operations.  These are the tables and objects and their
            sensitivity/vulnerability:
            <vspace blankLines="1" />

            <list style="symbols">
                <t>
                    hdsl2ShdslSpanConfTable
                    <vspace blankLines="1" />

                    The table consists of the following objects that support 
                    SET operations:
                    <vspace blankLines="1" />

                    <list style="symbols">
                        <t> hdsl2ShdslSpanConfNumRepeaters  </t>
                        <t> hdsl2ShdslSpanConfProfile       </t>
                        <t> hdsl2ShdslSpanConfAlarmProfile  </t>
                    </list>
                    <vspace blankLines="1" />

                    Unauthorized changes to hdsl2ShdslSpanConfNumRepeaters could result 
                    in a hdsl2ShdslSpanInvalidNumRepeaters notification.  Note the discussion 
                    on hdsl2ShdslSpanInvalidNumRepeaters in the Notifications Section above.
                    <vspace blankLines="1" />

                    Unauthorized changes to hdsl2ShdslSpanConfProfile could have an adverse
                    operational effect on a span. Reference the 
                    hdsl2ShdslSpanConfProfileTable discussion below.
                    <vspace blankLines="1" />

                    Unauthorized changes to hdsl2ShdslSpanConfAlarmProfile could have a
                    contrary effect on notifications. Reference the 
                    hdsl2ShdslEndpointAlarmConfProfileTable discussion below.
                    <vspace blankLines="1" />
                </t>
                <t>
                    hdsl2ShdslEndpointConfTable
                    <vspace blankLines="1" />

                    This table contains one object, hdsl2ShdslEndpointAlarmConfProfile,
                    that supports SET operations. Unauthorized changes could have an
                    undesirable notifications. Reference the 
                    hdsl2ShdslEndpointAlarmConfProfileTable discussion below.
                    <vspace blankLines="1" />
                </t>
                <t>
                    hdsl2ShdslEndpointMaintTable
                    <vspace blankLines="1" />

                    The table consists of the following objects that support 
                    SET operations:
                    <vspace blankLines="1" />

                    <list style="symbols">                    
                        <t> hdsl2ShdslMaintLoopbackConfig </t>
                        <t> hdsl2ShdslMaintPowerBackoff   </t>
                        <t> hdsl2ShdslMaintSoftRestart    </t>
                    </list >
                    <vspace blankLines="1" />

                    Unauthorized changes to hdsl2ShdslMaintLoopbackConfig 
                    could prevent end-to-end data transfer due to an activation
                    of a loopback.
                    <vspace blankLines="1" />

                    Unauthorized changes to hdsl2ShdslMaintPowerBackoff could
                    result in an increased in bundle interference.
                    <vspace blankLines="1" />

                    Unauthorized changes to hdsl2ShdslMaintSoftRestart could
                    result in a temporary interruption of end-to-end data
                    transfer as the result of the triggering of a soft restart.
                    <vspace blankLines="1" />
                   
                </t>
                <t>
                    hdsl2ShdslUnitMaintTable
                    <vspace blankLines="1" />

                    This table contains one object, hdsl2ShdslMaintLoopbackTimeout,
                    that supports SET operations. An unauthorized change to this
                    object could result in the timeout value for loopbacks being
                    increased, decreased, or disabled.
                    <vspace blankLines="1" />              
                </t>
                <t>
                    hdsl2ShdslSpanConfProfileTable
                    <vspace blankLines="1" />                    

                    The table consists of the following objects that support 
                    SET operations:
                    <vspace blankLines="1" />

                    <list style="symbols">
                        <t> hdsl2ShdslSpanConfWireInterface             </t>
                        <t> hdsl2ShdslSpanConfMinLineRate               </t>
                        <t> hdsl2ShdslSpanConfMaxLineRate               </t>
                        <t> hdsl2ShdslSpanConfPSD                       </t>
                        <t> hdsl2ShdslSpanConfTransmissionMode          </t>
                        <t> hdsl2ShdslSpanConfRemoteEnabled             </t>
                        <t> hdsl2ShdslSpanConfPowerFeeding              </t>
                        <t> hdsl2ShdslSpanConfCurrCondTargetMarginDown  </t>
                        <t> hdsl2ShdslSpanConfWorstCaseTargetMarginDown </t>
                        <t> hdsl2ShdslSpanConfCurrCondTargetMarginUp    </t>
                        <t> hdsl2ShdslSpanConfWorstCaseTargetMarginUp   </t>
                        <t> hdsl2ShdslSpanConfUsedTargetMargins         </t>
                        <t> hdsl2ShdslSpanConfReferenceClock            </t>
                        <t> hdsl2ShdslSpanConfLineProbeEnable           </t>
                        <t> hdsl2ShdslSpanConfProfileRowStatus          </t>
                    </list>
                    <vspace blankLines="1" />            

                    Setting any of the objects to an incorrect value could have an 
                    adverse operational effect on a span.
                    <vspace blankLines="1" />

                    Unauthorized changes to the hdsl2ShdslSpanConfWireInterface
                    could result in the failure of a span to achieve activation
                    to a state that would permit data flow. For example, setting
                    this object to six-wire or eight-wire operation when one of the 
                    units in the span only supports two-wire or four-wire operation
                    would likely prevent an expected end-to-end data transfer 
                    capability.
                    <vspace blankLines="1" />

                    Unauthorized changes to hdsl2ShdslSpanConfMinLineRate or
                    hdsl2ShdslSpanConfMaxLineRate could have an adverse effect
                    on performance. The range of allowable line rates could be 
                    altered such that the span may not be able to train to an
                    line rate that would permit any end-user data to traverse 
                    the span or the span could train to a line rate that is 
                    either greater than or less than the line rate that the 
                    provider has pledged.
                    <vspace blankLines="1" />

                    Unauthorized changes to hdsl2ShdslSpanConfPSD or
                    hdsl2ShdslSpanConfTransmissionMode could have a detrimental
                    effect loop reach, performance, or spectral compatibility.
                    <vspace blankLines="1" />

                    Unauthorized changes to hdsl2ShdslSpanConfRemoteEnable could
                    alter the remote management ability of units.
                    <vspace blankLines="1" />

                    Unauthorized changes to hdsl2ShdslSpanConfPowerFeeding could
                    shutdown units that are expected to be feed power remotely.
                    Changing the configuration such that wetting current is 
                    not supplied may result in corrosion of electrical contacts.
                    <vspace blankLines="1" />

                    Unauthorized changes to 
                    hdsl2ShdslSpanConfCurrCondTargetMarginDown,
                    hdsl2ShdslSpanConfWorstCaseTargetMarginDown,
                    hdsl2ShdslSpanConfCurrCondTargetMarginUp,
                    hdsl2ShdslSpanConfWorstCaseTargetMarginUp, or
                    hdsl2ShdslSpanConfUsedTargetMargins could result in invalid
                    parameters used to determine if a data rate can be supported
                    under current and worst-case noise.
                    <vspace blankLines="1" />

                    Unauthorized changes to hdsl2ShdslSpanConfReferenceClock could 
                    result in the selection of a clock source which might either
                    prevent any data from being transferred or impair data 
                    transfer. In addition, an increase in CRC anomalies may be
                    experienced.
                    <vspace blankLines="1" />

                    Unauthorized changes to hdsl2ShdslSpanConfLineProbeEnable could
                    have a negative effect on selecting the optimum rate or power 
                    level based on current line conditions.
                    <vspace blankLines="1" />

                    Unauthorized changes to row status could result in 
                    unwanted profiles being created or brought into
                    service.  Also, changes to the row status could result
                    in profiles being inadvertently deleted or taken out of 
                    service.
                    <vspace blankLines="1" />
             
                </t>
                <t>
                    hdsl2ShdslEndpointAlarmConfProfileTable
                    <vspace blankLines="1" />

                    The table consists of the following objects that support 
                    SET operations:
                    <vspace blankLines="1" />

                    <list style="symbols">
                        <t> hdsl2ShdslEndpointThreshLoopAttenuation      </t>
                        <t> hdsl2ShdslEndpointThreshSNRMargin            </t>
                        <t> hdsl2ShdslEndpointThreshES                   </t>
                        <t> hdsl2ShdslEndpointThreshSES                  </t>
                        <t> hdsl2ShdslEndpointThreshCRCanomalies         </t>
                        <t> hdsl2ShdslEndpointThreshLOSWS                </t>
                        <t> hdsl2ShdslEndpointThreshUAS                  </t>
                        <t> hdsl2ShdslEndpointAlarmConfProfileRowStatus  </t>
                    </list>
                    <vspace blankLines="1" />

                    Increasing any of the threshold values could result a
                    notification being suppressed or deferred. Setting a 
                    threshold to 0 could result in a notification being 
                    suppressed. Suppressing or deferring a notification could 
                    prevent the timely delivery of important diagnostic 
                    information. Decreasing any of the threshold values 
                    could result in a notification being sent from the 
                    network falsely reporting a threshold crossing. 
                    <vspace blankLines="1" />

                    Changing a threshold value could also have an impact
                    on the amount of notifications the agent sends.  This
                    document adds a paragraph, which was not in  
                    RFC 3276 <xref target="RFC3276"/>, to the Notifications 
                    Section which provides general guidance to the rate
                    limiting of notifications.  Agent implementations not 
                    adhering to the rate-limiting desires could result in 
                    notifications being generated at an uncontrolled rate.  
                    Unauthorized changes to a threshold value could result 
                    in an undesired notification rate.
                    <vspace blankLines="1" />

                    Unauthorized changes to row status could result in 
                    unwanted profiles being created or brought into
                    service.  Also, changes to the row status could result
                    in profiles being inadvertently deleted or taken out of 
                    service.
                </t>
            </list>
        </t>   
        <t>
            Some of the readable objects in this MIB module (i.e., objects with a
            MAX-ACCESS other than not-accessible) may be considered sensitive or
            vulnerable in some network environments.  It is thus important to
            control even GET and/or NOTIFY access to these objects and possibly
            to even encrypt the values of these objects when sending them over
            the network via SNMP.  These are the tables and objects and their
            sensitivity/vulnerability:
            <vspace blankLines="1" />

            <list style="symbols">
                <t>
                    hdsl2ShdslInventoryTable
                    <vspace blankLines="1" />

                    Access to these objects would allow an intruder to obtain 
                    information about which vendor&apos;s equipment is in use on 
                    the network.  Further, such information is considered sensitive 
                    in many environments for competitive reasons.
                    <vspace blankLines="1" />

                    <list style="symbols">
                        <t> hdsl2ShdslInvVendorID                     </t>
                        <t> hdsl2ShdslInvVendorModelNumber            </t>
                        <t> hdsl2ShdslInvVendorSerialNumber           </t>
                        <t> hdsl2ShdslInvVendorEOCSoftwareVersion     </t>
                        <t> hdsl2ShdslInvStandardVersion              </t>
                        <t> hdsl2ShdslInvVendorListNumber             </t>
                        <t> hdsl2ShdslInvVendorIssueNumber            </t>
                        <t> hdsl2ShdslInvVendorSoftwareVersion        </t>
                        <t> hdsl2ShdslInvEquipmentCode                </t>
                        <t> hdsl2ShdslInvVendorOther                  </t>
                        <t> hdsl2ShdslInvTransmissionModeCapability   </t>
                    </list>
                </t>
            </list>
        </t>     
        <t>
            SNMP versions prior to SNMPv3 did not include adequate security.
            Even if the network itself is secure (for example by using IPSec),
            even then, there is no control as to who on the secure network is
            allowed to access and GET/SET (read/change/create/delete) the objects
            in this MIB module.
        </t>
        <t>
            It is RECOMMENDED that implementers consider the security features as
            provided by the SNMPv3 framework (see [RFC3410], Section 8),
            including full support for the SNMPv3 cryptographic mechanisms (for
            authentication and privacy).
        </t>
        <t>
            Further, deployment of SNMP versions prior to SNMPv3 is NOT
            RECOMMENDED.  Instead, it is RECOMMENDED to deploy SNMPv3 and to
            enable cryptographic security.  It is then a customer/operator
            responsibility to ensure that the SNMP entity giving access to an
            instance of this MIB module is properly configured to give access to
            the objects only to those principals (users) that have legitimate
            rights to indeed GET or SET (change/create/delete) them.
        </t>    

    </section>  <!--  title="Security Considerations"  -->

    <section title="Acknowledgments">
 
        <t>
            The authors are deeply grateful to the authors of the ADSL LINE MIB
            (RFC 2662 <xref target="RFC2662"/>), Gregory Bathrick and Faye Ly, as much of the text
            and structure of this document originates in their documents.
        </t>
        <t>
            The authors are also grateful to the authors of FR MFR MIB (RFC 3020
            <xref target="RFC3020"/>), Prayson Pate, Bob Lynch, and Kenneth Rehbehn, as the majority
            of the Security Considerations section was lifted from their
            document.
        </t>
        <t>
            The authors also acknowledge the importance of the contributions and
            suggestions regarding interface indexing structures received from
            David Horton of CITR.
        </t>
        <t>
            The authors are extremely thankful to Bert Wijnen, Randy Presuhn, and 
            C. M. Heard for their extensive review and the many suggestions they provided.
        </t>
        <t>
            Other contributions were received from the following:

            <figure><artwork>
      Matt Beanland (Extel Communications)
      Philip Bergstresser (Adtran)
      Steve Blackwell (Centillium)
      Umberto Bonollo (NEC Australia)
      John Egan (Metalink BroadBand)
      Yagal Hachmon (RAD)
      Mark Johnson (Red Point)
      Sharon Mantin (Orckit)
      Moti Morgenstern (ECI)
      Raymond Murphy (Ericsson)
      Lee Nipper (Verilink)
      Randy Presuhn (BMC Software)
      Katy Sherman (Orckit)
      Mike Sneed (ECI)
      Jon Turney (DSL Solutions)
      Aron Wahl (Memotec)
      Jim Wilson (for Mindspeed)
      Bert Wijnen (Lucent)
      Michael Wrobel (Memotec)
            </artwork></figure>
        </t>
  
    </section>  <!--  title="Acknowledgments"  -->

</middle>

<back>
    <references title="Normative References">

        &rfc2119;
        &rfc2578;
        &rfc2579;
        &rfc2580;
        &rfc2863;
        &rfc3411;
        &rfc3593;

        <reference anchor="T1E1.4">
            <front>
                <title abbrev="ANSI T1E1.4">
                    ANSI T1E1.4/2000-006
                </title>
                 <author initials="" surname="American National Standards Institute">
                    <organization/>
                </author>
                <date month="February" year="2000" />
            </front>
        </reference>

        <reference anchor="G.991.2">
            <front>
                <title abbrev="ITU-T G.991.2">
                    Single-Pair High-Speed Digital Subscriber Line (SHDSL) Transceivers
                </title>
                <author initials="S." surname="Blackwell">
                    <organization/>
                </author>
                <date month="December" year="2003" />
            </front>
             <seriesInfo name="ITU-T" value="G.991.2" />
        </reference>

    </references>

    <references title="Informative References">

        &rfc2662;
        &rfc3020;
        &rfc3276;
        &rfc3410;
        &rfc3418;

    </references>
</back>

</rfc>