Subject: [Adslmib] draft-ietf-adslmib-vdsl2-03.txt

From: "Moti Morgenstern" <[email-masked]>
Date: Sun, 7 Oct 2007 13:18:40 +0200

Hello all,

I've submitted the -03 version to the internet-drafts. 

This version is still not the final one. It reflects objects from
ITU-T G.997.1 rev. 3 that were missing till now, as well as 
objects added to the ITU-T model only after G.997.1 rev. 3
was consented.

Here are the main changes included in this revision
compared to -02 version.

1) Added textual conventions, such as:
- Xdsl2LinePsdMaskSelectUs
- Xdsl2LineCeFlag,
- Xdsl2LineSnrMode,
- Xdsl2LineTxRefVnDs,
- Xdsl2LineTxRefVnUs
- Xdsl2SymbolProtection8
- Xdsl2LineForceInp
- Xdsl2LineReset
- Xdsl2RfiBands

2) Added the symbolic names of objects as appear in G.997.1 to
     complement the reference clause.  Those names appear as 
     part of the objects' description clause.

3) Added dozens of objects that were missing in rev -02, such as:
- xdsl2LConfProfCeFlag
- xdsl2LConfProfSnrModeDs
- xdsl2LConfProfSnrModeUs
- xdsl2LConfProfTxRefVnDs
- xdsl2LConfProfTxRefVnUs
- xdsl2ChConfProfMinDataRateLowPwrDs
- xdsl2ChConfProfMinProtection8Ds
- xdsl2ChConfProfMinProtection8Us
- xdsl2LConfProfForceInp
- xdsl2LineStatusActProfile
- xdsl2LineStatusActLimitMask
- xdsl2LineStatusActUs0Mask
- xdsl2LineStatusActSnrModeDs
- xdsl2LineStatusActSnrModeUs
- xdsl2LineStatusElectricalLength
- xdsl2LineStatusTrellisDs
- xdsl2LineStatusTrellisUs
- xdsl2LineStatusActualCe
- xdsl2ChStatusActInp
- xdsl2ChStatusInpReport
- xdsl2ChStatusNFec
- xdsl2ChStatusRFec
- xdsl2ChStatusLSymb
- xdsl2ChStatusIntlvDepth
- xdsl2ChStatusIntlvBlock
- xdsl2ChStatusLPath
- xdsl2PMLCurrInit15MValidIntervals
- xdsl2PMLCurrInit15MInvalidIntervals
- xdsl2PMLCurrInit1DayValidIntervals
- xdsl2PMLCurrInit1DayInvalidIntervals
- xdsl2LineCmndConfReset

4) Updated the reference clause of objects, as result of 
     changes made to ITU-T G.997.1   

5) Changes to sub carrier status tables
- Clarify when values in these tables will be updated,
  i.e. after a DELT test, after line initialization
  or at show time.
- State explicitly the parent child relationship
  between the sub carrier status tables. That is,
  state the rules for creation and deletion.
- Remove xdsl2SCStatusBandSnrMargin from xdsl2SCStatusBandTable
  because SNR Margin is already available in
xdsl2LineBandStatusSnrMargin
  and SNR Margin is not a result from a DELT test.
- Remove xdsl2SCStatusActAtp from xdsl2SCStatusTable because
  Actual Aggregate Transmit Power is already available in
  xdsl2LineStatusActAtpDs and xdsl2LineStatusActAtpUs
  and Actual Aggregate Transmit Power is not a result
  from a DELT test.

6) Update description for xdsl2LConfProfRowStatus
- State explicitly the parent child relationship
  between the tables. That is,
  state the rules for creation and deletion where
  xdsl2LineConfProfTable is the master table and
  xdsl2LineConfProfModeSpecTable and
xdsl2LineConfProfModeSpecBandUsTable
  are child tables.

7) Changed description for xdsl2SCStatusSegment Attribute
- The new comment is like this :
  "GET operations for the remaining segment
  numbers (n+1 to 8) will respond with a zero length
  OCTET STRING."

8) Changed description for xdsl2LineCmndConfLdsf attribute
- Changed the comments so that they match the comments in G997.1.
- Removed the comment that stated that the attribute should be
persistent.

9) Changed description for xdsl2LineCmndAutomodeColdStart attribute
- Removed the comment that stated that the attribute should be
persistent.

10) Changed type of xdsl2LConfProfRfiBands attribute
- Changed the SYNTAX of this attribute to Xdsl2RfiBands.
  The new syntax specifies an array of bands where a
  band is defined by a start and stop subcarrier index.

11) Changed the UNITS clause for Power related attributes
- xdsl2LineStatusActPsdDs : dBm/Hz 
- xdsl2LineStatusActPsdUs : dBm/Hz 
- xdsl2LineStatusActAtpDs : dBm
- xdsl2LineStatusActAtpUs : dBm
- xdsl2LConfProfDpboMus : dBm/Hz

12) Added DEFVAL Clauses to attributes in
- xdsl2LineTable.
- xdsl2ChannelStatusTable.
- xdsl2LineBandTable.

13) Usage of ifStackTable
- Added a section in the first part of the document describing the use
of the ifStackTable.

14) Creation and Deletion of Rows when number of bearer channels changes
- Added a comment to the description of xdsl2LineConfTemplateTable 
  that specifies that when the number of bearer channels changes
  then rows should be created/deleted in tables indexed by a
  channel index.

15) Added an OPTIONAL mechanism to fetch the bits per SC during
Showtime.
This mechanism uses a  new table (xdsl2LineSegmentTable) as well as 3
attributes in xdsl2LineTable and several textual conventions.
The mechanism has also new conformance groups.

16) Changed wording in several locations
- The wording of several attributes and textual conventions
  was changed to help improve clarity. Also adapted text to ITU-T
  G.997.1 where was relevant.

17) Changed enumerated value name
- Changed forceImpulseNoiseProtection to forceFramerForInp 
  to improve clarity of the meaning.

18) Corrected few spelling errors.

Best Regards,
Moti Morgenstern

_______________________________________________
Adslmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/adslmib

---

From: "Menachem Dodge" <[email-masked]>
Date: Sun, 7 Oct 2007 14:59:13 +0200

Hello All,
 
    I would like to thank the editors, Moti, Scott and Umberto for their
efforts in producing this draft.
 
    As this document is approaching maturity, I would like to call on
the working group to review the document
and provide any feedback. This will assist the editors in their work on
the next version of the draft. 
 
    Best Regards,
    Menachem

________________________________

From: Moti Morgenstern [mailto:[email-masked]] 
Sent: Sunday, October 07, 2007 1:19 PM
To: [email-masked]
Cc: Wijnen, Bert (Bert)
Subject: [Adslmib] draft-ietf-adslmib-vdsl2-03.txt

Hello all,

was consented.

compared to -02 version.

- Xdsl2LineCeFlag,

- Xdsl2LineSnrMode,

- Xdsl2LineTxRefVnDs,

- Xdsl2LineTxRefVnUs

- Xdsl2SymbolProtection8

- Xdsl2LineForceInp

- Xdsl2LineReset

- Xdsl2RfiBands

- xdsl2LConfProfCeFlag

- xdsl2LConfProfForceInp

- xdsl2ChStatusActInp

- xdsl2ChStatusInpReport

- xdsl2ChStatusNFec

- xdsl2ChStatusRFec

- xdsl2ChStatusLSymb

- xdsl2ChStatusLPath

- xdsl2LineCmndConfReset

  or at show time.

  from a DELT test.

  are child tables.

  OCTET STRING."

- xdsl2LineTable.

- xdsl2LineBandTable.

  channel index.

Best Regards,

Moti Morgenstern