Subject: [Aeon] A paper about Skype and Vidyo adaptation when network conditions change

From: "Jose Saldana" <[email-masked]>
Date: Mon, 3 Mar 2014 17:31:22 -0000

Hi all,

During the discussion today in London we have talked about how applications
are able to self-adapt to network conditions.

Perhaps you may find this paper interesting:
http://downloads.hindawi.com/journals/tswj/2014/860170.pdf

We put a bandwidth limitation, additional delay and packet loss between the
two nodes making a video conference and we saw how the applications adapted
their traffic.

Best regards,

Jose Saldana

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 26 Mar 2014 18:02:29 +0000

Hi Jose,

Thanks for sharing this. It illustrates the capabilities of limitation of application adaptation in the absence of communication with the network. One of the primary goals of AEON is to remove the limitations highlighted in the paper.
For example, the applications responded to loss by increasing or maintaining their bandwidth utilization. In some cases, this is appropriate, but in others it is not. If the loss was due to congestion, sending more may hurt rather than help. If the network was able to inform the applications of the congestion, the applications could have taken better corrective action.
Similarly, the need to send redundant information at the start of the session could be removed, or at least minimized, in cases in which the application is able to receive some explicit information from the network.

Cheers,
Charles

From: Jose Saldana <[email-masked]<mailto:[email-masked]>>
Date: Monday, March 3, 2014 at 10:31 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Aeon] A paper about Skype and Vidyo adaptation when network conditions change

Hi all,

During the discussion today in London we have talked about how applications are able to self-adapt to network conditions.

Perhaps you may find this paper interesting: http://downloads.hindawi.com/journals/tswj/2014/860170.pdf

We put a bandwidth limitation, additional delay and packet loss between the two nodes making a video conference and we saw how the applications adapted their traffic.

Best regards,

Jose Saldana

---

From: "Jose Saldana" <[email-masked]>
Date: Mon, 31 Mar 2014 16:23:46 +0200

You are right. The idea is that if the applications do not have to “survive
in a hostile environment” (as the title of the paper says), they will not
need to use these aggressive policies. So let’s share information between
network and applications.
 
Jose
 
De: Charles Eckel (eckelcu) [mailto:[email-masked]] 
Enviado el: miércoles, 26 de marzo de 2014 19:02
Para: Jose Saldana; [email-masked]
Asunto: Re: [Aeon] A paper about Skype and Vidyo adaptation when network
conditions change
 
Hi Jose,
 
Thanks for sharing this. It illustrates the capabilities of limitation of
application adaptation in the absence of communication with the network. One
of the primary goals of AEON is to remove the limitations highlighted in the
paper. 
For example, the applications responded to loss by increasing or maintaining
their bandwidth utilization. In some cases, this is appropriate, but in
others it is not. If the loss was due to congestion, sending more may hurt
rather than help. If the network was able to inform the applications of the
congestion, the applications could have taken better corrective action. 
Similarly, the need to send redundant information at the start of the
session could be removed, or at least minimized, in cases in which the
application is able to receive some explicit information from the network.
 
Cheers,
Charles
 
From: Jose Saldana <[email-masked]>
Date: Monday, March 3, 2014 at 10:31 AM
To: "[email-masked]" <[email-masked]>
Subject: [Aeon] A paper about Skype and Vidyo adaptation when network
conditions change
 
Hi all,

 
 
Best regards,
 
Jose Saldana