Subject: Updated goals and milestones

From: Bob Natale <[email-masked]>
Date: Tue, 30 Jun 1998 11:44:41 -0400

Hi,

The AgentX page at <http://www.ietf.org/>www.ietf.org has been updated with the
following:

Goals and Milestones:

Done Publication of AgentX protocol specification
Done Submit working draft version of AgentX MIB I-D.
Jun 98 Collect and evaluate implementation reports
       (through bake-off).
Jul 98 Conduct AgentX interoperability testing
       (July 23-24, Sunnyvale).
Aug 98 Meet at 42nd IETF-Chicago (refine or revise
       RFC 2257).
Sep 98 Petition IESG to advance RFC 2257 to Draft
       or recycle at Proposed
Oct 98 Submit final version of AgentX MIB I-D to
       IESG for consideration as Proposed.
Nov 98 Submit initial draft version of AgentX API I-D
Dec 98 Submit interim draft version of AgentX API I-D.
Jan 99 Submit final version of AgentX API I-D to IESG
       for consideration as an Informational RFC.
Feb 99 Evaluate necessary revisions to RFC 2257.
Feb 99 Evaluate necessary revisions to AgentX MIB RFC.
Mar 99 Meet at 44th IETF to
          Assess status of AgentX deployment
          Determine need for AgentX v2 (Protocol, MIB, or API)
          Plan future work items accordingly.
Apr 99 Submit new charter proposal to IESG or retire WG.

I have submitted a request for a single 2hr meeting slot in
Chicago...I have not yet received notification of the scheduled
time and place.  The basic agenda will include:

 - the usual preliminaries
 - review implementation status reports
 - review bake-off results, findings
 - review list of open issues
 - review status of AgentX MIB
 - review need/desire for a standard AgentX API
 - review status of SNMPv3 and DISMAN wrt AgentX
 - recommend working plan wrt any of the above items
 - the usual summaries

Comments on any of the above are welcomed...as are proposed
mods (additions/deletions/changes) to the agenda outline.

Cordially,

BobN
------------ ISO 9001 Registered Quality Supplier -----------
Bob Natale         | ACE*COMM              | 301-721-3000 [v]
Dir, Net Mgmt Prod | 704 Quince Orchard Rd | 301-721-3001 [f]
[email-masked]| Gaithersburg MD 20878 |
<http://www.acecomm.com/>www.acecomm.com
------------- Free downloads at <http://www.winsnmp.com/>www.winsnmp.com
-------------

---

From: "Ashish K Hanwadikar" <[email-masked]>
Date: Wed, 1 Jul 1998 14:31:07 +0530

Hi,
    Is the AgentX API I-D going to be an information RFC or a standard RFC?
Where can I get more information about the efforts on AgentX API (mailing
lists, working groups etc.)?

    Also, one more thing, the AgentX-Close-PDU when sent by Sub Agent to
Master Agent does not require master agent to respond until there is an
error in closing the session. This is unnecessarily making the
implementation complicated. Why can't master agent send response to all
agentx-close-PDUs irrespective of the outcome? Otherwise, the sub agent has
to keep on waiting for the response to agentx-close-PDU, when he don't even
know whether there will be any response or not. The same is true for
agentx-notify-PDU. The implementation becomes very complicated when we have
to design a generic sub agent API. What should be the semantics of the call
agent-close-session(sessionID), blocking or non-blocking? If it is
non-blocking what happens when there is error in closing the session and
response is received from the master agent? If it is made blocking and there
is no resonse because the session was closed successfuly then how long
should the call block?

    This waiting on the sub agent side is a general problem. What should be
the timeout values from the sub agent side, i.e. for how long should the sub
agent wait for responses from the master agent for various PDU's like
registration etc.

    Thanks in advance.

> -----Original Message-----
> From: Bob Natale [mailto:[email-masked]]
> Sent: Tuesday, June 30, 1998 9:15 PM
> To: [email-masked]
> Subject: Updated goals and milestones
>
>
> Hi,
>