Subject: agentxSessionIndex description

From: "Smitha Gudur" <[email-masked]>
Date: Mon, 03 Aug 1998 14:33:48 PDT

Hi, Bob & Mike,

So the changes to agentxSessionIndex description will be as follows:

"agentxSesssionIndex is the same as h.sessionID defined in the agentx
header.  It is a unique index for the subagent session. Note that if a 
subagent's session with the master agent is closed for any reason its 
index should not be re-used, therefore, the values of agentxSessionIndex 
may not be contiguous and will generally not be the same for the same 
subagent across multiple sessions." 

thanks 
smitha

>From [email-masked] Mon Aug  3 13:59:01 1998
>Received: (from uucp@localhost)
>	by almond.bmc.com (8.8.8/8.8.8) id PAA16591
>	for <[email-masked]>; Mon, 3 Aug 1998 15:58:49 -0500 (CDT)
>Received: from firewall.bmc.com(192.245.162.250)
>	by almond.bmc.com via smap (V2.0)
>	id xma016364; Mon, 3 Aug 98 15:58:04 -0500
>Received: (from uucp@localhost)
>	by dresden.bmc.com (8.8.5/8.8.6) id PAA00875
>	for <[email-masked]>; Mon, 3 Aug 1998 15:57:21 -0500 (CDT)
>Received: from tangelo.bmc.com(172.17.7.166) by dresden.bmc.com via 
smap (3.2)
>	id xma024895; Mon, 3 Aug 98 15:51:22 -0500
>Received: from dorothy.bmc.com (dorothy.peer.com [192.146.153.65])
>	by tangelo.bmc.com (8.8.6 (PHNE_14041)/8.8.6) with ESMTP id PAA03166;
>	Mon, 3 Aug 1998 15:49:29 -0500 (CDT)
>Received: from almond.bmc.com (almond.bmc.com [172.17.0.100])
>	by dorothy.bmc.com (8.8.6 (PHNE_12836)/8.8.6) with ESMTP id NAA10066
>	for <[email-masked]>; Mon, 3 Aug 1998 13:34:16 -0700 (PDT)
>Received: (from uucp@localhost)
>	by almond.bmc.com (8.8.8/8.8.8) id PAA13400
>	for <[email-masked]>; Mon, 3 Aug 1998 15:34:13 -0500 (CDT)
>Received: from relay1.smtp.psi.net(38.8.14.2)
>	by almond.bmc.com via smap (V2.0)
>	id xma013201; Mon, 3 Aug 98 15:33:21 -0500
>Received: from [192.152.208.5] (helo=acecomm.com)
>	by relay1.smtp.psi.net with smtp (Exim 1.90 #1)
>	id 0z3RI0-0001B0-00; Mon, 3 Aug 1998 16:33:04 -0400
>Received: from bnatale by acecomm.com (5.65/3.2.083191-ACE*COMM)
>	id AA15080; Mon, 3 Aug 1998 16:35:17 -0400
>Message-Id: <[email-masked]>
>X-Sender: [email-masked]
>X-Mailer: QUALCOMM Windows Eudora Pro Version 4.0.1
>Date: Mon, 03 Aug 1998 16:35:28 -0400
>To: Mike Daniele <[email-masked]>
>From: Bob Natale <[email-masked]>
>Subject: Re: open issues in agentX MIB
>Cc: [email-masked]
>In-Reply-To: <[email-masked]>
>References: <Your message of "Mon, 03 Aug 98 14:47:17 EDT."             
<[email-masked]>
>Mime-Version: 1.0
>Content-Type: text/plain; charset="us-ascii"
>
>>At 8/3/98 03:42 PM, Mike Daniele wrote:
>
>Hi Mike,
>
><...>
>>It's not just the name of the object, right?
>>The real issue is, is agentxSessionIndex == h.SessionID?
>>We need to say so in the MIB spec one way or the other.
>
>Right.
>
>>I asked a while ago
>>
>>> 5) Is the value of agentxSessionId the same as the sessionID field
>>>    within the protocol?
>>
>>And Randy replied
>>
>>>The value of agentxSessionIndex should map to the value of 
h.sessionID 
>>>used for a given session.  The non-reuse requirements for the MIB 
index
>>>are stricter than those for the protocol field.  (Aside: why does the
>>>protocol require that h.sessionID be given values unique across all 
of
>>>a master agent's transports?  The logical requirement for uniqueness
>>>ends at the level of a transport connection.)
>>
>>Since we're moving toward refining h.SessionID to not be reused by the 
>>master within the realm of 32-bit rollover, it seems like the 
non-reuse 
>>requirements of the 2 are identical.
>
>Right.  Maintaining uniqueness of h.SessionID across all active
>sessions--irrespective of transport connections--is simpler than
>maintaining uniqueness within transport connections and yields
>more payoff to boot (e.g., simplifying registration relationships
>and possibly traffic/error reporting).
>
>>Given that, it seems beneficial to me to use an index with semantic
>>meaning.  Make them the same value.
>
>Yes.
>
>>I think the name agentxSessionIndex is fine.  
>
>Ok by me.
>
>>I think the description should state this value must equal h.SessionID
>>for this session.
>
>Yes.
>
>>Note, currently it's legal to use a SessionID of 0.  If we're going
>>to make agentxSessionIndex == h.SessionID, we may want to stipulate
>>SessionIDs start at 1.
>
>I favor this stipulation too.
>
>Cordially,
>
>BobN
>------------ ISO 9001 Registered Quality Supplier -----------
>Bob Natale         | ACE*COMM              | 301-721-3000 [v]
>Dir, Net Mgmt Prod | 704 Quince Orchard Rd | 301-721-3001 [f]
>[email-masked]| Gaithersburg MD 20878 | www.acecomm.com
>------------- Free downloads at www.winsnmp.com -------------
>
>

______________________________________________________
Get Your Private, Free Email at http://www.hotmail.com

---

From: Randy Presuhn <[email-masked]>
Date: Mon, 3 Aug 1998 14:50:13 -0700 (PDT)

Hi - 

> From: "Smitha Gudur" <[email-masked]>
> To: [email-masked]
> Cc: [email-masked]
> Subject: agentxSessionIndex description
> Date: Mon, 03 Aug 1998 14:33:48 PDT
...
> index should not be re-used, therefore, the values of agentxSessionIndex 

but (for any long-lived system) the value will have to be re-used eventually

> may not be contiguous and will generally not be the same for the same 

??? I think you mean "may be discontiguous" rather than "may not be
contiguous".

> subagent across multiple sessions." 
...

 -----------------------------------------------------------------------
 Randy Presuhn           Email: [email-masked]      http://www.bmc.com     
 Voice: +1 408 616-3100  BMC Software, Inc.           965 Stewart Drive
 Fax:   +1 408 616-3101  Sunnyvale, California 94086  USA
 -----------------------------------------------------------------------
 In accordance with the BMC Communications Systems Use and Security
 Policy, I explicitly state that although my affiliation with BMC may be
 apparent, implied, or provided, my opinions are not necessarily those
 of BMC Software and that all external representations on behalf of
 BMC must first be cleared with a member of "the top management team."
 -----------------------------------------------------------------------

---

From: "Smitha Gudur" <[email-masked]>
Date: Mon, 03 Aug 1998 15:26:29 PDT

Hi, Randy,

>From [email-masked] Mon Aug  3 15:04:09 1998
>	by almond.bmc.com (8.8.8/8.8.8) id RAA26329
>	for <[email-masked]>; Mon, 3 Aug 1998 17:03:46 -0500 (CDT)
>	id xma025876; Mon, 3 Aug 98 17:02:22 -0500
>	by dresden.bmc.com (8.8.5/8.8.6) id RAA00449
>	for <[email-masked]>; Mon, 3 Aug 1998 17:01:46 -0500 (CDT)
smap (3.2)
>	id xma027793; Mon, 3 Aug 98 16:59:03 -0500
>	by tangelo.bmc.com (8.8.6 (PHNE_14041)/8.8.6) with ESMTP id QAA21186;
>	Mon, 3 Aug 1998 16:56:52 -0500 (CDT)
>Received: (from rpresuhn@localhost)
>	by dorothy.bmc.com (8.8.6 (PHNE_12836)/8.8.6) id OAA10759
>	for [email-masked]; Mon, 3 Aug 1998 14:50:13 -0700 (PDT)
>Date: Mon, 3 Aug 1998 14:50:13 -0700 (PDT)
>From: Randy Presuhn <[email-masked]>
>Message-Id: <[email-masked]>
>To: [email-masked]
>Subject: Re:  agentxSessionIndex description
>Mime-Version: 1.0
>Content-Type: text/plain; charset=us-ascii
>Content-Transfer-Encoding: 7bit
>
>Hi - 
>

As Mike suggested in the earlier email that there will be a refinement
to h.sessionID not to be reused. I thought it would be appropriate
to add this in the MIB also.

>??? I think you mean "may be discontiguous" rather than "may not be

Yes. To make it more clearer I will change it to "may be discontiguous". 

thanks
smitha