Subject: Re: AgentX implications of rfc 1905 changes

From: Randy Presuhn <[email-masked]>
Date: Mon, 27 Sep 1999 16:15:10 -0700 (PDT)

Hi -

> Date: Thu, 23 Sep 1999 19:54:58 -0700
> From: Michael Thatcher <[email-masked]>
> To: Randy Presuhn <[email-masked]>
> CC: [email-masked]
> Subject: Re: AgentX implications of rfc 1905 changes
> References: <[email-masked]>
> 
> Jez, I understood the proposal as being rejected, mostly on the grounds of
> dbh's message.  I.E it is raising an old issue which was not supported in
> the past and does not have concensus now.

1905-32 remains closed, after an emphatic pronouncement by the snmpv3
WG chair.

1905-37 was re-opened at the request of several people.  The agentx WG
chair has argued in favor of it.  I think Keith and I have more or less
given up on it, since we seem to be the only ones willing to speak up
against it.

When it is adopted, the agentx protocol will require modification.

What's the plan?

 ------------------------------------------------------------------------
 Randy Presuhn           [email-masked]     http://www.bmc.com/
 Voice: +1 408 616-3100  BMC Software, Inc.           965 Stewart Drive
 Fax:   +1 408 616-3101  Sunnyvale, California 94086  USA
 ------------------------------------------------------------------------
 Any relationship between my opinions and BMC's is probably coincidental.
 ------------------------------------------------------------------------

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 28 Sep 1999 11:03:53 +0200

>>>>> Randy Presuhn writes:

Randy> 1905-37 was re-opened at the request of several people.  The
Randy> agentx WG chair has argued in favor of it.  I think Keith and I
Randy> have more or less given up on it, since we seem to be the only
Randy> ones willing to speak up against it.

Randy> When it is adopted, the agentx protocol will require
Randy> modification.

Randy> What's the plan?

Be patient.

/js

-- 
Juergen Schoenwaelder      Technical University Braunschweig
<[email-masked]>  Dept. Operating Systems & Computer Networks
Phone: +49 531 391 3289    Bueltenweg 74/75, 38106 Braunschweig, Germany
Fax:   +49 531 391 5936    <URL:http://www.ibr.cs.tu-bs.de/~schoenw/>

---

From: Bob Natale <[email-masked]>
Date: Tue, 28 Sep 1999 09:36:13 -0400

At 9/27/99:07:15 PM, Randy Presuhn wrote:

Hi Randy,

><...>
>1905-32 remains closed, after an emphatic pronouncement
>by the snmpv3 WG chair.
>
>1905-37 was re-opened at the request of several people.

Actually, I *surmise* that a lot of people associate the two
proposals closely -- albeit neither is technically dependent
upon the other -- and many casual readers (i.e., most of the
SNMPv3 list) probably assume that closing -32 equates to
closing -37 also.  While not technically accurate, that
perception is meaningful all the same.

>The agentx WG chair has argued in favor of it.

I have argued in favor of tilting the scales in favor of
Aleksey on this one, in light of the sum of arguments on
this topic over the years.  As I have stated, I do believe
he has shown more merit to it than those who oppose it
have shown harm or irrelevance in it; however, I do not
feel that promulgating it is essential to SNMP progress,
as we have always relied on pragmatism in the area it
seeks to formalize (as in many others).

>I think Keith and I have more or less given up on it,
>since we seem to be the only ones willing to speak up
>against it.

See above.  Perhaps another (I know you're doing an
awful lot of work on these items!) summary posting on
-37 in light of the definitive closing of -32 would help
in re-gauging consensus on or opposition to this proposed
change...?

>When it is adopted, the agentx protocol will require modification.

Perhaps.  OTOH, we could treat is as an SNMP-level error
that is applied by the master agent based on either:

    - its assessment of the input SNMP request, in light of
      its own runtime constraints and/or known registrations
      and/or special knowledge that a particular implementation
      approach might gather (e.g., MIB awareness);

and/or

    - its assessment of sub-agent responses to the TestSet
      phase.

Regardless...

>What's the plan?

The AgentX docs are currently in the final stages of the AD
and IESG review processes.  They were written based upon a
set of IETF SNMP docs at a point in time which did not include
any action on item 1905-37.  If and when such underlying IETF
SNMP docs change, we'll examine the AgentX specs for any
corresponding necessary changes.

Are there any strong objections to that game plan on this
issue?

Cordially,

BobN
------------ ISO 9001 Registered Quality Supplier -----------
Bob Natale         | ACE*COMM              | 301-721-3000 [v]
Dir, Net Mgmt Prod | 704 Quince Orchard Rd | 301-721-3001 [f]
[email-masked]| Gaithersburg MD 20878 | www.acecomm.com
------------- Free downloads at www.winsnmp.com -------------

---

From: Mike Daniele <[email-masked]>
Date: Tue, 28 Sep 1999 10:13:38 -0400

Bob Natale wrote:

<much deleted>

> Are there any strong objections to that game plan on this

None whatsoever.

I find it hard to believe that new set processing semantics and a
new error code will be added to SNMP in our lifetimes, let alone imminently.

Mike