Subject: Re: [alto] Address type in Filtered Network Map queries

From: Richard Alimi <[email-masked]>
Date: Mon, 24 Oct 2011 10:13:12 -0700

I would agree this is a very reasonable piece of filtering criteria to
add to the map filtering service. Any objections to adding it in this
revision?

Rich

On Fri, May 27, 2011 at 11:52 AM, Richard Alimi <[email-masked]> wrote:
> Hi Robert,
>
> On Fri, May 27, 2011 at 11:29 AM, Robert Varga <[email-masked]> wrote:
>> Hi everyone,
>>
>> since we are throwing discussion topics on the list, how about having
>> the ability for the client to specify which Address Types it is
>> interested in while executing a request to Map Filtering Service?
>>
>> That will allow the clients to limit the size of the server response
>> when the server defines a multitude of address types. This is useful
>> even with IPv4/IPv6, as v4-only clients just do not care and will just
>> skip over any v6 addresses they encounter.
>>
>> From protocol and implementation perspective it can be easily achieved
>> by adding an 'AddressType address-types<0..*>' field in
>> ReqFilteredNetworkMap.
>>
>> Any thoughts?
>
> This sounds very reasonable to me.
>
> Rich
>
>>
>> Thanks,
>> Robert
>>
>> --
>> Robert Varga
>> Pantheon Technologies, s.r.o.
>> Mlynske Nivy 56
>> 831 05 Bratislava
>>
>> _______________________________________________
>> alto mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/alto
>>
>

---

From: Reinaldo Penno <[email-masked]>
Date: Tue, 25 Oct 2011 15:31:03 -0400

Yes, I believe it makes sense.

One snag: What would be the default case without the filtering? Does the
server:

- Reply with both IPv4 and IPv6 maps
- Matches the address family of the IP packet
- other?

I'm assuming that if the client is using IPv4 to contact the server and asks
for IPv6 maps it is okay. Similar to DNS client.

Thanks,

Reinaldo

---

From: Richard Alimi <[email-masked]>
Date: Tue, 25 Oct 2011 15:32:22 -0700

> - Matches the address family of the IP packet

I think the default should be that no filtering is done by address
type.  That would be more consistent with other similar cases we
already have in the spec.

Rich