Subject: Re: [alto] PID Properties in ALTO

From: Richard Alimi <[email-masked]>
Date: Mon, 24 Oct 2011 10:10:41 -0700

I'm fine with leaving this as an extension, I agree it falls outside
of the core set of functionality and could easily be done as an
extension. Objections to that?

Rich

On Fri, May 27, 2011 at 11:11 AM, Robert Varga <[email-masked]> wrote:
> Hi,
>
> I agree we should support it. I am just not sure we need it the base
> protocol, though, as it can easily be specified as an extension.
>
> Bye,
> Robert
>
> On 05/27/11 18:48, Richard Alimi wrote:
>> Hi All,
>>
>> Okay, third and final thread for discussion today :)  Another proposed
>> extension to the ALTO protocol has been to associate properties (like
>> we currently have with Endpoints) with PIDs.
>>
>> A proposed use case in draft-penno-alto-cdn was to indicate what types
>> of endpoints lived within a single PID. A more general mechanism to
>> support this would be to allow properties to be associated with a PID
>> as whole. In one light, this could be seen as an efficient way to
>> query for the properties of all endpoints within a PID (in which
>> membership in the PID determines the value of the property). It could
>> also be used to attach some semantic meaning to a PID (instead of
>> being an opaque identifier) in particular deployments.
>>
>> One way to support this would be to provide an additional "PID
>> Property" service, with a similar structure to the Endpoint Property
>> Service. Basically, it would amount to defining a registry, allowing
>> an ALTO Server to indicate its supported properties via capabilities,
>> defining encodings for the request and response, etc.
>>
>> Thoughts about supporting this?
>>
>> Thanks,
>> Rich
>> _______________________________________________
>> alto mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/alto
>
>
> --
> Robert Varga
> Pantheon Technologies, s.r.o.
> Mlynske Nivy 56
> 831 05 Bratislava
>
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto
>

---

From: Reinaldo Penno <[email-masked]>
Date: Tue, 25 Oct 2011 15:36:09 -0400

As one of the proponents I like the idea but an extension is fine.

---

From: "Y. Richard Yang" <[email-masked]>
Date: Tue, 25 Oct 2011 15:58:44 -0400

I like the idea of indicating properties to a group of points.  The 
particular approach
of annotating a PID appears to be clean and brings endpoints and PIDs 
(aggregations) uniform.
So I could imagine an OO implementation would define a base class to 
handle both, in a single
base class.

One semantics difficulty that this may cause is consistency. For 
example, if an endpoint A
has property P when the query is for A, and then not P, when queried by 
an enclosing PID.
In other words, redundancy may cause inconsistency. But this may not be 
a crucial issue.

I like the idea of extension too.

Richard Y.

On 10/25/11 3:36 PM, Reinaldo Penno wrote:
> On 10/24/11 10:10 AM, "Richard Alimi"<[email-masked]>  wrote:
>
>> On Fri, May 27, 2011 at 11:11 AM, Robert Varga<[email-masked]>
>> wrote:
>>> Hi,
>>>