Subject: [alto] Hopcount in ALTO TE Metrics draft

From: Qin Wu <[email-masked]>
Date: Fri, 18 Jul 2014 12:02:33 +0000

Hi, all:
Hopcount is a cost metric used in the example ALTO base protocol. We clarified its properties(e.g., cost metric string, metric value type) in the ALTO TE metrics draft.
The hop count is usually refers to the intermediate devices (like routers) through which data must pass between source and destination
I am wondering if we need to distinguish hop count in IP layer from hop count in higher layer or lower layer? Is there any hop count in lower layer,e.g., optical layer?

Regards!
-Qin

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 22 Jul 2014 13:57:08 -0400

Hi Qin,

IMHO we should limit the hop count to the output we expect if we run
traceroute to the endpoint thus not indicate any lower layer devices
in this.

Hop count by its nature is a rough metric and one must rely on other
metrics like routing cost, delay to judge an optimum endpoint.

Dhruv

On Fri, Jul 18, 2014 at 8:02 AM, Qin Wu <[email-masked]> wrote:
> Hi, all:
>
> Hopcount is a cost metric used in the example ALTO base protocol. We
> clarified its properties(e.g., cost metric string, metric value type) in the
> ALTO TE metrics draft.
>
> The hop count is usually refers to the intermediate devices (like routers)
> through which data must pass between source and destination
>
> I am wondering if we need to distinguish hop count in IP layer from hop
> count in higher layer or lower layer? Is there any hop count in lower
> layer,e.g., optical layer?
>
>
>
> Regards!
>
> -Qin