Subject: [alto] Submitting draft-wu-alto-te-metrics as a WG item

From: "Vijay K. Gurbani" <[email-masked]>
Date: Fri, 26 Aug 2016 15:23:58 -0500

Authors: Pursuant to the call for adoption for draft-wu-alto-
te-metrics  as a WG item issued on the mailing list [1] on
Jul-28-2016, it appears that there is strong support (as expressed on
the mailing list) for doing so.

In the call for adoption [1], the chairs raised a couple of issues that
should be addressed:

   1) privacy aspects,
   2) harmonize work with IPPM

To date, to the best of the chair's knowledge, the authors have not
responded to these issues on the list.  Jan and I would, therefore,
urge the authors to address these issues to satisfaction of the WG as
they work on the WG item -00 revision.  It will be good to have the
revision submitted, or at least some discussion started on how these
issues will be addressed, as soon as possible.

[1] https://www.ietf.org/mail-archive/web/alto/current/msg03245.html

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Nokia Networks
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: [email-masked] / [email-masked]
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq

---

From: Qin Wu <[email-masked]>
Date: Mon, 29 Aug 2016 08:36:51 +0000

Hi, Vijay:
Thank for your heads up. We have a briefly discussion on the second issue on the list but you are right,we haven't addressed these two issues.
To address the first issue, we like to add a note in the introduction to raise a warning on this privacy issue, we will not mandatory to expose all the cost metrics to the application.
To address the second issue, I have read 
draft-ietf-ippm-metric-registry-07 which provide template for performance metrics
draft-ietf-ippm-initial-registry which define a few performance metrics using template defined in draft-ietf-ippm-metric-registry-07
I think the only performance metrics which need to be aligned at this stage are delay metric and delayjitter metric.
To align with periodic one way delay metric, we will change delay metric name documented in our draft into periodic one way delay and use measurement method, measurement timing, measurement interval defined in draft-ietf-ippm-initial-registry
To align with packet delay variation metric, we will change delayjitter documented in our draft into packet delay variation metric and use measurement method, measurement timing, measurement interval defined in draft-ietf-ippm-initial-registry
For any other metrics, we don't see any overlapping or requires alignment at this stage, we will keep track of the update of draft-ietf-ippm-initial-registry and see any alignment is required if any new metric is put into draft-ietf-ippm-initial-registry.

The update of draft-wu-alto-te-metrics will come soon.

-Qin
-----邮件原件-----
发件人: Vijay K. Gurbani [mailto:[email-masked]] 
发送时间: 2016年8月27日 4:24
收件人: [email-masked]
抄送: IETF ALTO
主题: Submitting draft-wu-alto-te-metrics as a WG item

Authors: Pursuant to the call for adoption for draft-wu-alto- te-metrics  as a WG item issued on the mailing list [1] on Jul-28-2016, it appears that there is strong support (as expressed on the mailing list) for doing so.

In the call for adoption [1], the chairs raised a couple of issues that should be addressed:

   1) privacy aspects,

To date, to the best of the chair's knowledge, the authors have not responded to these issues on the list.  Jan and I would, therefore, urge the authors to address these issues to satisfaction of the WG as they work on the WG item -00 revision.  It will be good to have the revision submitted, or at least some discussion started on how these issues will be addressed, as soon as possible.

Thanks,

- vijay

---

From: Qin Wu <[email-masked]>
Date: Mon, 29 Aug 2016 08:47:24 +0000

Here is the update of draft-wu-alto-te-metrics to address two open issues raised in the last meeting.
The diff is:
https://www.ietf.org/rfcdiff?url2=draft-wu-alto-te-metrics-09

-Qin
-----邮件原件-----
发件人: alto [mailto:[email-masked]] 代表 Qin Wu
发送时间: 2016年8月29日 16:37
收件人: Vijay K. Gurbani; [email-masked]
抄送: IETF ALTO
主题: Re: [alto] Submitting draft-wu-alto-te-metrics as a WG item

Hi, Vijay:

draft-ietf-ippm-initial-registry which define a few performance metrics using template defined in draft-ietf-ippm-metric-registry-07
I think the only performance metrics which need to be aligned at this stage are delay metric and delayjitter metric.
To align with periodic one way delay metric, we will change delay metric name documented in our draft into periodic one way delay and use measurement method, measurement timing, measurement interval defined in draft-ietf-ippm-initial-registry To align with packet delay variation metric, we will change delayjitter documented in our draft into packet delay variation metric and use measurement method, measurement timing, measurement interval defined in draft-ietf-ippm-initial-registry For any other metrics, we don't see any overlapping or requires alignment at this stage, we will keep track of the update of draft-ietf-ippm-initial-registry and see any alignment is required if any new metric is put into draft-ietf-ippm-initial-registry.

-Qin
-----邮件原件-----
发件人: Vijay K. Gurbani [mailto:[email-masked]]
发送时间: 2016年8月27日 4:24
收件人: [email-masked]
抄送: IETF ALTO
主题: Submitting draft-wu-alto-te-metrics as a WG item

   1) privacy aspects,

Thanks,

- vijay

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 29 Aug 2016 14:36:30 -0500

On 08/29/2016 03:47 AM, Qin Wu wrote:
> Here is the update of draft-wu-alto-te-metrics to address two open
> issues raised in the last meeting. The diff is:

Qin: Thanks.  More below.

Folks: Please take a look at the above diffs that address the concerns
in [1].

Authors: Please wait a few days for any feedback from the WG and
incorporate feedback in a -00 version.  Irrespective of any feedback,
please generate a WG -00 and submit by next week (mid- to late next
week).

[1] https://www.ietf.org/mail-archive/web/alto/current/msg03277.html

Thanks,

- vijay