Subject: [alto] About draft-randriamasy-alto-cost-context-00

From: 陈 诗蔚 <[email-masked]>
Date: Sun, 26 Feb 2017 13:18:32 +0000

The use cases in the draft mainly focus on the last hop connection selection(user equipment to the access network) and calendaring for unattended data.Based on the use cases, two possible solutions are mentioned using alto contextual cost values.
Solution 1: Cells in the Cellular network are regarded as PIDs. User equipment was assigned to the same PID it locates at/currently connected to. The way to distinguish whether a specific PID represents a UE(user equipment) or  a cell is that the PID in "src" stands for UE and the PID in "dst" stands for cell.
Solution 2 : Cells in the Cellular network are regarded as PIDs. User equipment was assigned a new PID(named "UE" for example).
Compare the above two solutions, the drawback of Solution2 is that user equipment need to be assigned to two PIDs("UE" and the Cell PID).

 But here are some problems. I think what we desire is actually the endpoint(user equipment) to PID values.
Assume now we have 2 user equipment located in/currently connected to Cell1. According to solution1, the two user equipment are both recognized as "Cell1", so, distinguishing the values between them are difficult.
If the returning values of these 2 user equipment are regarded as same, then, it is actually a PID-PID cost rather than a endpoint-PID cost.
As for solution2, since there might be many user equipment, the network map can be huge. Another point is that,due to the mobility of the user equipment, the network maps must change frequently to adapt the current circumstance.

Regards，
Dawn

Get Outlook for iOS<https://aka.ms/o0ukef>

---

From: "Randriamasy, Sabine (Nokia - FR)" <[email-masked]>
Date: Tue, 28 Feb 2017 08:24:41 +0000

Hello Dawn,

Thanks a lot for your feedback. Please see my answers inline.
Best regards,
Sabine

From: alto [mailto:[email-masked]] On Behalf Of ? ??
Sent: dimanche 26 février 2017 14:19
To: [email-masked]<mailto:[email-masked]>
Subject: [alto] About draft-randriamasy-alto-cost-context-00

>> SR: that’s right in the “uplink” direction

>> SR: and also the PID-to-endpoint value

>> SR: Actually, we do not necessarily want to distinguish among UEs. The main goal is to expose cost values associated to the cellular connection between UE and cell1. Typically, metrics such as RF Cost or other metrics to be defined. To address your point, we have to distinguish between the uplink and downlink direction and using the context parameters “uplink” and “downlink” is one way to do it.

>> SR: yes, this option 1 definitely provides PID-PID costs.

>> SR: I agree with you. Design option 2 is neither scalable nor stable and will be dropped in the next update of this draft.

Regards，
Dawn

>> SR: Thanks, Sabine