Subject: [alto] Review on draft-ietf-alto-performance-metrics-01 by Geng

From: "Li, Geng" <[email-masked]>
Date: Thu, 29 Jun 2017 01:34:28 +0000

Dear authors,

Your work is quite excellent, and here are some suggestions I have.

1. The ALTO server should have the capability to track and record the most frequently used or requested cost metrics of each ALTO client. I’m not sure if it is true, that each client may only run one or two certain applications at most of the time. Then, the benefit is that the ALTO server can prepare the cost metrics in advanced and respond the clients fast after receiving the request.

2. Another benefit of recording the type of cost metrics of each client is that the ALTO server can detect abnormal behavior of client or application, such as database resource leaks, illegal occupation, or other security issues.

3. A variety of performance cost metrics also raise an interesting scheduling problem. For example, client “A” requests two metrics, client “B” just requests one, and client “C” requests three metrics, then how the ALTO server schedules to respond them in the constraint of given resources for workload processing and network transmitting. And for each client, what is the order of the cost metric types to be returned?

Hope these are helpful.

Best, Geng

Computer Science, Yale

---

From: Qin Wu <[email-masked]>
Date: Thu, 29 Jun 2017 10:28:51 +0000

Thanks Geng for your interesting comments, please see my reply inline below.

-Qin
发件人: Li, Geng [mailto:[email-masked]]
发送时间: 2017年6月29日 9:34
收件人: [email-masked]; [email-masked]
主题: Review on draft-ietf-alto-performance-metrics-01 by Geng

Dear authors,

[Qin]: This draft allows ALTO server collect and record a bunch of data on time period covering past and present, but I am not sure how you can prepare cost metrics in advance, unless you can predict the change pattern of some performance metric or predict the possible value of cost metric in the future.

[Qin]: The performance metric we exposed to the client is used to help the client to select the right access point or select appropriate site in the data center based on network performance criteria. I am not sure we can used these performance metric to detect abnormal behavior of client or prevent any resource leak unless you provide me  a clear use cases for that.

[Qin]: I am not sure we need a sophisticated scheduling feature here. The ALTO server will process request from each client by order, who request first, whose request will be processed first.

Hope these are helpful.

Best, Geng

Computer Science, Yale