Subject: [alto] Review on draft-ietf-alto-cost-calendar-01 by Geng

From: "Li, Geng" <[email-masked]>
Date: Thu, 29 Jun 2017 01:01:03 +0000

Dear authors,

Your work on cost calendar makes a lot of sense to me, and here are some comments I have.

Issues:

1. In the 4th paragraph of section 1 (Page 4), here is supposed to introduce the advantages of cost calendar. I would like to add another significant advantage which is the reduction of the frequent information exchange between ALTO client and ALTO server. And I think it may be the salient benefit that leads to saving the network resources for ALTO protocol.

2. In section 2.2.1, the word “time-sensitive” comes up several times, but what is the exact definition for “time-sensitive”? Maybe I’m wrong, but I reckon it is used to describe the data for real-time service. I suggest the authors can give a definition and examples here, or provide the references where the word is interpreted.

3. I think maybe the authors missed a point which many audiences are concerned about. When the network state is getting changed by e.g., link failures, node crashed, and if there is a conflict between the cost calendar that has already been conveyed and the current new cost map, then how the client can be aware of it? The ALTO server needs to notify the clients before they schedule data transfers according to the old cost calendar.

Typos:

1. In the first line of section 3.1, there is a redundant space before the comma.

2. At the end of the 3rd paragraph of section 3.1,  “ressources” ==> “resources”.

Hope these are helpful.

Best, Geng

Computer Science, Yale

---

From: "Randriamasy, Sabine (Nokia - FR/Nozay)" <[email-masked]>
Date: Fri, 30 Jun 2017 17:59:29 +0000

Hi Geng,

Thanks a lot for your feedback,
Please see my responses inline,
Thanks,
Sabine

From: Li, Geng [mailto:[email-masked]]
Sent: 29 June 2017 03:01
To: [email-masked]; [email-masked]
Subject: Review on draft-ietf-alto-cost-calendar-01 by Geng

Dear authors,

Issues:

[SR     ]  this was meant in the first sentence of paragraph 5. I will try to clarify it.

2. In section 2.2.1, the word "time-sensitive" comes up several times, but what is the exact definition for "time-sensitive"? Maybe I'm wrong, but I reckon it is used to describe the data for real-time service. I suggest the authors can give a definition and examples here, or provide the references where the word is interpreted.

[SR     ] Agree, "time varying" is more appropriate

[SR     ] Agree, such a notification may be conveyed via incremental updates, see [draft-ietf-alto-incr-update-sse]

Typos:

2. At the end of the 3rd paragraph of section 3.1,  "ressources" ==> "resources".

[SR     ] Thanks for catching those

Hope these are helpful.

[SR     ] They are, thanks a lot

Sabine

Best, Geng

Computer Science, Yale