Subject: [alto] Here is a review of draft-ietf-alto-performance-metrics-01

From: xin wang <[email-masked]>
Date: Wed, 28 Jun 2017 02:05:42 +0000

Dear authors of "ALTO Performance Cost Metrics”,

Your draft about extending cost metrics of ALTO looks very useful, especially for varieties of applications with different criteria to make decisions for traffic engineering. The following is a review of your draft:

a. Link Maximum Reservable Bandwidth and Link Residue Bandwidth

These three cost metrics look very similar but have different meanings according to your draft. In my understanding, based on the concept of bandwidth oversubscription, a reserved bandwidth could be larger than current remaining bandwidth (equals to max bandwidth subtract the sum of all reserved bandwidth). Then, Link Maximum Reservable Bandwidth should be slightly larger than Link Residue Bandwidth. Is this right?

b. Unitless performance scores

In section 2.1, the draft suggests providing unitless performance scores for privacy issues. In ALTO cost mode, it defines “ordinal” which indicates the ranking of the cost values instead of actual costs. Do you suggest to add more intelligent abstraction of cost values besides of ranking?

c. Packet Delay Variation

The draft uses the minimum delay observed as the definition of packet delay variation. I am not sure it is a good solution. There are some other approaches you may consider, such as standard deviation.

d. The unit of Periodic One Way Delay

The draft uses seconds as the unit of Periodic One Way Delay. I am not sure it is typos or not since the example shows the powdelay cost values are 10, 20, and 30.

Also there are some typos you may fix:

Abstraction: add space between "BGP-LS,OSPF-TE";

Page 2: “delay sensitive” -> “delay-sensitive”;

Page 2: “a set new” -> “a set of new”;

Page 2: “ explicitely” -> “ explicitly”

Page 4: “ invlove” -> “ involve"

Best,

Xin

---

From: Qin Wu <[email-masked]>
Date: Thu, 29 Jun 2017 09:43:51 +0000

Thanks Xin, see reply inline below.
发件人: xin wang [mailto:[email-masked]]
发送时间: 2017年6月28日 10:06
收件人: [email-masked]
抄送: IETF ALTO
主题: Here is a review of draft-ietf-alto-performance-metrics-01

[Qin]: Short answer is Yes. Long answer is:

Residbw = maxbw -  tunnel reservation bw

Maxresbw can be larger than maxbw if the link is oversubscirbed

Therefore Maxresbw could be larger than Residbw.

[Qin]: I think adding more intelligent abstraction of cost values besides of ranking useful, but we need to identify use case to show deficiency of ranking before introducing new intelligent abstraction.

[Qin]: The minimum delay  observed is just used as reference delay, see the complete definition as follows:

“
   Metric name:
      Packet Delay Variation
   Metric Description:
      To specify spatial and temporal aggregated jitter (packet delay
      variation) with respect to the minimum delay observed on the

      stream over the specified source and destination.

”

You are right, standard deviation will be used.

[Qin]: It is not typo, it is intended. See section 7.4.3 of draft-ietf-ippm-initial-registry-03.

We don’t define any new metric with new measurement unit here.

[Qin]: Fixed, thanks.

Best,

Xin