Subject: [alto] a survey of ALTO

From: Shawn Lin <[email-masked]>
Date: Mon, 11 Jun 2018 13:20:47 +0800

Dear ALTOers,

@Dawn, @Danny and I are working on a survey of ALTO. Our goal is to
understand what ALTO can already do in the real system, how others use ALTO
and the additional requirements for newer applications (like SDN, NFV,
Block-chain network) to do the traffic optimization.

Currently, we have a deck of slides and a skeleton of our draft. We had
some wonderful discussions with @Richard and @Sabine! So here we would like
to share the slides with the WG and get feedback from WG members. I believe
it is a good way to summarize the current status and look into the next
step :)

The current slides include 6 ALTO implementations (from open source
project, academic research, and company production) and 18 use cases (from
IETF drafts/slides, papers, and white papers) in 5 categories like below:

ALTO Use Cases

  |

  +--> Information Source

  |     |

  |     +---> Path Selection in MPTS-AR

  |     |

  |     +---> Locate Content in Mobile Edge Cache

  |     |

  |     +---> Virtualized Service Function Chain Placement

  |     |

  |     +---> Intelligent VM Placement

  |     |

  |     +---> Service Placement in IoT

  |

  +--> Ranking Server

  |     |

  |     +---> A Peer Ranking Service for P2P Streaming

  |     |     Information

  |     +---> A Service to Select CDN Surrogate

  |     |

  |     +---> A Service to Select CDN Servers from

  |     |     Different SDN Domains

  |     +---> A Service to Select downstream CDN

  |     |

  |     +---> A Service to Guide the Peer Connection

  |           in  Blockchain

  |

  +--> Network Abstraction

  |     |

  |     +---> Network Abstraction Provider in SDN

  |     |

  |     +---> Topology Abstraction for VPN Scale-out

  |     |     Decisions

  |     +---> ALTO being Used to Solving n2  Problem

  |

  |--> Information Exchanger

  |     |

  |     +---> Network Behaviors Exchanger between

  |           Providers

  |

  +--> Measure Results Interface

        |

        +---> An Interface to Query on the LMAP

              measure results

We attach the slides below. You can also access the editable version in
Google Slides:

*https://docs.google.com/presentation/d/1aXIZfUjQrSFhkVIUbvt2ouKWqLgGq4kbG-EBmSaZtKo/edit?usp=sharing
<https://docs.google.com/presentation/d/1aXIZfUjQrSFhkVIUbvt2ouKWqLgGq4kbG-EBmSaZtKo/edit?usp=sharing>*

Any comments or suggestions are welcomed and appreciated!

Bests,
Shawn Lin

---

From: Jensen Zhang <[email-masked]>
Date: Mon, 11 Jun 2018 02:32:19 -0400

Hi Shawn,

Thank you a lot! Also, thank Dawn and Danny. A survey on the current ALTO
related works is very helpful.

I believe your classification for the ALTO use cases is based on the role
ALTO plays in the existing system. Do we have any summary of the
requirements? All of them use the standard ALTO without any modification or
extension? I believe such information is more useful and should be
considered in the survey. Because we try to understand what are the
essential additional requirements for newer scenarios. It will decide
whether we need to recharter the WG.

Best,
Jensen

On Mon, Jun 11, 2018 at 1:21 PM Shawn Lin <[email-masked]> wrote:

> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto
>

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 11 Jun 2018 11:01:15 -0500

Shawn: This is very informative; thanks for putting this together!

Cheers,

On 06/11/2018 12:20 AM, Shawn Lin wrote:
> understand what ALTO can already do in the real system, how others use
> ALTO and the additional requirements for newer applications (like SDN,
> NFV, Block-chain network) to do the traffic optimization. [...]

- vijay
--
Vijay K. Gurbani / [email-masked]
Network Data Science, Nokia Networks
Calendar: http://goo.gl/x3Ogq

---

From: Christian Esteve Rothenberg <[email-masked]>
Date: Mon, 11 Jun 2018 13:06:04 -0300

Nice work!

In line with Jensen questions, I was going to suggest adding the RFC /
draft info to the Implementation details, e.g. Network Map, Cost Map,
Unified Property Map, Path Vector.
Especially highlighting the proposed extensions would help to identify
the need to move these extensions forward to become RFC, and/or
eventually be merged, if / after we realize through a proper Table
mapping proposed extensions to use case implementations and citations.
Such a table could also incorporate the additional requirements
suggested by Jensen and altogether contribute to a potential WG
recharter.

-ch
Em seg, 11 de jun de 2018 às 03:32, Jensen Zhang
<[email-masked]> escreveu:
>
> Hi Shawn,
>
> Thank you a lot! Also, thank Dawn and Danny. A survey on the current ALTO related works is very helpful.
>
> I believe your classification for the ALTO use cases is based on the role ALTO plays in the existing system. Do we have any summary of the requirements? All of them use the standard ALTO without any modification or extension? I believe such information is more useful and should be considered in the survey. Because we try to understand what are the essential additional requirements for newer scenarios. It will decide whether we need to recharter the WG.
>
> Best,
> Jensen
>
>> @Dawn, @Danny and I are working on a survey of ALTO. Our goal is to understand what ALTO can already do in the real system, how others use ALTO and the additional requirements for newer applications (like SDN, NFV, Block-chain network) to do the traffic optimization.
>>
>> Currently, we have a deck of slides and a skeleton of our draft. We had some wonderful discussions with @Richard and @Sabine! So here we would like to share the slides with the WG and get feedback from WG members. I believe it is a good way to summarize the current status and look into the next step :)
>>
>> The current slides include 6 ALTO implementations (from open source project, academic research, and company production) and 18 use cases (from IETF drafts/slides, papers, and white papers) in 5 categories like below:
>>
>>
>> ALTO Use Cases
>>
>>   |
>>
>>   +--> Information Source
>>
>>   |     |
>>
>> We attach the slides below. You can also access the editable version in Google Slides:
>>
>> https://docs.google.com/presentation/d/1aXIZfUjQrSFhkVIUbvt2ouKWqLgGq4kbG-EBmSaZtKo/edit?usp=sharing
>>
>>

---

From: Qiao Xiang <[email-masked]>
Date: Mon, 11 Jun 2018 17:09:31 -0400

Hi Christian,

Great suggestion! I fully agree. Such a table would be very helpful!

Shawn: I understand this is not a complete list. Just a reminder that you
should add Kai's IWQoS'17 paper (NOVA) and its previous ICNP'16 poster
paper (ORSAP) in the survey. They are based on the ALTO-PV and ALTO-RSA
drafts.

Best
Qiao

On Mon, Jun 11, 2018 at 12:06 PM Christian Esteve Rothenberg <
[email-masked]> wrote:

> > I believe your classification for the ALTO use cases is based on the
> role ALTO plays in the existing system. Do we have any summary of the

-- 
Qiao Xiang
Postdoctoral Fellow,
Department of Computer Science,
Yale University

---

From: "Y. Richard Yang" <[email-masked]>
Date: Mon, 11 Jun 2018 18:22:24 -0400

Great suggestion, Christian!

Qiao: thanks for pointing out the related work. The IWQoS'17 and ICNP'16
work are highly related indeed.

Shawn: I will be more than happy to review the addition of the table, as
Christian suggested. It can be part of the draft, or you can post such a
table on the mailing list for discussions, as IETF uses mailing list as one
key venue of discussions.

Thanks!
Richard

On Mon, Jun 11, 2018 at 5:09 PM Qiao Xiang <[email-masked]> wrote:

> [email-masked] <chesteve@dca..fee.unicamp.br>> wrote:
>
>> Nice work!
>>
>> >> Currently, we have a deck of slides and a skeleton of our draft. We
>> had some wonderful discussions with @Richard and @Sabine! So here we would
>> like to share the slides with the WG and get feedback from WG members. I
>> believe it is a good way to summarize the current status and look into the
>> next step :)
>> >>

-- 
-- 
 =====================================
| Y. Richard Yang <[email-masked]>   |
| Professor of Computer Science       |
| http://www.cs.yale.edu/~yry/        |
 =====================================

---

From: Shawn Lin <[email-masked]>
Date: Tue, 12 Jun 2018 10:11:53 +0800

Hi Jensen, Vijay, Christian, Qiao, and Richard,

Thank you so much for your confirmations and fruitful suggestions!

We created a Google Sheets [1] to collect such information. Please feel
free to edit or comment on it!
The current header of this Google Sheets mainly includes "Paper/Project/RFC
Name", "Cited", "Year", "Extend Standard ALTO or not", "How they use
ALTO?", "Challenges and Research Opportunities", "Others" and "Catagory".

Qiao: Just add NOVA and ORSAP, please see row 124 and 125.

[1]
https://docs.google.com/spreadsheets/d/1dgbVApnyyiIjbSFp49jSIz3XQHMbmme3WXMQfOZVpY0/edit?usp=sharing

Bests,
Shawn

---

From: "Y. Richard Yang" <[email-masked]>
Date: Mon, 11 Jun 2018 23:30:10 -0400

Great idea to use a Google doc for shared collaboration! I am making some
edits to add some more columns...

Richard

On Mon, Jun 11, 2018 at 10:12 PM Shawn Lin <[email-masked]> wrote:

> The current header of this Google Sheets mainly includes
> "Paper/Project/RFC Name", "Cited", "Year", "Extend Standard ALTO or not",
> "How they use ALTO?", "Challenges and Research Opportunities", "Others" and
> "Catagory".
>
>>> Shawn: I understand this is not a complete list. Just a reminder that
>>> you should add Kai's IWQoS'17 paper (NOVA) and its previous ICNP'16 poster

---

From: Dawn Chan <[email-masked]>
Date: Tue, 12 Jun 2018 05:07:38 +0000

Hi Shawn,

I remember that the document is set privacy, so could you please send an invitation to others?

Dawn

________________________________________
From: alto <[email-masked]> on behalf of Shawn Lin <[email-masked]>
Sent: Tuesday, June 12, 2018 10:11:53 AM
To: Y. Richard Yang
Cc: IETF ALTO
Subject: Re: [alto] a survey of ALTO

We created a Google Sheets [1] to collect such information. Please feel free to edit or comment on it!
The current header of this Google Sheets mainly includes "Paper/Project/RFC Name", "Cited", "Year", "Extend Standard ALTO or not", "How they use ALTO?", "Challenges and Research Opportunities", "Others" and "Catagory".

[1] https://docs.google.com/spreadsheets/d/1dgbVApnyyiIjbSFp49jSIz3XQHMbmme3WXMQfOZVpY0/edit?usp=sharing

Bests,
Shawn

On Tue, Jun 12, 2018 at 6:22 AM Y. Richard Yang <[email-masked]<mailto:[email-masked]>> wrote:
Great suggestion, Christian!

Qiao: thanks for pointing out the related work. The IWQoS'17 and ICNP'16 work are highly related indeed.

Shawn: I will be more than happy to review the addition of the table, as Christian suggested. It can be part of the draft, or you can post such a table on the mailing list for discussions, as IETF uses mailing list as one key venue of discussions.

Thanks!
Richard

On Mon, Jun 11, 2018 at 5:09 PM Qiao Xiang <[email-masked]<mailto:[email-masked]>> wrote:
Hi Christian,

Shawn: I understand this is not a complete list. Just a reminder that you should add Kai's IWQoS'17 paper (NOVA) and its previous ICNP'16 poster paper (ORSAP) in the survey. They are based on the ALTO-PV and ALTO-RSA drafts.

Best
Qiao

On Mon, Jun 11, 2018 at 12:06 PM Christian Esteve Rothenberg <[email-masked]..unicamp.br<mailto:chesteve@dca..fee.unicamp.br>> wrote:
Nice work!

-ch
Em seg, 11 de jun de 2018 às 03:32, Jensen Zhang
<[email-masked]<mailto:[email-masked]>> escreveu:
> On Mon, Jun 11, 2018 at 1:21 PM Shawn Lin <[email-masked]<mailto:[email-masked]>> wrote:
>>
>> Dear ALTOers,
>>
>>
>> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
alto mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/alto

--
Qiao Xiang
Postdoctoral Fellow,
Department of Computer Science,
Yale University
_______________________________________________
alto mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/alto

--
--
 =====================================
| Y. Richard Yang <[email-masked]<mailto:[email-masked]>>   |
| Professor of Computer Science       |
| http://www.cs.yale.edu/~yry/        |
 =====================================
_______________________________________________
alto mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/alto

---

From: Shawn Lin <[email-masked]>
Date: Tue, 12 Jun 2018 18:49:40 +0800

Thanks, Dawn.

The current setting of this Google Sheets is *"Anyone with the link can
edit"*. So I think everyone can edit it through that link.
If anyone has a problem with editing that sheet, please ping me, and I will
send an invitation:)

Bests,
Shawn

On Tue, Jun 12, 2018 at 1:07 PM Dawn Chan <[email-masked]> wrote:

> On Mon, Jun 11, 2018 at 12:06 PM Christian Esteve Rothenberg
> <[email-masked]..unicamp.br<mailto:chesteve@dca..fee.unicamp.br>> wrote:
> Nice work!
>

---

From: Qiao Xiang <[email-masked]>
Date: Wed, 13 Jun 2018 21:32:03 -0400

Hi Shawn,

I added a column "single/multi domain" in the spreadsheet. I feel this is
important because as we are seeing more and more multi-domain use cases of
ALTO. For starters, there are two active drafts in the WG documenting the
design and deployment of ALTO in multi-domain networks, i.e., Unicorn and
Broker-assisted orchestration. Danny, Christian and I are also working on a
new draft on multi-domain service function chaining with ALTO.

Best
Qiao

On Tue, Jun 12, 2018 at 6:50 AM Shawn Lin <[email-masked]> wrote:

> If anyone has a problem with editing that sheet, please ping me, and I
> will send an invitation:)
>
> Bests,
> Shawn
>
>
> On Tue, Jun 12, 2018 at 1:07 PM Dawn Chan <[email-masked]
> <dawn_chen_f@hotmail..com>> wrote:
>
>> Hi Shawn,
>>
>> From: alto <[email-masked]> on behalf of Shawn Lin <
>> [email-masked] <[email-masked]>>