Subject: [alto] Need to move SSE to WGLC, but ...

From: "Vijay K. Gurbani" <[email-masked]>
Date: Fri, 8 Jun 2018 10:04:01 -0500

Folks: Jan and I would like to move SSE [1] to WGLC.

Looking at the mailing list, we note that the authors are asking input
from the WG on an issue in SSE [2].

We would kindly request the WG to spend some time thinking about the
question being asked in [2] and to chime in with some thoughts.

Assuming that there is no response by next week on this, the authors can
proceed with their default position on this, for which they have an
articulated reason in [2].

Jan and I will follow up next week and if there has not been any further
list discussion on this, we will move the work ahead to WGLC.

[1] https://datatracker.ietf.org/doc/draft-ietf-alto-incr-update-sse/
[2] https://www.ietf.org/mail-archive/web/alto/current/msg03684.html

Thanks,

- vijay
--
Vijay K. Gurbani / [email-masked]
Network Data Science, Nokia Networks
Calendar: http://goo.gl/x3Ogq

---

From: "Y. Richard Yang" <[email-masked]>
Date: Sat, 9 Jun 2018 15:57:14 -0400

Dear Vijay, Jan,

Thank you so much. It is a wonderful idea to check the WG for additional
comments on the mentioned issues. The authors will address suggestions, if
any, and then move the document forward.

Thanks!
Richard

On Fri, Jun 8, 2018 at 11:04 AM Vijay K. Gurbani <[email-masked]>
wrote:

> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto
>

-- 
-- 
 =====================================
| Y. Richard Yang <[email-masked]>   |
| Professor of Computer Science       |
| http://www.cs.yale.edu/~yry/        |
 =====================================

---

From: Dawn Chan <[email-masked]>
Date: Mon, 11 Jun 2018 08:47:48 +0000

Hi Vijay,

Thanks for the reply, it is a good point that the result should also be sent in the update stream service.

Besides, there is another point that the result should also be sent in the update stream service. If the server process requests asynchronously, when it receives the request from the client and insert it in its queue, it will first send a response back to the client; and after the server successfully processed the request, it will send a reply via the update stream service. This case requires the server to indicate the state of the “remove” operation in the reply. A simple attribute “state” with type JSON boolean in the UpdateStream ControlEvent can solve the concern. If "state" is false, the operation fails; if "state" is true, the operation succeeds.

object {
        [String control-uri;]
        [Boolean state;]
        [String remove<1..*>;]
} UpdateStreamControlEvent;

This is my idea for option 2.

Wish to hear opinions from others in the group.

Best Wishes,
Dawn

________________________________________
From: alto <[email-masked]> on behalf of Y. Richard Yang <[email-masked]>
Sent: Sunday, June 10, 2018 3:57:14 AM
To: Gurbani, Vijay (Nokia - US)
Cc: IETF ALTO
Subject: Re: [alto] Need to move SSE to WGLC, but ...

Dear Vijay, Jan,

Thank you so much. It is a wonderful idea to check the WG for additional comments on the mentioned issues. The authors will address suggestions, if any, and then move the document forward.

Thanks!
Richard

On Fri, Jun 8, 2018 at 11:04 AM Vijay K. Gurbani <[email-masked]<mailto:[email-masked]>> wrote:
Folks: Jan and I would like to move SSE [1] to WGLC.

Thanks,

- vijay
--
Vijay K. Gurbani / [email-masked]<mailto:[email-masked]>
Network Data Science, Nokia Networks
Calendar: http://goo.gl/x3Ogq

_______________________________________________
alto mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/alto

--
--
 =====================================
| Y. Richard Yang <[email-masked]<mailto:[email-masked]>>   |
| Professor of Computer Science       |
| http://www.cs.yale.edu/~yry/        |
 =====================================

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 11 Jun 2018 10:03:16 -0500

Dawn: Yes, pipelining is another good reason to send the response in
the update stream control service.

This, and the other reasons I indicate in a different thread [1]
makes me prefer option 2.

[1] https://www.ietf.org/mail-archive/web/alto/current/msg03687.html

Cheers,

- vijay

---

From: "Y. Richard Yang" <[email-masked]>
Date: Mon, 11 Jun 2018 18:50:39 -0400

Hi Vijay, all

> makes me prefer option 2.
+1

Richard

> > Besides, there is another point that the result should also be sent in
> the update stream service. If the server process requests asynchronously,
> when it receives the request from the client and insert it in its queue, it
> will first send a response back to the client; and after the server
> successfully processed the request, it will send a reply via the update
> stream service. This case requires the server to indicate the state of the
> “remove” operation in the reply. A simple attribute “state” with type JSON
> boolean in the UpdateStream ControlEvent can solve the concern. If "state"
> is false, the operation fails; if "state" is true, the operation succeeds.
> >
> > object {
> >         [String control-uri;]
> >         [Boolean state;]
> >         [String remove<1..*>;]
> > On Fri, Jun 8, 2018 at 11:04 AM Vijay K. Gurbani <
> [email-masked]<mailto:[email-masked]>> wrote:

---

From: Dawn Chan <[email-masked]>
Date: Tue, 12 Jun 2018 05:14:59 +0000

Hi Richard, all

I see no objection in option 2 and the new attribute in UpdateStreamControlEvent to deal with the pipelining. I will upload a new version using this design soon.

object {
        [String control-uri;]
        [Boolean state;]
        [String remove<1..*>;]

Thanks,
Dawn

________________________________________
From: Y. Richard Yang <[email-masked]>
Sent: Tuesday, June 12, 2018 6:50:39 AM
To: Gurbani, Vijay (Nokia - US)
Cc: Chan Dawn; IETF ALTO
Subject: Re: [alto] Need to move SSE to WGLC, but ...

Hi Vijay, all

On Mon, Jun 11, 2018 at 11:03 AM Vijay K. Gurbani <[email-masked]<mailto:[email-masked]>> wrote:
Dawn: Yes, pipelining is another good reason to send the response in
the update stream control service.

+1

Richard

Cheers,

On 06/11/2018 03:47 AM, Dawn Chan wrote:
> From: alto <[email-masked]<mailto:[email-masked]>> on behalf of Y. Richard Yang <[email-masked]<mailto:[email-masked]>>
> On Fri, Jun 8, 2018 at 11:04 AM Vijay K. Gurbani <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>> wrote:
> Vijay K. Gurbani / [email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>
> [email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>
> | Y. Richard Yang <[email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>>   |

- vijay

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Fri, 15 Jun 2018 08:24:59 -0500

Richard, Dawn: As per [1], we need to move SSE ahead.

Since the posting of [1], there has been some discussion on the
remaining open issue with SSE; this discussion is captured in [2].

So, I think it is time to move the work ahead with the consensus reached
in [2].

Please issue a new version of the SSE draft by Monday.  As soon as it
appears in the IETF archives, Jan and I will start a WGLC on it.
Further discussions --- if any --- on the consensus reached in [2], can
be held as part of WGLC.

[1] https://www.ietf.org/mail-archive/web/alto/current/msg03686.html
[2] https://www.ietf.org/mail-archive/web/alto/current/msg03684.html

Thanks,

On 06/11/2018 05:50 PM, Y. Richard Yang wrote:
> Hi Vijay, all
> 
> 
> On Mon, Jun 11, 2018 at 11:03 AM Vijay K. Gurbani
> <[email-masked] <mailto:[email-masked]>> wrote:
> 

- vijay

---

From: Dawn Chan <[email-masked]>
Date: Sat, 16 Jun 2018 06:36:50 +0000

Hi Vijay,

A new version of SSE is already submitted to the WG. We can move things forward.

Thanks,
Dawn
> On 15 Jun 2018, at 9:24 PM, Vijay K. Gurbani <[email-masked]> wrote:
>

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 18 Jun 2018 10:07:58 -0500

Dawn: Does the version of SSE submitted to the IETF archives reflect the
consensus achieved in [1]?

If not, I would kindly urge you to spin a new version of SSE with this
consensus in it.  I will like that version to go to WGLC so that list
members get another opportunity to comment on it.

Please do so as soon as you can, preferably within a 24-hour period if
possible.  I will start a WGLC for the new version as soon as it becomes
available.

[1] https://www.ietf.org/mail-archive/web/alto/current/msg03684.html

Thanks,

- vijay