Subject: [ANCP] Reporting "Training" state

From: [email-masked]
Date: Mon, 22 Jan 2007 10:53:45 +0100

Hi all,

In the current ANCP IETF draft,
http://www.ietf.org/internet-drafts/draft-wadhwa-gsmp-l2control-configuration-02.txt

One reads that DSL "Training" state, 

1) should be reported upon OAM requests,
Cf  section 5.4.4:
    0x500 : Specified access line does not exist. 
    0x501 : Loopback test timed out. 
    0x502 : Reserved 
    0x503 : DSL line status showtime. 
    0x504 : DSL line status idle. 
    0x505 : DSL line status silent. 
    0x506 : DSL line status training. 
    0x507 : DSL line integrity error. 
    0x508 : DSLAM resource not available. 
    0x509 : Invalid test parameter. 

2) but not in "Toplogy Discovery" messages, 
Cf section 5.4.2: 
    Type (DSL line state = 0x8F)
    (...)
    { SHOWTIME = 0x01, IDLE = 0x02, SILENT = 0x03 } 

Question: is this intentional or is "training" state just forgotten in 
"Topology Discovery" messages ?

Thanks for clarifications,
Kind regards,
Robert Peschi

_______________________________________________
ANCP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ancp

---

From: "Busser, M" <[email-masked]>
Date: Thu, 25 Jan 2007 14:52:15 +0100

Hi all

I agree with Robert.

OAM-Ping is intended to request the actual state of a line. 

Therefor, if a line is in training mode, we should report "training mode".

The PortUp/Down Event messages are intend to give the BRAS the actual state of each port.

The "training state" can only be entered from the silent state, but it is not a steady state.

As long as a line is not in showtime, no traffic can flow. For that reason, sending Port Down 

with line state = "silent" seems to be appropriate. 

Kind regards

Michael

	-----Ursprüngliche Nachricht-----
	Von: [email-masked] [mailto:[email-masked]] 
	Gesendet: Dienstag, 23. Januar 2007 11:46
	An: Jakob Heitz
	Cc: [email-masked]
	Betreff: Re: [ANCP] Reporting "Training" state

	Hello Jakob and All, 
	
	My take: 
	
	1) Training means that the DSLAM is establishing DSL connectivity 
	     so DSLAM is certainly "willing"  to establish connectivity with CPE 
	        so DSLAM  is certainly NOT idle which would mean "unwilling" 
	
	2) Training also means that the DSL connectivity is not yet OK 
	    so it is certainly NOT showtime which would mean "traffic able to flow" 
	
	So, for  what topology discovery is used for, the most sensible looks to be: 
	
	"Send port DOWN with line state = silent" 
	
	Kind regards, 
	Robert 

Jakob Heitz <[email-masked]> 

01/22/2007 09:25 PM 

        To:        [email-masked] 
        cc:         
        Subject:        Re: [ANCP] Reporting "Training" state

	
	The "DSL line state" TLV is mandatory in PORT DOWN messages
	and optional in PORT UP messages. When the DSLAM establishes
	an ANCP connection, it will send a topology discovery message
	for EVERY port: either PORT UP or PORT DOWN.
	
	What should this TLV contain if a DSL line is in the "training"
	state at this time?
	
	Kind Regards,
	Jakob Heitz.
	
	Derek Harkness wrote:
	> My understanding would be that the topology discovery message is sent 
	> when the line reaches a steady state ( one of the 3 listed ) and when 
	> it is training the line state is in some form transition between 2 of 
	> these states
	>  
	> D
	>  
	> +=============================+
	> Derek Harkness
	> Juniper Networks
	> Nymphenburger Strasse 13-15
	> 80335 Munich
	> Germany
	> Tel: +49 89 5529 4916
	> Mobile: +49 172 843 6621
	> Email: [email-masked] <mailto:[email-masked]>
	> +=============================+
	>  
	>
	> ------------------------------------------------------------------------
	> *From:* [email-masked] 
	> [mailto:[email-masked]]
	> *Sent:* 22 January 2007 14:23
	> *To:* [email-masked]
	> *Subject:* [ANCP] Reporting "Training" state
	>
	>
	> Hi All,
	>
	> /    0x500 : Specified access line does not exist. /
	> /    0x501 : Loopback test timed out. /
	> /    0x502 : Reserved /
	> /    0x503 : DSL line status showtime. /
	> /    0x504 : DSL line status idle. /
	> /    0x505 : DSL line status silent. /
	> /    0x506 : DSL line status *training*//. /
	> /    0x507 : DSL line integrity error. /
	> /    0x508 : DSLAM resource not available. /
	> /    0x509 : Invalid test parameter. /
	>
	>
	> Cf section 5.4.2:/ /
	> /    (...)/
	> /    { SHOWTIME = 0x01, IDLE = 0x02, SILENT = 0x03 } /
	>
	>
	> ------------------------------------------------------------------------
	>