Subject: Admission Request message Re: [ANCP] Comments on draft-maglione

From: Francois Le Faucheur IMAP <[email-masked]>
Date: Fri, 7 Sep 2007 13:58:17 +0200

Sanjay et al,

> 4.2 Conditional access and admission control with NAS decision
> It is not clear what information is required / envisaged for the  
> Admission Request / Response messages -
> Multicast Flow and ACI at a minimum seems to be needed.

The document lists the parameters for Admission Requests in the  
"Message Flows" section, but I agree that those need to be listed  
first in the "Protocol Requirements" sections.

The parameters currently identified for Admission Request are:
	- Flow_Id
	- Port_Id
Flow_Id = (S,G) or (*,G)
Do you see other parameters that need to be added to Admission Request?

The parameters currently identified for Admission Response are:
	- Accounting_Flag (which allows the NAS to tell AN if accounting is  
required for this flow).
Do you see other parameters that need to be added to Admission Response?

> It will be useful to clarify that the NAS is expected to know the  
> BW information for the multicast flow (flow-group) for which  
> admission control is being requested.

Agreed.

> This could be locally configured on the NAS, could be provided at  
> auth time from radius/policy server, or could be dynamically auto- 
> sensed (measured) on the NAS.

Agreed. In the future it could also potentially be explicitely  
signaled by the source.

Francois

_______________________________________________
ANCP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ancp

---

From: "Wojciech Dec (wdec)" <[email-masked]>
Date: Wed, 19 Sep 2007 16:46:43 +0200

Hi Francois,
 
inline...

________________________________

	From: Francois Le Faucheur (flefauch) 
	Sent: 07 September 2007 13:58
	To: Sanjay Wadhwa
	Cc: [email-masked]
	Subject: Admission Request message Re: [ANCP] Comments on
draft-maglione

	Sanjay et al, 

		4.2 Conditional access and admission control with NAS
decision
		It is not clear what information is required / envisaged
for the Admission Request / Response messages - 
		Multicast Flow and ACI at a minimum seems to be needed.

	The document lists the parameters for Admission Requests in the
"Message Flows" section, but I agree that those need to be listed first
in the "Protocol Requirements" sections.

	The parameters currently identified for Admission Request are:
	- Flow_Id
	- Port_Id 
	Flow_Id = (S,G) or (*,G)
	Do you see other parameters that need to be added to Admission
Request? 
	 
	Woj> IMO it wouldn't hurt to allow the message to optionally
carry of other info that could be derived from the received trigger, eg
source MAC, and source IP address.

	The parameters currently identified for Admission Response are:
	- Accounting_Flag (which allows the NAS to tell AN if accounting
is required for this flow).
	Do you see other parameters that need to be added to Admission
Response? 
	 
	Woj> Additional parameters will be needed, especially to allow
the Admission Response to be decoupled from the Request. These would
then be:
	- Flow_Id
	- Target Port_id
	 
	Regards,
	Woj.

		It will be useful to clarify that the NAS is expected to
know the BW information for the multicast flow (flow-group) for which
admission control is being requested. 

	Agreed.

		This could be locally configured on the NAS, could be
provided at auth time from radius/policy server, or could be dynamically
auto-sensed (measured) on the NAS.

	Francois