Subject: [ANCP] Link bonding

From: "Sanjay Wadhwa" <[email-masked]>
Date: Wed, 19 Sep 2007 14:53:25 -0400

All  
   I would like to get some feedback on requirements for ANCP to support link bonding e.g.as defined in ITU-T G.998.2 (EFM bonding). At a high level it seems the AN should report the aggregate rate for the bonded links to the BNG. If an existing link in the bundle goes down or a new link in the bundle is added, the AN should report this to the BNG as a change in the downstream and upstream rate. In case of regular un-bonded link, the ACI that is used for addressing a local-loop has a default syntax that carries 
AN-name/slot/port/vpi.vci or vlan. In case of link bonding, I suppose the AN should use "logical addressing" for the bonded link when constructing the ACI (inserted in DHCP opt82/pppoe IA tags, and ANCP). BNG would transparently correlate the rate received in ANCP messages to subscriber's interface based on ACI and adjust its traffic-shaping accordingly. The overhead due to (variable sized) fragmentation on the bonded link somehow needs to be accounted for on the BNG to calculate the effective rate of the local-loop. This is dependent on the packet sizes, and the framgentation scheme used on the AN. A very simplistic solution could be for the AN to report a fixed overhead to the BNG for fragmentation.

Do we see other implications of bonding on the topology-discovery/adaptive-rate use case ?

Thanks
-Sanjay

_______________________________________________
ANCP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ancp

---

From: "Haag, T" <[email-masked]>
Date: Thu, 20 Sep 2007 12:46:06 +0200

All,

considering link bonding (ITU-T G.998.2 (EFM bonding) and ANCP is very welcome but I would like to recommend not combine DHCP Option 82 or PPPoE intermediate function issues with that use case. 

I think these are two separate issues which may be combined but not necessarily needed to be combined. From an operator's standpoint ANCP protocol issues should be considered stand alone for link bonding without PPPoE or DHCP because for products using bonded links PPP or DHCP is not mandatory. 

Regards

Thomas

-----Ursprüngliche Nachricht-----
Von: Sanjay Wadhwa [mailto:[email-masked]] 
Gesendet: Mittwoch, 19. September 2007 20:53
An: [email-masked]
Cc: Haag, Thomas; [email-masked]
Betreff: Link bonding

All  

Thanks
-Sanjay