Subject: [ANCP] PORT UP Data Rate?

From: "Wojciech Dec (wdec)" <[email-masked]>
Date: Mon, 5 Nov 2007 10:36:05 +0100

Hi All,

Hopefully someone can clarify for me the meaning of the Actual data rate
value in ANCP's PORT-UP messages, and also perhaps comment on their
current implementations. Is this rate meant to be the rounded up
effective transport capacity (deriving from various ADSL Transport
Classes) or raw DSL modem speed? The difference between the two is
primarily in the DSL PHY encoding overhead.

The framework and protocol drafts are not too clear on this matter, but
seem to point more towards the former if anything. 

For example the framework 03 draft currently reads in Section 3.1 as
follows :

  o  The identification and speed (data rate) of the DSL Access Loop
      (also known as the "DSL sync rate")

   o  The identification and speed (data rate) of the Remote
      Terminal(RT)/Access Node uplink (when relevant)

   The NAS can adjust downstream shaping to current Access Loop actual
   data rate, and more generally re-configure the appropriate nodes of
   its hierarchical scheduler (support of advanced capabilities
   according to TR-101).

   This use case may actually include more information than link
   identification and corresponding data rates.  In case of DSL Access
   Loops, the following Access Loop characteristics can be sent to the
   NAS (cf. ITU-T Recommendation G.997.1 [G.997.1]):

   o  DSL Type (e.g.  ADSL1, ADSL2, SDSL, ADSL2+, VDSL, VDSL2)

   o  Framing mode (e.g.  ATM, ITU-T Packet Transfer Mode (PTM), IEEE
      802.3 Ethernet in the First Mile (EFM))

   o  DSL port state (e.g. synchronized/showtime, low power, no power/
      idle)

   o  Actual net data rate (upstream/downstream)

While the protocol draft says the following:

         Following sub-TLVs are currently defined : 

          . Type (DSL-Type = 0x91) : Defines the type of transmission
system 
             in use. This is a mandatory TLV. 

             Length :  (4 bytes)   

             Value  : (Transmission system : ADSL1 = 0x01, ADSL2 = 0x02,

             ADSL2+ = 0x03, VDSL1 = 0x04, VDSL2 = 0x05, SDSL = 0x06,
UNKNOWN 
             = 0x07). 

          . Type (Actual-Data-Rate-Upstream = 0x81) : Actual data rate 
             upstream of a synchronized DSL line. This is a mandatory
TLV. 
             This rate value and all the subsequent ones account for the
DSL 
             overhead (i.e. signify the net rate).   

            Length  :  (4 bytes) 

            Value   : (Rate in Kb/sec) 

          . Type (Actual-Data-Rate-Downstream = 0x82) : Actual data rate

             downstream of a synchronized DSL line. This is a mandatory
TLV. 

             Length :  (4 bytes) 

Regards,
Woj.

_______________________________________________
ANCP mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ancp

---

From: "Wojciech Dec (wdec)" <[email-masked]>
Date: Wed, 7 Nov 2007 09:46:50 +0100

Hi Folks,
 
can anyone reply? To put the question in other words, if ANCP signals a
line rate of downstream rate of 4Mbps, is this the effective ATM VC or
Ethernet "circuit" data carrying capacity, or is it the raw modem rate
which does not include DSL PHY overheads? The text should be *very*
clear about this.
 
-Woj.

________________________________

	From: Wojciech Dec (wdec) 
	Sent: 05 November 2007 10:36
	To: [email-masked]
	Subject: [ANCP] PORT UP Data Rate?

	Hi All, 

	Hopefully someone can clarify for me the meaning of the Actual
data rate value in ANCP's PORT-UP messages, and also perhaps comment on
their current implementations. Is this rate meant to be the rounded up
effective transport capacity (deriving from various ADSL Transport
Classes) or raw DSL modem speed? The difference between the two is
primarily in the DSL PHY encoding overhead.

	The framework and protocol drafts are not too clear on this
matter, but seem to point more towards the former if anything. 

	For example the framework 03 draft currently reads in Section
3.1 as follows : 

	  o  The identification and speed (data rate) of the DSL Access
Loop 
	      (also known as the "DSL sync rate") 

	   The NAS can adjust downstream shaping to current Access Loop
actual 
	   data rate, and more generally re-configure the appropriate
nodes of 
	   its hierarchical scheduler (support of advanced capabilities 
	   according to TR-101). 

	   identification and corresponding data rates.  In case of DSL
Access 
	   Loops, the following Access Loop characteristics can be sent
to the 
	   NAS (cf. ITU-T Recommendation G.997.1 [G.997.1]): 

	   o  Framing mode (e.g.  ATM, ITU-T Packet Transfer Mode (PTM),
IEEE 
	      802.3 Ethernet in the First Mile (EFM)) 

	   o  DSL port state (e.g. synchronized/showtime, low power, no
power/ 
	      idle) 

	          . Type (DSL-Type = 0x91) : Defines the type of
transmission system 
	             in use. This is a mandatory TLV. 

	             Length :  (4 bytes)   

	             Value  : (Transmission system : ADSL1 = 0x01, ADSL2
= 0x02,     
	             ADSL2+ = 0x03, VDSL1 = 0x04, VDSL2 = 0x05, SDSL =
0x06, UNKNOWN 
	             = 0x07). 

	          . Type (Actual-Data-Rate-Upstream = 0x81) : Actual
data rate 
	             upstream of a synchronized DSL line. This is a
mandatory TLV. 
	             This rate value and all the subsequent ones account
for the DSL 
	             overhead (i.e. signify the net rate).   

	            Length  :  (4 bytes) 

	            Value   : (Rate in Kb/sec) 

	          . Type (Actual-Data-Rate-Downstream = 0x82) : Actual
data rate 
	             downstream of a synchronized DSL line. This is a
mandatory TLV. 

	             Length :  (4 bytes) 

	Regards, 
	Woj.

---

From: Stefaan DE CNODDER <[email-masked]>
Date: Wed, 07 Nov 2007 10:24:10 +0100

Woj,

It looks to me that the framework document is correct, and that the 
protocol draft has to replace "data rate" by "net data rate" to make it 
more accurate, i.e., for istance:

Type (Actual-Data-Rate-Upstream = 0x81) : Actual data rate upstream of a 
synchronized DSL line...

should be

Type (Actual-Data-Rate-Upstream = 0x81) : Actual net data rate upstream 
of a synchronized DSL line...

The term "net data rate" is accurately defined in section 1.2 of the 
framework document by referring to the ITU standard.

I hope we all have the same understanding of the definition of the 
bandwidth advertised by ANCP.

regards,
Stefaan

Wojciech Dec (wdec) wrote:

>              upstream of a synchronized DSL line. This is a mandatory TLV.
> ------------------------------------------------------------------------
>

---

From: "Moti Morgenstern" <[email-masked]>
Date: Wed, 7 Nov 2007 12:05:41 +0200

Hi,

May I comment that in DSLF WT-147 both terms are included and the
relationship (sameness?) between them is described.

Regards,
Moti Morgenstern

-----Original Message-----
From: Stefaan DE CNODDER [mailto:[email-masked]] 
Sent: Wednesday, November 07, 2007 11:24 AM
To: Wojciech Dec (wdec)
Cc: [email-masked]
Subject: Re: [ANCP] PORT UP Data Rate?

Woj,

synchronized DSL line...

should be

regards,
Stefaan

TLV.
>              downstream of a synchronized DSL line. This is a
mandatory

---

From: <[email-masked]>
Date: Wed, 7 Nov 2007 15:38:47 +0530

Hi Woj,
 
It looks to me that the terminology used here is consistent with the physical layer definitions of ITU-T G.997.1 (sec. 7.5.2.1). This is what will be probably used by ANCP from MIB. Actual data rate is defined to indicate the actual net data rate of the bearer channel, but this excludes the rates in DSL line power saving states L1 and L2. ANCP needs to include report rate reduction in L2 state as well.
 
With ATM transport over DSL, ITU-T has an illustration of what rate includes overhead:
53 × 8 × ATM cell rate = "Net data rate" 
"Net data rate" + Frame overhead rate = "Aggregate data rate"  
"Aggregate data rate" + RS Coding overhead rate = "Total data rate" 
"Total data rate" + Trellis Coding overhead rate = Line rate
But some implementations treat Net data rate + frame overhead rate as the line rate.
 
For ANCP, it is probably the net data rate at all states of the line.
 
Thanks,
Kirubaharan

	-----Original Message-----
	From: Wojciech Dec (wdec) [mailto:[email-masked]] 
	Sent: Wednesday, November 07, 2007 2:17 PM
	To: Wojciech Dec (wdec); [email-masked]
	Subject: RE: [ANCP] PORT UP Data Rate?

	Hi Folks,
	 
	can anyone reply? To put the question in other words, if ANCP signals a line rate of downstream rate of 4Mbps, is this the effective ATM VC or Ethernet "circuit" data carrying capacity, or is it the raw modem rate which does not include DSL PHY overheads? The text should be *very* clear about this.
	 
	-Woj.

		Hi All, 

		Hopefully someone can clarify for me the meaning of the Actual data rate value in ANCP's PORT-UP messages, and also perhaps comment on their current implementations. Is this rate meant to be the rounded up effective transport capacity (deriving from various ADSL Transport Classes) or raw DSL modem speed? The difference between the two is primarily in the DSL PHY encoding overhead.

		The framework and protocol drafts are not too clear on this matter, but seem to point more towards the former if anything. 

		For example the framework 03 draft currently reads in Section 3.1 as follows : 

		          . Type (DSL-Type = 0x91) : Defines the type of transmission system 
		             in use. This is a mandatory TLV. 

		             Length :  (4 bytes)   

		             Value  : (Transmission system : ADSL1 = 0x01, ADSL2 = 0x02,     
		             ADSL2+ = 0x03, VDSL1 = 0x04, VDSL2 = 0x05, SDSL = 0x06, UNKNOWN 
		             = 0x07). 

		          . Type (Actual-Data-Rate-Upstream = 0x81) : Actual data rate 
		             upstream of a synchronized DSL line. This is a mandatory TLV. 
		             This rate value and all the subsequent ones account for the DSL 
		             overhead (i.e. signify the net rate).   

		            Length  :  (4 bytes) 

		            Value   : (Rate in Kb/sec) 

		          . Type (Actual-Data-Rate-Downstream = 0x82) : Actual data rate 
		             downstream of a synchronized DSL line. This is a mandatory TLV. 

		             Length :  (4 bytes) 

		Regards, 
		Woj.

---

From: "Sanjay Wadhwa" <[email-masked]>
Date: Wed, 7 Nov 2007 07:12:35 -0500

The reported rate is "net data rate" (includes DSL overhead). The
protocol draft explicitly mentions it:

. Type (Actual-Data-Rate-Upstream = 0x81): Actual data rate upstream of
a synchronized DSL line. This is a mandatory TLV.

This rate value and all the subsequent ones account for the DSL overhead
(i.e. signify the net rate).

-Sanjay

-----Original Message-----
From: Stefaan DE CNODDER [mailto:[email-masked]] 
Sent: Wednesday, November 07, 2007 4:24 AM
To: Wojciech Dec (wdec)
Cc: [email-masked]
Subject: Re: [ANCP] PORT UP Data Rate?

Woj,

synchronized DSL line...

should be

regards,

Stefaan

>              Value  : (Transmission system : ADSL1 = 0x01, ADSL2 = 

> 0x02,    

TLV.

mandatory 

 

ANCP mailing list

[email-masked]

---

From: Stefaan DE CNODDER <[email-masked]>
Date: Wed, 07 Nov 2007 13:27:26 +0100

net data rate does not include DSL overhead (I understand DSL overhead 
as being the overhead at PHY level, but not the ATM overhead or EFM 
overhead).  See mail of Kirubaharan.

So if net data rate is 4 Mbps, then ATM cells can be transported over 
the DSL line at a rate of 4 Mbps.

regards,
Stefaan

Sanjay Wadhwa wrote:
> /This rate value and all the subsequent ones account for the DSL 
> overhead (i.e. signify the net rate)./
> 
> / /
> 
> -Sanjay
> 
>  
>

---

From: "Haag, T" <[email-masked]>
Date: Wed, 7 Nov 2007 14:00:26 +0100

Woj,

Referring to Table 1, WT147 DSLForum as well as TR-101 Table 3 the definition looks like the following table. 

Both tables are the same to be consistent between requirements of PPPoE intermediate/DHCP relay agent and Layer 2 Control. From my understanding there should not be a range for interpretation because ITU G.99x defines the meaning of the referred rates.

Pos.

Message Type

Information

Reference 

1

DSL Type: ADSL Transmission System

Which DSL type is in use

(e.g. ADSL1, ADSL2, SDSL, ADSL2+, VDSL, VDSL2...)

This parameter defines the transmission system in use

Not described 

ITU-T G.997.1 

Section 7.5.1.1

2

DSL Port State

Port up (showtime)/ port down (idle or silent)

ITU-T G.997.1 Section 7.5.1.5

3

Actual data rate Up- and Downstream

Actual data rate upstream and downstream of a synchronized DSL port

ITU-T G.997.1

Section 7.5.2.1

4

Attainable Data Rate Up- and Downstream

Maximum data rate which can be achieved.

ITU-T G.997.1 Section 7.5.1.19 and 7.5.1.20

5

Minimum Data Rate

minimum data rate desired by the operator in kbit/s (up/down)

ITU-T G.997.1 

Section 7.3.2.1.1

6

Maximum Data Rate

maximum data rate desired by the operator in kbit/s. (up/down)

ITU-T G.997.1

Section 7.3.2.1.3

7

Minimum Data Rate in low power state

minimum data rate  desired by the operator during the low power state (L1/L2). 

ITU-T G.997.1

Section 7.3.2.1.5

8

Maximum Interleaving Delay

maximum one-way interleaving delay

ITU-T G.997.1

Section 7.3.2.2

9

Actual interleaving Delay

Value in milliseconds which corresponds to inter leaver setting.

ITU-T G.997.1

section 7.5.2.3

Referring now to the open question of: What does "data rate" mean? ITU-T G.997.1 Section 7.5.2.1 gives the following definition:

7.5.2.1  Actual Data Rate

This parameter reports the actual net data rate the bearer channel is operating at excluding rate in L1 and L2 states. In L1 or L2 states, the parameter contains the net data rate in the previous L0 state. The data rate is coded in bit/s.

Now considering the meaning of net data rate:

G.997.1 referres in chapter 3 Definitions to the relevant DSL standards:

3.5              net data rate: Net data rate is defined in G.992.x-series Recommendations.

That means that the net data rate differs.

For ADSL2: G.992.3

3.28net data rate: The sum of all frame bearer data rates over all latency paths in any one direction.

Table 5-1/G.992.3 - Data rate terminology and definitions

Data rate

Equation (kbit/s)

Reference point

Net data rate

(see Table 7-7)

α, β

Aggregate data rate = Net data rate + Frame overhead rate

 (see Table 7-7)

A

Total data rate = Aggregatedata rate + RS Coding overhead rate

(see Table 7-6)

B, C, δ

Line rate = Total data rate + Trellis Coding overhead rate

(see Table 8-4)

U

For VDSL2 G.993.2 provides appropriate definitions. These definitions are dependent on the used TC layer. For more details G.993.2 is recommended.

Regards

Thomas 

Von: Wojciech Dec (wdec) [mailto:[email-masked]] 
Gesendet: Mittwoch, 7. November 2007 09:47
An: Wojciech Dec (wdec); [email-masked]
Betreff: RE: [ANCP] PORT UP Data Rate?

Hi Folks,

-Woj.

	Hi All, 

	             Length :  (4 bytes)   

	            Length  :  (4 bytes) 

	            Value   : (Rate in Kb/sec) 

	             Length :  (4 bytes) 

	Regards, 
	Woj.

---

From: "PESCHI Robert" <[email-masked]>
Date: Wed, 7 Nov 2007 14:13:21 +0100

Sanjay Wadhwa wrote:
> . Type (Actual-Data-Rate-Upstream = 0x81): Actual data rate upstream 
> of a synchronized DSL line. This is a mandatory TLV.
> 

Just unfortunate wording I would say...

I think that "Accounting for DSL overhead" means "having substacted DSL
overhead";
it does not mean "including DSL overhead".

("Including DSL overhead" cannot mean "DSL net rate")

Regards,
Robert

-----Original Message-----
From: DE CNODDER Stefaan 
Sent: Wednesday, November 07, 2007 1:27 PM
To: Sanjay Wadhwa
Cc: [email-masked]
Subject: Re: [ANCP] PORT UP Data Rate?

regards,
Stefaan

Sanjay Wadhwa wrote:
> . Type (Actual-Data-Rate-Upstream = 0x81): Actual data rate upstream 
> of a synchronized DSL line. This is a mandatory TLV.
> 
> Type (Actual-Data-Rate-Upstream = 0x81) : Actual data rate upstream of

> a
TLV.

---

From: "REYNDERS Paul" <[email-masked]>
Date: Wed, 7 Nov 2007 14:08:33 +0100

The DSL overhead is not transmitted between NAS and Access Node. As
such, the DSL data rate that includes DSL overhead ("Sanjay's net data
rate") must not be input for the Hierarchical Scheduling by NAS. For
this HS, NAS needs DSL data rate that excluding DSL overhead ("Stefaan's
net data rate"). The latter also decouples the access line technology
(ADSL, EFM,...) from the aggregation network technology (ATM, Ethernet).
Also consider the difficulties HS at NAS may have with evolving
subsciber line transmission technologies if the data rate reported to
NAS includes "DSL overhead".
 
Paul Reynders

Alcatel-Lucent Bell NV 
Copernicuslaan 50, 2018 Antwerp, Belgium
________________________________

From: Sanjay Wadhwa [mailto:[email-masked]] 
Sent: woensdag 7 november 2007 13:13
To: DE CNODDER Stefaan; Wojciech Dec (wdec)
Cc: [email-masked]
Subject: RE: [ANCP] PORT UP Data Rate?

-Sanjay

-----Original Message-----
From: Stefaan DE CNODDER [mailto:[email-masked]] 
Sent: Wednesday, November 07, 2007 4:24 AM
To: Wojciech Dec (wdec)
Cc: [email-masked]
Subject: Re: [ANCP] PORT UP Data Rate?

Woj,

synchronized DSL line...

should be

regards,

Stefaan

---

From: "Sanjay Wadhwa" <[email-masked]>
Date: Wed, 7 Nov 2007 09:23:38 -0500

Steffan
  You are ignoring what the draft says. It clearly says "account for the
DSL overhead" i.e. the value sent in the TLV has factored in the DSL
overhead. I don't see any ambiguity here. 
Use of "including" in the mail didn't mean expclitly sending in the
overhead. It was meant as DSLAM sends the rate after including the DSL
overhead in its calculation (i.e. accounting for it / subtracting it). 

-Sanjay

>From: PESCHI Robert [mailto:[email-masked]]
>Sent: Wednesday, November 07, 2007 8:13 AM
>To: DE CNODDER Stefaan; Sanjay Wadhwa
>Cc: [email-masked]
>> From: Stefaan DE CNODDER 
>[mailto:[email-masked]]
>>>  Hopefully someone can clarify for me the meaning of the 
>Actual data 
>>> rate
>> 
>>>  The framework and protocol drafts are not too clear on 
>this matter, 
>>> but
>> 
>transmission
>>>              This rate value and all the subsequent ones 
>account for 
>>> the
>> 
>>>  DSL
>>

---

From: Jakob Heitz <[email-masked]>
Date: Wed, 07 Nov 2007 09:59:05 -0800

Whatever it is, it needs to be constant in time.
Then the BRAS needs to know all the encapsulations
on top of it so that it can properly count data
bits in the shaper/meter.

If it is not constant in time, then the BRAS cannot
do that.

Examples of *not* constant in time
o HDLC bit stuffing at lower layer.
  actual data rate depends on the bit pattern.
o framing at lower layer.
  There are frame headers introduced between data
  bits that are unpredictable by the BRAS.

For any of this to be useful, it is imperative that the
shaper/meter in the BRAS can accurately track the time
that bits are sent at the DSLAM.

Wojciech Dec (wdec) wrote:
> Hi Folks,
>  
> can anyone reply? To put the question in other words, if ANCP signals 
> a line rate of downstream rate of 4Mbps, is this the effective ATM VC 
> or Ethernet "circuit" data carrying capacity, or is it the raw modem 
> rate which does not include DSL PHY overheads? The text should be 
> *very* clear about this.
>  
> -Woj.
>
>     *From:* Wojciech Dec (wdec)
>     *Sent:* 05 November 2007 10:36
>     *To:* [email-masked]
>     *Subject:* [ANCP] PORT UP Data Rate?
>
>     Hi All,
>
>     data rate value in ANCP's PORT-UP messages, and also perhaps
>     comment on their current implementations. Is this rate meant to be
>     the rounded up effective transport capacity (deriving from various
>     ADSL Transport Classes) or raw DSL modem speed? The difference
>     between the two is primarily in the DSL PHY encoding overhead.
>

-- 
Jakob Heitz.

---

From: "Wojciech Dec (wdec)" <[email-masked]>
Date: Thu, 8 Nov 2007 10:12:16 +0100

Precisely. So we seem to agree that the appropriate edits need to be
made in the protocol draft to clarify this? Section 3.1 of the framework
draft should also see a minor edit to the term "DSL sync rate", and the
use of the full "net data rate" term as introduced in the terminology
section.
 
Regards,
Woj.

	From: REYNDERS Paul [mailto:[email-masked]] 
	Sent: 07 November 2007 14:09
	To: Sanjay Wadhwa
	Cc: [email-masked]; DE CNODDER Stefaan; Wojciech Dec (wdec)
	Subject: RE: [ANCP] PORT UP Data Rate?

	The DSL overhead is not transmitted between NAS and Access Node.
As such, the DSL data rate that includes DSL overhead ("Sanjay's net
data rate") must not be input for the Hierarchical Scheduling by NAS.
For this HS, NAS needs DSL data rate that excluding DSL overhead
("Stefaan's net data rate"). The latter also decouples the access line
technology (ADSL, EFM,...) from the aggregation network technology (ATM,
Ethernet).
	Also consider the difficulties HS at NAS may have with evolving
subsciber line transmission technologies if the data rate reported to
NAS includes "DSL overhead".
	 
	Paul Reynders

	Alcatel-Lucent Bell NV 

	The reported rate is "net data rate" (includes DSL overhead).
The protocol draft explicitly mentions it:

	. Type (Actual-Data-Rate-Upstream = 0x81): Actual data rate
upstream of a synchronized DSL line. This is a mandatory TLV.

	-Sanjay

	-----Original Message-----
	From: Stefaan DE CNODDER

	Woj,

	It looks to me that the framework document is correct, and that
the 

	protocol draft has to replace "data rate" by "net data rate" to
make it 

	Type (Actual-Data-Rate-Upstream = 0x81) : Actual data rate
upstream of a 

	synchronized DSL line...

	should be

	Type (Actual-Data-Rate-Upstream = 0x81) : Actual net data rate
upstream 

	The term "net data rate" is accurately defined in section 1.2 of
the 

	I hope we all have the same understanding of the definition of
the 

	regards,

	Stefaan

---

From: "Sanjay Wadhwa" <[email-masked]>
Date: Thu, 8 Nov 2007 05:20:09 -0500

As I said in my previous mail, the protocol draft is quite explicit.
The rate is reported from the DSLAM to the NAS, and the reported rate
already has DSL overhead accounted for (as specified in the text in bold
below). What exactly is the confusion ?
 
. Type (Actual-Data-Rate-Upstream = 0x81): Actual data rate upstream  of
a synchronized DSL line. This is a mandatory TLV. This rate value and
all the subsequent ones account for the DSL overhead (i.e. signify the
net rate).
 
-Sanjay

-----Original Message-----
From: Wojciech Dec (wdec) [mailto:[email-masked]]
Sent: Thursday, November 08, 2007 4:12 AM
To: REYNDERS Paul; Sanjay Wadhwa
Cc: [email-masked]; DE CNODDER Stefaan
Subject: RE: [ANCP] PORT UP Data Rate?

Regards,
Woj.

  _____  

 
Paul Reynders

Alcatel-Lucent Bell NV 
  _____  

-Sanjay

-----Original Message-----
From: Stefaan DE CNODDER [mailto:[email-masked]] 
Sent: Wednesday, November 07, 2007 4:24 AM
To: Wojciech Dec (wdec)
Cc: [email-masked]
Subject: Re: [ANCP] PORT UP Data Rate?

Woj,

synchronized DSL line...

should be

regards,

Stefaan

---

From: "REYNDERS Paul" <[email-masked]>
Date: Thu, 8 Nov 2007 12:01:23 +0100

Hi Sanjay,
 
i think the confusion is about the wording "account for the DSL
overhead".
To my knowledge of the english language (i'm a dutch speaker), this can
mean: 
"make allowance for the DSL overhead".
 
Regards,
Paul Reynders

From: Sanjay Wadhwa [mailto:[email-masked]] 
Sent: donderdag 8 november 2007 11:20
To: Wojciech Dec (wdec); REYNDERS Paul
Cc: [email-masked]; DE CNODDER Stefaan
Subject: RE: [ANCP] PORT UP Data Rate?

 
-Sanjay

-----Original Message-----
From: Wojciech Dec (wdec) [mailto:[email-masked]]
Sent: Thursday, November 08, 2007 4:12 AM
To: REYNDERS Paul; Sanjay Wadhwa
Cc: [email-masked]; DE CNODDER Stefaan
Subject: RE: [ANCP] PORT UP Data Rate?

	Precisely. So we seem to agree that the appropriate edits need
to be made in the protocol draft to clarify this? Section 3.1 of the
framework draft should also see a minor edit to the term "DSL sync
rate", and the use of the full "net data rate" term as introduced in the
terminology section.
	 
	Regards,
	Woj.

		From: REYNDERS Paul
[mailto:[email-masked]] 
		Sent: 07 November 2007 14:09
		To: Sanjay Wadhwa
		Cc: [email-masked]; DE CNODDER Stefaan; Wojciech Dec
(wdec)
		Subject: RE: [ANCP] PORT UP Data Rate?

		The DSL overhead is not transmitted between NAS and
Access Node. As such, the DSL data rate that includes DSL overhead
("Sanjay's net data rate") must not be input for the Hierarchical
Scheduling by NAS. For this HS, NAS needs DSL data rate that excluding
DSL overhead ("Stefaan's net data rate"). The latter also decouples the
access line technology (ADSL, EFM,...) from the aggregation network
technology (ATM, Ethernet).
		Also consider the difficulties HS at NAS may have with
evolving subsciber line transmission technologies if the data rate
reported to NAS includes "DSL overhead".
		 
		Paul Reynders

		Alcatel-Lucent Bell NV 

		The reported rate is "net data rate" (includes DSL
overhead). The protocol draft explicitly mentions it:

		. Type (Actual-Data-Rate-Upstream = 0x81): Actual data
rate upstream of a synchronized DSL line. This is a mandatory TLV.

		This rate value and all the subsequent ones account for
the DSL overhead (i.e. signify the net rate).

		-Sanjay

		-----Original Message-----
		From: Stefaan DE CNODDER

		Woj,

		It looks to me that the framework document is correct,
and that the 

		protocol draft has to replace "data rate" by "net data
rate" to make it 

		Type (Actual-Data-Rate-Upstream = 0x81) : Actual data
rate upstream of a 

		synchronized DSL line...

		should be

		Type (Actual-Data-Rate-Upstream = 0x81) : Actual net
data rate upstream 

		The term "net data rate" is accurately defined in
section 1.2 of the 

		I hope we all have the same understanding of the
definition of the 

		regards,

		Stefaan

---

From: "Wojciech Dec (wdec)" <[email-masked]>
Date: Thu, 8 Nov 2007 12:19:18 +0100

Please read these statements (from the mails in this thread), and let us
know if it's the required minor change is still not clear. Also note
that the net data rate term should be used in the description of both
the upstream and downstream actual-rate TLVs.
 
--snip--
 
net data rate"). 
 
And:
 
---snip---

I think that "Accounting for DSL overhead" means "having substacted DSL
overhead"; it does not mean "including DSL overhead".

---snip---

Last but not least, a Terminology reference to the framework doc should
be added, if not a terminology section outright.

-Woj.

	Sent: 08 November 2007 11:20

	 As I said in my previous mail, the protocol draft is quite
explicit. The rate is reported from the DSLAM to the NAS, and the
reported rate already has DSL overhead accounted for (as specified in
the text in bold below). What exactly is the confusion ?
	 
	. Type (Actual-Data-Rate-Upstream = 0x81): Actual data rate
upstream  of a synchronized DSL line. This is a mandatory TLV. This rate
value and all the subsequent ones account for the DSL overhead (i.e.
signify the net rate).
	 
	-Sanjay

	-----Original Message-----
	From: Wojciech Dec (wdec) [mailto:[email-masked]]
	Sent: Thursday, November 08, 2007 4:12 AM
	To: REYNDERS Paul; Sanjay Wadhwa
	Cc: [email-masked]; DE CNODDER Stefaan
	Subject: RE: [ANCP] PORT UP Data Rate?

		Precisely. So we seem to agree that the appropriate
edits need to be made in the protocol draft to clarify this? Section 3.1
of the framework draft should also see a minor edit to the term "DSL
sync rate", and the use of the full "net data rate" term as introduced
in the terminology section.
		 
		Regards,
		Woj.

			From: REYNDERS Paul
[mailto:[email-masked]] 
			Sent: 07 November 2007 14:09
			To: Sanjay Wadhwa
			Cc: [email-masked]; DE CNODDER Stefaan; Wojciech
Dec (wdec)
			Subject: RE: [ANCP] PORT UP Data Rate?

			The DSL overhead is not transmitted between NAS
and Access Node. As such, the DSL data rate that includes DSL overhead
("Sanjay's net data rate") must not be input for the Hierarchical
Scheduling by NAS. For this HS, NAS needs DSL data rate that excluding
DSL overhead ("Stefaan's net data rate"). The latter also decouples the
access line technology (ADSL, EFM,...) from the aggregation network
technology (ATM, Ethernet).
			Also consider the difficulties HS at NAS may
have with evolving subsciber line transmission technologies if the data
rate reported to NAS includes "DSL overhead".
			 
			Paul Reynders

			Alcatel-Lucent Bell NV 

			The reported rate is "net data rate" (includes
DSL overhead). The protocol draft explicitly mentions it:

			. Type (Actual-Data-Rate-Upstream = 0x81):
Actual data rate upstream of a synchronized DSL line. This is a
mandatory TLV.

			This rate value and all the subsequent ones
account for the DSL overhead (i.e. signify the net rate).

			-Sanjay

			-----Original Message-----
			From: Stefaan DE CNODDER

			Woj,

			It looks to me that the framework document is
correct, and that the 

			protocol draft has to replace "data rate" by
"net data rate" to make it 

			Type (Actual-Data-Rate-Upstream = 0x81) : Actual
data rate upstream of a 

			synchronized DSL line...

			should be

			Type (Actual-Data-Rate-Upstream = 0x81) : Actual
net data rate upstream 

			The term "net data rate" is accurately defined
in section 1.2 of the 

			framework document by referring to the ITU
standard.

			regards,

			Stefaan

---

From: "Sanjay Wadhwa" <[email-masked]>
Date: Thu, 8 Nov 2007 06:43:20 -0500

No, it is not clear to me from from the statements below that we need to
change anything. Can you let me know where in the draft does it say that
DSL overhead is transmitted between NAS and the Access Node (as
mentioned by one of the statements below)? As Robert says (included his
original mail below), the confusion came about when I used the word
"include overhead" in my mail (note : this is not in the draft). I
clarified that "include overhead" in my mail was meant as "DSLAM should
include overhead in calcuation of the net rate". 
 
-Sanjay

 -----Original Message-----
From: Wojciech Dec (wdec) [mailto:[email-masked]]
Sent: Thursday, November 08, 2007 6:19 AM
To: Sanjay Wadhwa; REYNDERS Paul
Cc: [email-masked]; DE CNODDER Stefaan
Subject: RE: [ANCP] PORT UP Data Rate?

--snip--

And:
 
---snip---
[[SW]]  

 

---snip---

-Woj.

  _____  

 
 
-Sanjay

-----Original Message-----
From: Wojciech Dec (wdec) [mailto:[email-masked]]
Sent: Thursday, November 08, 2007 4:12 AM
To: REYNDERS Paul; Sanjay Wadhwa
Cc: [email-masked]; DE CNODDER Stefaan
Subject: RE: [ANCP] PORT UP Data Rate?

Regards,
Woj.

  _____  

 
Paul Reynders

Alcatel-Lucent Bell NV 

-Sanjay

-----Original Message-----
From: Stefaan DE CNODDER [mailto:[email-masked]] 
Sent: Wednesday, November 07, 2007 4:24 AM
To: Wojciech Dec (wdec)
Cc: [email-masked]
Subject: Re: [ANCP] PORT UP Data Rate?

Woj,

synchronized DSL line...

should be

regards,

Stefaan

---

From: "Sanjay Wadhwa" <[email-masked]>
Date: Thu, 8 Nov 2007 06:48:29 -0500

Would it be clearer if it said "Access Node reports the rate after
accounting for the DSL overhead i.e. it reports the net rate" ? If not,
please suggest suitable verbiage.
 
Thanks
-Sanjay

-----Original Message-----
From: REYNDERS Paul [mailto:[email-masked]]
Sent: Thursday, November 08, 2007 6:01 AM
To: Sanjay Wadhwa
Cc: [email-masked]
Subject: RE: [ANCP] PORT UP Data Rate?

Hi Sanjay,

Regards,
Paul Reynders

  _____  

 
 
-Sanjay

-----Original Message-----
From: Wojciech Dec (wdec) [mailto:[email-masked]]
Sent: Thursday, November 08, 2007 4:12 AM
To: REYNDERS Paul; Sanjay Wadhwa
Cc: [email-masked]; DE CNODDER Stefaan
Subject: RE: [ANCP] PORT UP Data Rate?

Regards,
Woj.

  _____  

 
Paul Reynders

Alcatel-Lucent Bell NV 

-Sanjay

-----Original Message-----
From: Stefaan DE CNODDER [mailto:[email-masked]] 
Sent: Wednesday, November 07, 2007 4:24 AM
To: Wojciech Dec (wdec)
Cc: [email-masked]
Subject: Re: [ANCP] PORT UP Data Rate?

Woj,

synchronized DSL line...

should be

regards,

Stefaan

---

From: "Wojciech Dec (wdec)" <[email-masked]>
Date: Thu, 8 Nov 2007 13:00:06 +0100

The text currently has some rather unfortunate wording which leaves too
much room for an incorrect interpretation  (the data rate question I
originally posted was in fact a result of a customer pointing out the
issue).
Instead the text should say:
 
(Actual-Data-Rate-Upstream = 0x81): ... specify it as NET DATA RATE... +
removing any mention of "accounting for the DSL overhead"
(Actual-Data-Rate-Downstream= 0x82):  ...specify it as NET DATA RATE...
For clarity one may also remove the term "synchronised DSL line" unless
there a case of an unsynchronised DSL line for which the actual data
rate would be transmitted.
 
Finally, a terminology reference needs to be made (likely a new section
added, with appropriate cross reference to the terminology used in the
framework draft).
 
Hopefully the above makes things clearer, otherwise please let us know.
 
-Woj.

	Sent: 08 November 2007 12:43

	No, it is not clear to me from from the statements below that we
need to change anything. Can you let me know where in the draft does it
say that DSL overhead is transmitted between NAS and the Access Node (as
mentioned by one of the statements below)? As Robert says (included his
original mail below), the confusion came about when I used the word
"include overhead" in my mail (note : this is not in the draft). I
clarified that "include overhead" in my mail was meant as "DSLAM should
include overhead in calcuation of the net rate". 
	 
	-Sanjay
	
	 -----Original Message-----
	From: Wojciech Dec (wdec) [mailto:[email-masked]]
	Sent: Thursday, November 08, 2007 6:19 AM
	To: Sanjay Wadhwa; REYNDERS Paul
	Cc: [email-masked]; DE CNODDER Stefaan
	Subject: RE: [ANCP] PORT UP Data Rate?

		Please read these statements (from the mails in this
thread), and let us know if it's the required minor change is still not
clear. Also note that the net data rate term should be used in the
description of both the upstream and downstream actual-rate TLVs.
		 
		--snip--
		 
DSL overhead ("Stefaan's net data rate"). 
		 
		And:
		 
		---snip---
		[[SW]]  

overhead). The protocol draft explicitly mentions it:

		>> . Type (Actual-Data-Rate-Upstream = 0x81): Actual
data rate upstream of a synchronized DSL line. This is a mandatory TLV.

		>>  /This rate value and all the subsequent ones account
for the DSL  overhead (i.e. signify the net rate)./

		

		---snip---

		Last but not least, a Terminology reference to the
framework doc should be added, if not a terminology section outright.

		-Woj.

			 As I said in my previous mail, the protocol
draft is quite explicit. The rate is reported from the DSLAM to the NAS,
and the reported rate already has DSL overhead accounted for (as
specified in the text in bold below). What exactly is the confusion ?
			 
			. Type (Actual-Data-Rate-Upstream = 0x81):
Actual data rate upstream  of a synchronized DSL line. This is a
mandatory TLV. This rate value and all the subsequent ones account for
the DSL overhead (i.e. signify the net rate).
			 
			-Sanjay

			-----Original Message-----
[mailto:[email-masked]]

				Precisely. So we seem to agree that the
appropriate edits need to be made in the protocol draft to clarify this?
Section 3.1 of the framework draft should also see a minor edit to the
term "DSL sync rate", and the use of the full "net data rate" term as
introduced in the terminology section.
				 
				Regards,
				Woj.

				From: REYNDERS Paul
[mailto:[email-masked]] 
				Sent: 07 November 2007 14:09
				To: Sanjay Wadhwa
				Cc: [email-masked]; DE CNODDER Stefaan;
Wojciech Dec (wdec)
				Subject: RE: [ANCP] PORT UP Data Rate?

				The DSL overhead is not transmitted
between NAS and Access Node. As such, the DSL data rate that includes
DSL overhead ("Sanjay's net data rate") must not be input for the
Hierarchical Scheduling by NAS. For this HS, NAS needs DSL data rate
that excluding DSL overhead ("Stefaan's net data rate"). The latter also
decouples the access line technology (ADSL, EFM,...) from the
aggregation network technology (ATM, Ethernet).
				Also consider the difficulties HS at NAS
may have with evolving subsciber line transmission technologies if the
data rate reported to NAS includes "DSL overhead".
				 
				Paul Reynders

				Alcatel-Lucent Bell NV 

				From: Sanjay Wadhwa
[mailto:[email-masked]] 
				Sent: woensdag 7 november 2007 13:13
				To: DE CNODDER Stefaan; Wojciech Dec
(wdec)
				Cc: [email-masked]
				Subject: RE: [ANCP] PORT UP Data Rate?

				The reported rate is "net data rate"
(includes DSL overhead). The protocol draft explicitly mentions it:

				. Type (Actual-Data-Rate-Upstream =
0x81): Actual data rate upstream of a synchronized DSL line. This is a
mandatory TLV.

				This rate value and all the subsequent
ones account for the DSL overhead (i.e. signify the net rate).

				-Sanjay

				-----Original Message-----
				From: Stefaan DE CNODDER
[mailto:[email-masked]] 
				Sent: Wednesday, November 07, 2007 4:24
AM
				To: Wojciech Dec (wdec)
				Cc: [email-masked]
				Subject: Re: [ANCP] PORT UP Data Rate?

				Woj,

				It looks to me that the framework
document is correct, and that the 

				protocol draft has to replace "data
rate" by "net data rate" to make it 

				Type (Actual-Data-Rate-Upstream = 0x81)
: Actual data rate upstream of a 

				synchronized DSL line...

				should be

				Type (Actual-Data-Rate-Upstream = 0x81)
: Actual net data rate upstream 

				The term "net data rate" is accurately
defined in section 1.2 of the 

				framework document by referring to the
ITU standard.

				I hope we all have the same
understanding of the definition of the 

				regards,

				Stefaan

---

From: "Moti Morgenstern" <[email-masked]>
Date: Thu, 8 Nov 2007 14:01:18 +0200

Hi,
 
'Accounting' means you should 'take into account'. It does not
explicitly say that you are supposed to subtract the overhead from the
total rate.
So I suggest: "Access Node reports the DSL line rate after deducting the
DSL overhead from it i.e. it reports the net rate".
 
Regards,
Moti

From: Sanjay Wadhwa [mailto:[email-masked]] 
Sent: Thursday, November 08, 2007 1:48 PM
To: REYNDERS Paul
Cc: [email-masked]
Subject: RE: [ANCP] PORT UP Data Rate?

Thanks
-Sanjay

	-----Original Message-----
	From: REYNDERS Paul [mailto:[email-masked]]
	Sent: Thursday, November 08, 2007 6:01 AM
	To: Sanjay Wadhwa
	Cc: [email-masked]
	Subject: RE: [ANCP] PORT UP Data Rate?

	Hi Sanjay,
	 
	i think the confusion is about the wording "account for the DSL
overhead".
	To my knowledge of the english language (i'm a dutch speaker),
this can mean: 
	"make allowance for the DSL overhead".
	 
	Regards,
	Paul Reynders

	 
	 
	-Sanjay

	-----Original Message-----
	From: Wojciech Dec (wdec) [mailto:[email-masked]]
	Sent: Thursday, November 08, 2007 4:12 AM
	To: REYNDERS Paul; Sanjay Wadhwa
	Cc: [email-masked]; DE CNODDER Stefaan
	Subject: RE: [ANCP] PORT UP Data Rate?

		Regards,
		Woj.

			From: REYNDERS Paul

			Paul Reynders

			Alcatel-Lucent Bell NV 

			-Sanjay

			-----Original Message-----
			From: Stefaan DE CNODDER

			Woj,

			synchronized DSL line...

			should be

			regards,

			Stefaan

---

From: Stefaan DE CNODDER <[email-masked]>
Date: Thu, 08 Nov 2007 13:04:07 +0100

It seems we all agree on what the bandwidth means and since these terms 
are defined accurately by the DSL Forum and ITU (see mail of Thomas) it 
looks to me that it is sufficient to add a reference to the DSLF or ITU 
documents.  This should not be too difficult to do....

regards,
Stefaan

Sanjay Wadhwa wrote:
> *include *overhead in calcuation of the net rate".
>  
> -Sanjay
> 
> *From:* Wojciech Dec (wdec) [mailto:[email-masked]]
> *Sent:* Thursday, November 08, 2007 6:19 AM
> *To:* Sanjay Wadhwa; REYNDERS Paul
> *Cc:* [email-masked]; DE CNODDER Stefaan
> *Subject:* RE: [ANCP] PORT UP Data Rate?
> 
>     Please read these statements (from the mails in this thread), and
>     let us know if it's the required minor change is still not clear.
>     Also note that the net data rate term should be used in the
>     The DSL overhead is not transmitted between NAS and Access Node. *As
>     such, the DSL data rate that includes DSL overhead ("Sanjay's net
>     data rate") must not be input for the Hierarchical Scheduling by
>     NAS. For this HS, NAS needs DSL data rate that excluding DSL
>     overhead ("Stefaan's net data rate"). *
>     ** 
>     And:
>      
>     ---snip---
>     [[SW]] 
> 
>> >  /This rate value and all the subsequent ones account for the
>     DSL  overhead (i.e. signify the net rate)./
> 
>>
> 
>     Last but not least, a Terminology reference to the framework doc
>     should be added, if not a terminology section outright.
> 
>     -Woj.
> 
>      
> 
> 
>         *From:* Sanjay Wadhwa [mailto:[email-masked]]
>         *Sent:* 08 November 2007 11:20
>         *To:* Wojciech Dec (wdec); REYNDERS Paul
>         *Cc:* [email-masked]; DE CNODDER Stefaan
>         *Subject:* RE: [ANCP] PORT UP Data Rate?
> 
>         explicit. The rate is reported from the DSLAM to the NAS, and
>         the reported rate already has DSL overhead accounted for (as
>         TLV. *This rate value and all the subsequent ones account for
>         the DSL overhead (i.e. signify the net rate).*
>          
>         *-Sanjay*
> 
>         **-----Original Message-----
>         *From:* Wojciech Dec (wdec) [mailto:[email-masked]]
>         *Sent:* Thursday, November 08, 2007 4:12 AM
>         *To:* REYNDERS Paul; Sanjay Wadhwa
>         *Cc:* [email-masked]; DE CNODDER Stefaan
>         *Subject:* RE: [ANCP] PORT UP Data Rate?
> 
>             Precisely. So we seem to agree that the appropriate edits
>             need to be made in the protocol draft to clarify this?
>             Section 3.1 of the framework draft should also see a minor
>             edit to the term "DSL sync rate", and the use of the full
>             "net data rate" term as introduced in the terminology section.
>              
>             Regards,
>             Woj.
>              
>              
> 
>                 *From:* REYNDERS Paul
>                 *Sent:* 07 November 2007 14:09
>                 *To:* Sanjay Wadhwa
>                 *Cc:* [email-masked]; DE CNODDER Stefaan; Wojciech Dec (wdec)
>                 *Subject:* RE: [ANCP] PORT UP Data Rate?
> 
>                 Access Node. As such, the DSL data rate that includes
>                 DSL overhead ("Sanjay's net data rate") must not be
>                 input for the Hierarchical Scheduling by NAS. For this
>                 HS, NAS needs DSL data rate that excluding DSL overhead
>                 ("Stefaan's net data rate"). The latter also decouples
>                 the access line technology (ADSL, EFM,...) from the
>                 evolving subsciber line transmission technologies if the
>                 *From:* Sanjay Wadhwa [mailto:[email-masked]]
>                 *Sent:* woensdag 7 november 2007 13:13
>                 *To:* DE CNODDER Stefaan; Wojciech Dec (wdec)
>                 *Cc:* [email-masked]
>                 *Subject:* RE: [ANCP] PORT UP Data Rate?
> 
>                 /This rate value and all the subsequent ones account for
>                 the DSL overhead (i.e. signify the net rate)./
> 
>                 / /
> 
>                 -Sanjay
> 
>                  
>

---

From: "Sanjay Wadhwa" <[email-masked]>
Date: Thu, 8 Nov 2007 07:22:43 -0500

Moti
  This sounds reasonable, and will be reflected in the next rev.
 
Thanks
-Sanjay

-----Original Message-----
From: Moti Morgenstern [mailto:[email-masked]]
Sent: Thursday, November 08, 2007 7:01 AM
To: Sanjay Wadhwa; REYNDERS Paul
Cc: [email-masked]
Subject: RE: [ANCP] PORT UP Data Rate?

Hi,

Regards,
Moti

  _____  

 
Thanks
-Sanjay

-----Original Message-----
From: REYNDERS Paul [mailto:[email-masked]]
Sent: Thursday, November 08, 2007 6:01 AM
To: Sanjay Wadhwa
Cc: [email-masked]
Subject: RE: [ANCP] PORT UP Data Rate?

Hi Sanjay,

Regards,
Paul Reynders

  _____  

 
 
-Sanjay

-----Original Message-----
From: Wojciech Dec (wdec) [mailto:[email-masked]]
Sent: Thursday, November 08, 2007 4:12 AM
To: REYNDERS Paul; Sanjay Wadhwa
Cc: [email-masked]; DE CNODDER Stefaan
Subject: RE: [ANCP] PORT UP Data Rate?

Regards,
Woj.

  _____  

 
Paul Reynders

Alcatel-Lucent Bell NV 

-Sanjay

-----Original Message-----
From: Stefaan DE CNODDER [mailto:[email-masked]] 
Sent: Wednesday, November 07, 2007 4:24 AM
To: Wojciech Dec (wdec)
Cc: [email-masked]
Subject: Re: [ANCP] PORT UP Data Rate?

Woj,

synchronized DSL line...

should be

regards,

Stefaan

---

From: "Sanjay Wadhwa" <[email-masked]>
Date: Thu, 8 Nov 2007 07:35:56 -0500

Yes. The framework draft defines the terminology (e.g "DSL overhead",
and "Net-Data-Rate") and can make these references (e.g. to point the
reader to technology dependent net-data-rate calculation on the AN).
IMHO, the protcol draft should just refer to the framework draft for
definition of baseline terminology, and not need to contain additional
(re)defintions and references.

Thanks
-Sanjay

>Sent: Thursday, November 08, 2007 7:04 AM
>To: Sanjay Wadhwa
>Cc: Wojciech Dec (wdec); [email-masked]
>Access Node. *As
>have with

---

From: "Haag, T" <[email-masked]>
Date: Thu, 8 Nov 2007 13:53:31 +0100

Thanks Stefaan,

I fully agree. We have definitions already in use and agreed by several bodies which should be used also to avoid the confusion we are discussing about. Otherwise I don't understand the goal of this discussion.

Per definition a DSLAM does not account. Accounting rate is a BRAS specific term which is dependent on an algorithm which may be dependent from other factors e.g. encapsulation type.

But all in common is the net data rate communicated via layer 2 control. We have additional fields like DSL Type encapsulation type which give information to the BRAS providing sufficient information for accounting calculation. 

Regards
Thomas

-----Ursprüngliche Nachricht-----
Von: Stefaan DE CNODDER [mailto:[email-masked]] 
Gesendet: Donnerstag, 8. November 2007 13:04
An: Sanjay Wadhwa
Cc: [email-masked]
Betreff: Re: [ANCP] PORT UP Data Rate?

regards,
Stefaan

---

From: "Wojciech Dec (wdec)" <[email-masked]>
Date: Thu, 8 Nov 2007 15:29:26 +0100

No one is suggesting re-definitions, rather use of consistent
terminology and reference to where this terminology is defined (as
needed). See it from the point of document readability. Currently the
spec does not mention anything about terminology (implicitly assuming
that the reader looks it up in the framework draft).

-Woj.

> Sent: 08 November 2007 13:36
> To: Stefaan DE CNODDER
> Yes. The framework draft defines the terminology (e.g "DSL 
> overhead", and "Net-Data-Rate") and can make these references 
> (e.g. to point the reader to technology dependent 
> net-data-rate calculation on the AN).
> IMHO, the protcol draft should just refer to the framework 
> draft for definition of baseline terminology, and not need to 
> contain additional (re)defintions and references.
> 
> Thanks
> -Sanjay
> 
> thread), and
> framework doc
> appropriate edits

---

From: "Wojciech Dec (wdec)" <[email-masked]>
Date: Thu, 8 Nov 2007 20:44:42 +0100

BTW This applies also to the framework draft, which appears to need a
touch-up or two in Section 3.1 and 4.8.1 as well. (The term DSL sync
rate is used)

-Woj. 

> Sent: 08 November 2007 15:29
> To: Sanjay Wadhwa; Stefaan DE CNODDER
> Cc: [email-masked]
> terminology and reference to where this terminology is 
> defined (as needed). See it from the point of document 
> readability. Currently the spec does not mention anything 
> about terminology (implicitly assuming that the reader looks 
> it up in the framework draft).
> 
> -Woj.
> 
> overhead", 
> draft for 
> draft is quite
> Actual data rate
> between NAS and
> (includes DSL
> > >>                 rate upstream of a synchronized DSL 
> line. This is a
> > >>                 mandatory TLV.
> > >>

---

From: "OOGHE Sven" <[email-masked]>
Date: Fri, 9 Nov 2007 10:46:36 +0100

Woj,

I will correct the references to "DSL sync rate" in the framework and
refer to "net data rate".

Regards,
Sven 

-----Original Message-----
From: Wojciech Dec (wdec) [mailto:[email-masked]] 
Sent: donderdag 8 november 2007 20:45
To: Sanjay Wadhwa; DE CNODDER Stefaan
Cc: [email-masked]
Subject: RE: [ANCP] PORT UP Data Rate?

-Woj.

---

From: "Sanjay Wadhwa" <[email-masked]>
Date: Mon, 12 Nov 2007 08:27:31 -0500

We will add explicit reference to section 1.2 of the framework draft for
definitions/terminology. We need a few minor changes for consistency
with the framework draft (including the agreed upon use of "net data
rate"). I will send out an updated version of the protocol draft before
11/19 cutoff.

-Sanjay

-----Original Message-----
From: Wojciech Dec (wdec) [mailto:[email-masked]] 
Sent: Thursday, November 08, 2007 9:29 AM
To: Sanjay Wadhwa; Stefaan DE CNODDER
Cc: [email-masked]
Subject: RE: [ANCP] PORT UP Data Rate?

-Woj.