Subject: [ANCP] Mandatory TLVs in draft-ietf-ancp-protocol proposal

From: "Busser, M" <[email-masked]>
Date: Thu, 24 Apr 2008 13:56:10 +0200

Hi all
 
At the actual ANCP draft most of the Sub-TLVs in "DSL Line Attributes"  are optional.
At the DSL Forum, this TLVs are mandatory.
 
I suggest to set them mandatory in ANCP as well to be in line with the DSL Forum.
 
Another suggestion is to have a small table somewhere in the draft (maybe an appendix)
where all the TLVs are listed with their encodings an if they are mandatory or optional.
Please see attachement as an example.  
 
Best Regards; Freundliche Grüße 

Michael Busser

T-Systems Enterprise Services GmbH 
Production Line Network Centric Systems
ICT-Systems Integration
Network Integration Services
 
Brückes 2 -8, 55545 Bad Kreuznach
Postfach 9100, 55541 Bad Kreuznach
+49 671 8333 8911 (Phone)
+49 521 9210 3859 (Fax)
+49 151 1211 9689 (Mobile)
E-Mail: [email-masked]
Internet: http://www.t-systems.com <http://www.t-systems.com/>  
 
T-Systems Enterprise Services GmbH
Aufsichtsrat: René Obermann (Vorsitzender)
Executive Committee: Reinhard Clemens (Vorsitzender)*, Helmut Binder, Albert Henn, Olaf Heyden*, Katrin Horstmann, Ulrich Kemp, Wilfried Peters*,
Dr. Herbert Schaaff*, Zvezdana Seeger*
Handelsregister: Amtsgericht Frankfurt am Main HRB 55933
Sitz der Gesellschaft: Frankfurt am Main
WEEE-Reg.-Nr. DE87523644
*Geschäftsführer gem. § 35 GmbHG
 
Notice: This transmittal and/or attachments may be privileged or confidential. If you are not the intended recipient, you are hereby notified that you have received this transmittal in error; any review, dissemination, or copying is strictly prohibited. If you received this transmittal in error, please notify us immediately by reply and immediately delete this message and all its attachments. Thank you. 
T-Systems - Business flexibility 

_______________________________________________
ANCP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ancp

---

From: "Wojciech Dec (wdec)" <[email-masked]>
Date: Thu, 24 Apr 2008 14:21:32 +0200

Hi Michael,
 
inline...

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Busser, M
	Sent: 24 April 2008 13:56
	To: [email-masked]
	Subject: [ANCP] Mandatory TLVs in draft-ietf-ancp-protocol proposal

	Hi all

	 
	Woj> Existing implementations seem to work fine with them being precisely optional. Why should they be mandatory? 

	Woj> I second this suggestion, adding that it should be done on a per application basis.
	 
	Regards,
	Woj

	Michael Busser