Subject: [ANCP] FW: draft-bitar-wadhwa-ancp-pon-00.txt

From: "Sanjay Wadhwa" <[email-masked]>
Date: Sat, 12 Jul 2008 08:45:33 -0400

Hi All
  We have submitted a new draft (attached) on ANCP applicability to PON
to the IETF repository, ahead of the cutoff for version 00. We expect
the draft to be posted soon. Any feedback is appreciated.

Thanks
-Sanjay & Nabil

----- Original Message ----- 
From: "Sanjay Wadhwa" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; "Sanjay Wadhwa" 
<[email-masked]>
Sent: Monday, July 07, 2008 7:27 PM
Subject: draft-bitar-wadhwa-ancp-pon-00.txt

Please find attached draft-bitar-wadhwa-ancp-pon-00.txt ("Applicability
of 
Access Node Control Mechanism to PON based Broadband Networks"). We
would 
like the draft to be posted to the ietf repository.

  <<draft-bitar-wadhwa-ancp-pon-00.txt>>

Thanks
-Sanjay Wadhwa & Nabil Bitar

 <<draft-bitar-wadhwa-ancp-pon-00.txt>>

>
>
>
>
>
>
>On Mon, July 7, 2008 4:27 pm, Sanjay Wadhwa wrote:
>> Please find attached draft-bitar-wadhwa-ancp-pon-00.txt 
>("Applicability of
>> Access Node Control Mechanism to PON based Broadband 
>Networks"). We would
>> like the draft to be posted to the ietf repository.
>>
>>   <<draft-bitar-wadhwa-ancp-pon-00.txt>>
>>
>> Thanks
>> -Sanjay Wadhwa & Nabil Bitar
>>
>>  <<draft-bitar-wadhwa-ancp-pon-00.txt>>
>>
>
>
>
_______________________________________________
ANCP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ancp

---

From: <[email-masked]>
Date: Tue, 22 Jul 2008 01:33:51 +0530

Hi Sanjay, Nabil

In Section 6.2 ,
Three different approaches have been discussed regarding Multicast Admission Control.

A suggestion would be that, with ONT and ONU being intelligent and capable of handling many of the subscriber information, can we also probe the below mentioned approach.

In this approach it is assumed that ONT / ONU is having full knowledge
of subscriber profile and makes an independent decision on admitting or rejecting
a multicast and unicast join. ONT/ONU performs check on Access list and as well on
subscriber bandwidth. When ONT receives a Join request it performs admission control
against subscriber video bandwidth and Access list. If the check passes, the ONT updates 
the OLT with message subscriber bandwitdth available bandwidth. The OLT performs check on
the PON bandwidth and uplink to the GWR. If the Check passes the OLT updates the video
available bandwidth per PON. If the multicast stream is already available at OLT,
it adds the subscribers to list of receivers and  the PON to multicast tree,
if it is not already on it. It sends an ANCP message to the ONT to add the subscriber
to the requested stream and also sends an ANCP message to the NAS informing it of the
subscriber and link available video bandwidth and the Stream subscriber has joined. 
The NAS upon receiving this message updates the necessary information.

If the ONT/ONU check on Subscriber bandwidth fails, then it drops the IGMP message.
If the OLT fails in performing the PON bandwidth check then it sends an reject message
to the ONT. If the OLT is not already having the channel requested, it sends the IGMP 
request towards the NAS. The NAS checks for the bandwidth availability on the link 
between NAS and OLT. If the check passes, it sends ANCP message to the OLT directing
it to add this Stream for replication. The OLT sends ANCP message directing the ONT to 
add the Subscriber port to this Stream.

Thanks
Vish

Hi All

Thanks
-Sanjay & Nabil

----- Original Message ----- 
From: "Sanjay Wadhwa" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; "Sanjay Wadhwa" 
<[email-masked]>

Thanks