Subject: [ANCP] Partition ID

From: Maglione Roberta <[email-masked]>
Date: Mon, 3 Nov 2008 12:21:15 +0100

Hello,
        according to the requirements specified in the ancp framework draft an Access Node, as physical device, can be split in different logical partitions. A mechanism that specifies how AN and NAS agree on the partition numbers needs to be defined.  Two different approaches could be followed:
1. the Partition ID could be configured on the AN and learnt by NAS in the adjacency message;
2. the Partition ID could be statically configured on the NAS as part of configuring the neighbor information.

Feedback on the preferred approach would be appreciated.

Thanks and best regards,
Sanjay and Roberta.

CONFIDENTIALITY NOTICE

This message and its attachments are addressed solely to the persons above and may contain confidential information. If you have received the message in error, be informed that any use of the content hereof is prohibited. Please return it immediately to the sender and delete the message. Should you have any questions, please contact us by replying to [email-masked].

        Thank you

                                        www.telecomitalia.it
_______________________________________________
ANCP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ancp

---

From: "Haag, Thomas" <[email-masked]>
Date: Mon, 3 Nov 2008 13:39:50 +0100

Roberta, Sanjay,

You raised an interesting question we were facing to few weeks ago.

Problem statement / situation:
AN sends a partition ID towards the NAS to which NAS ia not configured to reply. 
As aconsequence the connection fails and will not come up. 
This is not desirable from an operational point of view.

Discussion option 1 vs. option 2:
Option 1 you proposed will solve this problem. AN is the partioned device which has knowledge about the relation DSL-port to partition.

If Option 2 would be applied NAS has the knowledge about partions but not about relationship between AN's dsl-port to partition ID. Somehow AN needs to be configured to DSL-port to partition ID. But if AN needs to be configured (DSL-port/partition ID) and NAS need configuration (number of partition ID's per domain) both elements need static configuration before option 2 works.

Conclusion DT:
>From simplicty point of view and from operational point of view DT's preference will be "option 1 Partition ID learnt by NAS".

Regards
Thomas

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Maglione Roberta
Gesendet: Montag, 3. November 2008 12:21
An: [email-masked]
Betreff: [ANCP] Partition ID

Hello,

Thanks and best regards,
Sanjay and Roberta.

CONFIDENTIALITY NOTICE

        Thank you

                                        www.telecomitalia.it

---

From: Maglione Roberta <[email-masked]>
Date: Thu, 6 Nov 2008 12:39:28 +0100

Hello Thomas,
        thanks for your feedack.
I do share the same opinion as you as far as preference: option 1 seems to me simpler from the operational point of view, but I'd like to know if any body see issues with this approach or would prefer another mechanism.
I'd like to get additional feedback from the WG members (either on the list or during the meeting in Minneapolis) before updating the draft with the preferred approach.

Regards,
Roberta

-----Original Message-----
From: Haag, Thomas [mailto:[email-masked]]
Sent: Monday, November 03, 2008 1:40 PM
To: [email-masked]
Cc: Maglione Roberta
Subject: AW: [ANCP] Partition ID

Roberta, Sanjay,

Regards
Thomas

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Maglione Roberta
Gesendet: Montag, 3. November 2008 12:21
An: [email-masked]
Betreff: [ANCP] Partition ID

Hello,

Thanks and best regards,
Sanjay and Roberta.

CONFIDENTIALITY NOTICE

        Thank you

                                        www.telecomitalia.it

CONFIDENTIALITY NOTICE

        Thank you

                                        www.telecomitalia.it

---

From: "Sanjay Wadhwa" <[email-masked]>
Date: Thu, 6 Nov 2008 08:25:54 -0500

Option 1 is preferred, which is why it is listed ahead of the other option :-). However, option 1 needs a bit more thought. The NAS can send an initial adjacency message (SYN) without having received one from the AN. In this case the NAS will send Partition ID 0, where as the AN would expect the configured partition ID for that ANCP session in the SYN from NAS. For option 1 to work, we need to let the NAS learn the partition ID by allowing the mismatch in partition ID in initial adjacency messages (by defining appropriate behavior on the AN)...or will need to mandate an order on the initial SYN generation (e.g. NAS waits to see the first SYN before generating its own).

Option 2 depends on consistent configuration on both ends. We do need to add some text for describing partition ID mismatch handling in periodic adjacency messages.

Original GSMP allows for an elaborate partition assignment from the NAS (which is another option). However, we would like to keep it simple with just the two options.

-Sanjay

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Maglione Roberta
Sent: Thursday, November 06, 2008 6:39 AM
To: 'Haag, Thomas'; [email-masked]
Subject: Re: [ANCP] Partition ID

Hello Thomas,
        thanks for your feedack.

Regards,
Roberta

-----Original Message-----
From: Haag, Thomas [mailto:[email-masked]]
Sent: Monday, November 03, 2008 1:40 PM
To: [email-masked]
Cc: Maglione Roberta
Subject: AW: [ANCP] Partition ID

Roberta, Sanjay,

Regards
Thomas

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Maglione Roberta
Gesendet: Montag, 3. November 2008 12:21
An: [email-masked]
Betreff: [ANCP] Partition ID

Hello,

Thanks and best regards,
Sanjay and Roberta.

CONFIDENTIALITY NOTICE

        Thank you

                                        www.telecomitalia.it

CONFIDENTIALITY NOTICE

        Thank you

                                        www.telecomitalia.it