Subject: [ANCP] I-D Action:draft-ietf-ancp-protocol-04.txt

From: [email-masked]
Date: Mon, 3 Nov 2008 02:45:01 -0800 (PST)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Access Node Control Protocol Working Group of the IETF.

	Title           : Protocol for Access Node Control Mechanism in Broadband Networks
	Author(s)       : S. Wadhwa, et al.
	Filename        : draft-ietf-ancp-protocol-04.txt
	Pages           : 59
	Date            : 2008-11-03

This document describes proposed extensions to the GSMPv3 protocol to
allow its use in a broadband environment, as a control plane between
Access Nodes (e.g.  DSLAM) and Broadband Network Gateways (e.g.
NAS).  These proposed extensions are required to realize a protocol
for "Access Node Control" mechanism as described in [ANCP-FRAMEWORK].
The resulting protocol with the proposed extensions to GSMPv3
[RFC3292] is referred to as "Access Node Control Protocol" (ANCP).
This document currently focuses on specific use cases of access node
control mechanism for topology discovery, line configuration, and OAM
as described in ANCP framework document [ANCP-FRAMEWORK].  It is
intended to be augmented by additional protocol specification for
future use cases considered in scope by the ANCP charter.

ANCP framework document [ANCP-FRAMEWORK] describes the ANCP use-cases
in detail.  Illustrative text for the use-cases is included here to
help the protocol implementer understand the greater context of ANCP
protocol interactions.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ancp-protocol-04.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
ANCP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ancp

---

From: Tom Taylor <[email-masked]>
Date: Mon, 03 Nov 2008 17:08:54 -0500

The first thing I'd suggest is that the abstract should be brought up to date. 
Get rid of "proposed", since this IS the ANCP protocol document. Get rid of 
GSMPv3, since ANCP isn't really an extension of GSMPv3. So the first few 
sentences might read:

"This document describes the Access Node Control Protocol (ANCP), which is used 
in a broadband environment as a control plane between Access Nodes (e.g. DSLAM) 
and Broadband Network Gateways (e.g. NAS). ANCP realizes the "Access Node 
Control" mechanism described in [ANCP-FRAMEWORK].  This document currently 
focuses ..."

[email-masked] wrote:
> ------------------------------------------------------------------------
>

---

From: Maglione Roberta <[email-masked]>
Date: Thu, 6 Nov 2008 12:22:16 +0100

Hello Tom,
        thanks for your suggestions.  I agree with you that ANCP is a new protocol and not just an extension of GSMPv3, and in particular with both the new recently defined extensions and the discussions regarding messaging principles and result field, ANCP is getting more and more different from GSMP. However we cannot refuse the fact that initial design of ANCP protocol was inspired by GMSPv3, thus most of the original ANCP messages inherited GSMPv3 header.
Moving forward, we are working on trying to make ancp protocol draft self consistent and independent from GSMPv3 spec. In particular in version 04 of the draft we started adding clarifications for each single field inserted in the ANCP header in order to clean up unclear dependencies from GSMPv3 RFCs/drafts that in the past created issues and miss-interpretations.
In my opinion we are actually going in the direction you are suggesting and not only for the abstract thus I don't have any problem with the new text you are proposing.
However as modifying the abstract of the protocol draft seems to me a big change, I would really appreciate additional feedback and comment from the WG on this proposal.

Best Regards,
Roberta

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tom Taylor
Sent: Monday, November 03, 2008 11:09 PM
To: [email-masked]
Subject: Re: [ANCP] I-D Action:draft-ietf-ancp-protocol-04.txt

CONFIDENTIALITY NOTICE

This message and its attachments are addressed solely to the persons above and may contain confidential information. If you have received the message in error, be informed that any use of the content hereof is prohibited. Please return it immediately to the sender and delete the message. Should you have any questions, please contact us by replying to [email-masked].

        Thank you

                                        www.telecomitalia.it

---

From: "DE CNODDER Stefaan" <[email-masked]>
Date: Thu, 6 Nov 2008 12:40:02 +0100

Since ANCP is using the same port number as GSMP, you cannot say that ANCP is a new protocol but rather it is a new GSMP version (although I also would have preferred that it was a new protocol).  It would also be a bit strange that a new protocol starts immediately with version 3.1 instead of 1.0.  It would be very good to have a spec that can be read without reading the GSMPv3 spec.
 
regards,
Stefaan

________________________________

Van: [email-masked] namens Maglione Roberta
Verzonden: do 6/11/2008 12:22
Aan: 'Tom Taylor'; [email-masked]
Onderwerp: Re: [ANCP] I-D Action:draft-ietf-ancp-protocol-04.txt

Hello Tom,

Best Regards,
Roberta

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tom Taylor
Sent: Monday, November 03, 2008 11:09 PM
To: [email-masked]
Subject: Re: [ANCP] I-D Action:draft-ietf-ancp-protocol-04.txt

CONFIDENTIALITY NOTICE

        Thank you

                                        www.telecomitalia.it