Subject: Re: [ANCP] TC Information "unknown" State

From: "Wojciech Dec (wdec)" <[email-masked]>
Date: Wed, 1 Apr 2009 10:45:38 +0200

Hi Thomas,
 
if the line is not (and never was) synchronised to a CPE, what would be
the point of reporting it to the NAS?
 
Thanks,
Woj.

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of [email-masked]
	Sent: 01 April 2009 08:29
	To: [email-masked]
	Subject: [ANCP] TC Information "unknown" State

	All, 

	operating a DSL port in multi mode which means that ADSL2plus
(ATM ) and VDSL2 (ETH) is enabled the following situation occur:

	For a DSL port which has never been synchronized with a CPE
(regardless if ADSL2plus or VDSL2) there is the situation, which layer 2
information has to be reported to BNG via ANCP port status message. In
that case new information in the protocol is necessary to inform the BNG
about this "unknown" State which is neither represented by ATM nor ETH.

	I like to encourage ANCP working group to tackle this issue and
define a new TC information [ATM, ETH; UNKNOWN] in the protocol draft to
indicate the port status as described above.

	Best regards 

	Thomas

---

From: <[email-masked]>
Date: Wed, 1 Apr 2009 11:33:47 +0200

Hi Woj,
 
the case occurs if:

*	
	 a IP-DSLAM Port is preprovisioned and
*	
	aDSL port operates in Multi Mode (without DSL pre-enforcement to
VDSL2(ETH) or ADSL2plus(ATM)) and 
*	
	customer did not switch on his CPE (first time) and 
*	
	DSLAM-BNG sets up adjacency or 
*	
	a DSL line card comes up.

In that situation a DSLAM does not know on which Layer 2 mode the DSL
line will synchronize. Having only ATM and ETH without "Unknown" coded
the message will be wrong because a DSLAM does not know what to choose
because of an unknown L2 status at the DSL port.
 
Regards
Thomas

Von: Wojciech Dec (wdec) [mailto:[email-masked]] 
Gesendet: Mittwoch, 1. April 2009 10:46
An: Haag, Thomas; [email-masked]
Betreff: RE: [ANCP] TC Information "unknown" State

Hi Thomas,

Thanks,
Woj.

	All, 

	Best regards 

	Thomas

---

From: "Wojciech Dec (wdec)" <[email-masked]>
Date: Wed, 1 Apr 2009 13:31:21 +0200

Hi Thomas,
 
I still don't quite follow.
If the DSLAM is pre-provisioned and the port is down (no CPE on the
other end), what is the point of signalling this pre-provisioned but
down and "unknown" port to the NAS?
 
Thanks,
Woj.

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of [email-masked]
	Sent: 01 April 2009 11:34
	To: Wojciech Dec (wdec); [email-masked]
	Subject: Re: [ANCP] TC Information "unknown" State

	Hi Woj,
	 
	the case occurs if:

	*	
		 a IP-DSLAM Port is preprovisioned and
	*	
		aDSL port operates in Multi Mode (without DSL
pre-enforcement to VDSL2(ETH) or ADSL2plus(ATM)) and 
	*	
		customer did not switch on his CPE (first time) and 
	*	
		DSLAM-BNG sets up adjacency or 
	*	
		a DSL line card comes up.

	In that situation a DSLAM does not know on which Layer 2 mode
the DSL line will synchronize. Having only ATM and ETH without "Unknown"
coded the message will be wrong because a DSLAM does not know what to
choose because of an unknown L2 status at the DSL port.
	 
	Regards
	Thomas

	Hi Thomas,
	 
	if the line is not (and never was) synchronised to a CPE, what
would be the point of reporting it to the NAS?
	 
	Thanks,
	Woj.

		From: [email-masked]
[mailto:[email-masked]] On Behalf Of [email-masked]
		Sent: 01 April 2009 08:29
		To: [email-masked]
		Subject: [ANCP] TC Information "unknown" State

		All, 

		operating a DSL port in multi mode which means that
ADSL2plus (ATM ) and VDSL2 (ETH) is enabled the following situation
occur:

		For a DSL port which has never been synchronized with a
CPE (regardless if ADSL2plus or VDSL2) there is the situation, which
layer 2 information has to be reported to BNG via ANCP port status
message. In that case new information in the protocol is necessary to
inform the BNG about this "unknown" State which is neither represented
by ATM nor ETH.

		I like to encourage ANCP working group to tackle this
issue and define a new TC information [ATM, ETH; UNKNOWN] in the
protocol draft to indicate the port status as described above.

		Best regards 

		Thomas

---

From: <[email-masked]>
Date: Wed, 1 Apr 2009 16:35:52 +0200

Hi Woj,
 
the point is that the DSLAM does not know in which Layer 2 mode (Packet
Mode, ATM Mode) the Line will synchronize if a port is configured for
multimode.
>From an ANCP perspective all ports have to report their status
regardless if in sync, out of sync, idle what ever.
 
But those ports which do not know the mode because of not beeing
synchronized the first time will not retrieve an information from DSL
port beeing communicated via ANCP. 
If a port is not ATM synchronized and if a port is not ETH synchronized
what has the DSLAM to report? The Layer 2 status is unknown. 
 
>From protocol point of view it should be a point of integrity because we
use it for a use case called topology discovery which means to have real
information about all ports within a domain. 
The BRAS can use it for statistics correlate with OAM use case, Line
config use case or irgnore it. But this is not a protocol issue it is an
element implementation issue.
 
Regards
Thomas

  _____  

Von: Wojciech Dec (wdec) [mailto:[email-masked]] 
Gesendet: Mittwoch, 1. April 2009 13:31
An: Haag, Thomas; [email-masked]
Betreff: RE: [ANCP] TC Information "unknown" State

Hi Thomas,

Thanks,
Woj.

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: 01 April 2009 11:34
To: Wojciech Dec (wdec); [email-masked]
Subject: Re: [ANCP] TC Information "unknown" State

Hi Woj,
 
the case occurs if:

*	

 
Regards
Thomas

  _____  

Hi Thomas,

Thanks,
Woj.

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: 01 April 2009 08:29
To: [email-masked]
Subject: [ANCP] TC Information "unknown" State

All, 

operating a DSL port in multi mode which means that ADSL2plus (ATM ) and
VDSL2 (ETH) is enabled the following situation occur:

For a DSL port which has never been synchronized with a CPE (regardless
if ADSL2plus or VDSL2) there is the situation, which layer 2 information
has to be reported to BNG via ANCP port status message. In that case new
information in the protocol is necessary to inform the BNG about this
"unknown" State which is neither represented by ATM nor ETH.

I like to encourage ANCP working group to tackle this issue and define a
new TC information [ATM, ETH; UNKNOWN] in the protocol draft to indicate
the port status as described above.

Best regards 

Thomas

---

From: <[email-masked]>
Date: Mon, 6 Apr 2009 08:22:19 +0200

All,
 
in the framwork draft (draft-ietf-ancp-framework-08), there is a passage
in chapter 4.4 saying the following:
o The ANCP MUST support a mechanism to synchronize access port
configuration and status information between ANCP peers as part of
establishing or recovering the Access Node Control Adjacency. 

This comfirms IMO the issue raised from Thomas.
As specified above, the the AN must report the port status as part of
establishing the Access Node Control Adjacency. In practice the
Adjacency protocol is established before all the dsl lines are in
showtime. Which layer 2 mode (atm or eth) should the AN add into the
Access-Node-Identifier? At this point of time, he does not know, in
which layer 2 mode the port is operating. He may derives the information
from the configured value in the line profile but if the port is
configured with multiple modes enabled (e. g. ADSL2plus and VDSL2),
there is no clear disctinction possible.

Regards
Markus

  _____  

Von: [email-masked] [mailto:[email-masked]] Im Auftrag von
Haag, Thomas
Gesendet: Mittwoch, 1. April 2009 16:36
An: [email-masked]; [email-masked]
Betreff: Re: [ANCP] TC Information "unknown" State

Hi Woj,

 
 
Regards
Thomas

  _____  

Hi Thomas,

Thanks,
Woj.

  _____  

Hi Woj,
 
the case occurs if:

*	

 
Regards
Thomas

  _____  

Hi Thomas,

Thanks,
Woj.

  _____  

All, 

Best regards 

Thomas

---

From: Hongyu Li <[email-masked]>
Date: Thu, 16 Apr 2009 10:00:02 +0800

>From view of topology discovery, sending all physically existing ports is necessary. "unknown" is a proper value for never synced
ports.
 
Besides, exploring more about the case that these "unknown" state ports are discovered and reported, tens of ports' status may be
reported at the same time, e.g. triggered by pre-provision or line cards come up. Therefore, I suggest we think about using a batch
mode sending such a report, which means multiple discovery messages are merged into on ANCP message. This may greatly improve
performance and efficiency. Of course, format of such message needs further study.
 
BR,
Hongyu

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, April 06, 2009 2:22 PM
To: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [ANCP] TC Information "unknown" State

All,
 
in the framwork draft (draft-ietf-ancp-framework-08), there is a passage in chapter 4.4 saying the following:
o The ANCP MUST support a mechanism to synchronize access port configuration and status information between ANCP peers as part of
establishing or recovering the Access Node Control Adjacency. 

This comfirms IMO the issue raised from Thomas.
As specified above, the the AN must report the port status as part of establishing the Access Node Control Adjacency. In practice
the Adjacency protocol is established before all the dsl lines are in showtime. Which layer 2 mode (atm or eth) should the AN add
into the Access-Node-Identifier? At this point of time, he does not know, in which layer 2 mode the port is operating. He may
derives the information from the configured value in the line profile but if the port is configured with multiple modes enabled (e.
g. ADSL2plus and VDSL2), there is no clear disctinction possible.

Regards
Markus

  _____  

Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Haag, Thomas
Gesendet: Mittwoch, 1. April 2009 16:36
An: [email-masked]; [email-masked]
Betreff: Re: [ANCP] TC Information "unknown" State

Hi Woj,
 
the point is that the DSLAM does not know in which Layer 2 mode (Packet Mode, ATM Mode) the Line will synchronize if a port is
configured for multimode.
>From an ANCP perspective all ports have to report their status regardless if in sync, out of sync, idle what ever.
 
But those ports which do not know the mode because of not beeing synchronized the first time will not retrieve an information from
DSL port beeing communicated via ANCP. 
If a port is not ATM synchronized and if a port is not ETH synchronized what has the DSLAM to report? The Layer 2 status is unknown.

>From protocol point of view it should be a point of integrity because we use it for a use case called topology discovery which means
to have real information about all ports within a domain. 
The BRAS can use it for statistics correlate with OAM use case, Line config use case or irgnore it. But this is not a protocol issue
it is an element implementation issue.
 
Regards
Thomas

  _____  

Hi Thomas,
 
I still don't quite follow.
If the DSLAM is pre-provisioned and the port is down (no CPE on the other end), what is the point of signalling this pre-provisioned
but down and "unknown" port to the NAS?
 
Thanks,
Woj.

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 01 April 2009 11:34
To: Wojciech Dec (wdec); [email-masked]
Subject: Re: [ANCP] TC Information "unknown" State

Hi Woj,
 
the case occurs if:

*	

	aDSL port operates in Multi Mode (without DSL pre-enforcement to VDSL2(ETH) or ADSL2plus(ATM)) and 
*	

In that situation a DSLAM does not know on which Layer 2 mode the DSL line will synchronize. Having only ATM and ETH without
"Unknown" coded the message will be wrong because a DSLAM does not know what to choose because of an unknown L2 status at the DSL
port.
 
Regards
Thomas

  _____  

Hi Thomas,
 
if the line is not (and never was) synchronised to a CPE, what would be the point of reporting it to the NAS?
 
Thanks,
Woj.

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 01 April 2009 08:29
To: [email-masked]
Subject: [ANCP] TC Information "unknown" State

All, 

operating a DSL port in multi mode which means that ADSL2plus (ATM ) and VDSL2 (ETH) is enabled the following situation occur:

For a DSL port which has never been synchronized with a CPE (regardless if ADSL2plus or VDSL2) there is the situation, which layer 2
information has to be reported to BNG via ANCP port status message. In that case new information in the protocol is necessary to
inform the BNG about this "unknown" State which is neither represented by ATM nor ETH.

I like to encourage ANCP working group to tackle this issue and define a new TC information [ATM, ETH; UNKNOWN] in the protocol
draft to indicate the port status as described above.

Best regards 

Thomas