Subject: [ANCP] Framework draft question

From: "OOGHE Sven" <[email-masked]>
Date: Mon, 6 Apr 2009 15:40:58 +0200

Hi,

I would like to raise a question regarding draft-ietf-ancp-framework-08.

Section 4.1 states "The ANCP MUST allow fast completion of a given
operation, in the order of magnitude of tens of milliseconds." 

This is as such not a protocol requirement, but rather a requirement on
the platform choice (e.g. CPU speed).

I am soliciting feedback what to do with this (drop / reword / keep).

Regards,
Sven

---

From: "Wojciech Dec (wdec)" <[email-masked]>
Date: Thu, 9 Apr 2009 11:21:21 +0200

FWIW, my opinion is that this requirement isn't for a framework as it is
a performace requirement that depends on a large number of things. I'd
say drop.
 
-Woj.

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of OOGHE Sven
	Sent: 06 April 2009 15:41
	To: [email-masked]
	Subject: [ANCP] Framework draft question

	Hi, 

	I would like to raise a question regarding
draft-ietf-ancp-framework-08. 

	Section 4.1 states "The ANCP MUST allow fast completion of a
given operation, in the order of magnitude of tens of milliseconds." 

	This is as such not a protocol requirement, but rather a
requirement on the platform choice (e.g. CPU speed). 

	I am soliciting feedback what to do with this (drop / reword /
keep). 

	Regards, 
	Sven

---

From: <[email-masked]>
Date: Tue, 14 Apr 2009 11:35:58 +0200

Hi,
 
you're right that this  is a performance requirement. 
But I think this is an important requirement which has impact on
protocol design and gives some developing guideline. 
So I would propose to keep it.
 
Regards
 
Thomas

Von: [email-masked] [mailto:[email-masked]] Im Auftrag von
Wojciech Dec (wdec)
Gesendet: Donnerstag, 9. April 2009 11:21
An: OOGHE Sven; [email-masked]
Betreff: Re: [ANCP] Framework draft question

-Woj.

	Hi, 

	Regards, 
	Sven

---

From: "Wojciech Dec (wdec)" <[email-masked]>
Date: Tue, 14 Apr 2009 15:50:25 +0200

The performance of even the most optimized implementation of a protocol
on an OS, a generic CPU and I/O platform will degrade with the messaging
load. Hence what guideline is being provided here is doubtful. I don't
quite know who would develop any an implementation that was purposefully
slow, and it's equally doubtful as to what would happen should the 10s
of ms requirement below not be met (will the protocol break? Will the
use-fullness of the protocol disappear?)
 
Cheers,
Woj.

	From: [email-masked] [mailto:[email-masked]] 
	Sent: 14 April 2009 11:36
	To: Wojciech Dec (wdec); [email-masked];
[email-masked]
	Subject: AW: [ANCP] Framework draft question

	Hi,

	Regards
	 
	Thomas

	Von: [email-masked] [mailto:[email-masked]] Im
Auftrag von Wojciech Dec (wdec)
	Gesendet: Donnerstag, 9. April 2009 11:21
	An: OOGHE Sven; [email-masked]
	Betreff: Re: [ANCP] Framework draft question

	FWIW, my opinion is that this requirement isn't for a framework
as it is a performace requirement that depends on a large number of
things. I'd say drop.
	 
	-Woj.

		From: [email-masked]
[mailto:[email-masked]] On Behalf Of OOGHE Sven
		Sent: 06 April 2009 15:41
		To: [email-masked]
		Subject: [ANCP] Framework draft question

		Hi, 

		Section 4.1 states "The ANCP MUST allow fast completion
of a given operation, in the order of magnitude of tens of
milliseconds." 

		I am soliciting feedback what to do with this (drop /
reword / keep). 

		Regards, 
		Sven