Subject: [ANCP] Status-Info TLV Type

From: Francois Le Faucheur <[email-masked]>
Date: Mon, 12 Oct 2009 17:10:55 +0200

Folks,

When the Status-Info TLV was introduced there was a proposal for using  
0x106 as the TLV Type. The official TLV Type remained "TBD" for a long  
while and the value 0x10 was eventually allocated. While trying to use  
the 0x10 value, we run into interop issues with an earlier  
implementation that worked off 0x106.

Could we allocate 0x106 as the Status-Info TLV (instead of 0x10) to  
minimize interop issues with implementations that worked off the  
earlier value?

Thanks

Francois

---

From: Sidd Aanand <[email-masked]>
Date: Mon, 12 Oct 2009 11:17:29 -0400

I strongly vote for using 0x106. We have enough mess already dealing with TLVs being re-used between wadhwa-00 and later versions of ANCP drafts.

Thanks,
Sidd 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Francois Le Faucheur
Sent: Monday, October 12, 2009 11:11 AM
To: [email-masked]
Subject: [ANCP] Status-Info TLV Type

Folks,

When the Status-Info TLV was introduced there was a proposal for using
0x106 as the TLV Type. The official TLV Type remained "TBD" for a long while and the value 0x10 was eventually allocated. While trying to use the 0x10 value, we run into interop issues with an earlier implementation that worked off 0x106.

Could we allocate 0x106 as the Status-Info TLV (instead of 0x10) to minimize interop issues with implementations that worked off the earlier value?

Thanks

Francois
_______________________________________________
ANCP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ancp

---

From: Maglione Roberta <[email-masked]>
Date: Tue, 13 Oct 2009 10:27:41 +0200

Hello Francois, Sidd and All,
    I don't recall we select the value 0x0106 for Status-Info; anyway if both of you already have implementations using this value, and nobody else has any objections, in order to facilitate interoperability, I can update the protocol draft allocating 0x106 for Status info.
Best Regards,
Roberta

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Sidd Aanand
Sent: Monday, October 12, 2009 5:17 PM
To: Francois Le Faucheur; [email-masked]
Subject: Re: [ANCP] Status-Info TLV Type

Thanks,
Sidd

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Francois Le Faucheur
Sent: Monday, October 12, 2009 11:11 AM
To: [email-masked]
Subject: [ANCP] Status-Info TLV Type

Folks,

Thanks

Francois

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.