Subject: [ANCP] CAC vs. Admission Control in draft-ietf-ancp-mc-extensions

From: Tom Taylor <[email-masked]>
Date: Mon, 02 Dec 2013 05:22:56 -0500

To clear up a misunderstanding that led to an AD comment, I propose to 
add the following definitions to the terminology section of the document:

<quote>

Within this document, the term "conditional access control (CAC)" refers 
to a procedure wherein a decision is made to allow or disallow a 
subscriber request for a new media flow based on the subscriber profile. 
"Admission control" is a separate procedure wherein the admission 
decision is based on the availability of bandwidth to serve the request. 
Both procedures are applied to make the final decision. The NAS controls 
which procedures are performed at the Access Node and which by itself 
based on the capabilities both devices support and the provisioning 
information it sends to the Access Node.

</quote>

Based on these definitions, some of the protocol elements in the 
document are misnamed. So far I have identified three cases:

-- Multicast Admission Control Message (which is sent from the
    AN to the NAS for grey-listed flows, hence is for CAC to start
    with)

-- White-List-CAC and MRepCtl-CAC TLVs, which are actually
    controlling whether the AN does admission control

Would it be OK to rename these, given that it doesn't affect the bits on 
the wire?

Of course, the first question is whether the proposed definitions are 
acceptable.

Tom Taylor

---

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Wed, 4 Dec 2013 15:49:36 +0000

Hello Tom,

I think it is a good idea to provide a definition for the two concepts (policy-based admission vs resource-based admission).

With respect to the actual names for the two concepts, I am very uncomfortable in using a name that abreviates to "CAC" for the policy-based admission control because "CAC" (abbreviation of "Connection Admission Control")  has been extensively used in the industry for many years and generally implied either (i) resource-based admission or (ii) a combination of policy-based admission and resource-based admission (and never just policy-based admission).

My preference would be to just always use non-abbreviated terms. I'd probably go with "policy-based admission" and "resource-based admission", but can go with some variations of these such as "policy-based admission control" and "resource-based admission control (or "bandwidth-based admission control").

I had trouble parsing the last sentence of the definition. I'd suggest 
s/The NAS controls which procedures are performed at the Access Node and which by itself/The NAS controls which procedures are performed by the Access Node and which are performed by itself/

HTH

Francois

On 2 Dec 2013, at 11:22, Tom Taylor <[email-masked]> wrote:

> To clear up a misunderstanding that led to an AD comment, I propose to add the following definitions to the terminology section of the document:
> 
> <quote>
> 
> Within this document, the term "conditional access control (CAC)" refers to a procedure wherein a decision is made to allow or disallow a subscriber request for a new media flow based on the subscriber profile. "Admission control" is a separate procedure wherein the admission decision is based on the availability of bandwidth to serve the request. Both procedures are applied to make the final decision. The NAS controls which procedures are performed at the Access Node and which by itself based on the capabilities both devices support and the provisioning information it sends to the Access Node.
> 
> </quote>
> 
> Based on these definitions, some of the protocol elements in the document are misnamed. So far I have identified three cases:
> 
> Would it be OK to rename these, given that it doesn't affect the bits on the wire?
> 
> Of course, the first question is whether the proposed definitions are acceptable.
> 
> Tom Taylor
> _______________________________________________
> ANCP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ancp

---

From: Tom Taylor <[email-masked]>
Date: Wed, 04 Dec 2013 16:40:28 -0500

Sounds good to me. I won't bother changing TLV or command names, since 
the current ones work if I adopt your suggested terminology.

Aside from the MAC privacy issue, I think this takes care of any open 
questions I had. I'll update the draft. One possibility for the device 
identifier is to specify it as such in the TLV, leaving it up to the 
operator to configure a local mapping on the AN between MAC address and 
device identifier.

Tom