Subject: Re: [Anima] [6lo] Thread [Comments needed for Security Bootstrapping of IEEE 802.15.4 based Internet of Things]

From: Oliver Hahm <[email-masked]>
Date: Tue, 7 Jul 2015 14:12:45 +0200

Hi Hannes!

Am Wed, Mar 04, 2015 at 09:03:23AM +0100 schrieb Hannes Tschofenig:
> I was corrected after I sent the mail below to the list and learned
> something new (after consulting with my co-worker Robert).
> 
> The specifications are not yet available to all members but only to a
> core group of member companies. They will be made available to the them
> probably in June.
> 
> If the specs become available publically I will post a link to the list.

Any news on this?

Cheers,
Oleg

---

From: Alper Yegin <[email-masked]>
Date: Tue, 7 Jul 2015 15:36:59 +0300

There are other relevant forums as well, such as OIC, AllSeen Alliance, IIC, where IETF protocols are used.

On Feb 26, 2015, at 5:12 AM, Brian E Carpenter wrote:

> Hi Ralph,
> On 26/02/2015 14:44, Ralph Droms wrote:
>> 
>>> On Feb 25, 2015, at 4:52 PM 2/25/15, Brian E Carpenter <[email-masked]> wrote:
>>> 
>>> On 26/02/2015 10:25, Behcet Sarikaya wrote:
>>> 
>>> ...
>>>>>> I know nothing about Thread, whatever and whoever it is.
>>>>> 
>>>>> Here is an intro document:
>>>>> http://threadgroup.org/Portals/0/documents/events/ThreadIntro.pdf
>>> 
>>> Thanks for that. It seems to have all the downsides of secretive ad hoc
>>> membership-based consortia, except for the upside of a RAND-RF IPR
>>> policy.
>>> 
>>>> I think we need to clarify here that Thread Group is formed to deal
>>>> with home environments.
>>>> 
>>>> Enterprise or industrial environments seem to be excluded.
>>> 
>>> So far. The boundary between this and larger building services
>>> networks is pretty fuzzy, isn't it?
>>> 
>>> In any case, should we (the WGs on copy, and perhaps some others)
>>> be asking the IAB to arrange a meaningful liaison with Thread?
>> 
>> What would we want to get from a liaison arrangement with Thread?
> 
> I think the main thing is to have a chance to review their specs before
> finalization. They seem to touch numerous IETF WGs directly or
> indirectly (at least homenet, anima, 6lo, 6tisch and probably
> 6man indirectly). Both sides have everything to gain by detecting
> misfits and overlaps ASAP.
> 
>    Brian
> 
>> 
>> We had a liaison with ZigBee Alliance but let it lapse as ZA appears to have finished its work on Z-IP.
>> 
>> We might also consider a liaison arrangement with Wi-SUN Alliance because of the Wi-SUN FAN spec.
>> 
>> As I seem to sit at an intersection of WG chairs and IAB, I can bring up the issue if we think there is reason to move forward.
>> 
>> - Ralph
>> 
>>> 
>>> Back at Hannes: is there a spec for their approach to security
>>> enrollment?
>>> 
>>>  Brian
>>> 
>>> _______________________________________________
>>> 6lo mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/6lo
>> 
>> 
> 
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 07 Jul 2015 16:05:14 +0200

> There are other relevant forums as well, such as OIC, AllSeen Alliance, IIC, where IETF protocols are used.

Yes, and some of them are making the same mistake of developing
protocols under covers without the benefits of the expertise of a larger
community.

Not good.

I think the rationale is that having public discussions is going to slow
things down.

Unfortunately, designing broken protocols is going to slow things down
as well.

Grüße, Carsten