Subject: [Anima] intent specificity

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 19 Oct 2015 20:56:18 -0400

I am trying to make sure I understand what we mean by intent, and how 
things can be realized.

Is a statement like "in the case of congestion / contention, gold 
customers should get better service than others, but no customer may be 
starved" an example of the kind of intent we want to handle?  Maybe with 
more specific parameters for what we mean by better and starved?

If so, who or what provides the information to indicate which traffic si 
coming from gold customers?

Thank you,
Joel

---

From: Duzongpeng <[email-masked]>
Date: Tue, 20 Oct 2015 02:03:04 +0000

Hi, Joel

There is still no consensus about Intent or ANIMA intent. Some information can be found in the "intent" section of 
https://tools.ietf.org/id/draft-behringer-anima-reference-model-04.txt

and another draft
https://tools.ietf.org/id/draft-du-anima-an-intent-02.txt

Also, the former talking in the maillist can help.

About your question, IMO, it can be an Intent or ANIMA intent, because it expresses the need of the operator.
However, it has a high abstract level, and thus a policy continuum is needed to translate the requirement to what the device can understand.

It has been agreed that there is work to do for this policy continuum, and it is difficult to fit in with various situations.
But I am not sure whether the detailed realization of this policy continuum is in the scope of ANIMA intent.

Best Regards
Zongpeng Du

-----Original Message-----
From: Anima [mailto:[email-masked]] On Behalf Of Joel M. Halpern
Sent: Tuesday, October 20, 2015 8:56 AM
To: Anima WG
Subject: [Anima] intent specificity

I am trying to make sure I understand what we mean by intent, and how things can be realized.

Is a statement like "in the case of congestion / contention, gold customers should get better service than others, but no customer may be starved" an example of the kind of intent we want to handle?  Maybe with more specific parameters for what we mean by better and starved?

If so, who or what provides the information to indicate which traffic si coming from gold customers?

Thank you,
Joel

_______________________________________________
Anima mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/anima