Subject: Re: [Anima] I-D Action: draft-behringer-anima-autonomic-addressing-02.txt

From: Brian E Carpenter <[email-masked]>
Date: Sun, 18 Oct 2015 11:03:48 +1300

Hi,

I might have mentioned this before, but the use of the phrase "zone ID" in
this context is confusing, because it already has a meaning in IPv6 addressing
(see RFC 4007 and RFC 6874). I think we need to find an alternative phrase.

Regards
   Brian

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Sun, 18 Oct 2015 09:11:44 +0000

Hi Brian, 

We've tried other words before, for example "area". All of which have the same problem - they've been used before. (And, btw, I found "area" nicer).

I agree that it would be nice to have a  new term, but I can't find a good one. Suggestions? 

Otherwise, we'll have have to live with it, and when people talk they have to say "autonomic zone" as opposed to "IPv6 zone". 

Michael

> -----Original Message-----
> From: Anima [mailto:[email-masked]] On Behalf Of Brian E
> Carpenter
> Sent: 18 October 2015 00:04
> To: Anima WG <[email-masked]>
> Subject: Re: [Anima] I-D Action: draft-behringer-anima-autonomic-
> addressing-02.txt
> 
> Hi,
> 
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima

---

From: "Jason Coleman (colemaj)" <[email-masked]>
Date: Mon, 19 Oct 2015 03:25:16 +0000

I agree with Michael that it will be very hard to find a term that is not already in use somewhere.
I like the idea of using the term AN Area since that term is used in a number of routing instances today and fits in well with those definitions.
I think that in our writings if we prefix the term as much as possible with Autonomic Area or AN Area, or Autonoic Zone or AN Zone then we differentiate the term enough to get the point across with out worry of overlap with other definitions in use by other functions today.

— Jason Coleman

---

From: John Strassner <[email-masked]>
Date: Mon, 19 Oct 2015 19:30:17 -0700

+1
regards.
John

On Sun, Oct 18, 2015 at 8:25 PM, Jason Coleman (colemaj) <[email-masked]>
wrote:

> I like the idea of using the term AN Area since that term is used in a
> number of routing instances today and fits in well with those definitions.
> I think that in our writings if we prefix the term as much as possible
> with Autonomic Area or AN Area, or Autonoic Zone or AN Zone then we
> differentiate the term enough to get the point across with out worry of
> overlap with other definitions in use by other functions today.
>
> — Jason Coleman
>
> On 10/18/15, 2:11 AM, "Anima on behalf of Michael Behringer (mbehring)" <
> [email-masked] on behalf of [email-masked]> wrote:
>
> >Hi Brian,
> >
> >We've tried other words before, for example "area". All of which have the
> same problem - they've been used before. (And, btw, I found "area" nicer).
> >
> >Otherwise, we'll have have to live with it, and when people talk they
> have to say "autonomic zone" as opposed to "IPv6 zone".
> >
> >Michael
> >

-- 
regards,
John

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 20 Oct 2015 15:44:53 +1300

I agree. In fact it's critical that we do so. The particular case of
IPv6 Zone ID is very unfortunate, because *all* it refers to is the
local name of a specific interface within a specific node. It doesn't
even identify a given LAN link (i.e., "eth0" on one node might be
an interface to the same LAN as "eth1" on another node). So I think
we'll need to be very strict about saying "Autonomic" every time we
say "Zone".

Or we could call them "Autonomic Regions".

   Brian

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Wed, 21 Oct 2015 00:10:01 +0000

Shall we have a vote at the IETF? ;-) 

I have no strong views. 

Michael

> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: 19 October 2015 19:45
> To: John Strassner <[email-masked]>; Jason Coleman (colemaj)
> <[email-masked]>
> Cc: Michael Behringer (mbehring) <[email-masked]>; [email-masked]
> IPv6 Zone ID is very unfortunate, because *all* it refers to is the local name
> of a specific interface within a specific node. It doesn't even identify a given
> LAN link (i.e., "eth0" on one node might be an interface to the same LAN as
> "eth1" on another node). So I think we'll need to be very strict about saying
> "Autonomic" every time we say "Zone".
> 
> >> I like the idea of using the term AN Area since that term is used in
> >> a number of routing instances today and fits in well with those definitions.
> >> I think that in our writings if we prefix the term as much as
> >> possible with Autonomic Area or AN Area, or Autonoic Zone or AN Zone
> >> then we differentiate the term enough to get the point across with
> >> out worry of overlap with other definitions in use by other functions
> today.
> >>
> >> — Jason Coleman
> >>
> >> On 10/18/15, 2:11 AM, "Anima on behalf of Michael Behringer
> >> (mbehring)" < [email-masked] on behalf of
> [email-masked]> wrote:
> >>
> >>> Hi Brian,
> >>>
> >>> I agree that it would be nice to have a  new term, but I can't find
> >>> a
> >> good one. Suggestions?
> >>>
> >>>> I might have mentioned this before, but the use of the phrase "zone
> ID"
> >> in

---

From: Michael Richardson <[email-masked]>
Date: Fri, 30 Oct 2015 22:05:53 -0400

Michael Behringer (mbehring) <[email-masked]> wrote:
    > We've tried other words before, for example "area". All of which have
    > the same problem - they've been used before. (And, btw, I found "area"
    > nicer).

    > I agree that it would be nice to have a new term, but I can't find a

Pick a term you like, and translate it to another language, and then
import it back to english as eliterated.

-- 
Michael Richardson
-on the road-