Subject: [Anima] Confirmation of consensus to adopt draft-jiang-anima-prefix-management as ANIMA WG document, ends December 13, 2015,

From: Sheng Jiang <[email-masked]>
Date: Mon, 30 Nov 2015 01:26:23 +0000

There was clear consensus for adopting draft-jiang-anima-prefix-management as a
ANIMA working group document in the IETF 94 ANIMA WG meeting, Yokohama. 
This message starts a two-week call on confirming the consensus from the WG meeting.

  Title:      Autonomic Prefix Management in Large-scale Networks
  Authors :   Jiang, et al.
  Filename:  draft-jiang-anima-prefix-management
  
  https://tools.ietf.org/html/draft-jiang-anima-prefix-management

Please express your support or rejection. If you think this document should _not_ be
adopted, please also explicitly indicate the reasons.

This adoption call will end on December 13, 2015.

Regards,

Sheng + Toerless

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 30 Nov 2015 15:48:01 +1300

Hi,

I am also a co-author of this draft and I support its adoption,
although I believe we still have work to do on improving the use
case description and on mapping it to the Anima toolkit.

Regards
   Brian

On 30/11/2015 14:26, Sheng Jiang wrote:
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Sun, 29 Nov 2015 23:05:14 -0500

I do not think this document is in shape to be adopted by the working 
group.  It does not clearly state what sort of address prefix handling 
it is attempting to address, and is nowhere near sufficient for the 
general case.

I am sorry that due to the need to chair another working group, I could 
not be in the room for the discussion.

Yours,
Joel M. Halpern

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 1 Dec 2015 08:02:28 +1300

Joel,

As I said in my own comment, the use case aspect of the draft definitely
needs work. It was never intended to be sufficient for the general
case. Actually, it says that it's limited to ISP networks. It probably
needs an explicit applicability section with more details on that.
In particular, is it intended to be used during network creation
(and would it then use something like RFC 7695) or is it only for
prefix allocation to customer stubs in an established network?

(If it's used for network creation, there would be some interesting
questions about bootstrapping that I won't go into here.)

It's also not at all aligned with the current GRASP proposal, and that
needs to be fixed in the next version.

Its overall role in Anima is really supposed to be a worked example
to validate the infrastructure components.

Regards
   Brian

On 30/11/2015 17:05, Joel M. Halpern wrote:
> I do not think this document is in shape to be adopted by the working group.  It does not clearly state what sort of address
> prefix handling it is attempting to address, and is nowhere near sufficient for the general case.
> 
> I am sorry that due to the need to chair another working group, I could not be in the room for the discussion.
> 
> Yours,
> Joel M. Halpern
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 30 Nov 2015 14:09:28 -0500

I can well believe that there is a valuable demonstration case that 
could be covered by that document.
However, as I read it, the current document is not clear enough to even 
say that it is a good starting point on describing that case and its 
value to the group.

So I would like to se a round of clarity improvement by the authors, 
after which it is likely we could adopt the document.

Yours,
Joel

---

From: Duzongpeng <[email-masked]>
Date: Tue, 1 Dec 2015 02:01:25 +0000

I think the use case is clear, and support the adoption of this draft.

IMO, more use cases are needed besides this one, as the concept of autonomic network is hard to understand without some use cases.

-----Original Message-----
From: Anima [mailto:[email-masked]] On Behalf Of Joel M. Halpern
Sent: Tuesday, December 01, 2015 3:09 AM
To: Brian E Carpenter; Sheng Jiang; [email-masked]
Cc: [email-masked]; Toerless Eckert
Subject: Re: [Anima] Confirmation of consensus to adopt draft-jiang-anima-prefix-management as ANIMA WG document, ends December 13, 2015, 

I can well believe that there is a valuable demonstration case that could be covered by that document.
However, as I read it, the current document is not clear enough to even say that it is a good starting point on describing that case and its value to the group.

So I would like to se a round of clarity improvement by the authors, after which it is likely we could adopt the document.

Yours,
Joel

On 11/30/15 2:02 PM, Brian E Carpenter wrote:
> Joel,
>
> As I said in my own comment, the use case aspect of the draft 
> definitely needs work. It was never intended to be sufficient for the 
> general case. Actually, it says that it's limited to ISP networks. It 
> probably needs an explicit applicability section with more details on that.
> In particular, is it intended to be used during network creation (and 
> would it then use something like RFC 7695) or is it only for prefix 
> allocation to customer stubs in an established network?
>
> Its overall role in Anima is really supposed to be a worked example to 
> validate the infrastructure components.
>
> Regards
>     Brian
>
>
>> group.  It does not clearly state what sort of address prefix handling it is attempting to address, and is nowhere near sufficient for the general case.
>>
>>> There was clear consensus for adopting 
>>> draft-jiang-anima-prefix-management as a ANIMA working group document in the IETF 94 ANIMA WG meeting, Yokohama.
>>> Please express your support or rejection. If you think this document 
>>> should _not_ be adopted, please also explicitly indicate the reasons.
>>>

---

From: "Liubing (Leo)" <[email-masked]>
Date: Tue, 1 Dec 2015 06:10:44 +0000

Hi Dear all,

In general, I think the large scale ISP prefix management is a valid use case of GRASP. So I basically support the draft.

But I also think Joel's concern make sense that the current draft seems not describe the use case in a clear way. My personal comment is:
- IIRC, the document structure was based on a suggested "use case template" at the very beginning of the Anima BoF. The template intended to regular different use cases at that time. For now, I think maybe there is no need to stick to that template any more. It could be more direct to discuss the prefix management issues in the Problem Statement. Current texts describes the supporting technologies well (e.g. device credential/role, policy intent etc.), but could be more institutive to the prefix management issue itself.
- Section 3/4/5 describes the technology components of the solution well, but It seems it lacks a very clear whole picture of the prefix allocation/provisioning procedure. 

So, for me, the problem is mostly description issue rather than technical issue. From a use case perspective, I think it's ok to adopt it, and readability could be improved after adoption. 

Best regards,
Bing

> Subject: Re: [Anima] Confirmation of consensus to adopt
> draft-jiang-anima-prefix-management as ANIMA WG document, ends
> December 13, 2015,
> 
> However, as I read it, the current document is not clear enough to even say
> that it is a good starting point on describing that case and its value to the
> group.
> 
> So I would like to se a round of clarity improvement by the authors, after
> which it is likely we could adopt the document.
> 
> Yours,
> Joel
> 
> >> group.  It does not clearly state what sort of address prefix handling it is
> attempting to address, and is nowhere near sufficient for the general case.
> >>
> >>> draft-jiang-anima-prefix-management as a ANIMA working group
> document in the IETF 94 ANIMA WG meeting, Yokohama.

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Tue, 1 Dec 2015 07:47:48 +0000

I support the adoption. 

Michael

> From: Anima [mailto:[email-masked]] On Behalf Of Sheng Jiang
> Sent: 30 November 2015 02:26
> To: [email-masked]
> Cc: [email-masked]; Toerless Eckert (eckert) <[email-masked]>
> Subject: [Anima] Confirmation of consensus to adopt draft-jiang-anima-
> prefix-management as ANIMA WG document, ends December 13, 2015,
> 
> There was clear consensus for adopting draft-jiang-anima-prefix-
> management as a ANIMA working group document in the IETF 94 ANIMA WG
> meeting, Yokohama.
> Please express your support or rejection. If you think this document should
> _not_ be adopted, please also explicitly indicate the reasons.
>