Subject: [Anima] GRASP issue 57: Add M_INVALID message?

From: Brian E Carpenter <[email-masked]>
Date: Wed, 19 Oct 2016 09:04:46 +1300

57: Add M_INVALID message?

MR: What does one do with an invalid msgtype?  Options are:
     1) ignore (drop msg)
     2) die: drop TCP connection
     3) reply with ???-M_INVALID or something.

BC: I'm inclined to add M_INVALID as a MAY, or possibly a SHOULD,
but with a rule that you MUST NOT reply to M_INVALID with M_INVALID.
And the reason is indeed that we could use this to discover that
a peer doesn't understand a new (or obsolete) message or option.

Regards
   Brian

---

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Wed, 19 Oct 2016 08:47:55 +0000

> -----Original Message-----
> From: Anima [mailto:[email-masked]] On Behalf Of Brian E
> Carpenter
> Sent: 18 October 2016 22:05
> To: Anima WG <[email-masked]>
> Subject: [Anima] GRASP issue 57: Add M_INVALID message?
> 
> BC: I'm inclined to add M_INVALID as a MAY, or possibly a SHOULD, but with
> a rule that you MUST NOT reply to M_INVALID with M_INVALID.
> And the reason is indeed that we could use this to discover that a peer
> doesn't understand a new (or obsolete) message or option.

Agree. 

I think the handling of an invalid message is up to the ASA, so what it actually does depends on the use case. 

Michael

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 25 Oct 2016 12:37:00 +1300

And I'm going to take silence on this one as assent, and add the
message to the spec (and test it in the prototype).

Regards
   Brian