Subject: [Anima] State machine for an ANIMA device

From: "Michael Behringer (mbehring)" <[email-masked]>
Date: Mon, 17 Oct 2016 15:55:53 +0000

ANIMA WG,

I´m currently looking at the to do items in the reference model draft.  One thing I feel would add value is a state machine description of the various steps. It could explain how the various drafts fit together. I'm afraid we're not all on the same page here. So I drew up how I see the state machine for an ANIMA device, as a starting point, and how the drafts would link together:

The main states of an ANIMA device are "factory default", "enrolled", and "in ACP". BRSKI takes a device from "factory default" to "enrolled". Once "enrolled" the ACP draft explains how a device (now with a domain ID) would join the ACP for that domain. This draft explains how to get to the state "in ACP". Once a device is in the ACP, and (!) it sees a registrar (announced by GRASP), then it starts the bootstrap proxy.

The bootstrapping state machine is being worked on in the bootstrap design team. Let's leave the details of that one in that design team for now. (I sent a mail on Friday to that list with another state machine, if you're interested).

But my question to the team: Do you have the same view? (modulo the precise naming of particular states). Did we all agree that we'll discover ANIMA neighbors through mDNS? (I thought so). That we use GRASP in the ACP to find a Registrar? (Thought so, too).

Also the separation between the drafts - does that correspond with your view?

Michael

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 18 Oct 2016 08:28:29 +1300

Michael,

Good work, thanks.

Why do you have (mDNS)? We plan to use GRASP discovery to find candidate ACP
neighbors, as covered in paragraph 3) of
https://tools.ietf.org/html/draft-ietf-anima-grasp-07#section-3.3.2

In fact if you have a more detailed idea of that part of the ACP state machine,
my next toy ASA would be exactly that, to follow up from my BRSKI toys.
Its description would fit in
https://tools.ietf.org/html/draft-ietf-anima-reference-model-02#section-7.3
I would prefer that section to be entitled "Specific ASAs for the Autonomic
Infrastructure." Also of course we need detailed text in that section.

Regards
   Brian

On 18/10/2016 04:55, Michael Behringer (mbehring) wrote:
> _______________________________________________
> Anima mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/anima
>